Bash starting (and not closing automatically) on startup

Is there any way to disable the shell from autostarting? Sometimes it starts on startup and sometimes it doesnt… Theres nothing other in it than what u normally see when u open a new terminal

It’s possible that your previous session is restored (look at your KDE settings). If you have left the last session with a terminal open, it will be restored. You can change that in the settings in order to start with a clean session.


Are you referring to the dropdown terminal? Yakuake I think it is.

If so - disable it in the autostart settings - not a KDE user so I don’t know exactly where.