Banana Pi M2: no signal on screen - hdmi_force_hotplug=1 - could this cause the issue


#1

hello dear Manjaro-Experts,

on a Banana Pi M2 i have no signal on screen

i allready have tested a second monitor:

btw: could this detail lead to the issue: - hdmi_force_hotplug=1 - could this cause the issue ? - See more below:

btw i have found some very intersting thread …
https://www.raspberrypi.org/forums/viewtopic.php?t=34061 presume, you have installed your selected OS on SD card. Boot sector of the SD card is normally accessible from Windows, so you can edit file config.txt. What you maybe need? Add into config.txt this line:

hdmi_force_hotplug=1

well - how to edit this line !?

btw found some additonal texts: https://raspberrypi.stackexchange.com/questions/2169/how-do-i-force-the-raspberry-pi-to-turn-on-hdmi

Add these two lines to /boot/config.txt and reboot Raspbmc:

hdmi_force_hotplug=1 hdmi_drive=2

hdmi_force_hotplug=1 sets the Raspbmc to use HDMI mode even if no HDMI monitor is detected. hdmi_drive=2 sets the Raspbmc to normal HDMI mode (Sound will be sent if supported and enabled). Without this line, the Raspbmc would switch to DVI (with no audio) mode by default.

config.txt is read by the GPU so it will work on every distro.

There’s two ways to do it. In older Pi installs, use the fb0 framebuffer when you want to display stuff on the HDMI/TV display, for example: FRAMEBUFFER=/dev/fb0 startx will use the HDMI/TV framebuffer for X windows instead of the PiTFT

On Jessie Pi installs, run sudo nano /usr/share/X11/xorg.conf.d/99-fbdev.conf to edit the configuration file and make sure it contains:

Section “Device” Identifier “display” Driver “fbdev” Option “fbdev” “/dev/fb0” EndSection

change the Option “fbdev” “/dev/fb0” line to Option “fbdev” “/dev/fb1” if you want the xdisplay on the PiTFT or fb1 to fb0 for HDMI output. Update: If don’t see the code above in the file, then simply copy and paste what is shown in this answer at the bottom of that file.If you can’t find 99-fbdev.conf file in that folder, then there is probably another file with different name like 10-evdev.conf inv the same folder which you will have to modify to make it work as described above.

another solution could be - to install a new os : can i take the following one:

BPI-R2 new image : Armbian with kernel 4.19.y 2018-11-5,support by armbian


Armbian preview image for Bananapi R2 / K4.19.y

All but: onboard wifi, power off, HDMI, RTC. Perhaps some other minor things Power off and RTC was already fixed but is not yet present in the image.

Hdmi (old patches), rtc and wifi are already ported to 4.19 see my kernel-repo But nice that there is an archlinux-image is also now there. And with actual kernwl (imho currently too new).

look forward to hear from you

greetings


#2

This is not really related to Manjaro ARM, is it?


#3

hi there - hello Strit,

not really - but - besides the different flavours of linux os - i think that this is a pretty common issue - that may have to do with linux - and not only with certain distibution…

i will try to find out more - and come back and report all my findings.

Many thanks for your answer.

greetings


#4

HDMI support usually depends on the kernel and how much of the board has been added into mainline.


#5

hello dear Strit

guess that i am safe with the kernel 4.19

this supports the HDMI


#6

Yeah. Kernel 4.19 added lots of stuff for a lot of different boards. :slight_smile:


#7

hello Strit,

thanks alot - i will give it a try