Backup issues KDE plasma

I have been struggling a bit with backups since I migrated over to Manjaro from Mint. On Mint I used Luckybackup and it went well.

On Manjaro KDE I have tried different applications, like KBackup, Dejadup and although these backed up well I did not like that the backup was compressed in an array of different folders that was unrecognizable to me. I like to be able to go in and fetch what I want without having to decompress

So I went back to Luckybackup, but now it throws back lots of errors saying: failed: Invalid argument (22) on files. So I installed Kup Backup and get the same error.

If I check the files that gets the error messages they may have a special character somewhere or a long path.

Which leads me to an impression I have that KDE or is it perhaps dolphin, does not particularly like special characters because sometimes it will not “find” a folder or a file with special characters in it.

This is something I can work around up to a certain point, but being Scandinavian there will be special characters. It is also difficult to avoid long names as I work on an extra HD and once mounted it gets one of those long names of “/mnt/59b08e4b-1a8f-46f2-a410-5699bc1b1b7b/”

I am not much for command line, I prefer GUI. I like to use incremental backup, and I back up to an external HD, that I also use for other things.

Any suggestions on how to go about this?

If you don’t like compression and encryption and all that stuff, you’re a prime suspect to start using rsync:

rsync --archive --verbose --human-readable /home/$USER /media/backups/

for more information:

man rsync

Also please have a look here if you’re interested in crash-proof backups:

(You can change borg which I like because it compresses and deduplicates by rsync when following that tutorial…)


1 Like

I use Timeshift for system backup and BackInTime for user backup, never had issues with (german) special characters…maybe give those a try? ^^ (both have easy GUIs as well)

1 Like

I think (not sure though) that luckybackup and Kup are GUI’s for rsync. And that makes me think that rsync probably will give me the same error. Also rsync is command line and I prefer GUI. I am horrible at remembering commands.

I do use Timeshift to take snapshots of my system. But I have never considered it for regular backup of files. Perhaps I should check it out

1 Like

I am not sure if I have checked BackInTime, so I will have a look at it and see if it fits my requirements :slight_smile:

for files/home directory it’s not really the best tool, thats why i use BackinTime for that ^^

I used to use that as well, but I ran into some issues with it. It hasn’t seen any development for a couple years. I now use Timeshift for system backups and Back In Time for user files.

I recently came across Pika Backup that uses Borg as it’s backend. It’s still fairly new and basic. It’s available in the AUR.

1 Like

Yeah, there’s a few, but none of them currently support all borg features…


just type this once:

and then type rsy Enter

If that doesn’t work, you have not bound the to Search history in bash and then you need to do this

Note: Obviously you need to specify the correct path to backup to and /media/backups/ is just an example, but /home/$USER is correct if you want to backup your entire Home Directory…


P.S. Also, rsync will show you exactly what is going wrong where

BackinTime somehow reminded me of Kup once it was configured… and it threw back the same error too

all those tools use rsync, so i guess it might be a problem with leftover temp files?

Welcome to the forum! :slight_smile:

In that case, I would advise TimeShift. It does exactly what you want. It uses rsync to create a complete backup copy, with everything in the same folder names.

Upon every subsequent backup, it will then only copy the files that were altered against the original backup copy, while the unaltered files will simply be hard-linked, so that it doesn’t even need more storage space than what is strictly needed for storing incremental backups. At the same time, given that the unaltered files are hard links, you can still restore everything by simply selecting the individual files that you want to copy back from within a file manager or via the command line, and copying them.

1 Like

Thank you Aragorn.
The thing I run into with Timeshift for backing up my files and folders is that I back up to an external HD and Timeshift does not support the HD as it does not have Linux partition.

1 Like

I store nothing under Home folder, so yes I would have to change the path. I guess I will have to try your approach, because I would very much like to know:


1 Like

It certainly might be, but how to solve it…

Timeshift snapshots do not need much space. Is it an option to create a new ext4 partition of let’s say 40 - 50 GiB for that purpose on the external HDD?

1 Like

I use these two applications: Timeshift and dejadup.
I already had some start-up problems following some updates and because I only have one computer at home, I didn’t have access to the forum to ask my questions.
Fortunately, Timeshift was there.
After logging in tty, a man timeshift and I was able to put my configuration back in place before the - update(s).
Then, thanks to the forums or the Net, I could see what changes I had to make in my configuration files regarding these updates.
Of course, these backups are made on an external HDD.

1 Like

With no other information … the first thing this makes me think of is a combination of poorly named files (with spaces and special characters) and a program that for one reason or another doesnt know how to deal with them.

1 Like

would the program Kdiff be something useful for your task? Or, if additional ligraries don’t bother you, Meld is another nice choice. Both can compare directories (and their content) and do not necessarily use compression, they just mirror one directory on another (or merge them, or …).