Backlight not controllable Dell System XPS L702X

Problem: Cannot control backlight, brightness is always 100%, there is nothing in /sys/class/backlight

Tried all of the below and nothing worked:

  • adding Option "RegistryDwords" "EnableBrightnessControl=1" to /etc/X11/mhwd.d/nvidia.conf
  • installing ddcci-driver-linux-dkms
  • installed colorhug (complains about org.gnome.SettingsDaemon not being provided.)

inxi -Fxxz output:

System:    Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A Console: tty 0 DM: LightDM Distro: Manjaro Linux 
Machine:   Type: Portable System: Dell product: Dell System XPS L702X v: N/A serial: <filter> Chassis: type: 8 v: 0.1 
           serial: <filter> 
           Mobo: Dell model: 03RG89 v: FAB1 serial: <filter> UEFI [Legacy]: Dell v: A19 date: 09/07/2012 
Battery:   ID-1: BAT0 charge: 79.6 Wh condition: 84.2/93.2 Wh (90%) volts: 12.3/11.1 model: LGC Dell serial: <filter> 
           status: Unknown 
CPU:       Topology: Quad Core model: Intel Core i7-2630QM bits: 64 type: MT MCP arch: Sandy Bridge rev: 7 L2 cache: 6144 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31936 
           Speed: 798 MHz min/max: 800/2900 MHz Core speeds (MHz): 1: 798 2: 798 3: 798 4: 799 5: 798 6: 799 7: 798 8: 799 
Graphics:  Device-1: NVIDIA GF106M [GeForce GT 555M] vendor: Dell driver: nvidia v: 390.132 bus ID: 01:00.0 chip ID: 10de:0dcd 
           Device-2: Quanta type: USB driver: uvcvideo bus ID: 1-1.4:4 chip ID: 0408:2fb1 
           Display: server: X .org 1.20.9 driver: nvidia tty: 210x60 
           Message: Advanced graphics data unavailable in console. Try -G --display 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 chip ID: 8086:1c20 
           Device-2: NVIDIA GF106 High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:0be9 
           Device-3: Philips s SAA7231 vendor: Avermedia driver: N/A bus ID: 02:00.0 chip ID: 1131:7231 
           Sound Server: ALSA v: k5.8.11-1-MANJARO 
Network:   Device-1: Intel Centrino Advanced-N 6230 [Rainbow Peak] driver: iwlwifi v: kernel port: 4000 bus ID: 03:00.0 
           chip ID: 8086:0091 
           IF: wlp3s0 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8169 v: kernel port: 2000 
           bus ID: 0a:00.0 chip ID: 10ec:8168 
           IF: enp10s0 state: down mac: <filter> 
Drives:    Local Storage: total: 698.65 GiB used: 10.23 GiB (1.5%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 840 Series size: 232.89 GiB speed: 6.0 Gb/s serial: <filter> 
           ID-2: /dev/sdb vendor: Seagate model: ST9500420AS size: 465.76 GiB speed: 3.0 Gb/s serial: <filter> 
Partition: ID-1: / size: 211.34 GiB used: 10.23 GiB (4.8%) fs: ext4 dev: /dev/sda1 
Swap:      ID-1: swap-1 type: partition size: 17.16 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 52.0 C mobo: 36.0 C sodimm: 41.0 C gpu: nvidia temp: 43 C 
           Fan Speeds (RPM): cpu: 2428 
Info:      Processes: 244 Uptime: 2m Memory: 15.60 GiB used: 679.9 MiB (4.3%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
           Packages: pacman: 1233 Shell: Bash v: 5.0.18 running in: tty 0 inxi: 3.1.05
  • If there is noting in /sys/class/backlight none of the things you tried would have worked anyway as they all use this to change the brightness.
  • The 390 series seems to be the correct one got your GeForce GT 555M
  • An inxi --admin --verbosity=7 --filter --no-host --width would provide us with the kernel parameters of your install as well (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    I.E. Have you tried adding the acpi_backlight=vendor kernel parameter already?