Backlight not adjusting to backlight settings

I have recently switched to Manjaro GNOME (from Ubuntu), so the install very fresh. Since I installed it at night, I immediately ran into this issue: I can’t change the backlight brightness from the maximum brightness.

Whether I use function keys or any of the below commands, the brightness setting says it is changed, but the brightness stays on full.

echo 5 | sudo tee /sys/class/backlight/intel_backlight/brightness
xbacklight -25
gdbus call --session --dest org.gnome.SettingsDaemon.Power --object-path /org/gnome/SettingsDaemon/Power --method org.freedesktop.DBus.Properties.Set org.gnome.SettingsDaemon.Power.Screen Brightness "<int32 50>"

I have already tried adding these kernel options:


But none of them seem to change anything.

Does anyone have an idea how I could fix this?

inxi --full --verbosity=7 --filter --no-host output:

  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  Desktop: GNOME 3.38.3 tk: GTK 3.24.26 wm: gnome-shell dm: GDM 
  Distro: Manjaro Linux 
  Type: Laptop System: TOSHIBA product: SATELLITE P50-C v: PSPTSE-00Q003DU 
  serial: <filter> 
  Mobo: FF50 model: 06F2 v: Type2 - Board Version serial: <filter> 
  UEFI: INSYDE v: 5.10 date: 09/11/2015 
  ID-1: BAT1 charge: 15.8 Wh condition: 20.3/44.1 Wh (46%) volts: 15.9/14.8 
  model: Panasonic PA5195U-1BRS type: Li-ion serial: N/A status: Charging 
  cycles: 844 
  RAM: total: 7.69 GiB used: 2.37 GiB (30.8%) 
  RAM Report: 
  permissions: Unable to run dmidecode. Root privileges required. 
  Info: Dual Core model: Intel Core i7-5500U bits: 64 type: MT MCP 
  arch: Broadwell rev: 4 L2 cache: 4 MiB bogomips: 19160 
  Speed: 798 MHz min/max: 500/3000 MHz Core speeds (MHz): 1: 798 2: 798 
  3: 798 4: 798 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon 
  avx avx2 bmi1 bmi2 bts clflush cmov constant_tsc cpuid cpuid_fault cx16 
  cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority 
  flush_l1d fma fpu fsgsbase fxsr ht ibpb ibrs ida intel_pt invpcid 
  invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe msr mtrr 
  nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln 
  pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep smap 
  smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow 
  tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt 
  xtopology xtpr 
  Device-1: Intel HD Graphics 5500 vendor: Toshiba driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:1616 class ID: 0300 
  Device-2: NVIDIA GM108M [GeForce 930M] vendor: Toshiba driver: nvidia 
  v: 460.39 bus ID: 09:00.0 chip ID: 10de:1346 class ID: 0302 
  Device-3: Chicony TOSHIBA Web Camera - HD type: USB driver: uvcvideo 
  bus ID: 2-7:4 chip ID: 04f2:b446 class ID: 0e02 
  Display: x11 server: 1.20.10 compositor: gnome-shell driver: 
  loaded: modesetting,nvidia alternate: fbdev,intel,nouveau,nv,vesa 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 20.3.4 
  direct render: Yes 
  Device-1: Intel Broadwell-U Audio vendor: Toshiba driver: snd_hda_intel 
  v: kernel bus ID: 00:03.0 chip ID: 8086:160c class ID: 0403 
  Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Toshiba 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:9ca0 
  class ID: 0403 
  Sound Server: ALSA v: k5.9.16-1-MANJARO 
  Device-1: Intel Wireless 3160 driver: iwlwifi v: kernel port: 6040 
  bus ID: 07:00.0 chip ID: 8086:08b3 class ID: 0280 
  IF: wlp7s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Toshiba driver: r8169 v: kernel port: 4000 bus ID: 08:00.0 
  chip ID: 10ec:8168 class ID: 0200 
  IF: enp8s0 state: down mac: <filter> 
  WAN IP: <filter> 
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb 
  v: 0.8 bus ID: 2-6:3 chip ID: 8087:07dc class ID: e001 
  Message: Required tool hciconfig not installed. Check --recommends 
  Message: No RAID data was found. 
  Local Storage: total: 931.51 GiB used: 13.69 GiB (1.5%) 
  ID-1: /dev/sda vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB 
  speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 4M scheme: GPT 
  Message: No Optical or Floppy data was found. 
  ID-1: / size: 595.74 GiB used: 13.63 GiB (2.3%) fs: ext4 dev: /dev/dm-0 
  mapped: luks-c17cda1f-6283-4cff-be0d-25f09732593e label: N/A 
  uuid: 04f53f7b-91e4-4c50-a456-8e3312341813 
  ID-2: /boot/efi size: 96 MiB used: 57.7 MiB (60.1%) fs: vfat 
  dev: /dev/sda2 label: ESP uuid: A437-BCAB 
  ID-1: swap-1 type: partition size: 7.92 GiB used: 0 KiB (0.0%) 
  priority: -2 dev: /dev/sda8 label: N/A 
  uuid: 93998e19-b253-4260-856f-6eee42a66852 
  ID-1: /dev/sda1 size: 1024 MiB fs: ntfs label: WinRE 
  uuid: F09236C092368B5C 
  ID-2: /dev/sda3 size: 128 MiB fs: ntfs label: N/A uuid: 86E0FBEEE0FBE27B 
  ID-3: /dev/sda5 size: 477 MiB fs: ntfs label: N/A uuid: AA4E24154E23D939 
  ID-4: /dev/sda6 size: 12.53 GiB fs: ntfs label: Recovery 
  uuid: 001040D51040D378 
  ID-5: /dev/sda7 size: 303.11 GiB fs: ext4 label: N/A 
  uuid: 276fe933-51d6-4877-857d-2711520b5871 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Hub-2: 1-1:2 info: Intel Integrated Hub ports: 8 rev: 2.0 speed: 480 Mb/s 
  chip ID: 8087:8001 class ID: 0900 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 11 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Device-1: 2-1:2 info: Logitech Unifying Receiver type: Keyboard,Mouse 
  driver: logitech-djreceiver,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  chip ID: 046d:c534 class ID: 0301 
  Device-2: 2-6:3 info: Intel Bluetooth wireless interface type: Bluetooth 
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s chip ID: 8087:07dc 
  class ID: e001 
  Device-3: 2-7:4 info: Chicony TOSHIBA Web Camera - HD type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 04f2:b446 
  class ID: 0e02 
  Hub-4: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 
  speed: 5 Gb/s chip ID: 1d6b:0003 class ID: 0900 
  System Temperatures: cpu: 48.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 203 Uptime: 17m wakeups: 1 Init: systemd v: 247 Compilers: 
  gcc: N/A Packages: pacman: 1231 Shell: Zsh v: 5.8 
  running in: gnome-terminal inxi: 3.3.01

Seems to have been an issue in the 5.9 kernel. Upgrading to 5.10 solved this problem.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.