Back in Time - Cron - jobs are not excuted

Hello there,

I tried to search here and a general Google search, but could not find my problem. I think it may be Manjaro or Arch special - some default configuration missing and me being to noob to find the right topics to search for.

I’m using BackinTime (non-root) as my backup tool for my user directory and some other data folders.
I have different schedules for different profiles, all timer-based (cron jobs or anacron jobs). For example, my home directory should backup every hour.
Coming from Ubuntu-based distros, this has always worked for me.

Under Manjaro, the cron jobs are not excuted. (A cron -l gives a correct list of the jobs entered). Manually activating the backups works as intended.

Is it just me having no clue what I need to configure? Can someone point me in the correct direction, please?
(I remember having to install additional stuff for GUI printer configuration in GNOME as per Majaro WIKI, so maybe it is similar here)

Maybe cronie.service is disabled?

1 Like

Thanks!
Checked cronie’s status: it was loaded but inactive (dead).

~ >>> systemctl status cronie [1]
● cronie.service - Periodic Command Scheduler
Loaded: loaded (/usr/lib/systemd/system/cronie.service; enabled; vendor pr>
Active: inactive (dead)
…skipping…
● cronie.service - Periodic Command Scheduler
Loaded: loaded (/usr/lib/systemd/system/cronie.service; enabled; vendor pr>
Active: inactive (dead)

Tried a ‘sudo systemctl enable cronie’. Followed by a start of the service.

~ >>> systemctl enable cronie
~ >>> systemctl start cronie [1]
~ >>> systemctl status cronie
● cronie.service - Periodic Command Scheduler
Loaded: loaded (/usr/lib/systemd/system/cronie.service; enabled; vendor pr>
Active: active (running) since Fri 2021-01-01 23:27:26 CET; 4s ago
Main PID: 40901 (crond)
Tasks: 1 (limit: 19077)
Memory: 496.0K
CGroup: /system.slice/cronie.service
└─40901 /usr/bin/crond -n

Jan 01 23:27:26 rivendell systemd[1]: Started Periodic Command Scheduler.
Jan 01 23:27:26 rivendell crond[40901]: (CRON) STARTUP (1.5.5)
Jan 01 23:27:26 rivendell crond[40901]: (CRON) INFO (Syslog will be used instea>
Jan 01 23:27:26 rivendell crond[40901]: (CRON) INFO (RANDOM_DELAY will be scale>
Jan 01 23:27:26 rivendell crond[40901]: (CRON) INFO (running with inotify suppo>
~ >>>

After some minutes, rsync kicked in (with some popups about files it could not find, but at least, it started on its own…

I think, this was the solution, thanks for pointing me in the correct direction!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.