Ayuda!!! manjaro kde started tlp system startup/shutdow con video ati

Saludos, soy un nuevo usuario de manjaro, llevo unas semanas con el instalado, hasta hoy ningún problema, pero denante estuve tratando de instalar una interface tascam us- 428 usb con drivers alsa, y al parecer pase a llevar los drivers de video ati, el equipo se queda estancado con la pantalla en mensaje "started tlp system startup/shutdow " probé ingresando con control + alt +f2 y puedo ingresar a la consola con mi user , y ejecute el comando startx , pero me aparece error!!! como les comento soy novato en linux, les agradecería su ayuda!

Buscando algunos comandos por internet he podido dar con:
mhwd
mhwd --auto pci nonfree 0300

El primero me muestra el hardware y efectivamente cambie sin querer el freedriver por uno propietario para la tarjeta de video ati hd 8610g, el segundo comando debiera instalar , pero me arroja mensaje que se saltara el proceso por que ya esta instalado el catalyst, luego con una opcion que seria:
mhwd -r pci nonfree 0300, seria para remover el driver , me dice que no puedo hacerlo a menos de ser root, cuando instale manjaro, cree un root y un usuario y tengo las claves de ambos, como hago el proceso para dejar el video ati con driver free anterior , ya que desde ahí empezó el problema, les agradezco cualquier ayuda !!!

Si, es normal lo que te paso, con ATI/Radeon hay que usar lso drivers free, si o si.

Vas bien en lo que estas haciendo. Para lo de que te pide root, simplemente tienes que meter ese comando con el sudo delante, osea:
sudo mhwd -r pci nonfree 0300
y le metes la contraseña de sudo. Y luego ya instalar los free. Suerte.

1 Like

Saludos, gracias! al ingresar ese comando sudo mhwd -r pci nonfree 0300
Sale : Error: config ´nonfree´ is not installed!

Pues te dice que no estan instalados. Pon mhwd -li para listar los que tengas instalados, debería salirte video-linux y sino tienes ninguno, pues instala los free con sudo mhwd -a pci free 0300

De todas maneras, si se te queda parado en el mensaje del tlp, tambien puedes probar a desactivar el tlp con:
systemctl disable tlp.service
systemctl disable tlp-sleep.service
y reinicia, a ver si eso hace algo.

1 Like

me sale esa lista mhwd -li

aplique esto que me comentas
systemctl disable tlp.service
systemctl disable tlp-sleep.service
y reinicia, a ver si eso hace algo.

Se queda estancado en esa pantalla!

Que mal, tienes instalados los dos, los free y los non-free. Lo cual es un follón por que encima te habrá degradado de version los xorg y demás componentes esenciales.

Prueba con:
sudo mhwd -r pci video-catalyst
sudo rm -rf /etc/X11/xorg.conf.d/90-mhwd.conf
sudo rm -rf /etc/X11/mhwd.d/ati.conf
sudo rm "/etc/X11/xorg.conf"
sudo pacman -Rnc catalyst-input catalyst-server catalyst-utils catalyst-video
sudo pacman -Sy xf86-video-ati "xorg-server>1.19"
sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

Uno detrás de otro, reiniciar y cruza los dedos. Pero vamos, no te extrañe que te toque reinstalar.

Pude entrar como root y hacer ejecutar startx puedo ingresar con entorno grafico, no se si de ahi se pueda hacer algo mas, en realidad mas me interesa recuperar la sesion de usaurio donde tenia todos los archivos y programas, de todas maneras me arroja un eror de plasma , hice ping y tengo internet, peo firefox no levanta!

Por que entras como root? No te deja entrar con tu usuario?

No uses startx, usa startkde

Por lo que veo en las capturas, no se han desinstalado los non-free por un problema de dependencias. Asegurate de usar todo los comandos que te puse. Es imprescindible que elimines todos los catalyst

sudo pacman -Rnc catalyst-input catalyst-server catalyst-utils catalyst-video

y que instales xf86-video-ati y actualizar xorg-server a la ultima versión.

sudo pacman -Sy xf86-video-ati "xorg-server>1.19"

Sino, no vas a avanzar nada.

Amigo te cuento segui todo este proceso que me diste:
sudo mhwd -r pci video-catalyst
sudo rm -rf /etc/X11/xorg.conf.d/90-mhwd.conf
sudo rm -rf /etc/X11/mhwd.d/ati.conf
sudo rm "/etc/X11/xorg.conf"
sudo pacman -Rnc catalyst-input catalyst-server catalyst-utils catalyst-video
sudo pacman -Sy xf86-video-ati "xorg-server>1.19"
sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu
Y el quipo pasa del problema inicial que tenia,ahora entra a la consola , ingreso usuario y password, la unica forma de entrar al entorno grafico es con startx, startkde no me funciona?, ahora ya puedo ingresar a la sesion de mi usuario, salvo que entro por consola el login y debo colocar startx, no como antes que entraba al login grafico,y lo otro que no me toma el wifi, en realidad no me tomaba la ethernet ni wifi, pero logre seguir un procedimiento y me tomo la tarjeta por cable, el wifi no logro hacerlo funcionar, cambie kernel, desinstale drivers de la tarjeta broadcom wifi y nada, te agradezco mucho ya pude recuperar el escritorio, creo que ahora lo que falta ya no es nada al parecer,igualmente si me puedes indicar que hacer te agradezco ya que intente y no paso nada para recuperar el wifi!

Pero para que quieres hacer funcionar el wifi cuando el estado del sistema esta tan precario? No te renta mas guardar los datos que te interesen y reinstalar desde cero?

Las cosas de redes no son mi fuerte, pero si tu wifi es Broadcom, tienes que instalar el módulo correspondiente al kernel que uses. Osea linux50-broadcom-wl si usas el kernel 5.0, o linux419-broadcom-wl, etc...

Si con eso no te funciona, si entiendes inglés puedes probar a hacer esto siguiente, pero vamos, ya es un proceso mas complicado:

1 Like

Gracias por toda la orientacion, al final no pudo tomar la tarjeta wifi, lo intente varios dias y no hubo caso, inicie con usb para instalar manjaro de nuevo, particione el disco y comenze de 0, para no borrar la informacion y archivos mantube la particion anterior sin borrarla y pude recuperar todo, lo que si ahora al encender el notebook me aparecia un menu, donde podia seleccionar manjaro recien instalado y el anterior, note que el booteo demoraba mucho mas de lo normal , comparado cuando estaba sin particion y tenia un solo manjaro en el disco, buscando informacion pude modificar el grub y ahora parte directo sin menu , la particion antigua esta en sda1 y la nueva en sda3 la sda2 es swap, habra alguna forma de modificar el arranque para que sea mas rapido?
Mi equipo es un sony vaio: 8 GB de ram , disco solido de 1TB , creo que antes andaba mucho mas rapido el boteo,la verad estoy tratando de convencer a algunos amigo a que se animen a ussar manjaro, pero hoy hice un tiempo de boteo de un windows 10 en un i7 con 8 de ram y demoro 15 segundos y mi manjaro demoro casi 2 minutos 30 segundos!!! con este comando pude ver las caracteristicas, cualquier ayuda te agradezco!!!

CPU: Quad Core AMD A10-5745M APU with Radeon HD Graphics (-MCP-) speed/min/max: 2096/1100/2100 MHz
Kernel: 4.19.36-1-MANJARO x86_64 Up: 30m Mem: 1642.3/7166.4 MiB (22.9%) Storage: 953.87 GiB (11.2% used) Procs: 191
Shell: bash 5.0.3 inxi: 3.0.33

Como no hiciste instalación "limpia" de verdad, tiene pinta que tienes dos instalaciones a la vez y es muy posible que tengas un lío de montar particiones y sea eso lo que lo demore.

Necesitamos:

lsblk -f

cat /etc/fstab

cat /proc/cmdline

Copias y pegas aqui la salida de esos comandos de manera que se pueda ver bien por favor.

Esta es la salida de los comandos que me pides:

Lo siento pero tengo un problema de visión y no veo bien las fotos, por eso te decía lo de cortar y pegar.

1 Like

Asi sirve?

[eespinoza2@eespinoza ~]$ lsblk -f
NAME FSTYPE LABEL UUID FSAVAIL FSUSE% MOUNTPOINT
sda
├─sda1 ext4 eeeeae2c-8027-4b7a-b0e0-e41e5fc9e4f7
├─sda2 swap 1e5dfdcb-62a9-459a-8a2e-02d60eba7738 [SWAP]
└─sda3 ext4 1382c0ed-e163-46bc-a6b2-cb4e5621f3bb 333,5G 23% /
sr0
[eespinoza2@eespinoza ~]$ cat /etc/fstab

/etc/fstab: static file system information.

Use 'blkid' to print the universally unique identifier for a device; this may

be used with UUID= as a more robust way to name devices that works even if

disks are added and removed. See fstab(5).

UUID=1382c0ed-e163-46bc-a6b2-cb4e5621f3bb / ext4 defaults,noatime,discard 0 1
UUID=1e5dfdcb-62a9-459a-8a2e-02d60eba7738 swap swap defaults,noatime,discard 0 2
tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0
[eespinoza2@eespinoza ~]$ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64 root=UUID=1382c0ed-e163-46bc-a6b2-cb4e5621f3bb rw quiet resume=UUID=1e5dfdcb-62a9-459a-8a2e-02d60eba7738
[eespinoza2@eespinoza ~]$

Pues no veo nada raro la verdad. Las particiones están bien montadas. Lo único que la antigua sda1 no esta montada en el fstab, pero eso no debería ralentizar en un principio. Lo que no se es por que la pilla el grub.

Prueba a instalar haveged si no lo tienes ya, muchas veces eso hace que arranque mas rápido, sobre todo en KDE:

sudo pacman -S haveged --needed

systemctl enable haveged

Ah y a ver que dice esto sobre cuanto tarda cada cosa en arrancar:

systemd-analyze blame

Ok haveged lo instalo y quedo habilitado,al ingresar el comando systemd-analyze blame me arroja esto:
eespinoza2@eespinoza ~]$ systemd-analyze blame
1.276s lvm2-monitor.service
1.112s dev-sda3.device
1.009s systemd-logind.service
920ms udisks2.service
912ms mariadb.service
679ms systemd-udevd.service
638ms systemd-journald.service
449ms tlp.service
420ms ModemManager.service
412ms upower.service
250ms polkit.service
188ms systemd-journal-flush.service
155ms user@1000.service
137ms NetworkManager.service
123ms avahi-daemon.service
118ms systemd-udev-trigger.service
75ms systemd-tmpfiles-clean.service
72ms systemd-modules-load.service
47ms grub-boot-indeterminate.service
41ms org.cups.cupsd.service
39ms systemd-binfmt.service
35ms systemd-tmpfiles-setup.service
27ms user-runtime-dir@1000.service
26ms dev-hugepages.mount
25ms kmod-static-nodes.service
25ms dev-disk-by\x2duuid-1e5dfdcb\x2d62a9\x2d459a\x2d8a2e\x2d02d60eba7738.swap
24ms sys-kernel-debug.mount
24ms systemd-remount-fs.service
23ms systemd-tmpfiles-setup-dev.service
21ms sys-fs-fuse-connections.mount
21ms wpa_supplicant.service
20ms bluetooth.service
18ms dev-mqueue.mount
18ms systemd-user-sessions.service
17ms systemd-backlight@backlight:radeon_bl0.service
lines 1-35...skipping...
1.276s lvm2-monitor.service
1.112s dev-sda3.device
1.009s systemd-logind.service
920ms udisks2.service
912ms mariadb.service
679ms systemd-udevd.service
638ms systemd-journald.service
449ms tlp.service
420ms ModemManager.service
412ms upower.service
250ms polkit.service
188ms systemd-journal-flush.service
155ms user@1000.service
137ms NetworkManager.service
123ms avahi-daemon.service
118ms systemd-udev-trigger.service
75ms systemd-tmpfiles-clean.service
72ms systemd-modules-load.service
47ms grub-boot-indeterminate.service
41ms org.cups.cupsd.service
39ms systemd-binfmt.service
35ms systemd-tmpfiles-setup.service
27ms user-runtime-dir@1000.service
26ms dev-hugepages.mount
25ms kmod-static-nodes.service
25ms dev-disk-by\x2duuid-1e5dfdcb\x2d62a9\x2d459a\x2d8a2e\x2d02d60eba7738.swap
24ms sys-kernel-debug.mount
24ms systemd-remount-fs.service
23ms systemd-tmpfiles-setup-dev.service
21ms sys-fs-fuse-connections.mount
21ms wpa_supplicant.service
20ms bluetooth.service
18ms dev-mqueue.mount
18ms systemd-user-sessions.service
17ms systemd-backlight@backlight:radeon_bl0.service
17ms systemd-random-seed.service
17ms systemd-rfkill.service

Pues eso también se ve muy bien. Has reiniciado para ver si haveged ha echo algo?

Lo próximo que se me ocurre es que edites grub con:

sudo nano /etc/default/grub

Y quites quiet de GRUB_CMDLINE_LINUX_DEFAULT=

Guardar con Ctrl + O, salir con Ctrl + X y luego sudo update-grub.

Todo eso para que en el próximo arranque salgan todos los mensajes y te fijes donde se pueda quedar atascado.

Reinicie el equipo y demoro 25 segundos y me arroja esto con el comando,

[eespinoza2@eespinoza ~]$ systemd-analyze blame
1.206s lvm2-monitor.service
1.130s dev-sda3.device
1.050s systemd-logind.service
899ms mariadb.service
813ms udisks2.service
673ms systemd-udevd.service
624ms systemd-journald.service
569ms tlp.service
409ms upower.service
349ms ModemManager.service
278ms systemd-rfkill.service
212ms polkit.service
208ms systemd-journal-flush.service
133ms user@1000.service
121ms systemd-udev-trigger.service
115ms NetworkManager.service
84ms systemd-modules-load.service
83ms avahi-daemon.service
62ms systemd-binfmt.service
44ms org.cups.cupsd.service
41ms haveged.service
36ms systemd-tmpfiles-setup.service
30ms systemd-remount-fs.service
29ms dev-disk-by\x2duuid-1e5dfdcb\x2d62a9\x2d459a\x2d8a2e\x2d02d60eba7738.swap
27ms systemd-tmpfiles-setup-dev.service
25ms grub-boot-indeterminate.service
24ms sys-kernel-debug.mount
24ms wpa_supplicant.service
22ms dev-hugepages.mount
21ms proc-sys-fs-binfmt_misc.mount
20ms systemd-update-utmp.service
20ms bluetooth.service
20ms user-runtime-dir@1000.service
17ms systemd-random-seed.service
16ms rtkit-daemon.service
16ms kmod-static-nodes.service
15ms systemd-backlight@backlight:radeon_bl0.service
13ms systemd-user-sessions.service
12ms systemd-sysctl.service
10ms dev-mqueue.mount
10ms systemd-backlight@backlight:acpi_video0.service
10ms sys-kernel-config.mount
4ms tmp.mount