AX1650 WiFi Driver Issues

Hey everyone.

I have an HP Omen ax250wm which I just upgraded the HDD to an SSD (which works awesomely out of the box), and I tried to upgrade my WiFi module to a WiFi 6 (802.11ax) module. I was told by a random person (before I purchased it) that the drivers came with the linux50+ kernel by way of iwlwifi.

Over the past two days I've done everything I can think of to get it working correctly, and thus far have come up naught. My old WiFI module that came with the device is found without issue. Upon installing i3 and chrooting into the install inxi -Fxxxz returns (and WiFi works fine);

Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel port: 4000 bus ID: 04:00.00 [...]
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet [...]

However, when I installed the new module, and took the same steps (installing via Manjaro Architect v0.9.26 UEFI), it was recognized as a device, but there was no driver loaded. I tried running;

mhwd -a pci free 0280

Which returned;

Warning: No config found for device: 0000:04:00.0 (0280:8086:2723) Network controller Intel Corporation

Again, as I was told by some random guy, the WiFi drivers should be included in the wilwifi driver for the newer versions of the 5.0+ kernel, but despite trying on linux50, linux50-rt, and linux51 I still can't seem to get this device to use iwlwifi and thus load the proper driver.

Anyone have any suggestions or guidance? This hybrid laptop is a real pain when it comes to drivers.

You can download and test the most recent iwlwifi firmware from Intel.

Intel Firmware source:

That is, if your device truly uses the iwlwifi module.

Did you check your laptop models whitelist before you attempted a replacement. Is the model you purchased on the whitelist of compatible adapters for your bios.

If the replacement is not on the whitelist of accepted adapters it will not initialize.

As with everything that HP does, there's absolutely zero information online regarding anything even close to a whitelist for any hardware that HP seems to sell.

I've downloaded the .unicode driver from that Intel website and I've added it to /lib/firmware to no avail.

Feedback from the seller:

This is supported in the latest (5.1+) linux kernel's. It was added to the iwlwifi source in February. Installing/updating the latest kernel, or using backports should enable this in Linux without issue.

I'm at a loss considering this statement is clearly not true.


I've stumbled upon this commit from Linus which clearly states my device in iwlwifi so I'm confident this will work. I simply can't get between here and there.

But to be honest, it's all pretty moot considering the graphic drivers won't even install correctly. Updating to the newest linux51 kernel returns linux51-nvidia not found so when I try to boot into architect to install them that way, come to find out architect is running kernel 4.9 and can't even install them regardless.

Simply the state of drivers in linux is a fragmented hell of inconsistency and bullcrap.

You are sadly misinformed. The wifi devices the manufacturers permit to be swapped into their laptops is not a Linux limitation. This is an HP hardware limitation, it has absolutely nothing to do with the OS running on the device. If you were using Windows you would be subject to exactly the same restrictions. Complain to your manufacturer, don't cry about the state of Linux driver support because it has absolutely nothing to do with the drivers.

The manufacturers have whitelists of approved hardware PCI:ID's that will be accepted and run on their hardware. The PCI:ID of the device dictates whether the device will run on the restricted hardware. It is in no way influenced by the OS, or driver in use.

Linux is not responsible for the fact that the adapter you purchased will not run on your hardware, your manufacturers hardware restrictions are. You should have researched your purchase more carefully, rather than ranting about Linux's shortcomings. It was your lack of adequate research that is responsible for this wifi adapter not working, it is not related to Linux at all.

I'm sure your graphics drivers could have been made to work in Linux with the proper steps performed. It is far easier to rant and blame others than accept responsibility for your own inadequacies.

Perhaps you should return to Windows, as that OS seems more suited to your technical proficiency level.

This is an HP hardware limitation, it has absolutely nothing to do with the OS running on the device. If you were using Windows you would be subject to exactly the same restrictions.

I've already installed the module in the same laptop running Windows 10. It works perfect out of the box after installing Windows and using the driver explorer via Windows Update. You say it's not a linux issue, but graphic drivers and wireless drivers are notoriously difficult to get working. I know because I've been having the same issues on and off for the past 15 years with different hardware--since I started using *nix. Both the manufacturer and apparently Linus himself say this should work with linux50+ but it simply doesn't. Something in Manjaro specifically, or linux, is stopping the device from using iwlwifi as a driver, which is why I posted here for support from someone who is more experienced with Manjaro than I am. Your manufacturer=bad theory is great and all, but it doesn't make sense when it works under Windows but not *nix.

I really don't think it's too pointed to be frustrated with a distribution when graphics drivers work fine the very first time its setup on a device, and then never again, even though the setup steps are identical every single time. The first time I installed Manjaro via Architect I chose i3wm on linux50 and nonfree drivers installed fine and worked fine. Optirun worked great. I formatted the drive to accommodate a fresh start for the new WiFi module and graphics have not worked the same since.

As it stands I'm in some crazy limbo where I can't install nonfree drivers in linux50+ because they're not found even after syncing. Using any command via CLI which detects or uses hardware freezes and never completes, which forces me to use Architect, which would be fine except it's on the 4.9 kernel meaning I can't install linux50+ specific video drivers using mhwd. So as it stands there's no obvious way for me to get graphics working properly on linux50+ which would then let me get to my apex issue, which is my WiFi drivers.

The fact that this works under Windows doesn't help me in the least. I want this to work under *nix, and specifically Manjaro.

Any actual help would be appreciated. I'd very much like to get this working.


EDIT: Was finally able to fix graphics drivers. Still unable to get iwlwifi to take over as a driver.

Please post:

inxi -Fxxxz
rfkill list all
lsmod | sort
dmesg | grep wl
grep -r "blacklist\|install\|options"  /etc/modprobe.d/ /etc/modules-load.d/ /usr/lib/modprobe.d/
hwinfo --netcard --wlan --bluetooth | grep -Ei "model\:|driver\:|status\:|cmd\:|file\:|detected\:" | grep -v "Config Status" 

Also test this procedure:

Disconnect any other network devices that do not require troubleshooting. This includes LAN cables, USB to Ethernet adapters, and USB phone tethering.

Power down the laptop and remove the battery and power plug. Let the laptop sit without power for a few minutes. Then, hold down the power button for approximately 30 seconds. Pressing the power button will help drain all left over power from the unit’s motherboard.

Then reattach the AC power (no battery), and restart. Boot into your bios, then reset the bios to the factory defaults, save the default settings. See if it will boot correctly with the factory default settings. If not, you may have to change a few settings in the BIOS (such as secure boot) to get Manjaro to boot correctly. After rebooting your adapter may be properly detected and initialized.