awesome-wm windows have a slight concave shape top/bottom

i just noticed this in the past few days that the top and bottom of windows have a concave shape to them and show the wallpaper/background. it's not the laptop screen settings causing it since the wibar is fine and im left with a concave gap between wibar and whatever windows are below it.

anyone have an idea as to why or what to change in rc.lu/theme.lua ?

I cannot reproduce this. Is the concave part part of your browser or of the panel? I can't really tell from the screenshot. Do you have a compositor running? You could run "pkill compton" and see if the problem goes away.

the concave is on any window, whether it's a browser, a terminal, QT/GTK.

yes, but even after killing compton it remains. i think it has something to with gaps that i was playing with a few days back that i just now remembered. i was looking for a way to leave a small gap between terminal windows since i got rid of the title bar. im gonna take a look at what i did and i'll post it here. maybe you know of a better way of implementing it.

beautiful.useless_gap = "2" causes it. when i comment out the line and reload awesome the concave window shape is gone, but so are the gaps i set. i really only want the gaps for terminals but globally is fine also, any ideas on a better way to do this or a way of correcting the concave that useless_gap creates?

and thanks for your response, your help is appreciated.

my rc.lua

I'm not sure, this seems like a bug to me. In the doc it is specified as "the gap between clients". There's also nothing on it in the issue tracker.

when i was searching around for a way to set gaps there wasn't much i could find on it other than useless_gaps . maybe i can check unixporn for someone else using gaps and see how it's done, if they posted their rc.lua anyway.

i was thinking of maybe just using borders that are transparent since they only show when multiple windows are open but again, i dont see how it could be done.

this doesnt seem to make any difference at all:

client.connect_signal("focus", function(c)
                              c.border_color = beautiful.border_focus
                              c.opacity = 0
                           end)
client.connect_signal("unfocus", function(c)
                                c.border_color = beautiful.border_normal
                                c.opacity = 0
                             end)

i thought it would but the opacity values change nothing. :thinking:

EDIT: figured it out or at least figured out 1 way of doing it.

  • set border width in rc.lua
  • avoid setting gap or border transparency in rc.lua and instead set frame-opacity=0 in compton.conf.

it's not ideal if i dont have compton running but it's good enough for me.

I think this is an optical illusion the gaps are there.
If you have just one client open in tile mode, it also has a beautiful.useless_gap wide gap between itself and the borders of the screen / the wibar. You can check this by maximizing the window, then the gap should be gone. I think the curve you see is a optical illusion as a result of your wallpaper as it is dark at the sides and brighter in the middle. If you change to a all white wallpaper you should see the gaps.
After some research on the awesome github and the docs I found that there is:
beautiful.gap_single_client to get rid of it (https://awesomewm.org/doc/api/classes/tag.html#beautiful.gap_single_client) and it solves this for a single client.
But I found no quick way to enable gaps just for the terminal.
gap seems to be a variable of tag so it should be easy to have gaps just on one tag but per client is more complicated I think.

Edit: I just took your screenshot and filled the black part of your wallpaper in the left gap with red color to make the effect more visible:

1 Like

it was from me adding useless_gap, before that i never had that concave gap. after removing it and using transparent borders as a workaround everything looks exactly how i wanted it to. a single window or maximized window wont show a gap. only when multiple windows are open.

but yes, i do understand what your saying about the bright lines in the center being an illusion, i just knew i didnt have it before adding useless_gap which apparently also leaves a gap even in full screen though i dont know why..

I understand that, what I wrote was meant for the usage of useless_gap

Glad you have found a suitable workaround for you, I was just interested in finding the cause of the original issue and I think it is this:

When you use useless_gap, every client gets useless gaps as beautiful.gap_single_client defaults to true. Therefore, single (tiled) clients also have a gap around them. The gap shows only a part of your wallpaper, which colors make it appear to be concave, but in fact the gap is linear for the entire length of the screen.

Edit: I just wanted to also share my findings on how to use useless_gaps without a gap for single clients. I was aware you have found a workaround for yourself
Edit2: If you have a look into the github link you will see that this default behavior was requested by a hersbstluftwm user who thought it looked cool even with just one client

yeah, i was tricked by the brighter colors towards the center. looking back at them again even now it still looks concave. the top threw me off more than the bottom when what looked like a concave gap.

i looked in rc.lua and theme.lua for something to exclude a single window from being gapped but i didnt see it, im still on training wheels for lua, or code in general but it's starting to make more sense to me. i didnt even think there was any default gap behavior until i added useless gaps to rc.lua but i now understand what your saying about beautiful.gap_single_client and had i kept the useless_gap and set that to false i would get the desired behavior without needing a workaround and im likely going to switch back to it so gaps are consistent with or without compositing.

thanks for explaining it to me, i think i might of come across as dismissive of your suggestion though i wasnt trying to be and you were right, sorry if it came across that way.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by