Autostart of k3b - I want to disable that

What I have done:
I pinned the icon of k3b to the taskbar to autostart k3b.

Now I have two instances of k3b (version 19.04), which start automatically on start of desktop KDE.

When I close the two instances of k3b and log out of the desktop, then k3b does not start automatically.

When the computer is started into Manjaro KDE, then 2x k3b is started.

Look inside ~/.config/autostart/ and remove what you don't need.
You can also look inside ~/.config/plasma-workspace/env/ just in case.

In both ~/.config/autostart and ~./config/plasma-workspace/env is no entry related to k3b.

Impossible to guess. You must have added a custom command somewhere, and forgot about it.
Check your .xsession and/or your .xinitrc in your home folder for references to k3b.
Go to Settings > Startup and Shutdown > Autostart
Maybe you have a custom command there; in Desktop Session chose Start with an empty session and End current session
Make sure k3b has no pending Project loaded ...

Also check
System Settings --> Workspace --> Startup and Shutdown --> Autostart

oops, bogdancovaciu beaten me to it. :smile:

In my home folder is no .xsession and .xinitrc does not contain any autostart of k3b.
And in system settings -> Startup and Shutdown -> Autostart is only the entry of yakuake and not another one.

And k3b is started upon start of computer (not logout).

Maybe you have KDE configured to reopen applications on logon?

KDE is configured to start opened applications upon start.

What I have done:

  1. I have 4 desktops: 1st desktop Dolphin and Terminal, 2nd Firefox, 3rd Thunderbird, 4th I had opened k3b and pinned it to desktop #4

Now I want to not autostart k3b upon start of KDE.
So I closed both instances of k3b.

Test:

  1. Logout and login into KDE: k3b doesn´t start automatically
  2. Restart computer: k3b starts automatically despite the fact I have closed k3b.

I am unfamiliar with xfce stuff, but could it be due to this #xfce4-gtk3 stuff?
Try doing same (the k3b thingy) at not the #xfce4-gtk3 desktop but at other desktops and see if k3b fires up upon computer restart.

I have written

....and pinned it to desktop #4.

I have solved the problem myself:
Uninstallation and afterwards installation of k3b.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark