Automount HD at startup

I’ve been through Wiki and forum but cannot find simple explanation. Which I need because am lousy under-the-hood user despite being on Linux for over 10 years.

I have 3 drives in my Thinkpad W530:
An internal under-the-32GBRam 500 GB SSD (sdc). This is where my daily driver Gnome Manjaro used to be (well, it still is but it started malfunctioning recently to the point of being almost unusable, but that’s another story).
A 2 TB Data drive (sdb) inserted into the DVD Rom space using a container for that purpose. I have used this for 2 years without problem.
A new third drive, a 250 GB SSD (sda).

After trying many other distros because 2 weeks ago pacman was not working so every Manjaro install I tried - and every other Arch - was a mess, I returned to Manjaro Gnome 2 days ago and finally had a successful installation and got everything up and running again just like it used to be on the old Gnome OS have been using for almost 2 years.

Except getting the 2TB drive (sdb) to mount at startup.
(This has most of my data - plus most important stuff synced into a pCloud drive for I don’t really use the Home Directories).
When I go into ‘other locations’ in Nautilus, it mounts every time, no problem, but I cannot find out how to automount it on rebooting even though in Disks it is set to automount and it always used to do so just fine in the other system.

Note: this 2TB drive has 3 partitions, this being the first and main one (1 TB). That’s a change I made. (The other two partitions are for timeshift BU’s, one partition for the now almost dysfunctional daily driver Timeshifts, the other partition for the newly installed and seemingly working well (sda) system. I like to have two OS’s on hand in case OS1 craps out - as recently has been happening.)

Now maybe having 3 partitions is an issue, but I don’t believe it should be. In any case, in Disks it says that this first partition in the 2TB drive is auto mounting on startup, but it never does and I cannot find clear instructions anywhere on how to make this simple thing happen.

In Disks it says:
Mount at System Startup (checked)
Show in User interface (checked)
Require additional authorization section: all unchecked. Then:

Mount Point: /mnt/ec4a266c-f6e1-497c-91ab-af62b4230b7a
Identify as: /dev/disk/by-uuid/ec4a266c-f6e1-497c-91ab-af62b4230b7a
(I have tried identifying it as its name Label = 2TBData, but it makes no difference.)
Filesystem type: Auto

In the initial Disks Menu before you enter Settings to Edit Mount Options, it says:
Content: Ext 4 (version 1.0) - Mounted at: run/media/‘my user name’/2TBData.

Could some kind soul please tell me what specific steps I need to do in order to automount this partition at startup?

Thank you.

PS I went into Fstab and added the line:
UUID=ec4a266c-f6e1-497c-91ab-af62b4230b7a / ext4 defaults,noatime 0 0 (or 2)
but all that happens is that after Restart the disk doesn’t show up at all in Files so I cannot mount it by clicking on the icon.
The full fstab is: (with the 2TB uuid line ###-ed out)

UUID=fe64b8e5-27ee-4109-9270-431f953e2291 / ext4 defaults,noatime 0 1
#UUID=ec4a266c-f6e1-497c-91ab-af62b4230b7a / ext4 defaults,noatime 0 0
tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0


1 Like

First linking to some documentation :

The common way to mount partition automatically is to use fstab. When using gnome-disks like you are, you are actually editing that file.

Under the hood, the system actually translates fstab for systemd, so there is also sense in making the configuration directly for it.

Now a few tricks:

  • Once a partition is mounted, you can access it through its mount folder. But if you want “direct link” in your file manager side-panel, you can either:
    – use a folder in /media as mount point
    – add x-gvfs-show as mount option
  • You can easily check if your automount configuration works without rebooting : mount -a

Lastly, a question :

Why are you trying to mount your extra partition as the root folder?


Thanks for reply. Will try to digest the main part but as to your last question, I am not trying to mount it as root folder which is why ( I thought) the last column is either a 0 or 2, not 1 as per the first line which is the root folder. In any case, adding the line made no difference and I have commented it out with a # at the beginning of the line, no?

It looks like this part is the one for me to work with:

  • Once a partition is mounted, you can access it through its mount folder. But if you want “direct link” in your file manager side-panel, you can either:
    – use a folder in /media as mount point
    – add x-gvfs-show as mount option
  • You can easily check if your automount configuration works without rebooting : mount -a

Where it says: 'add x-gvfs-show is that added in the fstab line involving the 2TB partition (which you say I am trying to mount as root but which I just want to autostart/mount)?

If so would it look like this:
UUID=ec4a266c-f6e1-497c-91ab-af62b4230b7a / ext4 defaults,noatime,x-gvfs-show, 0 0.

But you seem to be saying that adding this line is a mistake since it makes it root.

It sounds like using the folder in /media as mount point is what I should do, but I don’t know how to effect this either in Disks or fstab.

I looked at the Mount Partition using Fstab Tutorial (why don’t these pages ever come up in searches??)
and went through the two mount command lines substitution ‘mydisk’ for ‘2TBData’ and then added in the three lines to the fstab:
su -
echo “UUID=$(lsblk -no UUID /dev/sdb1) $mount/2TBData $(lsblk -no FSTYPE /dev/sdb1) defaults,noatime 0 2” >> /etc/fstab
mount -a
but when running mount -a got message that those three lines were errors.
Then I realized I was supposed to run those lines in Terminal and did so and those commands added the following line into fstab:
UUID=ec4a266c-f6e1-497c-91ab-af62b4230b7a /2TBData ext4 defaults,noatime 0 2
After reboot, the disk is nowhere to be found so I cannot access it at all now.

(This is why after 10 years I am so lousy under the hood. Doing simple things like this either never get done or take days and when I have to do them again years later, cannot remember. So have learned almost nothing. Thankfully, I mainly just use the computer for doing things and don’t often have to fiddle. But when I do, it is always extremely baffling like now.)

See this : fstab - ArchWiki

Close : remove the last comma.

Take your time, it’s a long read.

THanks. Got nowhere this time around but will attack it again some other day. Am surprised at how difficult such seemingly simple things are to do. There should be a simple command in the coding to just auto-mount the drive at startup, something like: sudo automount sdb1. But of course there isn’t.

Well, I never could do it. Probably there’s a simple step I just don’t understand the language well enough to grasp. In any case, the HD never mounts and I have to mount it by clicking on it in Other Locations after which it is available. I still find it hard to believe this necessary thing is so complicated to set up. But thanks for trying to help.

I have never managed to get Virtual Box working in Manjaro either. Used it for years in Windows and other distros, but never once succeeded in Manjaro. Some things are just beyond my pay grade, I guess.

Try adding it like this in fstab then reboot
UUID=ec4a266c-f6e1-497c-91ab-af62b4230b7a /run/media/‘my user name’/2TBData ext4 defaults,noatime 0 0
Don’t forget to put your user name in without the ’

Straycat. Thank you. I did what you suggested however I figured that out myself (finally) and was returning to this thread to post that I had solved it.
Basically I did an lsblk after having mounted it via File Manager and saw it was in run/media/myusername/2TBData, put that into the line with its UUID and it worked just fine.

I don’t understand why it was so hard to figure it out given it takes about one minute to do, but that’s my experience with many of these things. I go through the Wiki but it has so many different options and variables for every single task that rarely do I learn anything from it and rarely does the problem get solved.

Anyway, this time it worked out and if I had read your offering it would have worked out 2 days earlier. I have notifications turned on but never get them.

Thank you.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.