Automatic reboot when shutdown | HP-ProBook 470-G0


#1

Hello, I’ll try to be as clear and efficient as possible.

Problem : Every time the computer shuts down, the power lights and fan stop, then the computer automatically reboots 3 seconds after. Only way I can shut down my computer is through a hard shutdown with pressing the power button for a long time (and I’d rather avoid doing that too often).

My computer is a HP-ProBook 470-G0, here is the output of inxi -Fxxxz :

System:
  Host: esteban-pc Kernel: 4.19.6-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN tk: Gtk 3.24.1 info: xfce4-panel 
  wm: xfwm4 dm: LightDM 1.28.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Hewlett-Packard product: HP ProBook 470 G0 
  v: A2019DD203 serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: Hewlett-Packard model: 1948 v: KBC Version 90.0C serial: <filter> 
  UEFI: Hewlett-Packard v: 68IRF Ver. F.04 date: 06/24/2013 
Battery:
  ID-1: BAT0 charge: 30.6 Wh condition: 40.4/40.4 Wh (100%) volts: 11.4/10.8 
  model: Hewlett-Packard Primary type: Li-ion serial: <filter> 
  status: Discharging 
CPU:
  Topology: Dual Core model: Intel Core i5-3230M bits: 64 type: MT MCP 
  arch: Ivy Bridge rev: 9 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20756 
  Speed: 1197 MHz min/max: 1200/3200 MHz Core speeds (MHz): 1: 1197 2: 1197 
  3: 1197 4: 1197 
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Hewlett-Packard 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0166 
  Device-2: AMD Mars [Radeon HD 8670A/8670M/8750M] vendor: Hewlett-Packard 
  driver: radeon v: kernel bus ID: 01:00.0 chip ID: 1002:6600 
  Display: x11 server: X.Org 1.20.3 driver: ati,intel,radeon 
  unloaded: modesetting alternate: fbdev,vesa resolution: 1600x900~60Hz 
  OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 18.2.6 
  compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:1e20 
  Sound Server: ALSA v: k4.19.6-1-MANJARO 
Network:
  Device-1: Ralink RT3290 Wireless 802.11n 1T/1R PCIe 
  vendor: Hewlett-Packard driver: rt2800pci v: 2.3.0 port: 3000 
  bus ID: 04:00.0 chip ID: 1814:3290 
  IF: wlo1 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8168 v: 8.045.08-NAPI port: 2000 
  bus ID: 05:00.0 chip ID: 10ec:8168 
  IF: enp5s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 465.76 GiB used: 205.94 GiB (44.2%) 
  ID-1: /dev/sda vendor: Toshiba model: MQ01ABF050 size: 465.76 GiB 
  speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 2C scheme: GPT 
Partition:
  ID-1: / size: 448.49 GiB used: 205.94 GiB (45.9%) fs: ext4 dev: /dev/dm-0 
  ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1 
Sensors:
  System Temperatures: cpu: 59.0 C mobo: N/A gpu: radeon temp: 54 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 183 Uptime: 8m Memory: 7.64 GiB used: 1.23 GiB (16.0%) 
  Init: systemd v: 239 Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 
  running in: xfce4-terminal inxi: 3.0.27

Based on my previous research, here is what I tried :

  • Remove any USB device or mouse plugged in before shutdown
  • Shutdown with systemctl poweroff instead of using the button
  • Disable the “Wake on LAN” option in my BIOS
  • Adding acpi=force at the end of GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub then running sudo update-grub
  • Adding acpi=noirq at the end of GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub then running sudo update-grub

I even tried completely disabling USB port in the BIOS just to check if it made any difference.

None of these made any difference.

If I can provide any more useful information I’d be glad to.


#2

It sounds like a hardware problem…
Are you dual-booting?
Have you tried to shutdown from LightDM?


#3

No, I’m not dual-booting.
What do you mean by “shutdown from LightDM” ? You mean shutdown using the GUI ? If so, I have tried that and it didn’t work.

It may be a hardware problem but there wasn’t any problem when I was using Windows 10 or Ubuntu before, no automatic reboot on shutdown. The only difference is :

  • It don’t remember if my Windows 10 was booting in UEFI or Legacy :confused:
  • Ubuntu was booting on Legacy
  • Manjaro is booting on UEFI because I couldn’t make it boot in Legacy (the first screen wouldn’t show up)