Autologin for Awesome ISO is not working

Autologin does not work on the Awesome live CD (I'll call it live image). If you install from the ISO, then the installed system (which I'll call installed image) does have working autologin, which means that it must be a configuration issue.

According to this SO question, autologin is configured in /etc/lightdm/lightdm.conf with the setting autologin-user.

In the installed image, it is correctly configured with autologin-user=frankk.
In live image, it is configured with autologin-user=manjaro (which should be fine).

Both frankk and manjaro user are member of autologin group.
Both images have ~/.dmrc with Session=awesome
Both images have /usr/share/xsessions/awesome.desktop with same content.

If I run lightdm --test-mode --debug, autologin works on both images (what the actual ****?!).

Checking /var/log/lightdm/lightdm.log in the live image shows this:

[+0.05s] DEBUG: Loading users from org.freedesktop.Accounts
[+0.05s] DEBUG: User /org/freedesktop/Accounts/User1000 added
[+0.13s] DEBUG: Seat seat0: Failed to find session configuration none
[+0.13s] DEBUG: Seat seat0: Can't find session 'none'
[+0.13s] DEBUG: Seat seat0: Creating greeter session
[+0.14s] DEBUG: Seat seat0: Creating display server of type x

The fact that it's looking for session 'none' is a hint. There's probably some kind of default that is set in the installed image but not in the live image. I'm not sure where to continue my search. Does anyone have ideas?

For completeness, both lightdm.conf files

From the live image:

[LightDM]
run-directory=/run/lightdm
[Seat:*]
pam-autologin-service=lightdm-autologin
greeter-session=lightdm-slick-greeter
session-wrapper=/etc/lightdm/Xsession
autologin-user=manjaro
autologin-user-timeout=0
[XDMCPServer]
[VNCServer]

And from the installed image:

[Seat:*]
[LightDM]
run-directory=/run/lightdm
[Seat:*]
greeter-session=lightdm-slick-greeter
session-wrapper=/etc/lightdm/Xsession
autologin-user=frankk
[XDMCPServer]
[VNCServer]

Hm, maybe it is some sort of configuration for the manjaro tools. I am not very familiar with them, but there is an option which enables the autologin (line 12,13):

However, it seems it is enabled by default:

Maybe you will find something in that direction. I mean for example Xfce also uses autologin with lightdm. So there has to be some sort of difference between the Awesome and the Xfce edition which causes this.

Ah yes. I failed to mention that I checked profile.conf in the iso profiles for these images. autorun=true is the default, and by inserting set -xv in strategic places in the manjaro-tools, I figured out that autorun is indeed set to true for both the Awesome and XFCE images.

Therefore I started my search backwards: figure out why the end result doesn't work, and then look which package or tool is creating the erroneous config file.

The XFCE live CD does have autologin working.

lightdm.conf on XFCE live CD
[LightDM]
run-directory=/run/lightdm
[Seat:*]
pam-autologin-service=lightdm-autologin
user-session=xfce
session-wrapper=/etc/lightdm/Xsession
autologin-user=manjaro
autologin-user-timeout=0
[XDMCPServer]
[VNCServer]

The only notable difference between the lightdm.conf files on the XFCE and Awesome live images is the fact that the XFCE image has user-session set. This might explain it (although user-session is also not set in the installed image).

So, I would like to change lightdm.conf, but I'm not sure where to do it. /etc/lightdm/lightdm.conf is supplied by the lightdm package. Apparently it is modified or overwritten, because the content is different for the different images. It is not overwritten by desktop-overlay or live-overlay, because it's not in there. What tool is writing lightdm.conf on either the live or installed image?

More things I tried that might or might not be relevant

I still don't have an explanation for why lightdm --test-mode does work (it shows an automatically logged in session).

I also don't have an explanation for this message: Seat seat0: Can't find session 'none'. If no session is configured, lightdm will fall back to default. The string none doesn't appear anywhere in lightdm's code. From that I conclude that the session has to be explicitly set to none somewhere (although I'm not 100% certain).

Looking through manjaro-tools, the only use of none is to set displaymanager (in the default configuration). In the Awesome profile.conf there is a line displaymanager=lightdm. So it doesn't seem likely that none is ending up in the user-session variable.

Forum kindly sponsored by