AUR package building is painfully slow

I’ve just made the switch from Gnome to KDE Plasma and tried installing ungoogled chromium. After more than an hour of “building” with fans kicked up on high, I forced a cancel.

Now I’m trying to install a different browser from AUR and now going on an hour again, high fans and “building.”

Is this normal, or is there something I’ve missed?

Building a browser like Chromium takes a long time and is very intensive. It could take 3 to 6 hours on a good machine.

Ok thank you. I didn’t miss anything or worse, break something :grin:. I just don’t recall ever waiting for an hour or more before, but also never tried the ungoogled chromium from aur either.

Might want to start the build before you go to bed with no other program open… especially browsers or Electron-based applications. :wink:

On notebooks I would avoid compiling.
…so you can choose a appimage or enable a private repo like this

All this (including the AUR) is outside the official repos, and on your responsibility.

Very good, thank you for the info. :+1:

i addition of previous post, there is also @cscs private repo. He is a manjaroo :kangaroo:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.