AUR conflict with official repository

Hello,

using Manajro 23.0.3 I have activatet AUR. The problem: Every day the paket manager wants to install the packages attached to this message.

These 3 packages are still installed from the official repository.

Any idea how to solve the problem?

Regards
Thomas
AUR

Welcome to the forum! :vulcan_salute:

You are probably using pamac in Software Mode, in which case it’s showing you all applicable software packages. Switching off Software Mode will show you only “full applications”.

Thank you very much! If I have understood you correctly: Software mode was/is off.

1 Like

Have you tried the “Refresh Databases” option in the menu?

Its simply that pamac doesnt do a good job differentiating and will gladly overwrite repo package with aur packages in cases where they have the same name.

Unless thats been changed/fixed recently?

2 Likes

I thought it was, but apparently it wasn’t.

I myself never use the pamac GUI either way. I use the pamac command-line utility from time to time, but only for AUR stuff — I always use pacman for repo packages — but there are so many problems with pamac that lately I just tend to use yay instead. And if I want to look up on information about a package, I’ll pull up octopi. :man_shrugging:

Don’t you mean: from the Manjaro repositories?

Please be advised that the posting of ChatGPT answers is seriously frowned upon here, unless you clearly point out that you have been using ChatGPT to beget the information you post.

I had updated the database several times in the last few days. But with today’s update the problem seems to be solved.

1 Like

There shouldn’t be any packages with the same name at all. It’s one of the requirements of uploading to AUR. (At least in regards to Arch repo.)

That is also one of the requirements. You can’t have two packages that provide same files installed at the same time.

It’s the opposite.

Manjaro is not Arch :person_shrugging:

pamac-cli for example is in the repos and the aur.

This problem is usually temporary and is resolved when packages on stable catch-up with packages released to other Manjaro branches and AUR
pamac cannot differentiate between packages with the same name, so it will suggest updating to an AUR package with the same name as repository package if AUR package has a higher version number.

This issue does not affect packages inherited from Arch because AUR packages are prohibited from having the same name as Arch packages

2 Likes

The ChatGPT bot you are replying to has been deleted. :smiling_imp:

As pointed out already, this is the expected behavior. If you have packages installed from the repositories, but they are also available in the AUR with the same name, and the AUR version has a higher version number, then if the AUR is enabled in Pamac, it will try to update from the AUR version.

This also happens when the package gets removed from the repositories, the AUR version takes precedence.

You probably had an outdated packages database in Pamac.

1 Like

Today the problem is back again: The 3 AUR-packages and additional “adw-gtk3” (also installed from orig.rep.) want to be installed…

Database update:
Warning
Invalid or corrupted file. Error synchronizing the (???)

:point_down:

He called it.

@TJF, or Chatbot:

Delete the databases:

sudo rm -rf /var/lib/pacman/sync/extra.db

and

sudo rm -rf /var/lib/pacman/sync/core.db

And try again.

:bangbang: Tip: :bangbang:

Also, in the future, when providing terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

```
pasted text
```

Or three (3) tilde signs, like this:

~~~
pasted text
~~~

This will just cause it to be rendered like this:

Portaest sed
elementum
cursus nisl nisi
hendrerit ac quis
sit
adipiscing
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby improving legibility and making it much easier for those trying to be of assistance.


:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

1 Like

@Mirdarthos
Thank you!

Now I get nearly the same warning. The warning is a gui-label - not a terminal output…

I get (complete message!):

Warning
Invalid or corrupted file.

OK, this tells me next to nothing. So open a terminal and run:

pamac checkupdates

…and provide the output as described earlier.

Only one terminal-line:

Your system is up to date.

But now the pamac gui doesn’t show the updates from AUR. The same as in my post 2 days ago.

Well, that doesn’t help me…

I don’t know what the reason for the error can be, then…I don’t have a clue about the GUI stuff as I use CLI and that message :point_down:

… isn’t descriptive enough (at least for me) to be able to know more.

I don’t really know who, if anyone, I should contact/notify/involve about this, so I’m going to tag the @moderators since they might know who to contact, at least.

@Mirdarthos
Thank you again!

One question: If I set “LC_ALL=C” is this only temporary or are my locale-settings gone after doing this?