Auflösung in Spielen nur vom Haupt-Monitor

Hallo,

Ich habe Manjaro Gnome Edition installiert.

Als Grafikkarte habe ich eine GTX 1070Ti mit aktuellem Nvidia Treiber.

Ich habe ein Dual Monitor Setup. Der linke Bildschirm ist 24" und der rechte 22".

Jetzt möchte ich die Gnome3-Top-Leiste auf dem 22" Monitor haben und auf dem 24" Monitor spielen/Programme benutzen. Damit die Leiste auf dem rechten 22" Monitor ist, muss ich diesen als Hauptanzeige definieren.

Wenn ich jetzt aber Spiele starte, werden mir in den Optionen des Spiels nur die möglichen Auflösungen des 22" Monitors angezeigt, jedoch nicht vom 24" Monitor.

Kann mir dabei jemand helfen?

Danke!

Definiere aktuell :wink: , egal :slight_smile:

Poste bitte die Ein- und Ausgabe von

$ inxi -Fxxxza --no-host

und

welcome-01-sgs :slight_smile:

Hallo SGS,

Danke für die Begrüßung!

Hier die Infos:

$ inxi -Fxxxza --no-host
System:
  Kernel: 5.3.0-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.3-x86_64 
  root=UUID=f9f3503e-ddb7-4534-9ab3-39314c3e78cf rw rootflags=subvol=@ quiet 
  udev.log_priority=3 
  Desktop: Gnome 3.32.2 wm: gnome-shell dm: GDM 3.32.0 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX Z370-H GAMING v: Rev 1.xx 
  serial: <filter> UEFI: American Megatrends v: 0505 date: 10/11/2017 
CPU:
  Topology: 6-Core model: Intel Core i7-8700K bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: A (10) 
  microcode: B4 L2 cache: 12.0 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 88824 
  Speed: 800 MHz min/max: 800/4700 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 802 11: 800 12: 801 
  Vulnerabilities: Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
Graphics:
  Device-1: NVIDIA GP104 [GeForce GTX 1070 Ti] vendor: ASUSTeK 
  driver: nvidia v: 435.21 bus ID: 01:00.0 chip ID: 10de:1b82 
  Display: x11 server: X.org 1.20.5 driver: nvidia compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: GeForce GTX 1070 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 435.21 
  direct render: Yes 
Audio:
  Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a2f0 
  Device-2: NVIDIA GP104 High Definition Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f0 
  Device-3: Logitech HD Pro Webcam C920 type: USB 
  driver: snd-usb-audio,uvcvideo bus ID: 1-2:2 chip ID: 046d:082d 
  serial: <filter> 
  Device-4: Corsair type: USB driver: hid-generic,snd-usb-audio,usbhid 
  bus ID: 3-1:2 chip ID: 1b1c:0a14 
  Sound Server: ALSA v: k5.3.0-1-MANJARO 
Network:
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k 
  port: f000 bus ID: 00:1f.6 chip ID: 8086:15b8 
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 1.62 TiB used: 74.33 GiB (4.5%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 500GB 
  size: 465.76 GiB block size: physical: 512 B logical: 512 B 
  speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 1B2QEXE7 scheme: GPT 
  ID-2: /dev/sda vendor: Samsung model: SSD 850 PRO 1TB size: 953.87 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 4B6Q scheme: MBR 
  ID-3: /dev/sdb vendor: Samsung model: SSD 850 PRO 256GB size: 238.47 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 3B6Q scheme: GPT 
Partition:
  ID-1: / raw size: 237.97 GiB size: 237.97 GiB (100.00%) 
  used: 74.32 GiB (31.2%) fs: btrfs dev: /dev/sdb2 
  ID-2: /home raw size: 237.97 GiB size: 237.97 GiB (100.00%) 
  used: 74.32 GiB (31.2%) fs: btrfs dev: /dev/sdb2 
Sensors:
  System Temperatures: cpu: 40.0 C mobo: N/A gpu: nvidia temp: 46 C 
  Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 0% 
Info:
  Processes: 280 Uptime: 1m Memory: 31.30 GiB used: 1.18 GiB (3.8%) 
  Init: systemd v: 242 Compilers: gcc: 9.1.0 Shell: bash v: 5.0.9 
  running in: gnome-terminal inxi: 3.0.36

Ich kann da leider nicht weiter helfen da ich weder gnome noch zwei Monitore benutze.
Aber evtl. solltest du schon mal ein BIOS Update machen?


Version 2102
2019/07/19

BIOS Update klingt gut. Werde ich machen.

Danke für den Versuch :slight_smile:

Eventuell weiß jemand anderes Rat?

Bestimmt, ich wecke mal @gosia :wink:
Die Spezialisten findest du aber wahrscheinlich schneller im englischen Forum.
Versuche auch die Forumsuche "display settings dual monitor".

Hallo SGS,

netter Versuch. Aber wenn ich was von "Hardware" höre überfällt mich so ein mächtiges Gähnen, daß ich eine Minute später in einen Tiefschlaf falle, aus dem mich niemand mehr ... zzz zzz zzz ...grafik

1 Like

Ist bei dem Spiel unter Einstellung ein Fenstermodus möglich?
Wenn ja, mal auf den 24Zöller verschieben, speichern, Spiel beenden und dann mal wieder starten.

Bleibt das Spiel auf dem 24er? Jetzt in den Spiele Einstellung der Monitor sichtbar?

Den Fenstermodus habe ich aktiviert und das Spiel verschoben. Im Spiel kann ich auch den zu benutzenden Monitor angeben (Monitor 1 und Monitor 2). Die Auflösungsoptionen bleiben trotzdem nur die, des 22 Zöllers :frowning:

Auch nach dem Neustart des Spiels. Das Spiel bleibt aber auf dem Monitor, auf dem es zuletzt war.

Um welches Spiel handelt es sich denn?
In einigen Fällen hilft es, die Konfigurationsdatei des Spiels ausfindig zu machen und manuell abzuändern.

Es handelt sich um World of Warcraft. Ich weiß ich komme immer nur kleckerweise mit Informationen um die Ecke, aber weiß nicht genau was ich alles angeben soll :smiley:

In der Konfigurationsdatei config.wtf (Konfigdatei von WoW) habe ich die Auflösung 1920x1200 manuell angegeben - ohne Erfolg.

Servus!
Probier doch mal Umschalt+Super(Windows Taste)+Rechts (oder Links, Hoch, Runter), das sind die Standard Hotkeys für Gnome um Fenster zu anderen Monitoren zu verschieben.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by