Audioengine B1 bluetooth receiver - cannot reconnect, only repair


I’m om 5.7.19-2 on a B550I AORUS PRO AX mini-ITX mainboard with built in bluetooth 5.0. Pulseaudio-bluetooth 13 has been installed automatically. I’ve not installed pulseaudio-modules-bt because aptx is hardware dependant and no mainstream mainboard has it afaik and I’m not sure how to apply/when the rest of the package bits are applied.

Recently acquired an Audioengine B1 (a bluetooth receiver) for my hifi setup (RX6 + Yamaha A-500).

When powered up it goes into pairing mode and my computer paired with it and I can play audio fine. If I turn BT on my computer off (or the machine is turned off or goes to sleep) or if I disconnect the B1 in the Gnome BT panel the connection is lost and the B1 goes into pairing mode for five minutes, a bit speculatively, and then its light goes off. If I turn my machine or bluetooth on again and attempt to reconnect the Gnome BT slider switches to on and then off immediately and the B1 never reacts.
Journalctl says
bluetoothd[1771]: connect error: Device or resource busy (16)

If I try to reconnect to it with my iOS device the B1 accepts immediately, its light turns on and I can stream music. Disconnect connect disconnect connect no issue.

I can re-pair the B1 to my computer without incident and then it will work until the connection is dropped and after that it fails to reconnect again. When it connects after pairing journalctl says:
bluetoothd[1771]: /org/bluez/hci0/dev_00_22_D9_00_1A_36/sep1/fd8: fd(151) ready

If I connect my older Logitech BT adapter , which automatically reconnects when a paired device is in range, I cannot keep it disconnected and when I switch BT on it connects to the computer immediately and shows connected in the BT panel in Gnome.
Journalctl says:
bluetoothd[1771]: /org/bluez/hci0/dev_88_C6_26_0B_34_77/sep1/fd6: fd(60) ready

Additional troubleshooting:
I have a Windows partition on the same machine only due to Planetfall PBEM and the same B1 and computer will disconnect and reconnect without an issue. Furthermore I inserted an Asus USB BT400 adapter in this machine while Manjaro was running and then turned BT off and on and I think it was using the adapter because the B1 could pair, connect, disconnect, connect without incident.

Any helpful hints? : /

Just to put this issue to rest and provide some sort of further info in case someone stumbles upon this in 2047 : )

After further troubleshooting including reinstallations of OSes and realizing that this [Solved] No bluetooth from AX200 / Kernel & Hardware / Arch Linux Forums is true (the AX200 chip is shifty and can drop BT entirely some boots. Then you need to unplug your machine from its power source and wait ten seconds like. ) were sooth I started looking at using my Asus BT400 USB adapter for sending audio instead (it can reconnect after disconnecting).

Therefore I am using “Blueman” I think (or bluetoothctl) to select the Asus adapter and make it the default bluetooth adapter (for when the AX200 bluetooth circuitry decides to show up). With pulseaudio-modules-bt several audio profiles are selectable to send to the B1, incl AptX. (Am not sure how that rhymes with the hardware requirement of the sender : Qualcomm® aptX™ Automotive | Bluetooth® Car Stereos & Receivers ). The B1 receives “AptX” it says (orange status light) so here come a few listening sessions.

1 Like

I’ve marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (I just want to avoid even more subjective opinions being posted and confusing you even more)

P.S. In the future, please mark a solution like this:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.