Audio when using Kdenlive 20, Microphone voice over-Strange

System: Gigabyte Z87-OCX 4th Gen Haswell i-7 ; 32 GB Ram Corsair Ripjaws; Nvidia 760 RTX

Hello Everyone.
Today I went to spend $100.00 at bestbuy because I thought the usb microphone I bought may have not been working in Kdenlive Flatpak ver 20. After you tubing and figuring out what the problem could be-After I already bought this expensive microphone- I went to my system settings and selected the hardware from the dropdown list in line output and selected the green checkmark in the box. The audio recording capability worked. But I could only play back and hear it when I unplugged the USB. This is strange because on other applications that I have used before, including Kdenlive before, this never happened before and the application would allow you to play the inserted audio for one to edit and play with without having to unplug it. Can anyone help me figure out what is wrong wit this setting? I have even used audacity in the past and never had to unplug my microphone before to hear what I have produced. This is for my son’s school project which they only gave us two days notice. and its due tomorrow. Can any one please help me understand this ? Thank you in advance!!!

Your post is really hard to read.

I guess your new microphone has also a loudspeaker or at least your system identifies it as such.
In the settings, for example in ‘pavucontrol’, you can set it to only input.