Audio Problems since latest update (25 May 2022) / PulseAudio instabilities

Since I started up this morning I seem to have several issues with audio.

Initially I noticed that trying to convert some downloaded WAVs to FLAC files was failing - Then I tried playing the files to see if there was an issue with them and they wouldn’t play at all.

I then tried some other (known good) files and had the same result.

I plugged in some cheap speakers into my headphones socket and I have sound output from there working OK. My main audio outputs via USB to an external DAC and that has just completely stopped working.

Can anyone point me in the right direction as to what’s been changed in the last week that could impact this?

Her’s my Inxi…

  Host: SILVER Kernel: 5.15.41-1-MANJARO arch: x86_64 bits: 64
    Console: pty pts/0 Distro: Manjaro Linux
  Type: Desktop System: ASUS product: N/A v: N/A serial: N/A
  Mobo: ASUSTeK model: PRIME Z690-P D4 v: Rev 1.xx serial: 210992078509415
    UEFI: American Megatrends v: 1008 date: 01/13/2022
  Info: 6-core model: 12th Gen Intel Core i5-12600 bits: 64 type: MT MCP
    cache: L2: 7.5 MiB
  Speed (MHz): avg: 969 min/max: 800/6100 cores: 1: 1201 2: 1200 3: 765
    4: 1112 5: 844 6: 637 7: 864 8: 692 9: 922 10: 745 11: 702 12: 1953
  Device-1: Intel driver: i915 v: kernel
  Device-2: Microsoft LifeCam Studio type: USB
    driver: hid-generic,snd-usb-audio,usbhid,uvcvideo
  Display: server: v: with: Xwayland v: 22.1.1 driver: X:
    loaded: modesetting,nvidia gpu: i915 resolution: 1: 2560x1440~60Hz
    2: 2560x1440~30Hz
  OpenGL: renderer: Mesa Intel Graphics (ADL-S GT1) v: 4.6 Mesa 22.0.4
  Device-1: Intel Alder Lake-S HD Audio driver: snd_hda_intel
  Device-2: Microsoft LifeCam Studio type: USB
    driver: hid-generic,snd-usb-audio,usbhid,uvcvideo
  Device-3: Cambridge Audio Azur DacMagic 100 type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound Server-1: ALSA v: k5.15.41-1-MANJARO running: yes
  Sound Server-2: PulseAudio v: 15.0 running: yes
  Sound Server-3: PipeWire v: 0.3.51 running: yes
  Device-1: Realtek RTL8125 2.5GbE driver: r8169
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: 04:42:1a:e9:5a:c5
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
  Local Storage: total: 9.1 TiB used: 2.96 TiB (32.5%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 980 PRO 500GB
    size: 465.76 GiB
  ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 980 PRO 1TB
    size: 931.51 GiB
  ID-3: /dev/sda vendor: Western Digital model: WD40EZRZ-22GXCB0
    size: 3.64 TiB
  ID-4: /dev/sdb vendor: Western Digital model: WD40EZRZ-00GXCB0
    size: 3.64 TiB
  ID-5: /dev/sdc vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB
  ID-1: / size: 423.41 GiB used: 169.62 GiB (40.1%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 292 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-1: swap-1 type: partition size: 34.21 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme0n1p3
  System Temperatures: cpu: 50.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 401 Uptime: 7m Memory: 31.1 GiB used: 6.75 GiB (21.7%)
  Shell: Zsh inxi: 3.3.16

I found that killing and restarting pulseaudio seems to bring it back, but then track skipping or trying a different file to play will just make it die again.

pulseaudio --kill
pulseaudio --start

PulseAudio seems really unstable - PA Volume Control is now hanging for me on “Establishing connection to PulseAudio. Please wait…”

Converting files have nothing to do with pulseaudio, so that’s a different issue.

Is there a reason you’re using pulseaudio? You could try pipewire:

pamac install manjaro-pipewire

(Beware of what will be removed; if in doubt, ask first)

…mine (xfce, install about 1 month old, defaulting to pulseaudio, no changes):

  Sound Server-1: ALSA v: k5.17.9-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.51 running: no

…use either one or the other.

I’ve thought about playing around with pipewire but I but so much effort into getting pulseaudio working with my DAC properly the idea doesn’t fill me with joy.

Something to try out when I have a spare few days at least. I have noticed recently that more and more distros seem to be switching over to pipewire as standard so I need to factor it in at some point.

Nice spot @banjo - That would explain a lot. Looks like PipeWire has been turned on. That may not play well (pun fully intended), I guess.

Quite possibly it wasn’t installed before and it’s been added recently as a dependency.

Will try this…

systemctl --user --now disable pipewire-media-session
systemctl --user --now disable pipewire

And see what happens post reboot (crossing fingers)

I did that @banjo - No joys. If I try and play music I’m getting nothing at all through the DAC output (This is actually worse than before, as it would work sometimes and then cut out). My tiny little plug in speakers that I use for zoom calls etc. seem to work fine if I switch the audio output over there but I’m getting nothing out of the main output at all. Same with a game - No audio at all.

This was all working fine before the recent raft of updates and is still working fine on my Windows and Ubuntu Studio partitions.

Just checked my System Monitor and PipeWire is still running - doesn’t look like it wants to be disabled fully.

Have re-enabled as follows anyway to set it back…

systemctl --user --now enable pipewire
systemctl --user --now enable pipewire-media-session

Not sure what I can do about that - I don’t want to start uninstalling it (If I even can with dependencies).

@mithrial - Wil linstalling manjaro-pipewire essentially switch everything over from PA to PW? That’s looking like my best option ATM.

…either this or the other. ( manjaro-pulse )

Edit: manjaro-pulse is default, at least here on xfce. If you install manjaro-pulse it will conflict with manjaro-pipewire and vice versa. There should only be one.

…you have it (explicly) installed ?

I already have manjaro-pulse so It’ll be a switch attempt.

Here goes nothing - At least I can update my DAC article for pipewire as well as pulseaudio.


No - Nothing explicit.

The behaviour is VERY odd. My audio just came back after playing a YouTube video in my browser, switching the Output from speakers back again to the Digital and Audio outputs for the DAC, and opening pavcontrol again.

Am installing manjaro-pipewire now.

In the end @mithrial 's suggestion of installing manjaro-pipewire seems to have got everything working again, in a basic sense anyway.

I am now getting fairly reliable output from my DAC but it seems everything is outputting at 48kHz, so my configuration to allow for multiple bitrates and sample rates is no longer being honoured (This was for pulse so this is expected anyway). I now have an “Azur DacMagic Pro” playback option which is new but it seems no different from the other two I had before in terms of the output.

I shall dig into PipeWire and look at how I can get my DAC working optimally and update my DAC setup article with PipeWire config over the next few weeks, hopefully.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.