Audio not working after latest update

After latest update, my audio stopped working. Sound applet in KDE system tray says “No output or input devices found”. I’ve tried every suggestion I could find on the net, but nothing helped.

inxi -Aa
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: ASUSTeK P8Z77-V LX
    driver: snd_hda_intel v: kernel bus-ID: 2-1.5:3 chip-ID: 0735:0269 bus-ID: 00:1b.0
    chip-ID: 8086:1e20 class-ID: 0102 class-ID: 0403 serial: SN0001
  Device-2: Asuscom Network HD 1080P PC-Camera type: USB driver: snd-usb-audio,uvcvideo
  Device-3: Yealink Network YHS3X-USB type: USB driver: hid-generic,snd-usb-audio,usbhid
    bus-ID: 2-1.6:4 chip-ID: 6993:b007 class-ID: 0301 serial: A02017101003
  Sound API: ALSA v: k6.0.6-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.59 running: yes

Output of --upload is located at (replaced dot with “-dot-” because it doesn’t let me include links):


dmesg doesn’t show any audio errors.

Answering my own question, I tried so many things so I am not sure what did the trick, but I think it’s the removal of config files and reinstall. Perhaps this will help someone

rm -r .config/pipewire* .config/pulse*
sudo rm -r /etc/pipewire* /etc/pulse.bak
sudo pacman -S pipewire pipewire-pulse pipewire-media-session --noconfirm && systemctl --user enable pipewire pipewire-pulse pipewire-media-session && systemctl --user restart pipewire pipewire-pulse pipewire-media-session

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.