Audio 'Line In' is not Being Detected on Machine

Hello, Im having trouble with my ‘Line In’ audio. I have two monitors(one machine), the first monitor is using HDMI as audio(works perfect). The second monitor I want to use the auxiliary port as audio. I have the AUX cord going from the monitor to the ‘Line In’ on my machine. Im doing this so I can hear my PS4 audio and PC audio at the same time. All of of my hardware works, I know this because I was using this same setup on Windows. Ive tried researching this problem but none of the solutions worked for me. Thank you in advance.

‘sudo alsa-info.sh --upload’ output:

http://alsa-project.org/db/?f=d2567c4dcf7cdc9382abe6fb686e376d1f7c47d7

'inxi -Fazy' output:

System:
  Kernel: 5.10.117-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
    root=UUID=33223392-cca6-499e-8ed9-a51a775de7fd rw quiet
    udev.log_priority=3
  Desktop: GNOME v: 42.1 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM v: 42.0
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASRock model: B450M-HDV R4.0
    serial: <superuser required> UEFI-[Legacy]: American Megatrends v: P3.70
    date: 11/14/2019
Battery:
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
CPU:
  Info: model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+
    family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 1721 high: 3044 min/max: 1550/3400 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1548 2: 1961
    3: 1303 4: 1270 5: 3044 6: 1557 7: 1479 8: 2743 9: 1268 10: 1418 11: 1527
    12: 1535 bogomips: 81471
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Retpolines, IBPB: conditional, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: Micro-Star MSI driver: amdgpu v: kernel pcie: gen: 3 speed: 8 GT/s
    lanes: 16 ports: active: HDMI-A-1,HDMI-A-2 empty: DP-1,DP-2,DVI-D-1
    bus-ID: 08:00.0 chip-ID: 1002:67df class-ID: 0300
  Display: wayland server: X.org v: 1.21.1.3 with: Xwayland v: 22.1.1
    compositor: gnome-shell driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa gpu: amdgpu
    display-ID: 0
  Monitor-1: HDMI-A-1 model: ASUS VG34V serial: <filter> built: 2021
    res: 3440x1440 dpi: 110 gamma: 1.2 size: 797x334mm (31.38x13.15")
    diag: 864mm (34") modes: max: 3440x1440 min: 720x400
  Monitor-2: HDMI-A-2 model: VG245 serial: <filter> built: 2018
    res: 1920x1080 dpi: 92 gamma: 1.2 size: 531x299mm (20.91x11.77")
    diag: 609mm (24") ratio: 16:9 modes: max: 1920x1080 min: 720x400
  OpenGL: renderer: AMD Radeon RX 580 Series (polaris10 LLVM 13.0.1 DRM 3.40
  5.10.117-1-MANJARO)
    v: 4.6 Mesa 22.0.4 direct render: Yes
Audio:
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: Micro-Star MSI driver: snd_hda_intel v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 08:00.1 chip-ID: 1002:aaf0 class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0a:00.3
    chip-ID: 1022:1457 class-ID: 0403
  Device-3: C-Media Blue Snowball type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-2:2 chip-ID: 0d8c:0005
    class-ID: 0300 serial: <filter>
  Sound Server-1: ALSA v: k5.10.117-1-MANJARO running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASRock driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: f000 bus-ID: 07:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 6.82 TiB used: 1.86 TiB (27.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT500MX500SSD1
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 023 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 model: 2.5 SATA SSD 3MG2-P size: 924.06 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
    serial: <filter> rev: 815 scheme: MBR
  ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Western Digital
    model: WD My Book 25ED size: 5.46 TiB block-size: physical: 4096 B
    logical: 512 B type: N/A serial: <filter> rev: 1031 scheme: GPT
Partition:
  ID-1: / raw-size: 924.06 GiB size: 908.48 GiB (98.31%)
    used: 184.86 GiB (20.3%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 36.4 C mobo: N/A gpu: amdgpu temp: 48.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1164
Info:
  Processes: 330 Uptime: 1h 22m wakeups: 8 Memory: 31.28 GiB
  used: 2.73 GiB (8.7%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1107 lib: 312 flatpak: 0
  Shell: Zsh v: 5.9 running-in: gnome-terminal inxi: 3.3.16

install the 5.15 and 5.17 kernel, also install sof-firmware, reboot and try with each of those kernels

Okay, ill try right now thank you. I will get back to you

This unfortunately didnt work. I can see line in under Input now but the most i can hear when i enable loop-back is static : (

you can also install the 5.18rc kernel … also install pipewire-media-session, it will remove wireplumber, or if you have it alredy installed, install wireplumber, and then reboot, select kernel and test
if it doesnt work post output from:
systemctl --user status pipewire

okay thank you. i will try right now

it didnt work, the output for that comand is :

● pipewire.service - PipeWire Multimedia Service
Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; vendor preset: enabled)
Active: active (running) since Sun 2022-05-29 13:31:32 EDT; 4min 29s ago
TriggeredBy: ● pipewire.socket
Main PID: 1254 (pipewire)
Tasks: 2 (limit: 38415)
Memory: 5.8M
CPU: 1.152s
CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
└─ 1254 /usr/bin/pipewire

May 29 13:31:32 manjaro systemd[1053]: Started PipeWire Multimedia Service.

nothing there…
run this command:
alsamixer and press f6 select your audio device and check if all is unmuted

this is what i see. i raised the line in yesterday and enabled loop-back. i also tried disabling auto mute mode

but you have enabled auto mute, disable it… and did the audio worked before? since when does it not work? did you install something/uninstall/updated … etc?

i enable and disable with every change to see if that changes anything. and it never worked i was using the setup on windows and wanted to use it on manjaro