Audio Issues TigerLake-LP

Hello everyone.

I am very very new to Linux and I need help. I have a Samsung Galaxy Book pro and Manjaro is working flawlessly. Except Audio. My Audio device shows Intel Tiger Lake LP and I followed this guide to get audio to work h t t p s : / / forum manjaro org/t/howto-set-up-the-audio-card-in-samsung-galaxy-book/37090 .

On Ubuntu that fix worked flawlessly. On Manjaro im having issues. Massive issues. Sometimes I have both speakers working. Sometimes only the right channel. Sometimes none at all. It happens at random when I restart or shutdown and reboot and it is incredibly frustraiting especially when all I want to do is listen to music and do my work.

I have tried re-installing and applying that fix I linked above multiple times now and no dice. I have tried hdajackretask and that doesn’t do anything either. I have tried using both pulseaudio and pipewire to no avail either.

This speakers work flawlessly in Windows 11 and Ubuntu when I do what the thread linked above specified but not in Manjaro and that is the distro I want to use. I’ve been at this for a week following guides and fixes in threads but so far nothing works in Manjaro. I’ve updated Manjaro so its all up to date but nothing.

I really want to swap to Manjaro full time as my OS of choice and not have to go back to Windows but I need the speakers working properly.

Thanks for the help.

Share output of inxi -Fazy.

Here is the output. I am at a total loss on how to get the audio working reliably

  Kernel: 5.15.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=0a3421c6-4d36-4416-982f-596fdd4e6ed5 rw quiet
  Desktop: GNOME 41.3 tk: GTK 3.24.31 wm: gnome-shell dm: GDM 41.3
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: SAMSUNG product: 935XDB v: P03AKE
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: SAMSUNG model: NP935XDB-KC1UK
    v: SGLA884A0U-C01-G001-S0001+10.0.19042 serial: <superuser required>
    UEFI: American Megatrends LLC. v: P03AKE.044.210602.SH date: 06/02/2021
  ID-1: BAT1 charge: 29.7 Wh (47.1%) condition: 63.1/62.0 Wh (101.9%)
    volts: 15.1 min: 15.4 model: SAMSUNG Electronics SR Real Battery
    type: Li-ion serial: <filter> status: Discharging cycles: 21
  Info: model: 11th Gen Intel Core i5-1130G7 bits: 64 type: MT MCP
    arch: Tiger Lake family: 6 model-id: 0x8C (140) stepping: 1 microcode: 0x8A
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB L3: 8 MiB
    desc: 1x8 MiB
  Speed (MHz): avg: 855 high: 1046 min/max: 400/4000 scaling:
    driver: intel_pstate governor: powersave cores: 1: 829 2: 931 3: 715 4: 922
    5: 1020 6: 456 7: 927 8: 1046 bogomips: 28888
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
 Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel vendor: Samsung Co driver: i915 v: kernel bus-ID: 00:02.0
    chip-ID: 8086:9a40 class-ID: 0300
  Device-2: Generic 720p HD Camera type: USB driver: uvcvideo bus-ID: 3-6:4
    chip-ID: 2b7e:0173 class-ID: fe01 serial: <filter>
  Display: wayland server: compositor: gnome-shell driver:
    loaded: i915 note: n/a (using device driver) - try sudo/root display-ID: 0
    resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Samsung Co
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0401
  Sound Server-1: ALSA v: k5.15.16-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.43 running: yes
  Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
    bus-ID: 2e:00.0 chip-ID: 8086:2725 class-ID: 0280
  IF: wlp46s0 state: up mac: <filter>
 Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-3:2
    chip-ID: 8087:0032 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 238.47 GiB used: 15.9 GiB (6.7%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZ9LQ256HBJD-00B
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: FXM7AK1Q temp: 33.9 C scheme: GPT
  ID-1: / raw-size: 237.97 GiB size: 233.74 GiB (98.22%)
    used: 15.89 GiB (6.8%) fs: ext4 dev: /dev/nvme0n1p3 maj-min: 259:2
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 4.6 MiB (0.9%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 58.0 C mobo: 58.0 C
  Fan Speeds (RPM): N/A
  Processes: 256 Uptime: 0m wakeups: 61 Memory: 7.46 GiB
  used: 1.91 GiB (25.6%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: pacman: 1068 lib: 326 Shell: Zsh v: 5.8
  running-in: gnome-terminal inxi: 3.3.12

Are you able to see sof-hda-dsp by typing alsamixer

Launch alsamixer in the terminal and modify volumes:

press F6,
ensure the sof-hda-dsp sound card is listed,
select it
increase the volume in all the columns,
ensure the db Gain (displayed at the top left corner) never exceeds 0.00


Yeah I am. Ive turned the volume on everything all the way up but no dice. like I said that guide works perfectly fine when done in ubuntu and they work on windows.

htt ps://imgur com/a/uNQLSGC

Everything seems fine to me. Can you install the manjaro-pipewire package and reboot. If it still occurs maybe @nikgnomic could help you.

Just installed it and no dice. No output from speakers at all.