Audio devices not working on boot until I re-plug them

In the last month or so I’ve encountered a problem with my manjaro system, where my usb microphone nor my headphones play any sound on boot. They are detected by the system, and if I play any audio or try to talk on discord the sound bars on pulseaudio move as if it was actually working. It will continue like that until I unplug and plug the device.
At first it just happened with the microphone, but since last week or so it also happens with my headphones. I tried restarting pulseaudio, checking if everything is alright on alsamixer and changing between audio drivers but couldn’t get any results.
I can’t think of anything I have tweaked in the system that could have caused this, maybe it was since an update but I really doubt that. Tried searching but I couldn’t find any other information about this online so, do you guys know anything I could try? Any help is appreciated of course, thanks for reading!

Hi @natan-r1 ,
I wonder whether this link could help you in order to solve the problem.
PulseAudio/Troubleshooting - ArchWiki


What kernel are you on? Out of curiosity, have you tried with 5.13 (or vice versa with 5.10?)

That is a possibility with recent update for PulseAudio

Hello, thanks for the info link! I tried some solutions listed there but none of them worked for me. I found the way to fix the headphone issue but my microhpone still does not record anything on boot despite it being detected by the system.

I was on 5.12 even when the devices were working fine, just updated to 5.13 but the issue persists. Thanks for the idea tho!