Audacity won't start: Aborted (core dumped)

After a recent system update I can’t run Audacity.

Here’s what I get when I try:

$ audacity 
01:20:28: Warning: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1013,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1014,wx containers,compatible with 2.8).

(audacity:272139): Gtk-WARNING **: 01:20:28.647: Theme parsing error: gtk.css:2:33: Failed to import: Error opening file /home/unfa/.config/gtk-3.0/window_decorations.css: No such file or directory

I’ve tried reinstalling Audacity - nothing changed.
I’ve done a full system update (pacman -Syu) - no luck.

Does anybody know what I can do to get Audacity working again?

Are you sure that was a full update?
Do you have mirrors changing?
( systemctl | grep mirrorlist )

So maybe try sudo pacman -Syyu

Also … if it is the theme … what theme are you using? Have you tried others?

Hey! Is pacman -Syyu really any different from pacman -Syu? I’ve heard someone saying it’s not really doing anything differently.

For whatever reason when I suspended and resumed my system Audacity has started on it’s own loading a file I tried to open it with before as if it was blocked by something and now was free to start up.

I’ve tried running it again and now it prints the same theme error message, but doesn’t stop there, prints much more output (seems like regular stuff it does every time it runs normally) and finally prints this and crashes:

Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4628
Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4628
Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4628
audacity: ../common/JackGraphManager.cpp:48: void Jack::JackGraphManager::AssertPort(jack_port_id_t): Assertion `port_index < fPortMax' failed.
Aborted (core dumped)

I’ve restarted my JACK and PulseAudio servers thinking it may be the cause - no change.

When I fiddle with disconnecting my USB audio interface and restarting JACK & PA it starts sometimes, but then gets back to Aborted (core dumped).

I haven’t switched away from the Audacity’s default theme - also it seems now that it’s not the root of the problem.

try rebuilding wxgtk.

sudo pacman -S wxgtk  

Also for the second issue.

Since your starting audacity from a terminal the errors are kinda normal. Audacity looks into different methods of connecting to the sound system till it probes the sound system that works.

So if jack is not working it should normally find a different method.

Do you need Jack and if so did you set the user to the realtime group and did a setup as described here?

I’ve reinstalled it - it didn’t compile anything, its’ a binary package - didn’t change anything.

I think there’s must be a problem with JACK:

audacity: ../common/JackGraphManager.cpp:48: void Jack::JackGraphManager::AssertPort(jack_port_id_t): Assertion `port_index < fPortMax' failed.


I’ve just run alsa_in and it crashed too the same way, so obviously something’s wrong with the audio stack,. and not Audacity itself.

WARNING: Rate doesn't match (requested 48000Hz, get 32000Hz)
WARNING: buffer size does not match: (requested 2048, got 1365)
WARNING: period size does not match: (requested 1024, got 682)
selected sample format: 16bit
alsa_in: ../common/JackGraphManager.cpp:48: void Jack::JackGraphManager::AssertPort(jack_port_id_t): Assertion `port_index < fPortMax' failed.
Aborted (core dumped)

I’ve been using JACK for years and it’s been working fine just last week. I can run Ardour and other software like Olive without issues as well.

Which means it is most likely an audacity problem.

Perhaps someone who is more into audacity can help. Or you could try the audacity forum

Correction: it seems any audio software I try to run now crashes the same way.
Ardour, Carla etc.

I think I’ll reboot and see if that’ll help.

1 Like

man pacman

-y, --refresh
           Download a fresh copy of the master package database from the server(s) defined
           in pacman.conf(5). This should typically be used each time you use --sysupgrade
           or -u. Passing two --refresh or -y flags will force a refresh of all package
           databases, even if they appear to be up-to-date.

Meaning the 2 ys is for forcing a full refresh/sync.
It isnt usually necessary unless you change branches or mirrors.
But, as I mentioned, by default many systems use a service that sorts mirrors in the background.
Hence the 2 y’s will be necessary if that timer is running.