Attempt to update an uploaded image issue

When I attempt to edit a post and update the uploaded image it results in this forum error, I have tried another browser, renaming the image, and using another image.

lib/discourse.rb:56:in `exec': convert: improper image header `/tmp/image20191229-5704-17cqwl2.jpg' @ error/png.c/ReadPNGImage/4293.

I'm not sure what the problem could be, but judging from the error message it looks like a PNG image file with the extension .jpg. Or it could be that the required image format is PNG and you try to upload a JPG. Another possibility is that the image is corrupt.

I’m not quite sure where the .jpg extension is coming into play in the error as it’s a .png image, I remotely hosted the file as a work around to the Manjaro forum issue and it displays fine.

I didn’t attempt a to use a .jpg file as the original one I posted was a .png, I’ve seen other forums spit out similar nonsense errors when a file size is too large, but it seems to me I’ve uploaded files here much larger than 3mb in the past.

I think on the forum side it’s trying to convert the .png to display in .jpg, and something has happened to prevent it in this particular post.

1 Like

When you edit the post, and want to "update" an image, simply delete it from your post and upload the new one in that place.
But, do not abuse the image upload, better use services like


or the one you prefer.

I did this very thing, which is why I posted this.

I am marking the post solved, though the error I ran into is still an issue.

Forum kindly sponsored by