Ath11k (Killer AX500-DBS) cannot connect to eduroam MSCHAPv2 network

I have two laptops, one with the ath11k device and the other with, I believe, an ath10k wifi adapter which has no problem connecting to eduroam.

I copied the relevant NetworkManager system-connection to the new ath11k computer, changing the device to the correct wifi adapter. I restarted NetworkManager and then it tried to automatically connect and it tries for a couple of seconds, and then prompts for a single password. I cancel this and the connection is failed.

I have tried with kernels 5.10 and 5.12 and 5.13.0 rc4. No changes to this, and I am running the latest firmware available for the device (I checked the linux-firmware git).

I can confirm that I am able to connect to the eduroam AP from Windows 10 on the same laptop.

[connection]
id=eduroam
uuid=2298a860-469b-4b60-959b-504327a65b88
type=wifi
interface-name=wlp113s0
permissions=user:sour:;

[wifi]
mac-address-blacklist=
mode=infrastructure
ssid=eduroam

[wifi-security]
key-mgmt=wpa-eap

[802-1x]
eap=ttls;
identity=<my uni email>
password=my password
phase2-auth=mschapv2

[ipv4]
dns-search=
method=auto

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
method=auto

[proxy]

And the system:

System:
  Kernel: 5.13.0-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 
  root=UUID=<filter> rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 memmap=12M$20M 
  Desktop: KDE Plasma 5.21.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
Machine:
  Type: Laptop System: Dell product: XPS 13 9310 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 0DMPXV v: A00 serial: <filter> UEFI: Dell v: 2.2.0 
  date: 04/06/2021 
Battery:
  ID-1: BAT0 charge: 51.0 Wh (100.0%) condition: 51.0/51.0 Wh (100.0%) 
  volts: 8.7 min: 7.6 model: LGC-LGC6.5 DELL 2XXFW11 type: Li-poly 
  serial: <filter> status: Full 
Memory:
  RAM: total: 31.07 GiB used: 4.07 GiB (13.1%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Info: Quad Core model: 11th Gen Intel Core i7-1185G7 bits: 64 type: MT MCP 
  arch: Tiger Lake family: 6 model-id: 8C (140) stepping: 1 microcode: 86 
  cache: L2: 12 MiB bogomips: 47936 
  Speed: 496 MHz min/max: 400/4800 MHz Core speeds (MHz): 1: 496 2: 549 
  3: 1090 4: 757 5: 791 6: 565 7: 971 8: 487 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities 
  arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2 avx512_vnni 
  avx512_vp2intersect avx512_vpopcntdq avx512bw avx512cd avx512dq avx512f 
  avx512ifma avx512vbmi avx512vl bmi1 bmi2 bts cat_l2 cdp_l2 clflush 
  clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl 
  dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma 
  fpu fsgsbase fsrm fxsr gfni ht hwp hwp_act_window hwp_epp hwp_notify 
  hwp_pkg_req ibpb ibrs ibrs_enhanced ida intel_pt invpcid invpcid_single 
  lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b movdiri msr mtrr 
  nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge 
  pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed rdt_a rdtscp rep_good 
  sdbg sep sha_ni smap smep smx split_lock_detect ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tme tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi vpclmulqdq vpid 
  x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel Iris Xe Graphics vendor: Dell driver: i915 v: kernel 
  bus-ID: 0000:00:02.0 chip-ID: 8086:9a49 class-ID: 0300 
  Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus-ID: 3-6:3 chip-ID: 0c45:672a class-ID: 0e02 
  Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: 
  loaded: intel unloaded: modesetting alternate: fbdev,vesa display-ID: :0 
  screens: 1 
  Screen-1: 0 s-res: 3456x2160 s-dpi: 96 s-size: 914x571mm (36.0x22.5") 
  s-diag: 1078mm (42.4") 
  Monitor-1: eDP1 res: 3456x2160 hz: 60 dpi: 303 size: 290x180mm (11.4x7.1") 
  diag: 341mm (13.4") 
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.1.2 
  direct render: Yes 
Audio:
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Dell 
  driver: sof-audio-pci-intel-tgl 
  alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3 
  chip-ID: 8086:a0c8 class-ID: 0401 
  Sound Server-1: ALSA v: k5.13.0-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.30 running: no 
Network:
  Device-1: Qualcomm vendor: Rivet Networks driver: ath11k_pci v: kernel 
  port: efa0 bus-ID: 0000:71:00.0 chip-ID: 17cb:1101 class-ID: 0280 
  IF: wlp113s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  IF-ID-1: docker0 state: down mac: <filter> 
  IP v4: <filter> scope: global broadcast: <filter> 
  WAN IP: <filter> 
Bluetooth:
  Message: No bluetooth data found. 
Logical:
  Permissions: Unable to run lvs. Root privileges required. 
RAID:
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd 
  v: 0.6 port: 3000 bus-ID: 0000:00:0e.0 chip-ID: 8086.9a0b rev: 
  class-ID: 0104 
Drives:
  Local Storage: total: 953.87 GiB used: 38.38 GiB (4.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: KIOXIA 
  model: KXG60ZNV1T02 NVMe 1024GB size: 953.87 GiB block-size: physical: 512 B 
  logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> 
  rev: 10604107 scheme: GPT 
  Message: No optical or floppy data found. 
Partition:
  ID-1: / raw-size: 439.45 GiB size: 431.48 GiB (98.19%) used: 38.3 GiB (8.9%) 
  fs: ext4 dev: /dev/nvme0n1p7 maj-min: 259:7 label: N/A 
  uuid: <filter> 
  ID-2: /boot/efi raw-size: 190 MiB size: 186 MiB (97.89%) 
  used: 77.2 MiB (41.5%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  label: ESP uuid: <filter> 
Swap:
  Alert: No swap data was found. 
Unmounted:
  ID-1: /dev/nvme0n1p2 maj-min: 259:2 size: 128 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 496.45 GiB 
  fs: <superuser required> label: N/A uuid: N/A 
  ID-3: /dev/nvme0n1p4 maj-min: 259:4 size: 990 MiB fs: <superuser required> 
  label: WINRETOOLS uuid: <filter> 
  ID-4: /dev/nvme0n1p5 maj-min: 259:5 size: 15.32 GiB fs: <superuser required> 
  label: Image uuid: <filter> 
  ID-5: /dev/nvme0n1p6 maj-min: 259:6 size: 1.37 GiB fs: <superuser required> 
  label: DELLSUPPORT uuid: <filter> 
USB:
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 1 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 3-3:2 info: Shenzhen Goodix FingerPrint type: <vendor specific> 
  driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 27c6:533c class-ID: ff00 
  Device-2: 3-6:3 info: Microdia Integrated_Webcam_HD type: Video 
  driver: uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s power: 500mA 
  chip-ID: 0c45:672a class-ID: 0e02 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
Sensors:
  System Temperatures: cpu: N/A mobo: N/A 
  Fan Speeds (RPM): cpu: 0 fan-2: 0 
Info:
  Processes: 216 Uptime: 1d 16m wakeups: 6042 Init: systemd v: 248 
  tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.0 Packages: pacman: 1452 
  lib: 391 flatpak: 0 Shell: Zsh v: 5.8 default: Bash v: 5.1.8 
  running-in: kitty inxi: 3.3.04

journalctl output of the connection:

Jun 15 10:53:17 manjarocomp systemd[1]: Started Network Manager.
Jun 15 10:53:17 manjarocomp audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=NetworkManager comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Jun 15 10:53:17 manjarocomp kdeconnectd[1212]: propsReply "No such interface “org.freedesktop.DBus.Properties” on object at path /org/freedesktop/NetworkManager"
Jun 15 10:53:17 manjarocomp audit[4337]: USER_END pid=4337 uid=1000 auid=1000 ses=2 subj==unconfined msg='op=PAM:session_close grantors=pam_limits,pam_unix,pam_permit acct="root" exe="/usr/bin/sudo" hostname=? addr=? terminal=/dev/pts/2 res=success'
Jun 15 10:53:17 manjarocomp audit[4337]: CRED_DISP pid=4337 uid=1000 auid=1000 ses=2 subj==unconfined msg='op=PAM:setcred grantors=pam_faillock,pam_permit,pam_env,pam_faillock acct="root" exe="/usr/bin/sudo" hostname=? addr=? terminal=/dev/pts/2 res=success'
Jun 15 10:53:17 manjarocomp kded5[1094]: propsReply "No such interface “org.freedesktop.DBus.Properties” on object at path /org/freedesktop/NetworkManager"
Jun 15 10:53:17 manjarocomp sudo[4337]: pam_unix(sudo:session): session closed for user root
Jun 15 10:53:17 manjarocomp systemd[1]: Starting Network Manager Wait Online...
Jun 15 10:53:17 manjarocomp kded5[1094]: nmReply "No such interface “org.freedesktop.NetworkManager” on object at path /org/freedesktop/NetworkManager"
Jun 15 10:53:17 manjarocomp kdeconnectd[1212]: nmReply "No such interface “org.freedesktop.NetworkManager” on object at path /org/freedesktop/NetworkManager"
Jun 15 10:53:17 manjarocomp NetworkManager[4343]: <info>  [1623718397.7877] manager[0x5568772bd030]: monitoring kernel firmware directory '/lib/firmware'.
Jun 15 10:53:17 manjarocomp kdeconnectd[1212]: "Object path cannot be empty"
Jun 15 10:53:17 manjarocomp kded5[1094]: "Object path cannot be empty"
Jun 15 10:53:17 manjarocomp dbus-daemon[418]: [system] Activating via systemd: service name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostname1.service' requested by ':1.640' (uid=0 pid=4343 comm="/usr/bin/NetworkManager --no-daemon ")
Jun 15 10:53:17 manjarocomp audit: BPF prog-id=19 op=LOAD
Jun 15 10:53:17 manjarocomp audit: BPF prog-id=20 op=LOAD
Jun 15 10:53:17 manjarocomp systemd[1]: Starting Hostname Service...
Jun 15 10:53:17 manjarocomp wpa_supplicant[723]: nl80211: deinit ifname=wlp113s0 disabled_11b_rates=0
Jun 15 10:53:17 manjarocomp dbus-daemon[418]: [system] Successfully activated service 'org.freedesktop.hostname1'
Jun 15 10:53:17 manjarocomp systemd[1]: Started Hostname Service.
Jun 15 10:53:17 manjarocomp audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=systemd-hostnamed comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Jun 15 10:53:17 manjarocomp NetworkManager[4343]: <info>  [1623718397.8740] hostname: hostname: using hostnamed
Jun 15 10:53:17 manjarocomp NetworkManager[4343]: <info>  [1623718397.8741] hostname: hostname changed from (none) to "manjarocomp"
Jun 15 10:53:17 manjarocomp NetworkManager[4343]: <info>  [1623718397.8745] dns-mgr[0x55687728e110]: init: dns=default,systemd-resolved rc-manager=symlink
Jun 15 10:53:17 manjarocomp NetworkManager[4343]: <info>  [1623718397.8756] rfkill1: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.0/0000:71:00.0/ieee80211/phy0/rfkill1) (driver ath11k_pci)
Jun 15 10:53:17 manjarocomp NetworkManager[4343]: <info>  [1623718397.8759] manager[0x5568772bd030]: rfkill: Wi-Fi hardware radio set enabled
Jun 15 10:53:17 manjarocomp NetworkManager[4343]: <info>  [1623718397.8759] manager[0x5568772bd030]: rfkill: WWAN hardware radio set enabled
Jun 15 10:53:17 manjarocomp NetworkManager[4343]: <info>  [1623718397.8847] Loaded device plugin: NMTeamFactory (/usr/lib/NetworkManager/1.30.4-3/libnm-device-plugin-team.so)
Jun 15 10:53:17 manjarocomp NetworkManager[4343]: <info>  [1623718397.8851] Loaded device plugin: NMAtmManager (/usr/lib/NetworkManager/1.30.4-3/libnm-device-plugin-adsl.so)
Jun 15 10:53:17 manjarocomp NetworkManager[4343]: <info>  [1623718397.8870] Loaded device plugin: NMWwanFactory (/usr/lib/NetworkManager/1.30.4-3/libnm-device-plugin-wwan.so)
Jun 15 10:53:17 manjarocomp NetworkManager[4343]: <info>  [1623718397.8874] Loaded device plugin: NMOvsFactory (/usr/lib/NetworkManager/1.30.4-3/libnm-device-plugin-ovs.so)
Jun 15 10:53:17 manjarocomp NetworkManager[4343]: <info>  [1623718397.8880] Loaded device plugin: NMBluezManager (/usr/lib/NetworkManager/1.30.4-3/libnm-device-plugin-bluetooth.so)
Jun 15 10:53:17 manjarocomp NetworkManager[4343]: <info>  [1623718397.8884] Loaded device plugin: NMWifiFactory (/usr/lib/NetworkManager/1.30.4-3/libnm-device-plugin-wifi.so)
Jun 15 10:53:17 manjarocomp NetworkManager[4343]: <info>  [1623718397.8888] manager: rfkill: Wi-Fi enabled by radio killswitch; enabled by state file
Jun 15 10:53:17 manjarocomp NetworkManager[4343]: <info>  [1623718397.8890] manager: rfkill: WWAN enabled by radio killswitch; enabled by state file
Jun 15 10:53:17 manjarocomp NetworkManager[4343]: <info>  [1623718397.8891] manager: Networking is enabled by state file
Jun 15 10:53:17 manjarocomp NetworkManager[4343]: <info>  [1623718397.8893] dhcp-init: Using DHCP client 'internal'
Jun 15 10:53:17 manjarocomp NetworkManager[4343]: <info>  [1623718397.8894] settings: Loaded settings plugin: keyfile (internal)
Jun 15 10:53:17 manjarocomp NetworkManager[4343]: <info>  [1623718397.8966] device (lo): carrier: link connected
Jun 15 10:53:17 manjarocomp NetworkManager[4343]: <info>  [1623718397.8970] manager: (lo): new Generic device (/org/freedesktop/NetworkManager/Devices/1)
Jun 15 10:53:17 manjarocomp NetworkManager[4343]: <info>  [1623718397.8978] device (wlp113s0): driver supports Access Point (AP) mode
Jun 15 10:53:17 manjarocomp NetworkManager[4343]: <info>  [1623718397.8986] manager: (wlp113s0): new 802.11 Wi-Fi device (/org/freedesktop/NetworkManager/Devices/2)
Jun 15 10:53:17 manjarocomp NetworkManager[4343]: <info>  [1623718397.9001] device (wlp113s0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
Jun 15 10:53:17 manjarocomp NetworkManager[4343]: <info>  [1623718397.9623] device (wlp113s0): set-hw-addr: set MAC address to <filter> (scanning)
Jun 15 10:53:18 manjarocomp NetworkManager[4343]: <info>  [1623718398.0706] modem-manager: ModemManager available
Jun 15 10:53:18 manjarocomp NetworkManager[4343]: <info>  [1623718398.0717] agent-manager: agent[829ecadeb2ce4ae3,:1.27/org.kde.plasma.networkmanagement/1000]: agent registered
Jun 15 10:53:18 manjarocomp NetworkManager[4343]: <info>  [1623718398.0719] ovsdb: Could not connect: No such file or directory
Jun 15 10:53:18 manjarocomp NetworkManager[4343]: <info>  [1623718398.0719] ovsdb: disconnected from ovsdb
Jun 15 10:53:18 manjarocomp wpa_supplicant[723]: dbus: fill_dict_with_properties dbus_interface=fi.w1.wpa_supplicant1.Interface.P2PDevice dbus_property=P2PDeviceConfig getter failed
Jun 15 10:53:18 manjarocomp NetworkManager[4343]: <info>  [1623718398.1300] device (wlp113s0): supplicant interface state: internal-starting -> disconnected
Jun 15 10:53:18 manjarocomp NetworkManager[4343]: <info>  [1623718398.1301] device (wlp113s0): state change: unavailable -> disconnected (reason 'supplicant-available', sys-iface-state: 'managed')
Jun 15 10:53:21 manjarocomp NetworkManager[4343]: <info>  [1623718401.7775] policy: auto-activating connection 'eduroam' (2298a860-469b-4b60-959b-504327a65b88)
Jun 15 10:53:21 manjarocomp NetworkManager[4343]: <info>  [1623718401.7781] device (wlp113s0): Activation: starting connection 'eduroam' (2298a860-469b-4b60-959b-504327a65b88)
Jun 15 10:53:21 manjarocomp NetworkManager[4343]: <info>  [1623718401.7781] device (wlp113s0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
Jun 15 10:53:21 manjarocomp NetworkManager[4343]: <info>  [1623718401.7785] manager: NetworkManager state is now CONNECTING
Jun 15 10:53:21 manjarocomp NetworkManager[4343]: <info>  [1623718401.8414] device (wlp113s0): set-hw-addr: reset MAC address to <filter> (preserve)
Jun 15 10:53:21 manjarocomp NetworkManager[4343]: <info>  [1623718401.9703] device (wlp113s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Jun 15 10:53:21 manjarocomp NetworkManager[4343]: <info>  [1623718401.9708] device (wlp113s0): Activation: (wifi) access point 'eduroam' has security, but secrets are required.
Jun 15 10:53:21 manjarocomp NetworkManager[4343]: <info>  [1623718401.9708] device (wlp113s0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Jun 15 10:53:21 manjarocomp NetworkManager[4343]: <info>  [1623718401.9747] device (wlp113s0): supplicant interface state: disconnected -> interface_disabled
Jun 15 10:53:21 manjarocomp NetworkManager[4343]: <info>  [1623718401.9784] device (wlp113s0): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
Jun 15 10:53:21 manjarocomp NetworkManager[4343]: <info>  [1623718401.9786] device (wlp113s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Jun 15 10:53:21 manjarocomp NetworkManager[4343]: <info>  [1623718401.9788] device (wlp113s0): Activation: (wifi) connection 'eduroam' has security, and secrets exist.  No new secrets needed.
Jun 15 10:53:21 manjarocomp NetworkManager[4343]: <info>  [1623718401.9788] Config: added 'ssid' value 'eduroam'
Jun 15 10:53:21 manjarocomp NetworkManager[4343]: <info>  [1623718401.9789] Config: added 'scan_ssid' value '1'
Jun 15 10:53:21 manjarocomp NetworkManager[4343]: <info>  [1623718401.9789] Config: added 'bgscan' value 'simple:30:-65:300'
Jun 15 10:53:21 manjarocomp NetworkManager[4343]: <info>  [1623718401.9789] Config: added 'key_mgmt' value 'WPA-EAP WPA-EAP-SHA256 FT-EAP FT-EAP-SHA384'
Jun 15 10:53:21 manjarocomp NetworkManager[4343]: <info>  [1623718401.9789] Config: added 'password' value '<hidden>'
Jun 15 10:53:21 manjarocomp NetworkManager[4343]: <info>  [1623718401.9789] Config: added 'eap' value 'TTLS'
Jun 15 10:53:21 manjarocomp NetworkManager[4343]: <info>  [1623718401.9789] Config: added 'fragment_size' value '1266'
Jun 15 10:53:21 manjarocomp NetworkManager[4343]: <info>  [1623718401.9789] Config: added 'phase2' value 'auth=MSCHAPV2'
Jun 15 10:53:21 manjarocomp NetworkManager[4343]: <info>  [1623718401.9789] Config: added 'identity' value '<filter>'
Jun 15 10:53:21 manjarocomp NetworkManager[4343]: <info>  [1623718401.9789] Config: added 'proactive_key_caching' value '1'
Jun 15 10:53:21 manjarocomp kded5[1094]: plasma-nm: Unhandled active connection state change:  1
Jun 15 10:53:22 manjarocomp NetworkManager[4343]: <info>  [1623718402.0134] device (wlp113s0): supplicant interface state: interface_disabled -> inactive
Jun 15 10:53:22 manjarocomp NetworkManager[4343]: <info>  [1623718402.0308] device (wlp113s0): supplicant interface state: inactive -> scanning
Jun 15 10:53:25 manjarocomp wpa_supplicant[723]: wlp113s0: SME: Trying to authenticate with <eduroam MAC addr> (SSID='eduroam' freq=5540 MHz)
Jun 15 10:53:25 manjarocomp kernel: wlp113s0: authenticate with <eduroam MAC addr>
Jun 15 10:53:25 manjarocomp kernel: wlp113s0: send auth to <eduroam MAC addr> (try 1/3)
Jun 15 10:53:25 manjarocomp NetworkManager[4343]: <info>  [1623718405.8039] device (wlp113s0): supplicant interface state: scanning -> authenticating
Jun 15 10:53:25 manjarocomp wpa_supplicant[723]: wlp113s0: Trying to associate with <eduroam MAC addr> (SSID='eduroam' freq=5540 MHz)
Jun 15 10:53:25 manjarocomp kernel: wlp113s0: authenticated
Jun 15 10:53:25 manjarocomp kernel: wlp113s0: associate with <eduroam MAC addr> (try 1/3)
Jun 15 10:53:25 manjarocomp kernel: wlp113s0: RX AssocResp from <eduroam MAC addr> (capab=0x111 status=0 aid=4)
Jun 15 10:53:25 manjarocomp NetworkManager[4343]: <info>  [1623718405.8137] device (wlp113s0): supplicant interface state: authenticating -> associating
Jun 15 10:53:25 manjarocomp kernel: wlp113s0: associated
Jun 15 10:53:25 manjarocomp wpa_supplicant[723]: wlp113s0: Associated with <eduroam MAC addr>
Jun 15 10:53:25 manjarocomp wpa_supplicant[723]: wlp113s0: CTRL-EVENT-EAP-STARTED EAP authentication started
Jun 15 10:53:25 manjarocomp wpa_supplicant[723]: wlp113s0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
Jun 15 10:53:25 manjarocomp NetworkManager[4343]: <info>  [1623718405.8316] device (wlp113s0): supplicant interface state: associating -> associated
Jun 15 10:53:26 manjarocomp kernel: wlp113s0: Limiting TX power to 11 dBm as advertised by <eduroam MAC addr>
Jun 15 10:53:27 manjarocomp systemd[1]: NetworkManager-dispatcher.service: Succeeded.
Jun 15 10:53:27 manjarocomp audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Jun 15 10:53:27 manjarocomp kernel: kauditd_printk_skb: 6 callbacks suppressed
Jun 15 10:53:27 manjarocomp kernel: audit: type=1131 audit(1623718407.823:262): pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Jun 15 10:53:46 manjarocomp NetworkManager[4343]: <warn>  [1623718426.8264] device (wlp113s0): Activation: (wifi) association took too long
Jun 15 10:53:46 manjarocomp NetworkManager[4343]: <info>  [1623718426.8264] device (wlp113s0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Jun 15 10:53:46 manjarocomp NetworkManager[4343]: <warn>  [1623718426.8289] device (wlp113s0): Activation: (wifi) asking for new secrets
Jun 15 10:53:46 manjarocomp kernel: wlp113s0: deauthenticating from <eduroam MAC addr> by local choice (Reason: 3=DEAUTH_LEAVING)
Jun 15 10:53:46 manjarocomp kded5[1094]: plasma-nm: virtual NMVariantMapMap SecretAgent::GetSecrets(const NMVariantMapMap&, const QDBusObjectPath&, const QString&, const QStringList&, uint)
Jun 15 10:53:46 manjarocomp kded5[1094]: plasma-nm: Path: "/org/freedesktop/NetworkManager/Settings/3"
Jun 15 10:53:46 manjarocomp kded5[1094]: plasma-nm: Setting name: "802-1x"
Jun 15 10:53:46 manjarocomp kded5[1094]: plasma-nm: Hints: ()
Jun 15 10:53:46 manjarocomp kded5[1094]: plasma-nm: Flags: 3
Jun 15 10:53:46 manjarocomp wpa_supplicant[723]: wlp113s0: CTRL-EVENT-DISCONNECTED bssid=<eduroam MAC addr> reason=3 locally_generated=1
Jun 15 10:53:46 manjarocomp NetworkManager[4343]: <info>  [1623718426.8896] device (wlp113s0): supplicant interface state: associated -> disconnected
Jun 15 10:53:47 manjarocomp systemd[1]: systemd-hostnamed.service: Succeeded.
Jun 15 10:53:47 manjarocomp audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=systemd-hostnamed comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Jun 15 10:53:47 manjarocomp kernel: audit: type=1131 audit(1623718427.903:263): pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=systemd-hostnamed comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Jun 15 10:53:48 manjarocomp audit: BPF prog-id=20 op=UNLOAD
Jun 15 10:53:48 manjarocomp audit: BPF prog-id=19 op=UNLOAD
Jun 15 10:53:48 manjarocomp kernel: audit: type=1334 audit(1623718428.069:264): prog-id=20 op=UNLOAD
Jun 15 10:53:48 manjarocomp kernel: audit: type=1334 audit(1623718428.069:265): prog-id=19 op=UNLOAD
Jun 15 10:54:01 manjarocomp NetworkManager[4343]: <warn>  [1623718441.8044] device (wlp113s0): no secrets: User canceled the secrets request.
Jun 15 10:54:01 manjarocomp NetworkManager[4343]: <info>  [1623718441.8044] device (wlp113s0): state change: need-auth -> failed (reason 'no-secrets', sys-iface-state: 'managed')
Jun 15 10:54:01 manjarocomp NetworkManager[4343]: <info>  [1623718441.8051] manager: NetworkManager state is now DISCONNECTED
Jun 15 10:54:01 manjarocomp NetworkManager[4343]: <info>  [1623718441.8770] device (wlp113s0): set-hw-addr: set MAC address to <filter> (scanning)
Jun 15 10:54:01 manjarocomp NetworkManager[4343]: <warn>  [1623718441.9694] device (wlp113s0): Activation: failed for connection 'eduroam'
Jun 15 10:54:01 manjarocomp NetworkManager[4343]: <info>  [1623718441.9716] device (wlp113s0): supplicant interface state: disconnected -> interface_disabled
Jun 15 10:54:01 manjarocomp NetworkManager[4343]: <info>  [1623718441.9755] device (wlp113s0): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
Jun 15 10:54:01 manjarocomp plasmashell[1182]: file:///usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/NotificationPopup.qml:116:15: QML QQuickItem: Binding loop detected for property "height"
Jun 15 10:54:02 manjarocomp NetworkManager[4343]: <info>  [1623718442.0101] device (wlp113s0): supplicant interface state: interface_disabled -> disconnected
Jun 15 10:54:05 manjarocomp NetworkManager[4343]: <info>  [1623718445.6452] manager: startup complete
Jun 15 10:54:05 manjarocomp systemd[1]: Finished Network Manager Wait Online.
Jun 15 10:54:05 manjarocomp audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=NetworkManager-wait-online comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Jun 15 10:54:05 manjarocomp kernel: audit: type=1130 audit(1623718445.643:266): pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=NetworkManager-wait-online comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'

I don’t know if the eduroam setup is the same everywhere but for me, the config is slightly different:

[802-1x]
ca-cert=<ca-cert>
domain-suffix-match=<ca-domain>
eap=peap;
identity=<username>
password=<password>
phase2-auth=mschapv2

Especially, the eap=peap might be of importance.

I really need to get the certs for the connection. Interesting that there are differences in config, given that the connection seems to work on the other laptop. I will reexamine and see what it is doing.

Where did you get your config from?

I have it from my university and it worked throughout Germany, Austria, Switzerland, and Canada.