ASUS TUF Gaming FX504GM-E4353

hi. I can't install Manjaro XFCE on notebook ASUS TUF Gaming FX504GM-E4353. I chose the "Boot" in first menu of Manjaro, it boots and then hangs tight. hangs on the last line (screenshot). many times did not help. in bios disabled secure boot. Help please!

Maybe this will help.

1 Like

I have the same laptop. In order to get Manjaro to boot properly, I have to use the following kernel parameter:

acpi_osi='Windows 2018'

To test it do the following:

  1. On the Manjaro GRUB screen.

    a. Choose driver=free
    NOTE: Before we can install the nVidia driver, we need to get a stable install first.

    b. Goto the the Boot option and press E

  2. On the next screen, look for the line with quiet in it.

  3. Replace quiet with acpi_osi='Windows 2018'

  4. Hit F10 to boot the system.

You should be able to now boot into the live session and install Manjaro. Once Manjaro is installed, DO NOT REBOOT. Instead, follow the quoted text from my post below to add the boot parameter to GRUB permanently. This way, it will be used every time you boot your system.

The example given is what my GRUB_CMDLINE_LINUX_DEFAULT looks like.

Once you have added the kernel parameter to grub, you can reboot your laptop.

If the laptop reboot fine, now you can install the nVidia drivers. Here are your choices:

Personally, I use the Optimus-Switch option for my laptop. It is easy to install and use.

I have found the Manjaro works great on this laptop. It just takes a little "tweaking" to get it installed.

I hope this all helps.

3 Likes

Thank you very much! But I would like to install manjaro next to windows 10 ltsb 1607 (2016) (2 systems - manjaro and windows). For me need change acpi_osi='Windows 2018' to 'Windows 2016' ?
windows 10 1809 ltsc is very picky about laptop resources and have some unnecessary things, lots of processes loads - 129, and LTSB 1607 (2016) is vice versa - 72. But 1607 ltsb (2016) is better, but really need to download the driver from the site, they are not in the iso, that even wi-fi is missing from the system after installation.
I initially did not have installed Windows on my computer (no-os).

I am not familiar with that. All I can say is, any kernel parameter you use will not affect the Windows side at all.

Are you talking on the Windows side?

I would suggest staying with acpi_osi='Windows 2018'They are backwards compatible. So I suggest using the newest one you can.

1 Like

even wi-fi is missing from the system after installation

it on windows side
again thx!

what you said was unclear, maybe a language barrier. is the wifi issue on manjaro or on windows?

the kernel parameters you use with linux will have no effect on a windows installation and if "Windows 2018" works then leave it alone.

if you have not yet installed windows, just so you know it will become the default bootloader and replace grub. this is why installing windows before installing linux is recommended since microshyte's fat arse want to take control of everything. so after installing windows you'll probably have to use a manjaro usb to detect bootloaders and boot manjaro and from there you can reinstall grub and you will have your dual-boot system.

important: if manjaro is installed as UEFI/gpt, windows needs to also be installed UEFI/gpt. if MBR/bios then both need to be MBR/bios . make sure that windows ISO matches otherwise you'll need to reinstall manjaro to match what winblows is using.

GPT + MBR = :boom:
:sweat_smile:

3 Likes

thx

what you said was unclear, maybe a language barrier. is the wifi issue on manjaro or on windows?

wifi issue on windows 10 ltsb 2016 after install windows (iso of 2016 not have preinstalled drivers). i noticed real that windows 10 1809 ltsc have bugs and not optimezed. It is clear that Microsoft did not finish something. but i have notebook 2019 and going install windows 10 ltsb 1607 (2016)

This probably isn't the right place to get support for issues with Windows. While we tend to offer some topic flexibility as part of being a friendly community, Windows support is a bit too far off-topic for us here.

4 Likes

ok. :+1:

How to post required specs/logs from the terminal:

First install pastebinit:

sudo pacman -S pastebinit

Then run the important trobleshooting commands below (and post the outputs):

inxi -FGxxxz | pastebinit
dmesg | pastebinit 
journalctl -b0 -p4 | pastebinit
cat /var/log/Xorg.0.log | pastebinit
grep -v  /etc/X11/xorg.conf.d/*.conf | pastebinit

Please post the links returned from the pastebinit commands on the forum.

Have pacman terminal output piped directly to a log, then uploaded to pastebin:

Install pastebinit:

sudo pacman -S pastebinit

Then run this command to update your system and afterwards upload the log to pastebin:

sudo pacman-mirrors -f5 && sudo pacman -Syyu | tee log && cat ~/log | pastebinit

Then post the link generated by pastebinit on the forum.

If your computer has no working adapter for internet access then try using USB Android phone tethering.

1 Like

I cant boot

What this error mean in screenshots?

you can start a new thread for this since it seems your original post issue was solved. but before wasting anyone's time including yours, since you mentioned you wanted to install windows i suggest you wipe the drive, make sure your BIOS settings have the drive in AHCI mode, secure/fast boot disabled, and set to UEFI only, then do a clean install of windows first and let it's double-wide trailer sized arse do what it needs to do and then install manjaro after and make sure you boot the USB in UEFI mode from the boot selection menu when doing so.

this thread is marked solved and rightfully so. so either do whats suggested, OR dont, but dont expect any positive results. theres a reason installing windows first is suggested, with linux your in control of what happens and can control the outcome whereas with winblows your at the will of whatever it decides on it's own.

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.