ASUS router not visible

How can I find out if it is?

The easiest would be to install it but since you don’t have a wifi …

    pacman -Qi wireless-regdb

Do you have the option to use tether using your phone with an USB cable?

I am trying to fix a similar issue where my pbp can see some of my networks but not my NETGEAR nighthawk AP

I posted you the exact same link 4 posts above… to sum up

iw reg get

will show you the country. It will be what you set in the manjaro settings in the locale section under “Formats”. As long as it is not just the global or country 00 or US you will probably be good. I also told you to see what kind of settings do you see on the router side (Country, Band, Channel width/combining (20-40-80mhz), Short GI, compatibility for B clients can all cause some clients not to connect). It is even possible in rare cases that AC router does not support pure A, that happened to me once. Although i just checked the specs of the Pinebook pro,

Built-in 802.11ac WiFi with Bluetooth 5.0

so in your case might be the other way around. What is the model of the router by the way.

p.s. you read this i hope? About bluetooth and 2.4ghz etc.
https://wiki.pine64.org/wiki/Pinebook_Pro#Issues

It is likely that your reg domain is global.

You should set it using your country code.

E.g. for my pbp in Denmark it is

sudo iw reg set DK

In your case you would have to switch between AT and RO

Reboot your your system

This was all it took for my pbp to see my netgear AP.

You may need to cycle your wifi privacy switch

PineF11 numlock led → two blink = enabled, three blink = disabled.
Pinebook Pro - Privacy Switches

Either AT or RO will work - it is Europe so channels 1-13. Just don’t leave it global because it cuts the channels 12 and 13 then. Otherwise any EU country will be good because they share the legislation/regulation, with the small exception of France i think where something else was crippled but i do not remember what exactly.

p.s. and BTW there is a topic about problems (and the solution) with 5GHz on Manjaro Pinebook
https://forum.pine64.org/showthread.php?tid=17133&page=2&highlight=wifi

so at that point it will really be interesting to know what exactly makes/provides the router.

1 Like

OMG! If I’m not mistaken this problem started after using Bluetooth for my headphones.

Well, that is easy to debug. Turn Bluetooth on the pc and the headset off. If that is the reason make a separate 5ghz network on the router and see if that works and if it work connect to that and problem solved (with the additional driver maybe). If not - wired headphones.

AAH! Ol’ trusty!

I love my wired peripherals!

/off I wanted to use my fancy new Pixel Buds with my fancy new manjaro, but after i read in other forums how hard it will be to make them work in linux if at all ( :angry: google) i saved myself the trouble and bought a set of wired ones for 10 Euro just to go in the bag with the laptop if needed them someday.

pacman -Qi wireless-regdb
Name            : wireless-regdb
Version         : 2023.05.03-1
Description     : Central Regulatory Domain Database
Architecture    : any
URL             : https://wireless.wiki.kernel.org/en/developers/regulatory/wireless-regdb
Licenses        : custom
Groups          : None
Provides        : crda
Depends On      : bash  iw
Optional Deps   : None
Required By     : None
Optional For    : linux
Conflicts With  : crda
Replaces        : crda
Installed Size  : 18,11 KiB
Packager        : Arch Linux ARM Build System <builder+seattle@archlinuxarm.org>
Build Date      : So 14 Mai 2023 07:56:55
Install Date    : Mo 07 Aug 2023 09:33:28
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

You know what? You’re a genius! It works!!! Domain was unset.

No I am not :9 I just quoted the Arch Wiki

I have since got 5Ghz to work using the link posted by @Teo - the one that goes to the pine forum.

It is a bit tricky - as one has to take care not to alter to much - after all it is in /usr/lib - so chances are that changes will get overwritten on sync updates.

RT-AC53

However this still doesn’t explain why it was shortly visible without doing anything and then it disappeared until I set the domain with your help. 5G is still not visible.