Asus Rog Strix no sound from internal speakers on

Hi guys,
I see that I’m not the only one having issues with an Asus laptop(latest Manjaro Gnome). The backlit on the keyboard can be turned on with the FN+F3 keys but the sound is a real pain. External speakers work well through the 3.5mm jack but there is nothing coming out of the speakers. I have tried some tips from this forum but nothing seems to work. This is a brand new laptop. The bad part of this is that the sound doesn’t work in none of the live distros I tried. Debian 12 Gnome nothing, MX linux XFce nothing. It seems that there is a driver issue because it says that there is a an Intel HDA audio.

  Device-1: Intel vendor: ASUSTeK driver: snd_hda_intel v: kernel
    alternate: snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3 chip-ID: 8086:7a50
    class-ID: 0403
  Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
    bus-ID: 0000:01:00.1 chip-ID: 10de:22bc class-ID: 0403
  API: ALSA v: k6.3.5-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl

I’ll try a couple of more distros just to see if it works somewhere and for now stick with the external speakers…

You may want to switch to testing branch, which ships newer packages. Might solve your issue.

Thanks for the prompt reply!! It seems like the onboard sound card is a new chip. That’s why it doesn’t work properly just yet I suppose. Shame because it’s a great laptop over all.