Asus Numpad cum touchpad does not work

Touchpad of my laptop stopped working after latest set of updates. It is one of those Numpad cum touchpad in Asus Zenbook. The Numpad functionality never worked, but the touchpad was working fine until the update. I tried with a Manjaro livecd and it detects the touchpad fine.

One weird observation is that the touchpad is not detected after cold booting, but it is detected after rebooting. So I am forced to boot it and then again reboot it to work with the Laptop.

The Touchpad section of the System Settings just show “No Touchpad found”

sudo dmesg | grep touch

gives nothing

sudo libinput list-devices

does not show any touchpad

inxi -Fazy


  Kernel: 5.10.60-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=01e6c1d9-5825-4b3c-b03d-96752433aa3e ro nouveau.modset=0 quiet 
  apparmor=1 security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: ASUSTeK product: ZenBook UX434DA_UM433DA v: 1.0 
  serial: <filter> 
  Mobo: ASUSTeK model: UX434DA v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: UX434DA_UM433DA.302 date: 09/05/2019 
  ID-1: BAT0 charge: 41.9 Wh (100.0%) condition: 41.9/50.0 Wh (83.8%) 
  volts: 11.9 min: 11.9 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A 
  status: Not charging cycles: 82 
  Info: Quad Core model: AMD Ryzen 7 3700U with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen family: 17 (23) model-id: 18 (24) 
  stepping: 1 microcode: 8108109 cache: L2: 2 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 36748 
  Speed: 1297 MHz min/max: 1400/2300 MHz boost: enabled Core speeds (MHz): 
  1: 1297 2: 1243 3: 1225 4: 1226 5: 1225 6: 1227 7: 1224 8: 1223 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Picasso vendor: ASUSTeK driver: amdgpu v: kernel 
  bus-ID: 03:00.0 chip-ID: 1002:15d8 class-ID: 0300 
  Device-2: IMC Networks USB2.0 HD IR UVC WebCam type: USB driver: uvcvideo 
  bus-ID: 3-2:3 chip-ID: 13d3:56cb class-ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: 
  loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa 
  display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 158 size: 309x174mm (12.2x6.9") 
  diag: 355mm (14") 
  OpenGL: renderer: AMD Radeon Vega 10 Graphics (RAVEN DRM 3.40.0 
  5.10.60-1-MANJARO LLVM 12.0.1) 
  v: 4.6 Mesa 21.2.1 direct render: Yes 
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel 
  v: kernel bus-ID: 03:00.1 chip-ID: 1002:15de class-ID: 0403 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor driver: N/A 
  alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 03:00.5 
  chip-ID: 1022:15e2 class-ID: 0480 
  Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.60-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.33 running: yes 
  Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel 
  bus-ID: 01:00.0 chip-ID: 8086:24fd class-ID: 0280 
  IF: wlp1s0 state: up mac: <filter> 
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 
  bus-ID: 1-4:2 chip-ID: 8087:0a2b class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends 
  Local Storage: total: 476.94 GiB used: 52.39 GiB (11.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: HFM512GDJTNG-8310A 
  size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s 
  lanes: 2 type: SSD serial: <filter> rev: 80001C00 temp: 37.9 C scheme: GPT 
  ID-1: / raw-size: 50 GiB size: 48.97 GiB (97.93%) used: 22.3 GiB (45.5%) 
  fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  ID-2: /boot/efi raw-size: 513 MiB size: 512 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  ID-3: /home raw-size: 410.44 GiB size: 403 GiB (98.19%) 
  used: 30.08 GiB (7.5%) fs: ext4 dev: /dev/nvme0n1p4 maj-min: 259:4 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 16 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p3 maj-min: 259:3 
  System Temperatures: cpu: 59.6 C mobo: N/A gpu: amdgpu temp: 59.0 C 
  Fan Speeds (RPM): cpu: 2400 
  Processes: 260 Uptime: 25m wakeups: 3767 Memory: 13.67 GiB 
  used: 2.94 GiB (21.5%) Init: systemd v: 248 tool: systemctl Compilers: 
  gcc: 11.1.0 Packages: 1419 pacman: 1412 lib: 399 flatpak: 0 snap: 7 
  Shell: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

Look for an UEFI firmware update first…


I located an updated BIOS from ASUS. It is available as a exe file for windows. I have updated BIOS before from Windows, but finding updating BIOS from Linux challenge. I created a FreeDOS bootdisk using unetbootin , but won’t boot up from the laptop when I try to boot up from it.

I don’t have the same hardware as you, so please open a topic on your manufacturer’s forum on help with that…


Problem solved. I updated the BIOS to the latest using Asus EZ Flash utility. This didn’t fix the problem, but with the new BIOS, I got an error message about touchpad on screen while booting up.

When I further did:

sudo journalctl --since="2021-09-06 13:40:00" --no-pager | grep touchpad

I got -

Sep 06 13:47:37 subhabrata-zenbookum433da systemd[1]: asus_touchpad_numpad.service: Main process exited, code=exited, status=1/FAILURE
Sep 06 13:47:37 subhabrata-zenbookum433da systemd[1]: asus_touchpad_numpad.service: Failed with result 'exit-code'.
Sep 06 13:47:37 subhabrata-zenbookum433da audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=asus_touchpad_numpad comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'

It seems on reboot, it was loading a different service for touchpad and hence the touchpad worked after reboot.

Sep 06 13:47:42 subhabrata-zenbookum433da kded5[1133]: kcm_touchpad: Using X11 backend
Sep 06 13:47:42 subhabrata-zenbookum433da kcminit_startup[1121]: Initializing  "kded_touchpad" :  "kcminit_touchpad"
Sep 06 13:47:42 subhabrata-zenbookum433da kcminit_startup[1121]: kcm_touchpad: Using X11 backend
Sep 06 13:47:43 subhabrata-zenbookum433da plasmashell[1227]: kf.coreaddons: plugin metadata in "/usr/lib/qt/plugins/" does not have a valid 'MetaData' object
Sep 06 13:52:03 subhabrata-zenbookum433da audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=asus_touchpad_numpad comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'

I uninstalled the asus_numpad_touchpad driver and service and since then, touchpad works every time, even on cold boot. I have lost the numpad functionality, but it is what it is.

1 Like

Happy to have been able to guide you to the something that works for you. Therefore, I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.