Asus N52JV dual GPU laptop - UEFI - bootable USB - BLACK SCREEN after GRUB menu

Hello Community,

I am new and I am here because I would like to get rid of the Windows in my life forever. I have 2 laptops at home and I would like to use mentioned ASUS laptop as a testing machine for learning purposes. This model is from 2009 or 2010.

Currently there is Windows 7 installed on it which I planned to format during Linux installation. For now it appears I can not make to run any linux on it, I only tried these 2 because I want to have Manjaro so badly :slight_smile: maybe I should try some other versions as well. but I believe that the problem is only machine related.

I am new to Linux and at the same time I am not new to Linux :slight_smile: I work as a Network & Security Engineer and have some experience with linux based network devices such as Check Point firewalls, netscaler load balancers, F5 load balancers, etc. or linux servers (log servers, jump servers, etc.), I had some trainings for Linux administration so from my work and home experience I can manage basic OS administration.

I offer knowledge from 10 years of experience in network & security field to this community, feel free to ping me the message or link to the particular thread.

Back to my problem my attempts so far -->>

  • 2 different USB 3.0 [16GB and 32GB, both Sandisk Flair]
  • 2 different distributions (Manjaro KDE, Vector Linux - Vlocity 7.1)
  • Rufus [tried ISO and DD as well], LiveLinuxUSB creator, Etcher, Ventoy
  • FAT32
  • UEFI
  • MBR and also tried with GPT
  • Firmware does not have SecureBoot or FastBoot option
  • Original SATA was replaced with SSD some time ago (AHCI is enabled)
  • Vector Linux does not boot at all, windows is booted instead per boot priorities.

MANJARO KDE [latest version]

  • boots for GRUB menu but after continuing with booting kernel and system screen, showing nothing,
  • tried ctrl+alt+F2 on black screen - not worked
  • tried to edit boot parameters: nomodeset, xforcevesa, nvidia.modeset=0, nouveau.modeset=0, i915.modeset=0, grub_gfxmode=1280x1024x24, grub_gfxmode=1024x768x16
  • checked the “Detect EFI bootfiles” option in GRUB menu, says “no EFI files detected” - I was wondering if this is normal behaviour.
  • based on the research I have read that EFI files can be copied from other distro ISO to USB folder where I have manjaro EFI files…
  • BIOS firmware is on the latest version (was updated when I was trying to upgrade memory)

I would like to ask you guys for help and other options in troubleshooting

  • Should I try the option to copy EFI files from other distro to USB where manjaro is?
  • can this be fixed from GRUB cli which I can open from GRUB menu?
  • do I need to run GRUB recovery mode if yes then how? can it be fixed from this mode?
  • Can I inject graphics driver needed to run GUI of the installation manually to ISO ? if yes how can I identify correct drivers for download?
  • is this problem related to graphic drivers or EFI files not found?

Thank you very much, I will appreciate every effort.

the specs of the laptops are:

Motherboard: I have not found this information yet.
CPU: Intel Core i3 370M, 2.4GHz
GPU1: Intel integrated graphics [500 MB]
GPU2: NVIDIA® GeForce® GT 325M 1GB
Memory: 4GB DDR3 1066 Mhz
display resolution: 1366 x 768 pixels, HD
HDD: Patriot Burst SSD 480 GB Burst, 2.5” SSD, SATA III, 6Gbps

1 Like

Those should already be there.

Can you try the following kernel parameters (when using UEFI)

efi=debug earlycon=efifb keep_bootcon debug 3

and remove quiet (if it’s there), and see if you get any output?


I pasted the command and booted as you suggested, then it was running for 2-3 mins with lot of output displaying quickly and got stucked with last line saying “freeing SMP alternatives memory: 32K”

then did some research and found suggestion that it might be the problem with APIC

I tried to boot the manjaro again with the command you posted +
noapic acpi=off" and now finally I am able to login to TTY with default username and pass.

with what steps should I proceed with to run GUI or install the system from here ?

(I am not allowed to post screenshots don`t know why :frowning: )

Thank you

Are you sure acpi=off is needed? The capabilities of your machine could be severely limited without ACPI. If you remove the options I wrote, then it should boot into a graphical environment. So I suggest you try only noapic and remove quiet (if it’s there).

not sure about acpi=off that was just blind call. I will go for noapic.

I see “quiet” in boot parameters but not in the line beginning with the linux where I am adding additional commands/parameters so that is quite confusing.

I added just noapic at the end of the line and booted, still black screen after 10 minutes, will see if GUI appears once the driver is installed or should it be displayed immediately ?


The driver and the firmware files are already there, there is nothing to install.

Then add both (noapic acpi=off), remove quiet, and try booting that way.

wow, in the end the solution was to add noapic acpi=off and boot. I got CLI output from beginning but this one it looked different and the last task was saying starting small desktop manager and then live GUI with the classic desktop appearance was launched.

My question before I will proceed with an installation and formatting disk is that should I do some extra step to avoid this black screen behaviour after installation ?

Thank you very much :slight_smile:

You need to edit /etc/default/grub and add the two options to GRUB_CMDLINE_LINUX and then run sudo grub-mkconfig -o /boot/grub/grub.cfg if you cannot boot without the two options. You could also try if it boots with just acpi=off.

I have downloaded new version (Nibia) and this one boots and install without issues. Now I am going to study if I should use SWAP or HIBERNATION, I would like to keep clean and fast running system, in Windows I never used swap or hibernation so I am pretty curious how it works on Linux.

Thank you for the support pobrn ! :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.