Assign custom audio input/output to rear panel audio jacks?

Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Biostar Microtech Intl Corp driver: snd_hda_intel

I have 3 jacks on rear panel. One is where my speakers are,
and other two are for rear mic and line in.

I would like to connect my earphones to rear panel as I don't
need line in, or rear-mic panel. So basically to assign one more
jack to output in rear panel.

I know hardware supports assigning custom functions to panel jacks,
(in windows when I plug something it asks me what should be assigned to that device)
but where do I set it in Manjaro? In audio configuration I don't see an
option to do that.

This is mobo: https://www.biostar.com.tw/app/en/mb/introduction.php?S_ID=877

1 Like

You need hdajackretask to re-assign pins, so:

pamac install alsa-tools
sudo hdajackretask

and as per below screenshot:

  1. Set the correct codec
  2. Show Unconnected Pins
  3. Read the documentation
  4. Rejack the pin you want to use
  5. Apply now
  6. If it works and you're happy with the result OR if you get an error, press the Install Boot override button and reboot
  7. Enjoy! (or start testing if Apply now did not work)

:innocent:

1 Like

I wondered how much user friendly will it be :smiley:

Thanks! :slight_smile:

Screenshot_20200326_075130

This is what I get... (when trying to apply change)

¯\_(ツ)_/¯

Ok, with this boot override it kinda works... but, there is no option
to select earphones, just separately front, surround, back, center... whichever one
I select I have impression I don't get full sound, just that one channel,
there is no something like mixed output, just components.

Anyway, this tools works as intended, I guess, can't blame it on that one :slight_smile:

If you have an unconnected pin just next to the back, you might be able to rejack that too. Can I have a screenshot of your hdajackretask and the output of amixer --card=0 ???

:innocent:

I have 3 on the rear, green, blue, and pink. Green is for speaker output,
and there are my speakers connected. Other two are (normally) for mic-in
and for line-in. The one for line-in I've tried to configure to be out-put so I
can connect earphones there.

[srdjan@Desktop ~]$ amixer --card=0
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 69 [79%] [-13.50dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Mono:
  Front Left: Playback [off]
  Front Right: Playback [off]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Front',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'Front Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Front Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Surround',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'Center',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'LFE',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 63
  Front Left: Capture 39 [62%] [12.00dB] [on]
  Front Right: Capture 39 [62%] [12.00dB] [on]
Simple mixer control 'Capture',1
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 63
  Front Left: Capture 0 [0%] [-17.25dB] [off]
  Front Right: Capture 0 [0%] [-17.25dB] [off]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'
Simple mixer control 'Channel Mode',0
  Capabilities: enum
  Items: '2ch' '4ch' '6ch'
  Item0: '2ch'
Simple mixer control 'Input Source',0
  Capabilities: cenum
  Items: 'Rear Mic' 'Front Mic' 'Line'
  Item0: 'Rear Mic'
Simple mixer control 'Input Source',1
  Capabilities: cenum
  Items: 'Rear Mic' 'Front Mic' 'Line'
  Item0: 'Rear Mic'
Simple mixer control 'Loopback Mixing',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Disabled'
Simple mixer control 'Rear Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Rear Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
[srdjan@Desktop ~]$ 

I reverted settings to normal, because if I apply that for earphones on the
back, I have no more control for speakers in KDE, just for that earphone output...

I do not have any connectors on front of case (no usb, no audio, nothing), just rear,
so I wanted to connect headphones there, and to have volume control separated for
both headphones and speakers not to crawl every time under the table to connect/disconnect stuff.

1b

How do I get all the stuff from alsa-mixer to apear in KDE applet
for audio volumes (in the notification area)? Is it possible?

I don't know. You cannot do what I can because Pink Mic Rear and Pink Mic Front follow each other without an unconnected pin in-between them.

2020-03-26_17-44

So sorry, my original is the best I can do for you...

maybe, just maybe if you override Pink mic rear 0x18 and not connected 0x1a to headphone and surround respectively, you might get a better sound quality, but doing everything you want, will need some experimentation on your side as it's hard to hear from here what you can hear through the headset!

:stuck_out_tongue_winking_eye: :crazy_face:

P.S. My knowledge of sound under Linux is fragmentary: I can do some stuff but not everything...

Thanks a lot! :slight_smile:

1 Like

Forum kindly sponsored by