Artix linux-lts not detecting Ethernet, only Wifi


#1

somehow the defaul linux-lts kernel isn’t supporting my ethernet but is supporting my wifi

and so i switched to a manjaro kernel and the ethernet is working again…

@thefallenrat what do you make of that?


Manjaro-openrc will be discontinued
Manjaro-openrc will be discontinued
#2

This really isn’t the place for getting support for Artix.


#3

Ok, but unfortunately, no place is yet


#4

Depending on the issue you’re having, they do have issue boards on GitHub. For example, if the issue is with a package in ‘system’ (which I’m pretty sure the kernel will be) you could try https://github.com/artix-linux/system/issues .

Really, though, the Artix team need to get something official in place seeing as they have users who need help. Feel free to bug them until they give in. :slight_smile:


#5

Wow…we are really getting the boot…no interim time to get our balance??

Best regards.


#6

This thread is nearly 300 posts long and a week old. It’s gone beyond a sensible place for getting help with Artix, and so people should be pressing the Artix project to set up their official community for you guys.

Think of this as some gentle persuasion rather than a boot. :slight_smile:


#7

I agree with jonathon that the announcement topic is not for getting a problem solved, just for informing and posting a link to a separate topic. But some user still don’t get how it works here.


#8

Indeed…:neutral_face:

Best regards.


#9

I think I am getting “how it works here” quite clearly. I will not comment further here concerning any issues.

Best regards.


#10

@artoo Please allow me to start an official unoffical forum somewhere with your blessing thanks…


#11

http://systemd-free.org/comments.php is the temp place for help


#12

Probably because, unlike linux-lts, the manjaro kernel get patched a lot by the team so that it supports most hardware out of the box ( Including your ethernet I think)

Here’s philm explaining about manjaro kernels…

If you want to keep the manjaro kernel and its updates, you need to re-enable manjaro [core], and install the manjaro-keyring. But, you need to be more extra careful when it comes to updating or installing packages or your artix core will replaced by manjaro ones…


#13

Ethernetworks fine here as it always does perhaps it was over looked on install called firmware,


#14

Or that. @LizziAS Try checking what ethernet you have … Maybe you just need to install a firmware…

inxi -Nnxz

#15
inxi -Nnxz
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8168 v: 8.044.02-NAPI port: e000 bus-ID: 05:00.0
           IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Intel Wireless 3160 driver: iwlwifi bus-ID: 06:00.0
           IF: wlp6s0 state: up mac: <filter>

#16

well i do have the artix repos listed first as instructed… however:



:: Starting full system upgrade...
warning: git: local (2.13.4-1) is newer than world (2.13.3-2)
warning: gnupg: local (2.1.22-1) is newer than system (2.1.21-3)
warning: libcups: local (2.2.4-2) is newer than world (2.2.4-1)
warning: linux-firmware: local (20170622.7d2c913-1) is newer than system (20170422.ade8332-1)
warning: pamac: local (4.9.1-1) is newer than world (4.9.0-1)
warning: qt5-base: local (5.9.1-3) is newer than world (5.9.1-1)
warning: wpa_supplicant: local (1:2.6-7) is newer than system (2.6-8)
warning: xf86-video-ati: local (1:7.9.0-1) is newer than world (7.9.0-1)
warning: zlib: local (1:1.2.11-2) is newer than system (1.2.11-2)
 there is nothing to do




#17


#18

and so the lts with no ethernet support


#19

It is likely that Manjaro packages linuxXYZ-r8168 are the key to the solution.

For artix you might need to install r8168-dkms from AUR.


#20

I think you need to run sudo pacman -Syuu so that your packages matches with the repo

If you have enabled arch linux repo, you can easily install r8168 packages in community

https://www.archlinux.org/packages/community/x86_64/r8168/

But since we’re coming from manjaro, I think it is best to install r8168-dkms from AUR :

  • Install linux-lts-headers :
sudo pacman -S linux-lts-headers
  • Then install r8168-dkms from AUR :
yaourt -S r8168-dkms
  • Reboot