Artifacts or blinks during screen recording and screen sharing

Hello!
I once had a problem with artifacts (blinks) during screen recording and during screen sharing (in video calls). Then after one of updates the problem has left, but now has appeared again.

Screenshots from video:

On duty, I have to make video calls and share the screen. Also, I often record the screen. My colleagues complain about artifacts and blinking on the recording during the screen demonstration. I have tried using many screen recording and video calling programs, but the problem is present in all.

I tried switching to use OpenGL 2 and 3. Changed settings "Tearing prevention", but it did not help. Artifacts disappear only when using XRender, but it does not suit me, as there is a tiring and blur effects disappear.

2019-11-07_08-38

The reason i point you to this wiki is because you posted in #technical-issues-and-assistance and also you provided the inxi as screenshot. Is not to demise the help, but you are also on a desktop pc, and all this should not happen at all ...
https://wiki.archlinux.org/index.php/Intel_graphics
... unless there is an issue with the 4.19 kernel as happens on 5.2. See 'caleb' comment.
https://bugs.archlinux.org/task/63159

When using kernel 5.3 I have the same problem.

Ok, but did you create/modify the config as on arch wiki ? As now the driver is none ...

image

Maybe you need to have /etc/X11/xorg.conf.d/20-intel.conf with:

Section "Device"
  Identifier  "Intel Graphics"
  Driver      "intel"
EndSection

or

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "TearFree"    "true"
EndSection

Or maybe that Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller requires you to simply install the xf86-video-intel and lib32-mesa packages to perform better. :man_shrugging:

Thanks, going to create xorg config.
As I can see, xf86-video-intel and lib32-mesa alredy installed.

This is my xorg.conf file section Device:

Problem not fixed.

The same with VSync=false
The same with TearFree=false

Also 'i915.enable_psr=0' have been added:

After that I regenerate grub with: 'sudo grub-mkconfig -o /boot/grub/grub.cfg' and reboot.

Problem still not fixed.

Finally the problem is solved. :man_dancing:

I only changed the AccelMethod value to "uxa" in xorg.conf and that solved my problem:

Now there are no artifacts visible on the record.

If I understand correctly, SNA is a new acceleration method and UXA is an old one. But the new method doesn't always work well and UXA is left for compatibility.

image
Source (Arch intel manual)

When using UXA there is no tiring or artifacts, now everything is OK.

1 Like

this is permanent fix for intel drivers link

Instead of simply posting a link to a Youtube video of yours (which suggests adding a number of options in /etc/X11/xorg.conf.d which might be useless or even dangerous for many users), could you explain what would be the "solution" or "fix"? Thanks.

1 Like

In the end, I solved all my problems by removing the intel driver (and xorg config file) and now using modesetting driver instead of i915.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by