[ARM Testing Update] 2023-11-01 - Kernels, OPI5-Plus, Plasma 5.27.9, Firefox, Thunderbird

Hello ARM community.


We updated kernels, added intitial support for OPI5-Plus, renewed Plasma and offer other related goodies for you.

Update Announcement

Some highlights:

  • Some Kernels got updated
  • We adopted some Phosh packages from ALARM
  • We added initial support for OrangePi 5-Plus
    • development images can be found here
  • Linux-Firmware got updated
  • KODI for RasberryPi got renewed
  • Plasma got updated to 5.27.9
  • Firefox is now at 119.0 and Thunderbird at 115.4.1
  • The usual python and KDE-git updates (which moved to Qt6)

Tips And Tricks

Error about missing openssl 1.1 library

Since the update to the new OpenSSL 3.0, some applications might still be looking for version 1.1 og openssl.
Fortunately Arch Linux created a compatability package for such events called openssl-1.1.
So if you encounter any such errors, please install the above mentioned package.
Applications currently known to specifically look for 1.1 is silver. We have not been able to rebuild it yet. So if you are on our Gnome or Sway editions, please install openssl-1.1 as part of this update.

How to get Waydroid working

If you follow these steps, you should have Waydroid working fine.

Remember, Waydroid only works on wayland!

  • Install waydroid-image and all it’s dependencies.
  • Run pkexec setup-waydroid.
  • You should now be able to launch Waydroid. The first launch takes a while.
How to use Kodi RPI on Manjaro ARM

If anyone wants to test kodi on the rpi, install these packages:

sudo pacman -S kodi-rpi kodi-rpi-dev kodi-rpi-eventclients kodi-rpi-tools-texturepacker libcec-rpi linux-rpi4 xf86-video-fbdev

Have it set up is to boot straight in to kodi

This means the kodi.service file need to replace whatever login manager you have installled. In my case I would:

sudo systemctl disable lightdm.service
sudo systemctl enable kodi.service

They recommend removing custom configs in config.txt. We ran into an issue if a value was set with gpu_mem=.

My config.txt with a bit of overclocking:

#gpu_mem=64     #disable this
initramfs initramfs-linux.img followkernel

#enable sound

#enable vc4
#max_framebuffers=2    #disable cause kodi uses more

Some notes:

The default user will be kodi
kodi home directory will be /var/lib/kodi
So put test video in /var/lib/kodi/Videos so you can get to it
after setting up the video directory in kodi.

Upstream Notifications:

Older notifications

The PHP package has been updated to 8.2. If you still need 8.1, use php-legacy packages.
Arch Linux - News: PHP 8.2 update and introduction of legacy branch

If you used the Manjaro ARM Installer or is using PinePhone or PineTab, you need to redo your passwords, because of an update to libxcrypt:
Arch Linux - News: Sorting out old password hashes

The ghostpcl and ghostxps requires manual intervention (if you have these installed):
Arch Linux - News: ghostpcl>=9.53.2-2 and ghostxps>=9.53.2-2 updates require manual intervention

The nss package requires manual intervention:
Arch Linux - News: nss>=3.51.1-1 and lib32-nss>=3.51.1-1 updates require manual intervention

The packages hplip and firewalld requires manual intervention:
Arch Linux - News: hplip 3.20.3-2 update requires manual intervention
Arch Linux - News: firewalld>=0.8.1-2 update requires manual intervention

Package Changes (Wed Nov 1 07:02:27 CET 2023)

  • arm-testing core aarch64: 48 new and 50 removed package(s)
  • arm-testing extra aarch64: 898 new and 918 removed package(s)
  • arm-testing kde-unstable aarch64: 274 new and 272 removed package(s)

A full list of all package changes can be found here.

Testers needed on arm-testing branch

We are in need of testers for our arm-testing and arm-unstable branches.
So if you are adventurous and want newer software quicker, we would love for you to help us test out the new packages in arm-testing branch.

All you have to do to switch to this branch is:

  • Run this command to switch branch: sudo pacman-mirrors -aS testing && sudo pacman -Syyu. This will generate a new mirrorlist for you, sync your databases with the new mirror and update your system using the arm-testing branch.

We would then love for you to give feedback in our update posts in Testing Updates. That way we can better find and fix bugs, before they hit arm-stable branch. Thank you!

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)
0 voters

Check if your mirror has already synced:


Manjaro, like many other open-source projects, relies on the generosity of its community through donations and corporate sponsorships to support its growth and development. These donations are essential in covering the various expenses incurred in the operations of the project such as server costs, software development tools, infrastructure expenses, training, flying people to events or conferences and the salaries of key developers. With the help of these donations, Manjaro is able to secure the necessary financial stability that allows the project to continuously improve and remain active. If you love Manjaro, consider to donate!


Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

:arrow_right: 2023-11-01


Phosh apps ignore dark theme (fixed with xdg-desktop-portal-gtk-1.15.1-1)
  • Problem: apps ignore dark theme preference
  • Workaround: downgrade xdg-desktop-portal-gtk from 1.15.0-1 to 1.14.1-1


Display doesn't load on PinePhone Pro running KDE Plasma
  • Problem: Failed to start Simple Desktop Display Manager
  • Workaround: (none known yet)


Pinephone Pro doesn't boot (fixed in latest update)
  • Problem: The Pinephone Pro will fail to boot after updating linux-pinephonepro 6.3.11-1 to 6.4.4-1
  • Workaround: Either wait for a non-broken kernel, or temporarily add linux-pinephonepro to the IgnorePkg line in /etc/pacman.conf to update the rest of the packages


Docker 23 not starting

Since the update to Docker 23, upstream is now inforcing new paths for apparmor related stuff. But there has been changes to dependencies yet. So Docker 23 will error on start.
Fix: Install apparmor from the repositories.


Reduced video playback performance in mpv

There has been reports of video playback performance in mpv has regressed since an update to mpv.
Fix: MPV now needs a vd-lavc-dr=no parameter to play hw acceleration supported 1080p videos smoothly.

Touch input on Firefox with Phosh not working in Firefox 108

Since the update to Firefox 108, the touch input does not work. Seems to be an issue with a couple of the changes the mobile-config brings in.
Fix Fixed in version 4.0.0-1 of mobile-config-firefox released with Manjaro testing on April 14, 2023


OpenSSL 1.1 library not found

Some applications might still be looking for openssl 1.1.
Solution: Install openssl-1.1 package with sudo pacman -S openssl-1.1.


Plasma Mobile Dialer seems to be unreliable

Plasma Dialer 22.09 seems to have issues switching audio profiles and as such might require manual switching. Sometimes audio is completely missing.

Reduced video performance on youtube

Some may encounter reduced video playback performance on YouTube in Firefox with the new Mesa 22.2 drivers.
No workaround at this time.

Old Issues

Phosh crashes when closing apps
An upstream issue results in the Phosh shell to crash when you close the app in the app switcher, with animations turned off.
Fix: Enable animations in Tweaks application

Mouse cursor is slow on Raspberry Pi
Due to a change in the Raspberry Pi kernels upstream, they no longer support FKMS. This can result in slow performance when using the FKMS drivers with the newer Raspberry Pi kernels.
Solution: Open /boot/config.txt, change fkms to kms in the dtoverlay line. Save the file and reboot.

[Waydroid container cannot access internet
Cause: new default waydroid configuration issue, tracked here.

Short-term Solution:

  1. create /etc/nftables.d/waydroid.nft with the following contents:
#!/usr/sbin/nft -f
table inet filter {
    chain input {
        iifname "waydroid0" accept comment "Allow incoming network traffic from WayDroid"
    chain forward {
        iifname "waydroid0" accept comment "Allow outgoing network traffic from WayDroid"
        ct state {established, related} counter accept comment "accept established connections"
  1. any time you launch waydroid, run the following after it has started:
echo "ip route add default via" |sudo waydroid shell

Previous testing threads:

The plain vanilla kodi package also was updated for depend fixup and version bump from 20.0-7 → 20.2-4.

1 Like

does plasma-20231030.img plasma5 renamed?

raspberrypi-utils and raspberrypi-userland-aarch64-git are in conflict (raspberrypi-firmware). Remove raspberrypi-userland-aarch64-git? [y/N]

raspberrypi-userland-aarch64-git is now obsolete

I installed Manjaro-ARM-plasma-mobile-pinephonepro-beta15-rc4.img, and then ran the command, sudo pacman-mirrors -aS testing && sudo pacman -Syyu. However, I’ve not been able to upgrade it successfully. It begins by asking a whack of questions, all in the format,

Replace package with extra/package5? [Y/n]

I’ll answer “Y”, and then when it comes down to upgrading, it informs me that “package” is necessary for the upgrade (this after prompting me to replace “package” with “package5”).

Note, I’m just using “package” as a generic term. A specific example is,

Replace plasma-framework with plasma-framework5? [Y/n]

I then did try it by answering “no” all of these questions, which resulted in it saying,

error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: plasma-framework5 and plasma-framework are in conflict (plasma-framework<5.111)

When I say “yes” to all of them, I receive the following feedback:

resolving dependencies...
warning: cannot resolve "modemmanager-qt", a dependency of "plasma-dialer"
warning: cannot resolve "kcontacts", a dependency of "plasma dialer"

It goes on for a while with similar messages citing various packages. Eventually, it proclaims:

:: The following packages cannot be upgraded due to unresolvable dependencies:

:: Do you want to skip the above packages for this upgrade? [y/N]

I’ve tried answering both Yes and No, and each fail, citing various issues. I also selectively answered “no” to the packages relied upon by the four listed above, but this led to other issues.

I’m not sure how to proceed.

I’m uncertain what potential complication you may have added by your Y / N attempts, however, you might have some success after first uninstalling the plasma dialer application.

sudo pacman -R plasma-dialer

After that, perform the update while choosing Y to each rename/ replace question. These packages are mostly being renamed in lieu of the forthcoming Qt6 version of KDE Plasma; so avoid choosing N.

The plasma-dialer package could then be reinstalled.

Note: Please wait for further confirmation on this approach, as there may be factors I’m not aware of.

I hope this helps.

Not all Plasma-Mobile apps got recompiled against the new KF5 renaming, which provides lines got dropped with KF 5.111 release.

Just booted up Manjaro-Arm-KDE for Orange Pi 5 Plus. No gpu hw acceleration support yet and does not have any access to USB drives. Wayland seems to work smoother better than the default X11.

Thank you Manjaro-Arm-Team.

1 Like

Hello soundofthunder. I tried your suggestion of removing plasma-dialer (along with kdav2, kimap2, kpeoplesink, and sink, which also seemed to be blocking the upgrade) and then did the upgrade. This worked. The upgrade succeeded. I then reinstalled plasma-dialer.

However, upon rebooting, the system is broken. It’s the same error I’ve had whenever I try to upgrade on the Pinephone Pro. “Failed to start Simple Desktop Display Manager.”

I’m glad that worked for you.

If you’ve had this issue for some time, it might be best to open a new thread dedicated to solving the issue; being that its not strictly a result of this update. I noticed several forum threads on the theme which may be helpful.

How did you solve it on those other occasions? Are you able to login via a TTY Ctrl+Alt+F2 (or 3/4/5/6) and perform maintenance?

My guess is that your system is quite the mixed bag at the moment. You might consider first ‘downgrading’ to stable, and then performing updates necessary to become stable, once again.

sudo pacman -Syyuu

From that point (with a reliable base), you could then decide whether to again switch to testing. This is what I might do, but keep in mind that I don’t know your system, and this could introduce more annoyances along the way.

See what others have to say about this approach.

When it happens, I am forced to reinstall the stable OS. I then upgrade that. Then I run the command to switch to the testing branch as outlined above ( sudo pacman-mirrors -aS testing && sudo pacman -Syyu). I do this because I bought the Pinephone Pro to help out, via giving feedback, with the development of the default OS for it (that being, Manjaro Plasma). I don’t believe that is indicative of a “mixed bag”.

Proposing a scenario to be either confirmed or denied can often lead to something not previously considered. Mixed bag, or not, it’s unfortunate your only resolution is to reinstall the OS to overcome the SDDM issue. That issue seems to stem from a known issue which, as I write, has no known apparent solution or workaround. Good luck.