[ARM Testing Update] 2023-04-14 - Kernels, Plasma, Frameworks, Thunderbird, Firefox

Hello ARM community.


Manjaro, like many other open-source projects, relies on the generosity of its community through donations and corporate sponsorships to support its growth and development. These donations are essential in covering the various expenses incurred in the operations of the project such as server costs, software development tools, infrastructure expenses, training, flying people to events or conferences and the salaries of key developers. With the help of these donations, Manjaro is able to secure the necessary financial stability that allows the project to continuously improve and remain active. If you love Manjaro, consider to donate!

Update Announcement

With this update we have added a lot of new stuff. Beside kernel updates you may find some to Apple Silicon and Station M3.

Some highlights:

  • Some Kernels got renewed
  • KDE Plasma is at 5.27.4
  • KDE Frameworks is at 5.105.0
  • Firefox got updated to 112.0
  • Thunderbird is renewed to 102.10.0
  • Pipewire is at 0.3.68
  • The usual KDE-git updates
  • Many python packages got updated

End Of Life kernels (will be removed from repo soon):

  • linux60 (EOL on 2023-01-12) (removed from repository)

Tips And Tricks

Error about missing openssl 1.1 library

Since the update to the new OpenSSL 3.0, some applications might still be looking for version 1.1 og openssl.
Fortunately Arch Linux created a compatability package for such events called openssl-1.1.
So if you encounter any such errors, please install the above mentioned package.
Applications currently known to specifically look for 1.1 is silver. We have not been able to rebuild it yet. So if you are on our Gnome or Sway editions, please install openssl-1.1 as part of this update.

How to get Waydroid working

If you follow these steps, you should have Waydroid working fine.

Remember, Waydroid only works on wayland!

  • Install waydroid-image and all it’s dependencies.
  • Run pkexec setup-waydroid.
  • You should now be able to launch Waydroid. The first launch takes a while.
How to use Kodi RPI on Manjaro ARM

If anyone wants to test kodi on the rpi, install these packages:

sudo pacman -S kodi-rpi kodi-rpi-dev kodi-rpi-eventclients kodi-rpi-tools-texturepacker libcec-rpi linux-rpi4 xf86-video-fbdev

Have it set up is to boot straight in to kodi

This means the kodi.service file need to replace whatever login manager you have installled. In my case I would:

sudo systemctl disable lightdm.service
sudo systemctl enable kodi.service

They recommend removing custom configs in config.txt. We ran into an issue if a value was set with gpu_mem=.

My config.txt with a bit of overclocking:

#gpu_mem=64     #disable this
initramfs initramfs-linux.img followkernel

#enable sound

#enable vc4
#max_framebuffers=2    #disable cause kodi uses more

Some notes:

The default user will be kodi
kodi home directory will be /var/lib/kodi
So put test video in /var/lib/kodi/Videos so you can get to it
after setting up the video directory in kodi.

Upstream Notifications:

Older notifications

The PHP package has been updated to 8.2. If you still need 8.1, use php-legacy packages.
Arch Linux - News: PHP 8.2 update and introduction of legacy branch

If you used the Manjaro ARM Installer or is using PinePhone or PineTab, you need to redo your passwords, because of an update to libxcrypt:
Arch Linux - News: Sorting out old password hashes

The ghostpcl and ghostxps requires manual intervention (if you have these installed):
Arch Linux - News: ghostpcl>=9.53.2-2 and ghostxps>=9.53.2-2 updates require manual intervention

The nss package requires manual intervention:
Arch Linux - News: nss>=3.51.1-1 and lib32-nss>=3.51.1-1 updates require manual intervention

The packages hplip and firewalld requires manual intervention:
Arch Linux - News: hplip 3.20.3-2 update requires manual intervention
Arch Linux - News: firewalld>=0.8.1-2 update requires manual intervention

Package Changes Fri Apr 14 08:41:35 CEST 2023)

  • arm-testing community aarch64: 381 new and 370 removed package(s)
  • arm-testing core aarch64: 22 new and 22 removed package(s)
  • arm-testing extra aarch64: 505 new and 503 removed package(s)
  • arm-testing kde-unstable aarch64: 350 new and 350 removed package(s)

See the full package list here

Testers needed on arm-testing branch

We are in need of testers for our arm-testing and arm-unstable branches.
So if you are adventurous and want newer software quicker, we would love for you to help us test out the new packages in arm-testing branch.

All you have to do to switch to this branch is:

  • Run this command to switch branch: sudo pacman-mirrors -aS testing && sudo pacman -Syyu. This will generate a new mirrorlist for you, sync your databases with the new mirror and update your system using the arm-testing branch.

We would then love for you to give feedback in our update posts in Testing Updates. That way we can better find and fix bugs, before they hit arm-stable branch. Thank you!

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

1 Like

Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

:arrow_right: 2023-04-14


Docker 23 not starting

Since the update to Docker 23, upstream is now inforcing new paths for apparmor related stuff. But there has been changes to dependencies yet. So Docker 23 will error on start.
Fix: Install apparmor from the repositories.


Ethernet and Wifi not working right on kernel 6.1.2+ on some devices

Some devices have been reported to not have properly working ethernet and wifi after the update to kernel 6.1.2 and above.
Fix: Kernel 6.1.5-2 and above should have working ethernet and wifi again.

Reduced video playback performance in mpv

There has been reports of video playback performance in mpv has regressed since an update to mpv.
Fix: MPV now needs a vd-lavc-dr=no parameter to play hw acceleration supported 1080p videos smoothly.

Touch input on Firefox with Phosh not working in Firefox 108

Since the update to Firefox 108, the touch input does not work. Seems to be an issue with a couple of the changes the mobile-config brings in.
Fix Fixed in version 4.0.0-1 of mobile-config-firefox released with Manjaro testing on April 14, 2023


OpenSSL 1.1 library not found

Some applications might still be looking for openssl 1.1.
Solution: Install openssl-1.1 package with sudo pacman -S openssl-1.1.


Firefox shows wrong colors when playing video on Raspberry Pi 4

Since Mesa 22.2, Firefox has been showing weird colors when playing video on the Raspberry Pi 4. This is caused by an issue in upstream mesa, which was recently fixed.
Fix: Update to mesa 22.2.3-0.1 in the repository, which includes this fix.

Chromium in Wayland crashes with --in-process-gpu

Since Mesa 22.2.0, Chromium running in wayland sessions seems to crash when running with the --in-process-gpu option. Running in X11 seems fine, although it’s slow.
Fix: Update to Mesa 22.3.2 was reported to work here.


Plasma Mobile Dialer seems to be unreliable

Plasma Dialer 22.09 seems to have issues switching audio profiles and as such might require manual switching. Sometimes audio is completely missing.

Reduced video performance on youtube

Some may encounter reduced video playback performance on YouTube in Firefox with the new Mesa 22.2 drivers.
No workaround at this time.

Old Issues

Phosh crashes when closing apps
An upstream issue results in the Phosh shell to crash when you close the app in the app switcher, with animations turned off.
Fix: Enable animations in Tweaks application

Mouse cursor is slow on Raspberry Pi
Due to a change in the Raspberry Pi kernels upstream, they no longer support FKMS. This can result in slow performance when using the FKMS drivers with the newer Raspberry Pi kernels.
Solution: Open /boot/config.txt, change fkms to kms in the dtoverlay line. Save the file and reboot.

[Waydroid container cannot access internet
Cause: new default waydroid configuration issue, tracked here.

Short-term Solution:

  1. create /etc/nftables.d/waydroid.nft with the following contents:
#!/usr/sbin/nft -f
table inet filter {
    chain input {
        iifname "waydroid0" accept comment "Allow incoming network traffic from WayDroid"
    chain forward {
        iifname "waydroid0" accept comment "Allow outgoing network traffic from WayDroid"
        ct state {established, related} counter accept comment "accept established connections"
  1. any time you launch waydroid, run the following after it has started:
echo "ip route add default via" |sudo waydroid shell

On PinePhone the KDE Plasma Mobile will hang at the lock screen, to access Ctrl+Alt+F2 and run loginctl unlock-session c1

Apparently the SSH is not running, so personally i can’t do much about it but re-flash. Also noticed that the phone got hot as never before while on that lock screen message…

1 Like

Maybe check with the phosh image if it is similar: Releases · manjaro-pinephone/phosh · GitHub

Phosh was flawless update regardless the branch i was using. Now currently on unstable with that install.

Is there any fix or workaround found? I already tried downgrading to stable, which didn’t worked and just unlocking the session like mentioned above also doesn’t work.

Possibly related to this report on the PINE64 forum (though that person is using unstable, not testing).

I found that sometimes kscreenlocker_greet got seg.fault,

/usr/lib/kscreenlocker_greet --testing

So, I mv -i /usr/lib/kscreenlocker_greet /usr/lib/kscreenlocker_greet.exec

and create /usr/lib/kscreenlocker_greet as a shell script always return code 0.


/usr/lib/kscreenlocker_greet.exec $1

exit 0

1 Like

Thank you for your solution, it looked promising, although it didn’t worked for me, instead of the message with “loginctl unlock-session c1”, I get a black screen. Here is the output when I execute /usr/lib/kscreenlocker_greet --testing in another tty:

qt.qpa.wayland: qtvirtualkeyboard currently is not supported at client-side, use QT_IM_MODULE=qtvirtualkeyboard at compositor-side.
wl_drm@22: error 0: authenticate failed
warning: queue 0xaaab05121bf0 destroyed while proxies still attached:
  wl_display@1 still attached
warning: queue 0xaaab05121a70 destroyed while proxies still attached:
  wl_display@1 still attached
qt.qpa.wayland: Failed to initialize EGL display 3001
The Wayland connection broke. Did the Wayland compositor die?

Am I missing something?

I managed to downgrade my system to stable, which works again.

I’m using Plasma on a Pinephone Pro. Things froze after the upgrade, but I was finally able to reboot it. However, I simply receive a message saying,

locker is broken and unlocking is not possible […] unlock it, switch to a virtual terminal (e.g.Ct […] in to your account and execute the command

loginctl unlock-session c1

out of the virtual session by pressing Ctrl+D, a […] back to the running session (Ctrl+Alt+F2). […] have forgotten the instructions, you can get […] screen by pressing CTRL+ALT+Fc1

Note, the message is truncated, in that it doesn’t fully fit the width of the Pinephone Pro screen. I’ve indicated where it’s cut off with the “[…]” notation.

I have no clue how to fix this.


I tried with the keyboard, and I did get into the virtual session (Ctrl+Fn+Alt+F2). So, I’m able to run commands there. But, I’m not sure what to do. I did run the command (both with sudo and just with my regular user) “loginctl unlock-session c1”. I then tried rebooting, but no luck. I tried “Ctrl+D”, which threw me out of the virtual session. I then went back into the session, though not via Ctrl+Fn+Alt+F2, but rather by logging back in. I’m not sure what “Fc1” is referring to. I tried Ctrl+Alt+Fn+F1, which leads to the KDE symbol, but it’s simply frozen (I then returned to terminal F2). I tried rerunning the update command (sudo pacman -Syyu), but it simply read, “there is nothing to do” (I did get WiFi working with nmtui).

Hi @philm

GT King Pro Manjaro-Arm-Gnome-linux-aml-6.1.19-1 Upgraded to Arm-Testing-2023-04-14 successfully but with the following warnings:

(27/67) upgrading graphviz                              [##############################] 100%
Warning: Could not load "/usr/lib/graphviz/libgvplugin_gdk.so.6" - It was found, so perhaps one of its dependents was not.  Try ldd.
Warning: Could not load "/usr/lib/graphviz/libgvplugin_gtk.so.6" - It was found, so perhaps one of its dependents was not.  Try ldd.
Warning: Could not load "/usr/lib/graphviz/libgvplugin_gdk.so.6" - It was found, so perhaps one of its dependents was not.  Try ldd.
Warning: Could not load "/usr/lib/graphviz/libgvplugin_gtk.so.6" - It was found, so perhaps one of its dependents was not.  Try ldd.
(28/67) upgrading gst-plugin-pipewire                   [##############################] 100%

Whenever the package “graphviz” is being upgraded these warnings always shows up.

Any suggestions how to rectify these warnings? Thanks.

Note, this update came with mobile-config-firefox 4.0.0-1 which fixes the firefox touch issue on my PinePhone Pro from 2023-01-03.

Same here.

Plasma-Mobile is currently broken. Partly also due to the Qt5 update. Also some packages of plamo are outdated with regular tarballs


Here to chew bubble gum and fix things…

Do we know what the status of KDE’s efforts are, and is there anything we can do to help?


A plasma mobile section is present

1 Like

did not seen LXQT-1.3 for test?

Interesting. I do not see it in unstable but do see it in the arch-arm packages. Looks like it was built yesterday; Maybe wait for our mirrors to sync with theirs?

1.3.0 is now in the unstable branch.

1 Like