[ARM Testing Update] 2022-06-05 - Toolchain, Perl, Firefox, Mesa and kernels

Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

Mouse cursor is slow on Raspberry Pi

Due to a change in the Raspberry Pi kernels upstream, they no longer support FKMS. This can result in slow performance when using the FKMS drivers with the newer Raspberry Pi kernels.
Solution: Open /boot/config.txt, change fkms to kms in the dtoverlay line. Save the file and reboot.

Waydroid container cannot access internet

Cause: new default waydroid configuration issue, tracked here.

Short-term Solution:

  1. create /etc/nftables.d/waydroid.nft with the following contents:
#!/usr/sbin/nft -f
table inet filter {
    chain input {
        iifname "waydroid0" accept comment "Allow incoming network traffic from WayDroid"
    chain forward {
        iifname "waydroid0" accept comment "Allow outgoing network traffic from WayDroid"
        ct state {established, related} counter accept comment "accept established connections"
  1. any time you launch waydroid, run the following after it has started:
echo "ip route add default via" |sudo waydroid shell
Old Issues
Plasma Dialer cannot answer calls

Sadly Plasma Dialer 22.02 has a serious regression with no known workaround. It’s not possible to accept incoming calls. Very sorry about this. Follow the upstream bug report. We will patch the package as soon as a solution is found.

Plasma Mobile - Black screen after update

We are seeing some reports about Plasma Mobile on the PinePhone only showing a black screen after entering the PIN after this update.
Workaround: Downgrade qt5-es2-wayland to 5.15.2+kde+r41 which is now back in Stable and Testing branch repositories.

New Breath theme not applying correctly

With the update to the new Breath theme, a migration package tries to apply the new theme correctly.
However this is not getting done for Plasma’s Lockscreen and the SDDM theme.
So please go through your settings after updating to make sure the themes are correctly applied.
Fix: manjaro-system should take care of this for you.

Plasma Mobile switch to ModemManager

With the PlaMo Gear 21.12 release, Plasma Mobile is now using ModemManager as the telephony stack. So in order to use SIM capabilities, you need to switch from using oFono to ModemManager.
Fix: Run sudo systemctl disable --now ofono ofonoctl && sudo systemctl enable --now ModemManager. You might have to reboot your phone for Plasma Mobile to pick up this change.

Plasma Mobile has does not launch after update
This was caused by an error in kwin 5.23.2 which only affects installs based on openGLES (qt5-es2).
Fix: Update to kwin 5.23.2-1.2 or above.

No ethernet on rk3399 boards
A recent kernel regression has resulted in built in ethernet on rk3399 based boards, such as RockPro64 and Rock Pi 4’s, no longer works on kernel 5.14. This is an upstream issue that has not been fixed yet.
Fix: Update to linux-5.14.1-2 or newer.

Vivaldi no longer working
The issue is present in all chrome based browser (except Chromium that got a patch for it).
It’s an issue with systemd-resolved and has been reported in the Arch Linux Bug Tracker.
Needs to be fixed by Vivaldi updates in the future.
Fix: Vivaldi 4.1.2369.21 fixed this issue.

Modemmanager-pp dependency issue
modemmanager-pp 1.16.10 depends on libqmi-pp and libmbim-pp, but they are no longer found in the repo.
Fixed by updated to modemmanager-pp 1.18rc1+2+ga20f2c05-2.

systemd-hook unsuccesful after pacman 6 update
After the pacman 6 update, updates will create this message in the post-transation hooks part:

Running the command manually works and there has been no issues reported as the result of this. This will either get fixed at some point in Pacman or SystemD.
Should be fixed with pacman-6.0.0-4

Keyring issues
If you have some gpg keyring issues, you can run sudo systemctl start pacman-init.service which will regenerate your keyring. Will take a few minutes to complete.
Should be fixed with manjaro-system-20210716-1

Plasma Mobile no longer boots
The current update to qt5-es2-base results in Plasma Mobile no longer booting, showing a screen that says to run a loginctl command to login.
Fixed by updating to qt5-es2-base-5.15.2+kde+r199-3.1 and qt5-es2-declarative-5.15.2+kde+r28-3.1.

Kwin crashes on startup on Pinebook Pro
This seems to be related to Mesa 20.3 and the Pinebook Pro support in kernel 5.10, as this does not seem to happen on other devices.
It does not impact 3d performance as far as I can tell. Just the OpenGL compositing in Kwin.
Fixed with mesa 20.3.2-2.

My VPN no longer connects
OpenVPN 2.5.0 changed how VPN routes work.
Workaround is to downgrade to previous version (2.4.9):

sudo pacman -U /var/cache/pacman/pkg/openvpn-2.4.9*

DP Alt Mode no longer works on Pinebook Pro
This is a known issue, the hacky patch we had to enable this has broken in recent kernels.
@tsys and Ayufan are looking into it.
As a workaround you can install linux-pinebookpro again.
FIXED with linux-5.9.12-4 and linux-rc-5.10-rc7-2 and above.

brcm-patchram-plus and pi-blueooth are in conflict
See this post for workaround:
[ARM Testing Update] 2020-11-16 - Bitwarden, Mesa-Git, Pacman and kernels - #10 by Darksky

Plasma Mobile Keyboard
The plasma mobile onscreen keyboard does not work with QT 5.15.0.
This is fixed by updating to kwin 5.19.3-1.1.

PinePhone uboot
This update to the PinePhone Uboot package (2020.04-2), changed how the DTS is loaded from the kernel, since the Kernel DTS for the Pinephone also changed. When doing this update on the PinePhone images from Alpha5 and back, please make this change to the /boot/extlinux/extlinux.conf before rebooting:

  • sun50i-a64-pinephone.dtb to sun50i-a64-pinephone-1.2.dtb

Manual interventions:
The nss and zn_poly packages prior to version 3.51.1-1 and version 0.9.2-2 respectively, were missing a soname link each. This has been fixed in 3.51.1-1 and 0.9.2-2 of these packages, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

nss: /usr/lib/p11-kit-trust.so exists in filesystem
zn_poly: /usr/lib/libzn_poly-0.9.so  exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/p11-kit-trust.so --overwrite /usr/lib/libzn_poly-0.9.so

to perform the upgrade.

Device stopped booting after Uboot update
The uboot update included a change to the extlinux.conf file. This change will be incompatible with the old 1 partition layout of some devices.
So if you are updating installs made with images 20.02.1 or older, you need to apply this fix before rebooting!
To fix this please edit your /boot/extlinux/extlinux.conf file and add 2 periods in front of each first slash, like so:

KERNEL ../Image
FDT ../dtbs/ #etc.
APPEND initrd=../initramfs-linux.img #etc.

Save the file and reboot.

Looks like Waybar is broken at the moment. Investigating it…

EDIT: seems the bluetooth module is the one causing the crash. If you comment it out in .config/waybar/config it loads fine. Will check if any changes to the current bluetooth config is needed.

EDIT2: OK there have been breaking changes in bluetooth configuration of Waybar…(not sure why they don’t follow semantic versioning, or documenting those in a changelog :frowning:). Reference: waybar `0.9.13` crashes · Issue #1574 · Alexays/Waybar · GitHub

EDIT3: here are the required changes to the Manjaro ARM Sway Waybar config: [sway] fix bluetooth configuration for waybar 0.9.13 (a5a292e7) · Commits · manjaro-arm / applications / arm-profiles · GitLab


No more network for the Odroid n2 after this up date.
The device boot with no issue

inxi -N
 Device-1: meson-g12a-dwmac driver: N/A

manjaro-arm 22.06

On PBP after the update, I don’t see bluetooth in waybar.

Waydroid not working after following the tips above.
waydroid-container.service logs snippet:

modprobe: FATAL: Module ashmem_linux not found in directory /lib/modules/5.18.1-3-MANJARO-ARM

Hm, that’s odd. I don’t believe there have been any changes to the N2 or Meson stuff between those two kernels.

So the fix in this post.

As far as I know, asmem is a built-in driver these days.
Looks like ashmem have been removed in kernel 5.18, to be replaced with memfd:

So this means our waydroid stuff needs to be updated. Although waydroid 1.2.1 should have the fix for it.

I can not confirm this.
everything works fine on N2+ with linux518

  Kernel: 5.18.1-3-MANJARO-ARM aarch64 bits: 64 compiler: gcc v: 12.1.0
    parameters: root=PARTUUID=15335d52-02 rootwait rw console=ttyAML0,115200n8 no_console_suspend
    fsck.repair=yes net.ifnames=0 clk_ignore_unused quiet splash plymouth.ignore-serial-consoles
  Console: pty pts/0 DM: LightDM 1.30.0 Distro: Manjaro ARM base: Arch Linux
  Type: ARM System: Hardkernel ODROID-N2Plus details: N/A

  Device-1: meson-g12a-dwmac driver: meson8b_dwmac v: N/A port: N/A bus-ID: N/A
    chip-ID: amlogic:ff3f0000 class-ID: ethernet
  IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>


Nice to read you, thanks for your reply.

Right now I build an image for the n2 (I’m not a n2+ owner for the moment), as wrote before the n2 is not up date with the 5.18 kernel, but the image I build is made with the 5.18, wait and see

==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k 5.18.1-3-MANJARO-ARM -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 5.18.1-3-MANJARO-ARM

It’s solved, with the new image I built, I wrote this message with the n2.
one more time thanks for your message.
no issue with samba and vnc, Enjoy !

@spikerguy and other dev

Odroid m1 LXQt up to date, no issue.


Just updated on the PinePhone with Plasma.
Haven’t noticed anything worth noting.

Now the pinephone keyboard is something I got just yesterday so I’m behind on what’s going on with it. As far as I understand, with kernel 5.17+ it should use userland xkb setup to access the alternative characters like - or | via AltG or however the special character is defined.

I can see this commit for 2.36-1 but I haven’t followed the progress there.
Using the following ppkb tool, there are still some evdev differences listed.

Probably there is some further conversation of this behaviour on Plasma Mobile’s team?

Yeah. Something like this was mentioned in the last meeting they had, and they are looking into what can be done for a better experience.

1 Like

I need to dig further into it. Can’t find any useful messages on the matrix channel :thinking:

Haven’t really spent much time with xkb to really know what I’m doing there.

PS: That little keyboard really is something else :smile:

No directly useful info in the plasma matrix channel. dobey and apol were really helpful and pointed me in a couple of directions.

Got a few leads for xkeyboard-config and this post on the pine64 forum. Haven’t tried it yet.

It would appear as the conversation in the previous Plasma Mobile meeting was in regards to maliit instead, not the physical i2c keyboard.

@Strit any chance we can get updated sources for gnome-clocks-mobile? repo package is at 42.0-1 while gitlab is still at 41.0-2.

EDIT: upon further investigation, it looks like the package is built by “Arch Linux ARM Build System”, so while it was formerly an overlay package, that no longer appears to be the case.

No further action is requested. Thank you

I think @philm was the one that pushed the updated version, so maybe he just forgot to push the updated PKGBUILD?

Seems like sound control is not working on my Pinebook Pro. The sound plays but no volume icon in tray or a way to control volume.

2 posts were split to a new topic: Is Discord available for ARM?

I cannot replicate that. I would recommend going to alsamixer if you haven’t, and press F6 to switch to the sound card rockchip,es8316-codec and playing around with the settings.

@Strit when I did an update today:

 alex@pbp    sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
error: failed retrieving file 'community.db' from mirrors.opensource.is : The requested URL returned error: 404
error: failed retrieving file 'core.db' from mirrors.opensource.is : The requested URL returned error: 404
error: failed retrieving file 'extra.db' from mirrors.opensource.is : The requested URL returned error: 404
warning: too many errors from mirrors.opensource.is, skipping for the remainder of this transaction
:: Starting full system upgrade...
 there is nothing to do

Just sounds like a mirror is offline.