[ARM Testing Update] 2021-02-18 - KDE Frameworks and kernels

Hello ARM community.

New testing update for all of you testers out there!


Some highlights:

  • A cpuple of our kernels got updated
  • KDE Frameworks is now updated to 5.79
  • Some python packages got updated

Upstream Notifications:

Older notifications

The ghostpcl and ghostxps requires manual intervention (if you have these installed):
https://www.archlinux.org/news/ghostpcl9532-2-and-ghostxps9532-2-updates-require-manual-intervention/

The nss package requires manual intervention:
https://www.archlinux.org/news/nss3511-1-and-lib32-nss3511-1-updates-require-manual-intervention/

The packages hplip and firewalld requires manual intervention:
https://www.archlinux.org/news/hplip-3203-2-update-requires-manual-intervention/
https://www.archlinux.org/news/firewalld081-2-update-requires-manual-intervention/


Package Changes

(Thu Feb 18 00:11:31 CET 2021)

  • arm-testing community aarch64: 141 new and 132 removed package(s)
  • arm-testing core aarch64: 10 new and 10 removed package(s)
  • arm-testing extra aarch64: 135 new and 134 removed package(s)
  • arm-testing kde-unstable aarch64: 160 new and 158 removed package(s)
  • arm-testing mobile aarch64: 5 new and 5 removed package(s)
:: Different overlay package(s) in repository community aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2021-02-14         2021-02-18
-------------------------------------------------------------------------------
                          bmap-tools                3.5-1                3.6-1
                               calls              0.3.0-1   0.3.0+1+gd75a08b-1
                              chatty 0.2.0+214+gd7f2eb8-1 0.2.0+217+g85b8df3-1
                        eg25-manager   0.1.2+2+g3bb6e15-3   0.1.2+2+g3bb6e15-4
                           feedbackd  0.0.0+git20210125-1  0.0.0+git20210125-2
                         gtk3-mobile            3.24.24-1            3.24.24-2
                     hfd-service-git        r21.896ef75-2        r25.c7d0237-1
                               phosh   0.8.1+1+g1fd951a-1  0.8.1+11+gb572f80-1
                     pico-wizard-git        r60.34083c8-1       r113.78f7351-2
              pinephone-post-install           20210210-2           20210215-1
                    plasma-angelfish              1.6.0-1              1.7.1-1
              plasma-mobile-settings           20210212-1           20210214-2
                     telepathy-ofono           20200305-2           20210214-1
                                 wys              0.1.8-1             0.1.10-1
                     breeze-plymouth                    -            5.20.90-1
                           corrosion                    -      r165.gd93a9e0-1
           pico-wizard-plamo-scripts                    -       r113.78f7351-2


:: Different sync package(s) in repository community aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2021-02-14         2021-02-18
-------------------------------------------------------------------------------
                               amule              11066-2            1:2.3.3-1
                        ansible-lint              4.3.7-5              5.0.0-1
                          arch-audit             0.1.15-2             0.1.16-1
                              bandit              1.7.0-1              1.7.0-2
                           bctoolbox             4.4.28-1             4.4.29-1
                                 bpf               5.10-2               5.11-1
                              bpytop             1.0.61-1             1.0.62-1
                               broot              1.2.3-1              1.2.4-1
                                btfs               2.23-1               2.24-1
                               bzrtp             4.4.28-1             4.4.29-1
                             calibre             5.10.1-1             5.11.0-1
               cgroup_event_listener               5.10-2               5.11-1
                          coolreader             3.2.51-1             3.2.53-1
                            cpupower               5.10-2               5.11-1
                             dblatex             0.3.11-1             0.3.12-1
                             ddcutil              1.0.1-1                    -
                             dua-cli             2.10.7-1             2.11.0-1
                          exfatprogs              1.0.4-2              1.1.0-1
                            feeluown              3.7.4-1              3.7.5-1
                               gobby1:0.5.0+116+g295e697-1            1:0.6.0-1
                          gpio-utils               5.10-2               5.11-1
                          gwenhywfar              5.4.1-1              5.5.1-1
                              hatari              2.3.0-1              2.3.1-1
                           highlight               3.60-1               3.61-1
                       highlight-gui               3.60-1               3.61-1
                            htmlhint             0.14.2-1             0.14.2-3
                              hyperv               5.10-2               5.11-1
                                i2pd             2.35.0-4             2.36.0-1
                       i3status-rust             0.14.3-1             0.14.7-1
                              igraph              0.8.5-1              0.9.0-1
                           iio-utils               5.10-2               5.11-1
                            lesspipe               1.84-2               1.85-1
                               libfm              1.3.1-2              1.3.2-1
                         libfm-extra              1.3.1-2              1.3.2-1
                          libfm-gtk2              1.3.1-2              1.3.2-1
                          libfm-gtk3              1.3.1-2              1.3.2-1
                           libosinfo              1.8.0-1              1.9.0-1
                       libtraceevent               5.10-2               5.11-1
                             libvips             8.10.2-2             8.10.3-1
                    linux-tools-meta               5.10-2               5.11-1
                              lrcalc                2.0-1                2.0-2
                             lxpanel             0.10.0-2             0.10.1-1
               matrix-appservice-irc             0.23.0-1             0.24.0-1
                       mediastreamer             4.4.28-1             4.4.29-1
                                mujs              1.0.9-1              1.1.0-1
                              nikola              8.1.2-2              8.1.3-1
                   npm-check-updates             11.1.1-1             11.1.4-1
                                ortp             4.4.28-1             4.4.29-1
                           osinfo-db           20201015-1           20210202-1
                   otf-cascadia-code            2009.22-1            2102.03-1
                            patroneo              2.0.0-2              2.1.0-1
                             pcmanfm              1.3.1-2              1.3.2-1
                        pcmanfm-gtk3              1.3.1-2              1.3.2-1
                                perf               5.10-2               5.11-1
                perl-mail-imapclient               3.42-3               3.43-1
                     perl-par-packer              1.052-1              1.052-2
                      perl-test-file              1.444-1              1.445-1
                             plocate              1.1.3-2              1.1.4-1
                            polymake                4.3-2                4.3-3
                             prosody           1:0.11.7-1           1:0.11.8-1
                  python-aiobotocore              1.2.0-1              1.2.1-1
                        python-anyio              2.0.2-4              2.1.0-1
                     python-atpublic              2.1.2-1              2.1.3-1
                      python-breathe             4.26.1-2             4.26.1-3
                    python-construct            2.10.59-1            2.10.60-1
         python-cryptography-vectors              3.4.4-1              3.4.5-1
                       python-docker              4.4.1-1              4.4.2-1
                   python-flufl-lock              5.0.4-1              5.0.5-1
                   python-flufl.i18n              3.1.4-1              3.1.5-1
                  python-google-auth             1.26.0-1             1.26.1-1
            python-jupyterlab_server              2.2.0-1              2.2.1-1
                        python-ldap3              2.8.1-3                2.9-1
                   python-oslo-utils              4.7.0-3              4.8.0-1
             python-ovirt-engine-sdk              4.4.9-1             4.4.10-1
                       python-pandas              1.2.1-1              1.2.2-1
                     python-pygments              2.7.4-1              2.8.0-1
                     python-pynamodb              5.0.0-1              5.0.2-1
                         python-rich             9.10.0-1             9.11.0-1
                       python-scramp              1.2.1-1              1.2.2-1
                       python-sphinx              3.4.3-1              3.5.1-1
               python-sphinx-autoapi              1.7.0-1              1.7.0-3
      python-sphinxcontrib-applehelp              1.0.2-3              1.0.2-5
        python-sphinxcontrib-devhelp              1.0.2-3              1.0.2-5
       python-sphinxcontrib-htmlhelp              1.0.3-3              1.0.3-5
         python-sphinxcontrib-jsmath              1.0.1-6              1.0.1-8
         python-sphinxcontrib-qthelp              1.0.3-3              1.0.3-5
python-sphinxcontrib-serializinghtml              1.1.4-3              1.1.4-5
                          python-tox             3.21.4-1             3.22.0-1
                      python-trustme              0.6.0-3              0.7.0-1
                         python2-tox             3.21.4-1             3.22.0-1
                                qmmp              1.4.3-1              1.4.4-1
                              restic             0.11.0-1             0.12.0-1
                        ruby-bundler              2.2.9-1             2.2.10-1
                           ruby-yard             0.9.25-1             0.9.26-1
                       rust-analyzer           20210208-1           20210215-1
                                skim              0.9.3-1              0.9.4-1
                           stylelint            13.10.0-1            13.10.0-3
           stylelint-config-standard             20.0.0-3             20.0.0-5
                           syncthing             1.12.1-1             1.13.1-1
                  syncthing-relaysrv             1.12.1-1             1.13.1-1
                     taskwarrior-tui             0.9.15-1             0.10.2-1
          terraform-provider-libvirt              0.6.3-1              0.6.3-2
                          terragrunt             0.27.1-1             0.28.4-1
                           texstudio              3.0.4-1              3.0.5-1
                                tmon               5.10-2               5.11-1
                               toxic             0.10.0-1             0.10.1-1
                   ttf-cascadia-code            2009.22-1            2102.03-1
                       ttf-joypixels              6.0.0-1              6.5.0-1
                   ttf-sarasa-gothic             0.17.0-1             0.18.1-1
                           uglify-js             3.12.7-1             3.12.8-1
                            urlwatch               2.22-3               2.22-5
                               usbip               5.10-2               5.11-1
         v2ray-domain-list-community     20210212170843-1     20210213084020-1
                            vim-clap               0.22-3               0.23-1
                          vokoscreen              3.0.7-1              3.0.8-1
                 woff2-cascadia-code            2009.22-1            2102.03-1
                              wpscan           1:3.8.13-1           1:3.8.14-1
                             xtrlock               2.14-1               2.15-1
                              libaxc                    -              0.3.4-2
                            libomemo                    -              0.7.1-2
                               micro                    -              2.0.8-3
                         plasma-pass                    -              1.2.0-1
                        python-hsluv                    -              5.0.0-2
        stylelint-config-recommended                    -              3.0.0-1
                            websocat                    -              1.6.0-2


:: Different overlay package(s) in repository core aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2021-02-14         2021-02-18
-------------------------------------------------------------------------------
                               linux            5.10.15-1            5.10.17-1
                       linux-headers            5.10.15-1            5.10.17-1
                     linux-pinephone            5.10.16-1            5.10.17-1
             linux-pinephone-headers            5.10.16-1            5.10.17-1
                      manjaro-system           20210116-2         20210217-1.0


:: Different sync package(s) in repository core aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2021-02-14         2021-02-18
-------------------------------------------------------------------------------
                            fakeroot             1.25.3-1             1.25.3-2
                                perl             5.32.0-3             5.32.1-1
                                 tar               1.33-1               1.34-1
                          util-linux             2.36.1-4             2.36.2-1
                     util-linux-libs             2.36.1-4             2.36.2-1


:: Different sync package(s) in repository extra aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2021-02-14         2021-02-18
-------------------------------------------------------------------------------
                             akonadi            20.12.2-1            20.12.2-2
                           appstream             0.14.0-4             0.14.1-1
                        appstream-qt             0.14.0-4             0.14.1-1
                              attica             5.78.0-1             5.79.0-1
                           audacious                4.1-1                4.1-2
                               baloo             5.78.0-1             5.79.0-1
                            bluez-qt             5.78.0-1             5.79.0-1
                        breeze-icons             5.78.0-1             5.79.0-1
                               cmake             3.19.4-1             3.19.5-1
                         dbus-broker                 26-1                 27-1
                                 eog             3.38.1-1             3.38.2-1
                              evince             3.38.1-1             3.38.2-1
                 extra-cmake-modules             5.78.0-1             5.79.0-1
                frameworkintegration             5.78.0-1             5.79.0-1
                                  gn    0.1831.e002e68a-1    0.1859.53d92014-1
                gnome-control-center             3.38.3-1             3.38.4-1
                       gnome-desktop           1:3.38.3-1           1:3.38.4-1
          gnome-getting-started-docs             3.38.0-1             3.38.1-1
                        gnome-photos             3.38.0-1             3.38.1-1
                      gnome-terminal             3.38.2-1             3.38.3-1
                           gucharmap             13.0.0-1             13.0.5-1
                         imagemagick          7.0.10.62-1           7.0.11.0-1
                     imagemagick-doc          7.0.10.62-1           7.0.11.0-1
                              jasper             2.0.24-1             2.0.25-1
                          jasper-doc             2.0.24-1             2.0.25-1
                         kactivities             5.78.0-1             5.79.0-1
                   kactivities-stats             5.78.0-1             5.79.0-1
                             kapidox             5.78.0-1             5.79.0-1
                            karchive             5.78.0-1             5.79.0-1
                               kauth             5.78.0-1             5.79.0-1
                          kbookmarks             5.78.0-1             5.79.0-1
                       kcalendarcore             5.78.0-1             5.79.0-1
                            kcmutils             5.78.0-1             5.79.0-1
                             kcodecs             5.78.0-1             5.79.0-1
                         kcompletion             5.78.0-2             5.79.0-1
                             kconfig             5.78.0-1             5.79.0-1
                      kconfigwidgets             5.78.0-1             5.79.0-1
                           kcontacts           1:5.78.0-1           1:5.79.0-1
                         kcoreaddons             5.78.0-1             5.79.0-1
                              kcrash             5.78.0-1             5.79.0-1
                                kdav           1:5.78.0-1           1:5.79.0-1
                         kdbusaddons             5.78.0-1             5.79.0-1
                        kdeclarative             5.78.0-1             5.79.0-1
                                kded             5.78.0-1             5.79.0-1
                     kdelibs4support             5.78.0-1             5.79.0-1
                     kdesignerplugin             5.78.0-1             5.79.0-1
                               kdesu             5.78.0-1             5.79.0-1
                            kdevelop              5.6.2-1              5.6.2-2
                           kdewebkit             5.78.0-1             5.79.0-1
                              kdnssd             5.78.0-1             5.79.1-1
                           kdoctools             5.78.0-1             5.79.0-1
                          kemoticons             5.78.0-1             5.79.0-1
                       kfilemetadata             5.78.0-1             5.79.0-1
                        kglobalaccel             5.78.0-1             5.79.0-1
                          kguiaddons             5.78.0-1             5.79.0-1
                           kholidays           1:5.78.0-1           1:5.79.0-1
                               khtml             5.78.0-1             5.79.0-1
                               ki18n             5.78.0-1             5.79.0-1
                         kiconthemes             5.78.0-1             5.79.0-1
                           kidletime             5.78.0-1             5.79.0-1
                     kimageannotator              0.4.0-2              0.4.1-1
                       kimageformats             5.78.0-1             5.79.0-1
                               kinit             5.78.0-1             5.79.0-1
                                 kio             5.78.0-3             5.79.0-1
                           kirigami2             5.78.0-1             5.79.0-1
                         kitemmodels             5.78.0-1             5.79.0-1
                          kitemviews             5.78.0-1             5.79.0-1
                         kjobwidgets             5.78.0-1             5.79.0-1
                                 kjs             5.78.0-1             5.79.0-1
                            kjsembed             5.78.0-1             5.79.0-1
                        kmediaplayer             5.78.0-1             5.79.0-1
                           knewstuff             5.78.0-1             5.79.0-1
                      knotifications             5.78.0-1             5.79.0-1
                       knotifyconfig             5.78.0-1             5.79.0-1
                            kpackage             5.78.0-1             5.79.0-1
                              kparts             5.78.0-1             5.79.0-1
                             kpeople             5.78.0-1             5.79.0-1
                           kplotting             5.78.0-1             5.79.0-1
                                kpty             5.78.0-1             5.79.0-1
                        kquickcharts             5.78.0-1             5.79.0-1
                               kross             5.78.0-1             5.79.0-1
                             krunner             5.78.0-1             5.79.0-1
                            kservice             5.78.0-1             5.79.0-1
                         ktexteditor             5.78.0-1             5.79.0-1
                        ktextwidgets             5.78.0-1             5.79.0-1
                     kunitconversion             5.78.0-1             5.79.0-1
                             kwallet             5.78.0-1             5.79.0-1
                            kwayland             5.78.0-1             5.79.0-1
                      kwidgetsaddons             5.78.0-1             5.79.0-1
                       kwindowsystem             5.78.0-1             5.79.0-1
                             kxmlgui             5.78.0-1             5.79.0-1
                       kxmlrpcclient             5.78.0-1             5.79.0-1
                          libakonadi            20.12.2-1            20.12.2-2
                         libbytesize                2.4-4                2.5-1
                          libebur128              1.2.5-1              1.2.6-1
                        libqalculate             3.16.1-1             3.17.0-1
                              libqmi           1.26.8-1.1            1.26.10-1
                               libuv             1.40.0-1             1.41.0-1
                                meld             3.20.2-2             3.20.3-1
                               meson             0.56.2-1             0.57.0-1
                     modemmanager-qt             5.78.0-1             5.79.0-1
                                 mpd             0.22.4-2             0.22.6-1
                   networkmanager-qt             5.78.0-1             5.79.0-1
                        oxygen-icons           1:5.78.0-1           1:5.79.0-1
                    oxygen-icons-svg           1:5.78.0-1           1:5.79.0-1
                              pahole               1.19-1               1.20-1
                             perl-tk            804.035-2            804.036-1
                      phonon-qt5-vlc             0.11.1-2             0.11.2-1
                    plasma-framework             5.78.0-1             5.79.0-1
                          postgresql               13.1-3               13.2-1
                     postgresql-docs               13.1-3               13.2-1
                     postgresql-libs               13.1-3               13.2-1
                              prison             5.78.0-1             5.79.0-1
            prometheus-node-exporter              1.1.0-1              1.1.1-1
                             purpose             5.78.0-1             5.79.0-1
                       qalculate-gtk             3.16.0-1             3.17.0-1
                  qqc2-desktop-style             5.78.0-1             5.79.0-1
                                   r              4.0.3-2              4.0.4-1
                            seahorse         1:3.38.0.1-1           1:3.38.1-1
                               solid             5.78.0-1             5.79.0-1
                              sonnet             5.78.0-1             5.79.0-1
                           spectacle            20.12.2-1            20.12.2-2
                         syndication             5.78.0-1             5.79.0-1
                 syntax-highlighting             5.78.0-1             5.79.1-1
                        threadweaver             5.78.0-1             5.79.0-1
                          vte-common             0.62.2-1             0.62.3-1
                                vte3             0.62.2-1             0.62.3-1
                   vulkan-icd-loader            1.2.166-1            1.2.169-1
                        vulkan-tools            1.2.166-1            1.2.169-1
                               whois              5.5.7-1              5.5.8-1
                           wpewebkit             2.30.4-2             2.30.5-1
               xfce4-cpugraph-plugin              1.2.1-1              1.2.2-1
                                yelp             3.38.2-1             3.38.3-1
                            yelp-xsl             3.38.2-1             3.38.3-1
                             ddcutil                    -              1.0.1-1


:: Different overlay package(s) in repository kde-unstable aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2021-02-14         2021-02-18
-------------------------------------------------------------------------------
                             akonadi20.12.2.r12434.gc7e84ea42-120.12.2.r12442.ga30386836-1
                    akonadi-calendar20.12.2.r1898.gee04456-120.12.2.r1902.g11e13f2-1
              akonadi-calendar-tools20.12.2.r842.g7aa6e1a-120.12.2.r845.g5315cfc-1
                    akonadi-contacts20.12.2.r2971.g2df8f923-120.12.2.r2976.g0e16bcea-1
               akonadi-import-wizard20.12.2.r1676.g3d51d11-120.12.2.r1679.g0e1b617-1
                        akonadi-mime20.12.2.r1588.gdf2f428-120.12.2.r1591.g0c125e6-1
                       akonadi-notes20.12.2.r978.g8548d37-120.12.2.r981.g3c29494-1
                      akonadi-search20.12.2.r1053.g500da7a-120.12.2.r1056.g9f3a7dd-1
                      akonadiconsole20.12.2.r1461.g9bd7137-120.12.2.r1464.g724fc5d-1
                           akregator20.12.2.r6047.gdd99e343-120.12.2.r6050.g5d8063aa-1
                            amazfish  1.9.4.r6.gfe2d3cc-1  1.9.6.r9.g0638cc7-1
                                 ark20.12.2.r4460.g27973370-120.12.2.r4464.gac60f6b4-1
                        breeze-icons5.79.0.r1699.gbcee7b30-15.79.0.r1701.g6f474dbb-1
                                buho      r347.g8e828dd-1      r348.g2d807a3-1
                     calendarsupport20.12.2.r484.g1fa76bb-120.12.2.r488.g60662dd-1
                           calindori   1.3.r63.gd9fde78-1   1.3.r68.g5d17254-1
                            discover5.21.0.r8010.g03f41d38-15.21.0.r8012.g6c9d2f24-1
                              disman5.20.90.r1788.g388e893-15.20.90.r1792.g2dffbe8-1
                             dolphin20.12.2.r6501.g39f5f1b53-120.12.2.r6505.g68704c2a2-1
                               elisa20.12.2.r2613.gbedc50ef-120.12.2.r2620.g80ea52d1-1
                          eventviews20.12.2.r596.gd7230c0-120.12.2.r599.g347b411-1
                frameworkintegration5.79.0.r562.g67e5c77-15.79.0.r564.g47ba14c-1
                           granatier20.12.2.r900.gaeb2d53-120.12.2.r902.g24faf9b-1
                     grantlee-editor20.12.2.r721.g657773a-120.12.2.r724.g38d624a-1
                       grantleetheme20.12.2.r295.ga26fed3-120.12.2.r299.gabaae00-1
                            gwenview20.12.2.r6514.gdec3c3f0-120.12.2.r6518.gd68d8765-1
                     incidenceeditor20.12.2.r668.g328d98b-120.12.2.r672.g45112fa-1
                           itinerary20.12.2.r1201.g940508b-120.12.2.r1202.gd529d83-1
                                 juk20.12.2.r3053.g8956f56d-120.12.2.r3055.g3a3bc5e5-1
                   kactivities-stats5.79.0.r327.g62b208f-15.79.0.r329.g69edcee-1
                        kaddressbook20.12.2.r5925.g972e192c-120.12.2.r5928.g2df751d3-1
                              kalarm20.12.2.r6317.gd3e93d57-120.12.2.r6320.gacb99805-1
                           kalarmcal20.12.2.r1084.g67b8139-120.12.2.r1087.gfb44b3b-1
                                kalk   0.1.r83.g51576a2-1   0.1.r85.gc67102a-1
                                kate20.12.2.r17569.gcfcb798e0-120.12.2.r17621.g35674bd6b-1
                           kblackbox20.12.2.r705.g7767b94-120.12.2.r706.g5a1a93e-1
                       kcalendarcore5.79.0.r1176.gdba85b39a-15.79.0.r1177.g2711272ea-1
                           kcalutils20.12.2.r808.g2a02f330f-120.12.2.r811.g612b6ded9-1
                              kclock  0.3.0.r1.gd02a4eb-1 0.3.0.r14.gb83c699-1
                             kconfig5.79.0.r786.g4af0de0-15.79.0.r787.ga06ffb3-1
                           kcontacts1:5.79.0.r3214.ga0ab8826-11:5.79.0.r3216.gced4ba53-1
                         kcoreaddons5.79.0.r1162.gdb9060e7-15.79.0.r1164.gbf182581-1
                                kdav1:5.79.0.r1262.gf71bf49-11:5.79.0.r1264.gcc8b73b-1
                       kde-dev-utils20.12.2.r539.g24e04dd-120.12.2.r540.g75e3f3d-1
                      kdebugsettings20.12.2.r770.g996e759-120.12.2.r776.g0fc6a71-1
                        kdeclarative5.79.0.r865.g9057ac2-15.79.0.r866.g9bd3ab1-1
                          kdeconnect20.12.2.r3130.g40c155f9-120.12.2.r3131.gcd1d047a-1
                     kdelibs4support5.79.0.r997.g20d525e5-15.79.0.r998.gb7c37da3-1
                            kdenlive20.12.2.r13836.g8672cec17-120.12.2.r13925.g94770e55a-1
                       kdepim-addons20.12.2.r3990.gb61d5a46-120.12.2.r3998.g49a897b1-1
                      kdepim-runtime20.12.2.r15042.gc5e2877b0-120.12.2.r15046.g18240a9ab-1
                    kdeplasma-addons5.21.0.r8462.g518ba82fc-15.21.0.r8466.g0129de135-1
                               kdesu5.79.0.r438.g7d7cb70-15.79.0.r440.g7269eb6-1
                           kdewebkit5.79.0.r256.g92e6556-15.79.0.r257.gf96e3f0-1
                            kdisplay5.20.90.r1435.g24a3e32-15.20.90.r1436.gb001f2f-1
                              kdnssd5.79.0.r287.g1b21805-15.79.0.r289.g8c14803-1
                      keditbookmarks20.12.2.r2722.g504da1ae5-120.12.2.r2724.gddd55c101-1
                       kfilemetadata5.79.0.r764.g916a47a-15.79.0.r765.g17f55ff-1
                                kget20.12.2.r3084.ga221dc10-120.12.2.r3085.g2983da50-1
                          kguiaddons5.79.0.r338.gdc97668-15.79.0.r340.g337b9a1-1
                           kholidays1:5.79.0.r905.gd63dc93-11:5.79.0.r906.g4f0810b-1
                               khtml5.79.0.r529.g9e58348-15.79.0.r530.g198bdbc-1
                         kiconthemes5.79.0.r473.g6bada57-15.79.0.r478.gbd648dd-1
                 kidentitymanagement20.12.2.r3752.g644b4a85-120.12.2.r3755.g72b3ecda-1
                       kimageformats5.79.0.r310.g0aaab10-15.79.0.r311.g7ba4d6a-1
                               kimap20.12.2.r1061.g8e8dd78-120.12.2.r1064.g8abcb21-1
                                 kio5.79.0.r4536.g42d6858c-15.79.0.r4546.gc5ca6820-1
                          kio-extras20.12.2.r6973.g0488ac0a-120.12.2.r6975.g7ba02f78-1
                          kio-gdrive20.12.2.r544.g73e34c9-120.12.2.r545.g4c86308-1
                           kirigami25.79.0.r2651.g81ccedfb-15.79.0.r2655.g60c8886d-1
                         kitemmodels5.79.0.r511.g54e8996-15.79.0.r513.g719feec-1
                          kitinerary20.12.2.r1584.gb85a41d-120.12.2.r1588.g0efe9f7-1
                            kjsembed5.79.0.r276.g3282a6b-15.79.0.r278.gcff2292-1
                               kldap20.12.2.r819.g34d108e-120.12.2.r822.g3b53360-1
                           kleopatra20.12.2.r5711.g56aec304-120.12.2.r5713.g716b09e9-1
                               kmail20.12.2.r25544.g901cc7a51-120.12.2.r25548.gda1c72a69-1
                kmail-account-wizard20.12.2.r756.gb7495e0-120.12.2.r759.g72734cd-1
                      kmailtransport20.12.2.r1572.g30b9034-120.12.2.r1575.g2231e34-1
                               kmbox20.12.2.r491.g0d89db7-120.12.2.r494.g28bc385-1
                        kmediaplayer5.79.0.r268.g0762fa6-15.79.0.r270.g531ea9a-1
                           kmenuedit5.21.0.r950.g493111f-15.21.0.r952.g01a673a-1
                               kmime20.12.2.r1407.g0a77358-120.12.2.r1410.gfd0237f-1
                                kmix20.12.2.r2326.g8baf8ca4-120.12.2.r2330.g962a1064-1
                           knewstuff5.79.0.r1043.g6bdce6bf-15.79.0.r1046.gac71f5f1-1
                              knotes20.12.2.r3410.ga95edda3-120.12.2.r3414.g9e4f09ca-1
                       knotifyconfig5.79.0.r319.gbb064da-15.79.0.r321.gabb472c-1
                           konqueror20.12.2.r14869.gdd9d21038-120.12.2.r14870.gef48b82b2-1
                             konsole20.12.2.r7705.g3b06b6f2-120.12.2.r7710.g78505040-1
                             kontact20.12.2.r5256.gfda02551-120.12.2.r5260.ga9e32ac8-1
                    kontactinterface20.12.2.r585.gc395a8e-120.12.2.r587.gf46654a-1
                        konversation20.12.2.r8937.g1a115f22-120.12.2.r8941.gd81b5806-1
                          korganizer20.12.2.r11286.g885766557-120.12.2.r11290.g3ae7478c2-1
                       kosmindoormap20.12.2.r586.gcabcf3f-120.12.2.r588.gd7e4a3f-1
                              kparts5.79.0.r473.g38a69c3-15.79.0.r474.gee74651-1
                             kpeople5.79.0.r1293.gb04a505-15.79.0.r1295.g639b277-1
                        kpimtextedit20.12.2.r1340.ge52da3a-120.12.2.r1343.g5043c93-1
                             kpkpass20.12.2.r190.g8b839ce-120.12.2.r193.g2a88cf7-1
                    kpublictransport20.12.2.r1479.gf8578e0-120.12.2.r1496.gafbcec1-1
                        kquickcharts5.79.0.r422.g93ef255-15.79.0.r424.g29d65b3-1
                               kross5.79.0.r310.gd110a9a-15.79.0.r311.g4994dec-1
                             krunner5.79.0.r576.g38b2ce7-15.79.0.r578.gb616420-1
                            kservice5.79.0.r873.g13ae7ce-15.79.0.r874.gfc86866-1
                               ksmtp20.12.2.r320.gec04739-120.12.2.r323.gca81636-1
                           ksysguard5.21.0.r3478.gab793762-15.21.0.r3479.gccca59fd-1
                          ksystemlog20.12.2.r602.ge3a70eb-120.12.2.r603.g542479e-1
                         ktexteditor5.79.0.r2717.gc439810e-15.79.0.r2721.g52b576ed-1
                               ktnef20.12.2.r618.gae4faad-120.12.2.r621.g102495e-1
                            ktorrent20.12.2.r2728.g744f7b26-120.12.2.r2729.g15858fe8-1
                             kwallet5.79.0.r1037.ge3214df-15.79.0.r1038.g98913c4-1
                     kwayland-server5.21.0.r1213.g7a1993a-15.21.0.r1219.g58eff40-1
                                kwin5.21.0.r18972.g12e0376fe-15.21.0.r18986.g378ecbc88-1
                              kwrite20.12.2.r17569.gcfcb798e0-120.12.2.r17621.g35674bd6b-1
                       kxmlrpcclient5.79.0.r425.ge96f3d5d2-15.79.0.r427.g5f0b3dedb-1
                          libakonadi20.12.2.r12434.gc7e84ea42-120.12.2.r12442.ga30386836-1
                         libgravatar20.12.2.r323.g20aa2e4-120.12.2.r326.g9f2701f-1
                           libkdepim20.12.2.r804.g4782e5d-120.12.2.r807.ge432148-1
                            libkgapi20.12.2.r1248.g31498b7-120.12.2.r1251.g10ff743-1
                             libkleo20.12.2.r713.g0f78fb7-120.12.2.r715.g4d26f5b-1
                            libksane20.12.2.r495.ge9973b8-120.12.2.r498.ga94333b-1
                          libkscreen5.21.0.r1564.g966f9a7-15.21.0.r1565.gbb3395f-1
                           libksieve20.12.2.r1485.gffca0245-120.12.2.r1488.g59160089-1
                         libquotient     r1958.g3fbd9ca-1     r1964.g48d2ecc-1
                          mailcommon20.12.2.r990.g2c87dbe-120.12.2.r994.g885048b-1
                        mailimporter20.12.2.r422.g5e653d4-120.12.2.r425.g2dad89b-1
                             mauikit1.2.0.r139.g138ecfc-11.2.0.r145.gb7ceab4-1
                       mbox-importer20.12.2.r466.g43b7436-120.12.2.r469.g12105d2-1
                          messagelib20.12.2.r5729.g9285ece1-120.12.2.r5735.g0d598e65-1
                     modemmanager-qt5.79.0.r486.gfe26584-15.79.0.r487.g35c8909-1
                             neochat     r1420.g9432e28-1     r1428.g43f81fc-1
                   networkmanager-qt5.79.0.r1080.gbd5db8c-15.79.0.r1081.g8c85264-1
                                nota 1.2.0.r21.gb28f225-1 1.2.0.r22.g193c825-1
                            palapeli20.12.2.r1196.g4639308-120.12.2.r1198.g755d0ad-1
                   pim-data-exporter20.12.2.r2370.ge4acfb0a-120.12.2.r2373.ga8ad38e6-1
                    pim-sieve-editor20.12.2.r1427.g735ba0a-120.12.2.r1430.gffe56fa-1
                           pimcommon20.12.2.r1003.g94cc008-120.12.2.r1007.g0ab2652-1
                    plasma-angelfish 1.7.1.r11.gc278469-1 1.7.1.r18.g5838d09-2
          plasma-browser-integration5.21.0.r1212.g64e3a853-15.21.0.r1214.g157a55f3-1
                      plasma-desktop5.21.0.r8214.g8a1cad91b-15.21.0.r8220.g6b650f963-1
                         plasma-nano5.20.90.r5.g2955745-15.20.90.r7.g3fe4308-1
                           plasma-nm5.21.0.r3011.g1b0f0e42-15.21.0.r3012.g8a76dc17-1
             plasma-phone-components5.20.90.r7.gcd4675b-15.21.0.r1301.ged91354-1
                    plasma-phonebook      r206.gf34ceb0-1      r208.g98d7684-1
                          plasma-pix 1.2.0.r40.g437cafe-1 1.2.0.r43.gdf722f6-1
                     plasma-settings      r852.g0fc9ca9-1      r858.g4ab1352-1
              plasma-wayland-session5.21.0.r9934.gbd034b4df-25.21.0.r9947.ge7e499167-1
                    plasma-workspace5.21.0.r9934.gbd034b4df-25.21.0.r9947.ge7e499167-1
                          powerdevil5.21.0.r2405.g3729b5d0-15.21.0.r2409.gbf9a1716-1
                              prison5.79.0.r292.g561a403-15.79.0.r293.gb680ef9-1
                             purpose5.79.0.r827.g6df071f-15.79.0.r829.gbb853bf-1
                  qqc2-desktop-style5.79.0.r444.gb52bcac-15.79.0.r449.g785d1fd-1
                               solid5.79.0.r641.g6b77862-15.79.0.r642.gf7f8ae0-1
                         syndication5.79.0.r802.g6f64a54-15.79.0.r804.gfc12594-1
                 syntax-highlighting5.79.0.r1501.ge57526b3-15.79.0.r1507.g286add40-1
                      systemsettings5.21.0.r2371.g2bca64e8-15.21.0.r2373.g3b4fe256-1
                        threadweaver5.79.0.r471.g8fab101-15.79.0.r473.g79aef04-1
                               vvave 1.2.0.r47.g7056453-1 1.2.0.r51.g81048ba-1
                            wrapland5.20.90.r1426.g917663b-15.20.90.r1430.g93f63c9-1
              xdg-desktop-portal-kde5.21.0.r339.gb378d0b-15.21.0.r340.g1061399-1
                              kwinft                    -5.20.90.r18645.g5f9a03445-1
                    maliit-framework                    -0.99.1.r54.gee7d872c-3


:: Different overlay package(s) in repository mobile aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2021-02-14         2021-02-18
-------------------------------------------------------------------------------
                           ksysguard           5.21.0-0.1           5.21.0-0.2
                                kwin           5.21.0-0.1           5.21.0-0.2
                    plasma-angelfish            1.6.0-1.5            1.7.1-1.1
                      plasma-desktop           5.21.0-0.1           5.21.0-0.2
             plasma-phone-components           5.20.5-1.5           5.21.0-0.2


Testers needed on arm-testing branch

We are in need of testers for our arm-testing and arm-unstable branches.
So if you are adventurous and want newer software quicker, we would love for you to help us test out the new packages in arm-testing branch.

All you have to do to switch to this branch is:

  • Run this command to switch branch: sudo pacman-mirrors -aS testing && sudo pacman -Syyu. This will generate a new mirrorlist for you, sync your databases with the new mirror and update your system using the arm-testing branch.

We would then love for you to give feedback in our update posts in #arm:testing-updates. That way we can better find and fix bugs, before they hit arm-stable branch. Thank you!


  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

Old Issues

Kwin crashes on startup on Pinebook Pro
This seems to be related to Mesa 20.3 and the Pinebook Pro support in kernel 5.10, as this does not seem to happen on other devices.
It does not impact 3d performance as far as I can tell. Just the OpenGL compositing in Kwin.
Fixed with mesa 20.3.2-2.

My VPN no longer connects
OpenVPN 2.5.0 changed how VPN routes work.
Workaround is to downgrade to previous version (2.4.9):

sudo pacman -U /var/cache/pacman/pkg/openvpn-2.4.9*

DP Alt Mode no longer works on Pinebook Pro
This is a known issue, the hacky patch we had to enable this has broken in recent kernels.
@tsys and Ayufan are looking into it.
As a workaround you can install linux-pinebookpro again.
FIXED with linux-5.9.12-4 and linux-rc-5.10-rc7-2 and above.

brcm-patchram-plus and pi-blueooth are in conflict
See this post for workaround:
[ARM Testing Update] 2020-11-16 - Bitwarden, Mesa-Git, Pacman and kernels - #10 by Darksky

Plasma Mobile Keyboard
The plasma mobile onscreen keyboard does not work with QT 5.15.0.
This is fixed by updating to kwin 5.19.3-1.1.

PinePhone uboot
This update to the PinePhone Uboot package (2020.04-2), changed how the DTS is loaded from the kernel, since the Kernel DTS for the Pinephone also changed. When doing this update on the PinePhone images from Alpha5 and back, please make this change to the /boot/extlinux/extlinux.conf before rebooting:

  • sun50i-a64-pinephone.dtb to sun50i-a64-pinephone-1.2.dtb
  • root=LABEL=ROOT to root=LABEL=ROOT_MNJRO

Manual interventions:
The nss and zn_poly packages prior to version 3.51.1-1 and version 0.9.2-2 respectively, were missing a soname link each. This has been fixed in 3.51.1-1 and 0.9.2-2 of these packages, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

nss: /usr/lib/p11-kit-trust.so exists in filesystem
zn_poly: /usr/lib/libzn_poly-0.9.so  exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/p11-kit-trust.so --overwrite /usr/lib/libzn_poly-0.9.so

to perform the upgrade.

Device stopped booting after Uboot update
The uboot update included a change to the extlinux.conf file. This change will be incompatible with the old 1 partition layout of some devices.
So if you are updating installs made with images 20.02.1 or older, you need to apply this fix before rebooting!
To fix this please edit your /boot/extlinux/extlinux.conf file and add 2 periods in front of each first slash, like so:

KERNEL ../Image
FDT ../dtbs/ #etc.
APPEND initrd=../initramfs-linux.img #etc.

Save the file and reboot.

Hi,

Odroid c4 Kde up to date , no issue for the moment.

[nlc4@c4 ~]$ date -u
jeu. 18 févr. 2021 08:28:45 UTC
[nlc4@c4 ~]$ screenfetch
                             nlc4@c4.test.2020.05.14
                             OS: Manjaro-ARM 21.02
                             Kernel: aarch64 Linux 5.10.17-1-MANJARO-ARM
         #####               Uptime: 3m
        #######              Packages: Unknown
        ##O#O##              Shell: bash 5.1.4
        #######              Resolution: 1920x1080
      ###########            DE: KDE 5.79.0 / Plasma 5.20.5
     #############           WM: KWin
    ###############          GTK Theme: Breeze [GTK2/3]
    ################         Icon Theme: oxygen
   #################         Disk: 22G / 59G (38%)
 #####################       CPU: Unknown @ 4x 1.908GHz
 #####################       GPU: 
   #################         RAM: 625MiB / 3628MiB
                            
                            
                            
[nlc4@c4 ~]$ uname -a
Linux c4.test.2020.05.14 5.10.17-1-MANJARO-ARM #1 SMP Wed Feb 17 12:03:31 UTC 2021 aarch64 GNU/Linux
[nlc4@c4 ~]$ 

No problems here so far. Haven’t rebooted the RPi yet though.

[olividir@RPi ~]$ screenfetch
                             olividir@RPi
                             OS: Manjaro-ARM 21.02
                             Kernel: aarch64 Linux 5.11.0-rc6-1-MANJARO-ARM
         #####               Uptime: 3d 14h 31m
        #######              Packages: Unknown
        ##O#O##              Shell: bash 5.1.4
        #######              Disk: 10G / 117G (9%)
      ###########            CPU: BCM2835 @ 4x 1.5GHz
     #############           GPU: 
    ###############          RAM: 3573MiB / 3806MiB
    ################        
   #################        
 #####################      
 #####################      
   #################        

I encountered issues upgrading r, but only because I’m a bad person who occasionally runs r as the root user in order to update the system packages. If you manage r in the same way, you will have seen errors similar to these when trying to update:

error: failed to commit transaction (conflicting files)
r: /usr/lib/R/library/Matrix/data/datalist exists in filesystem
r: /usr/lib/R/library/Matrix/data/wrld_1deg.R exists in filesystem
r: /usr/lib/R/library/Matrix/external/Z_NA_rnk.rds exists in filesystem
r: /usr/lib/R/library/Matrix/external/wrld_1deg_slots.rda exists in filesystem

To work around this, let pacman overwrite the r libraries that you manually updated:

sudo pacman -S r --overwrite /usr/lib/R/library/\*

I love the new Plasma 5.21 on RPi4 and the current overall status of arm-testing. Really excellent work by @Strit and the entire Manjaro ARM Team.

2 Likes

First time I’ve seen the colour of my wallpaper when logging into a Wayland desktop session.

EDIT: Spoke too soon );

Raspberry Pi 4 Model B Rev 1.1  
Linux 5.11.0-3-MANJARO-ARM
Plasma 5.20.5`

Updated without seeing any errors, so hopefully I’m not such a bad person.
And rebooted! But no problems here so far. Still on plasma 5.20.5 but can wait a little bit longer. Thank you all for your fantastic work. :penguin:

1 Like

no problems on the Pinebook Pro

OS: Manjaro ARM Linux 21.02 aarch64
Host: Hardkernel ODROID-N2
Kernel: 5.10.17-1-MANJARO-ARM 

:+1:

1 Like

Hallo,

Du bist wieder da, wie geht es dir ?

(I’m not german, but if I’m not wrong, you are aus deutschland, richtig ?)

1 Like

Ich war nie wirklich weg @nl.smart :wink: Auch schön dich zu lesen!
Danke, mir geht es sehr gut. Hoffe Dir/Euch auch!
Dein Deutsch ist klasse, viel besser als mein Englisch :partying_face:
Kom je uit de provincie Limburg?
Mijn huis ligt 10km van Venlo.

sry for OT :peace_symbol: :v: