[ARM Testing Update] 2020-09-25 - Firefox, Manjaro ARM Tools and kernels

Hello ARM community.

A small update for you.


Some highlights:

  • Most of our kernels got updated
  • Firefox got updated to 81.0
  • Our own Manjaro ARM Tools got updated to 2.9.0
  • Some python packages got updated

Upstream Notifications:

Older notifications

The nss package requires manual intervention:
Arch Linux - News: nss>=3.51.1-1 and lib32-nss>=3.51.1-1 updates require manual intervention
The packages hplip and firewalld requires manual intervention:
Arch Linux - News: hplip 3.20.3-2 update requires manual intervention
Arch Linux - News: firewalld>=0.8.1-2 update requires manual intervention


Package Changes

(Fri Sep 25 09:31:23 CEST 2020)

  • arm-testing community aarch64: 224 new and 216 removed package(s)
  • arm-testing core aarch64: 23 new and 23 removed package(s)
  • arm-testing extra aarch64: 145 new and 144 removed package(s)
:: Different overlay package(s) in repository community aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-09-20         2020-09-25
-------------------------------------------------------------------------------
                           baloo-git5.75.0.r2843.g524066e2-15.75.0.r2845.g2028883c-1
                       bluedevil-git5.19.90.r2152.g08c80929-15.20.80.r2160.g067f445d-1
                        bluez-qt-git5.75.0.r606.g38d6106-15.75.0.r611.g72e1f8e-1
                          breeze-git5.19.90.r2043.g9e72d2e0-15.20.80.r2048.g059ac0b7-1
                      breeze-gtk-git5.19.90.r393.g65ef4d4-15.20.80.r395.g25b81e3-1
                       calindori-git       r413.cd33d1e-1       r416.6689185-1
                        discover-git5.19.90.r7836.ga33a2e09-15.20.80.r7840.g293b5700-1
                       dmenu-manjaro                4.9-5                5.0-1
                         drkonqi-git5.19.90.r540.g7d399858-15.20.80.r544.gc302c5a7-1
             extra-cmake-modules-git5.75.0.r3186.gb2e4ee8-15.75.0.r3190.g2509327-1
                     hfd-service-git        r21.896ef75-1        r21.896ef75-2
               indicators-client-git   r18257.9beb6b675-3   r18257.9beb6b675-4
                             ion-git         52.bc26f29-1                    -
           kaccounts-integration-git    .r1148.g1c501f0-1    .r1155.g6bd487a-1
               kactivitymanagerd-git5.15.80.r1300.gff7d32b-15.15.80.r1301.g6f61549-1
                         kapidox-git5.75.0.r495.g72f580e-15.75.0.r496.g565fb28-1
                        kcmutils-git5.75.0.r432.g8ac50dd-15.75.0.r433.gd640cbf-1
                     kcompletion-git5.75.0.r384.gbfebef1-15.75.0.r386.g89db28d-1
                         kconfig-git5.75.0.r733.gf9079c8-15.75.0.r734.g21a40e0-1
                     kcoreaddons-git5.75.0.r1032.ge2f8d2e-15.75.0.r1034.gbfa1f61-1
                     kdbusaddons-git5.75.0.r320.g9c34b94-15.75.0.r321.gc74dbf7-1
                   kde-cli-tools-git5.19.90.r1805.g202c905-15.20.80.r1807.gcbab4f0-1
                  kde-gtk-config-git5.19.90.r855.g314b97e-15.20.80.r858.g7af241b-1
                    kdeclarative-git5.75.0.r807.g93d82d5-15.75.0.r808.g88aabf0-1
                     kdecoration-git5.19.90.r237.g074f517-15.20.80.r238.g46b7027-1
                            kded-git5.75.0.r342.g1a448a1-15.75.0.r345.g423868b-1
                kdeplasma-addons-git5.19.90.r8386.ga38b48681-15.20.80.r8391.g8438ebf28-1
                         kgamma5-git5.19.90.r428.g9fb9f1a-15.20.80.r429.g6050feb-1
                        khotkeys-git5.19.90.r2019.g1a53b72-15.20.80.r2021.g5bfb000-1
                     kinfocenter-git5.19.90.r1730.gd8cb2e4-15.20.80.r1732.g908d71c-1
                      kio-extras-git    r6855.gf6578019-1    r6859.g015a265d-1
                             kio-git5.75.0.r4203.g7d91cd24-15.75.0.r4213.g16400967-1
                       kirigami2-git5.75.0.r2410.gabf1a7c4-15.75.0.r2428.gaaaabf1e-1
                     kitemmodels-git5.75.0.r472.gcb6f0ae-15.75.0.r475.g63505dd-1
                     kjobwidgets-git5.75.0.r315.g36ab473-15.75.0.r316.ga7fac93-1
                       kmenuedit-git5.19.90.r933.g2b40024-15.20.80.r934.g92f41ee-1
                      knetattach-git5.19.90.r7872.g55dfd7d85-15.20.80.r7883.g3564a1e08-1
                       knewstuff-git5.75.0.r936.gfa05a109-15.75.0.r937.gccf54425-1
                        kongress-git        r95.68df765-1        r97.6555ef0-1
                        kpackage-git5.75.0.r597.gab765ba-15.75.0.r602.g59d7fb7-1
                          kparts-git5.75.0.r438.gbe37ada-15.75.0.r439.gefc3226-1
                    kquickcharts-git      r380.geeb4ab0-1      r381.gb231ab0-1
                         krunner-git5.75.0.r502.gc9fdf93-15.75.0.r506.gc42704a-1
                         kscreen-git5.19.90.r1271.g59d0877-15.20.80.r1274.g7223eaa-1
                   kscreenlocker-git5.19.90.r801.gbc2fe72-15.20.80.r803.g22bb146-1
                     ksshaskpass-git5.19.90.r175.gab2e434-15.20.80.r176.gbdf0f35-1
                       ksysguard-git5.19.90.r3357.gf462646c-15.20.80.r3364.g2f460ece-1
                     ktexteditor-git5.75.0.r2505.g75642bf2-15.75.0.r2512.g38b87e9f-1
                         kwallet-git5.75.0.r1005.g148a4f3-15.75.0.r1006.gd520f34-1
                     kwallet-pam-git5.19.90.r227.gaecc17c-15.20.80.r228.g046f346-1
            kwayland-integration-git5.19.90.r152.gb856124-15.20.80.r154.g00ae501-1
                 kwayland-server-git5.19.90.r1126.g0a07cb2-15.20.80.r1134.gd25db24-1
                  kwidgetsaddons-git5.75.0.r716.gd8d8338-15.75.0.r717.g1b2fac39-1
                            kwin-git5.19.90.r18386.g71dfd6028-15.20.80.r18418.g989e0987d-1
                   kwindowsystem-git5.75.0.r530.g3f71321-15.75.0.r533.gdcb6ae7-1
                         kwrited-git5.19.90.r447.ga3f5cad-15.20.80.r450.gc326b1d-1
                        libkgapi-git      r1197.5c66cb3-1      r1200.4b320bf-1
                      libkscreen-git5.19.90.r1529.gc0dddfa-15.20.80.r1530.g9c23ef2-1
                    libksysguard-git5.19.90.r1964.g5af911e-15.20.80.r1972.gc9eac35-1
               manjaro-arm-installer              1.3.4-1              1.3.5-1
                   messaging-app-git     r3305.29493b9e-2     r3309.dc1e5a6e-1
                           milou-git5.19.90.r707.gfef79aa-15.20.80.r709.g3ec02ea-1
                          oxygen-git5.19.90.r4389.g4e332a59-15.20.80.r4391.g6d7f4c80-1
                plasma-bigscreen-git       r322.b926ddd-1       r327.f6dd948-1
      plasma-browser-integration-git5.19.90.r1135.gd8f9fd83-15.20.80.r1138.g38906db1-1
                   plasma-camera-git       r172.ca65074-1       r173.8c33145-1
                  plasma-desktop-git5.19.90.r7872.g55dfd7d85-15.20.80.r7883.g3564a1e08-1
                plasma-framework-git5.75.0.r15566.ga7aeba21c-15.75.0.r15577.g316771779-1
              plasma-integration-git5.19.90.r481.gb09cc0f-15.20.80.r482.g297f8bf-1
                     plasma-nano-git       r123.83d3059-1       r124.4bc44dc-1
                       plasma-nm-git5.19.90.r2940.g93ec12dd-15.20.80.r2944.g7638b7fc-1
                       plasma-pa-git5.19.90.r847.g682473a-15.20.80.r848.g62d3c9e-1
         plasma-phone-components-git      r1217.ccdfd34-1      r1218.c735bf3-1
                plasma-phonebook-git       r168.0228631-1       r169.bd0492d-1
                      plasma-sdk-git5.19.90.r2204.gae371d94-15.20.80.r2205.gacf09562-1
                 plasma-settings-git       r784.20e2f1e-1       r785.6c156d8-1
                    plasma-vault-git5.19.90.r298.gc5185e8-15.20.80.r301.gc744953-1
          plasma-wayland-session-git5.19.90.r9413.g6cc5d4cf8-15.20.80.r9437.g99475b09a-1
                plasma-workspace-git5.19.90.r9413.g6cc5d4cf8-15.20.80.r9437.g99475b09a-1
     plasma-workspace-wallpapers-git5.19.90.r225.gdb707a8-15.20.80.r229.g3663154-1
                polkit-kde-agent-git5.19.90.r459.g1d67724-15.20.80.r463.gce6fc35-1
                      powerdevil-git5.19.90.r2351.g72c741d3-15.20.80.r2357.gaa6dba84-1
                      qmenumodel-git       r506.30e3dc5-4         r519.0.8.0-1
                      qmlkonsole-git        r51.300ebfe-1        r55.beb96c8-1
              qqc2-desktop-style-git5.75.0.r396.g6e0ead0-15.75.0.r400.gd45e382-1
                        sddm-kcm-git5.19.90.r542.g315d351-15.20.80.r543.g9901e49-1
                          sonnet-git5.75.0.r550.g3afca84-15.75.0.r552.gf8c519c-1
                        spacebar-git       r266.9175a33-1       r267.688bca5-1
             syntax-highlighting-git5.75.0.r1301.g7edab0b0-15.75.0.r1319.gb998b137-1
                  systemsettings-git5.19.90.r2268.ge540cdde-15.20.80.r2271.gbfc56dcf-1
                          unity8-git   r18257.9beb6b675-3   r18257.9beb6b675-4
                           vvave-git       r735.8c385ed-1       r737.dae4508-1
          xdg-desktop-portal-kde-git5.19.90.r310.g31abb93-15.20.80.r317.g8f488ca-1
                    paperdesktop-git                    -         67.c541d32-1
                        sensorfw-git                    -0.11.2.r30.g65080cb-2
                        wf-touch-git                    -         34.b1075c5-1


:: Different sync package(s) in repository community aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-09-20         2020-09-25
-------------------------------------------------------------------------------
                             ansible             2.9.13-1             2.10.0-1
                     archlinux-repro           20200613-1           20200921-1
                              bemenu              0.4.0-1              0.5.0-1
                      bemenu-ncurses              0.4.0-1              0.5.0-1
                      bemenu-wlroots              0.4.0-1              0.5.0-1
                          bemenu-x11              0.4.0-1              0.5.0-1
                             blender          17:2.90.0-3          17:2.90.1-1
                               bmake           20200318-1           20200902-1
                               boinc             7.16.9-1            7.16.10-1
                           boinc-nox             7.16.9-1            7.16.10-1
                              brotli              1.0.9-1              1.0.9-2
                     brotli-testdata              1.0.9-1              1.0.9-2
                             buildah             1.16.1-1             1.16.2-1
                              catch2             2.13.0-1             2.13.1-1
                                ccid             1.4.32-1             1.4.33-1
                               cgasm              0.0.0-1              1.0.0-1
                               cjdns               20.7-1                 21-1
                              clamtk               6.03-1               6.06-1
                              cobalt             0.16.2-1             0.16.3-1
                                crun             0.14.1-1               0.15-1
                                dfrs              0.0.5-1              0.0.6-1
                          diffoscope                146-1                160-1
                               dmenu                4.9-2                5.0-1
                      docker-compose             1.27.3-1             1.27.4-1
                              dqlite              1.6.0-2              1.6.0-3
                              drupal              9.0.5-1              9.0.6-1
                              fcitx5     0.0.0.20200915-1     0.0.0.20200924-1
               fcitx5-chinese-addons     0.0.0.20200915-1     0.0.0.20200923-1
                   fcitx5-configtool     0.0.0.20200915-1     0.0.0.20200921-1
                          fcitx5-skk     0.0.0.20200816-2     0.0.0.20200923-1
                                 fff                2.1-2                2.2-1
                    firefox-noscript            11.0.41-1            11.0.46-1
                           flameshot              0.6.0-4              0.8.1-2
                            gammaray             2.11.1-3             2.11.2-1
                           gandi.cli                1.5-3                1.6-1
                                gist              5.1.0-1              6.0.0-1
                         hcxdumptool              6.1.1-1              6.1.2-1
                            hcxtools              6.1.1-1              6.1.2-1
                                helm              3.3.3-1              3.3.4-1
                               hitch              1.5.2-1              1.6.0-1
                          inter-font               3.13-1               3.15-1
                              iperf3                3.7-2                3.9-1
                             jenkins              2.256-1              2.258-1
                                jmol            14.31.6-1            14.31.7-1
                               jsmol            14.31.6-1            14.31.7-1
                             klayout             0.26.7-1             0.26.8-1
                             kubeone              1.0.0-1              1.0.2-2
                          libstrophe            1:0.9.3-1           1:0.10.0-1
                      libstrophe-doc            1:0.9.3-1           1:0.10.0-1
                            liburing                0.7-1                    -
                       libwebsockets              4.1.0-1              4.1.2-1
                        lua-penlight              1.6.0-2              1.9.0-1
                      lua53-penlight              1.6.0-2              1.9.0-1
                              luakit                2.2-1              2.2.1-1
                                 lxd                4.6-1                4.6-2
                             mcabber              1.1.1-1              1.1.2-1
                       mediastreamer              4.4.0-1              4.4.2-1
                           memtester              4.3.0-4              4.4.0-1
                            newsboat             2.20.1-2               2.21-1
                              nodejs            14.11.0-1            14.12.0-1
                   npm-check-updates              9.0.1-1              9.0.2-1
                               osmid              0.6.8-2              0.8.0-1
                              podman              2.0.6-1              2.1.0-1
                       podman-docker              2.0.6-1              2.1.0-1
                            powerdns              4.2.2-2              4.2.3-1
                   powerdns-recursor              4.3.3-1              4.3.4-1
                 profile-sync-daemon               6.40-1               6.42-1
                      python-alembic              1.4.2-1              1.4.3-1
           python-aws-sam-translator             1.26.0-1             1.27.0-1
                    python-braintree              4.3.0-1              4.4.0-1
                       python-brotli              1.0.9-1              1.0.9-2
              python-cached-property              1.5.1-4              1.5.2-1
                     python-cfn-lint             0.36.0-1             0.36.1-1
         python-cryptography-vectors                3.1-1              3.1.1-1
                      python-cytoolz             0.10.1-3             0.11.0-1
                   python-diff-cover              4.0.0-1              4.0.1-1
                  python-google-auth             1.21.2-1             1.21.3-1
                     python-httpcore              0.9.1-3             0.10.2-1
                        python-httpx             0.13.3-5             0.14.0-1
                   python-hypothesis             5.35.3-1             5.36.0-1
                     python-identify              1.5.3-1              1.5.5-1
                  python-lark-parser              0.9.0-1             0.10.0-1
                      python-netaddr             0.7.20-1              0.8.0-1
                        python-paste              3.4.4-1              3.4.5-1
                         python-pint               0.16-1             0.16.1-1
             python-python-multipart              0.0.4-1              0.0.5-1
                        python-qiniu             7.2.10-1              7.3.0-1
                    python-reportlab             3.5.50-1             3.5.51-1
                        python-toolz             0.10.0-3             0.11.1-1
                   python-voluptuous             0.11.7-4             0.12.0-1
                         python-zipp              3.1.0-1              3.2.0-1
                     python2-alembic              1.4.2-1                    -
                         qpid-proton             0.31.0-1             0.32.0-1
                            rabbitmq              3.8.7-1              3.8.9-1
                       rabbitmqadmin              3.8.7-1              3.8.9-1
                           rofi-calc                1.8-1                1.9-1
                       ruby-kramdown              2.2.1-1              2.3.0-1
                       rust-analyzer           20200914-1           20200921-1
                                  sd              0.7.5-1              0.7.6-1
                           shorewall              5.2.7-1              5.2.8-1
                      shorewall-core              5.2.7-1              5.2.8-1
                          shorewall6              5.2.7-1              5.2.8-1
                             snapper             0.8.13-1             0.8.14-1
                               sndio              1.6.0-2              1.7.0-1
                       sqlitebrowser             3.11.2-2             3.12.0-1
                          streamlink              1.5.0-2              1.6.0-1
                            sundials              5.3.0-1              5.4.0-1
                  ttf-jetbrains-mono              2.001-1              2.002-1
                   ttf-sarasa-gothic             0.13.0-1             0.13.1-1
                      udp2raw-tunnel         20200715.0-1         20200818.0-1
                           ukui-menu              3.0.0-1              3.0.1-1
                          unarchiver            1.10.1-10             1.10.7-1
         v2ray-domain-list-community     20200918144814-1     20200923123822-1
                         v2ray-geoip       202009160005-1       202009230005-1
                             vim-ale              2.7.0-1              3.0.0-1
                        vim-nerdtree              6.9.6-1              6.9.7-1
                               vivid              0.5.0-1              0.6.0-1
                               vkd3d                1.1-1                1.2-1
                              waybar              0.9.3-3              0.9.4-1
                              wpscan            1:3.8.3-2            1:3.8.7-1
                                xapp              1.8.9-1             1.8.10-1
                                 yad                7.1-1                7.2-1
                      youtube-viewer            1:3.7.8-1            1:3.7.9-1
                        ansible-base                    -             2.10.1-1
                            glewlwyd                    -              2.3.3-1
                      lua51-penlight                    -              1.9.0-1
                      lua52-penlight                    -              1.9.0-1
             python-click-didyoumean                    -              0.0.3-1
                python-pytest-celery                    -            0.0.0a1-1
                      python-sequoia                    -             0.19.0-1
                             sequoia                    -             0.19.0-1


:: Different overlay package(s) in repository core aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-09-20         2020-09-25
-------------------------------------------------------------------------------
                               linux             5.8.10-2             5.8.11-1
                       linux-headers             5.8.10-2             5.8.11-1
                     linux-pinephone           5.7.19-3.0             5.7.19-4
             linux-pinephone-headers           5.7.19-3.0             5.7.19-4
                            linux-rc            5.9.rc5-3            5.9.rc6-4
                    linux-rc-headers            5.9.rc5-3            5.9.rc6-4
                           linux-vim             5.7.16-1              5.8.7-1
                   linux-vim-headers             5.7.16-1              5.8.7-1


:: Different sync package(s) in repository core aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-09-20         2020-09-25
-------------------------------------------------------------------------------
             ca-certificates-mozilla               3.56-1               3.57-1
                           e2fsprogs             1.45.6-2             1.45.6-3
                            elfutils              0.180-1              0.181-1
                              libelf              0.180-1              0.181-1
                             libldap             2.4.52-1             2.4.53-1
                                nspr               4.28-1               4.29-1
                                 nss               3.56-1               3.57-1
                            openldap             2.4.52-1             2.4.53-1
                             openssl            1.1.1.g-2            1.1.1.h-1
                                perl             5.32.0-1             5.32.0-3
                                sudo              1.9.2-1              1.9.3-1
                             systemd              246.5-1              246.6-1
                        systemd-libs              246.5-1              246.6-1
                  systemd-resolvconf              246.5-1              246.6-1
                  systemd-sysvcompat              246.5-1              246.6-1


:: Different overlay package(s) in repository extra aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-09-20         2020-09-25
-------------------------------------------------------------------------------
                             firefox             80.0.1-1               81.0-1
                    firefox-i18n-ach             80.0.1-1               81.0-1
                     firefox-i18n-af             80.0.1-1               81.0-1
                     firefox-i18n-an             80.0.1-1               81.0-1
                     firefox-i18n-ar             80.0.1-1               81.0-1
                    firefox-i18n-ast             80.0.1-1               81.0-1
                     firefox-i18n-az             80.0.1-1               81.0-1
                     firefox-i18n-be             80.0.1-1               81.0-1
                     firefox-i18n-bg             80.0.1-1               81.0-1
                     firefox-i18n-bn             80.0.1-1               81.0-1
                     firefox-i18n-br             80.0.1-1               81.0-1
                     firefox-i18n-bs             80.0.1-1               81.0-1
                     firefox-i18n-ca             80.0.1-1               81.0-1
                    firefox-i18n-cak             80.0.1-1               81.0-1
                     firefox-i18n-cs             80.0.1-1               81.0-1
                     firefox-i18n-cy             80.0.1-1               81.0-1
                     firefox-i18n-da             80.0.1-1               81.0-1
                     firefox-i18n-de             80.0.1-1               81.0-1
                    firefox-i18n-dsb             80.0.1-1               81.0-1
                     firefox-i18n-el             80.0.1-1               81.0-1
                  firefox-i18n-en-ca             80.0.1-1               81.0-1
                  firefox-i18n-en-gb             80.0.1-1               81.0-1
                  firefox-i18n-en-us             80.0.1-1               81.0-1
                     firefox-i18n-eo             80.0.1-1               81.0-1
                  firefox-i18n-es-ar             80.0.1-1               81.0-1
                  firefox-i18n-es-cl             80.0.1-1               81.0-1
                  firefox-i18n-es-es             80.0.1-1               81.0-1
                  firefox-i18n-es-mx             80.0.1-1               81.0-1
                     firefox-i18n-et             80.0.1-1               81.0-1
                     firefox-i18n-eu             80.0.1-1               81.0-1
                     firefox-i18n-fa             80.0.1-1               81.0-1
                     firefox-i18n-ff             80.0.1-1               81.0-1
                     firefox-i18n-fi             80.0.1-1               81.0-1
                     firefox-i18n-fr             80.0.1-1               81.0-1
                  firefox-i18n-fy-nl             80.0.1-1               81.0-1
                  firefox-i18n-ga-ie             80.0.1-1               81.0-1
                     firefox-i18n-gd             80.0.1-1               81.0-1
                     firefox-i18n-gl             80.0.1-1               81.0-1
                     firefox-i18n-gn             80.0.1-1               81.0-1
                  firefox-i18n-gu-in             80.0.1-1               81.0-1
                     firefox-i18n-he             80.0.1-1               81.0-1
                  firefox-i18n-hi-in             80.0.1-1               81.0-1
                     firefox-i18n-hr             80.0.1-1               81.0-1
                    firefox-i18n-hsb             80.0.1-1               81.0-1
                     firefox-i18n-hu             80.0.1-1               81.0-1
                  firefox-i18n-hy-am             80.0.1-1               81.0-1
                     firefox-i18n-ia             80.0.1-1               81.0-1
                     firefox-i18n-id             80.0.1-1               81.0-1
                     firefox-i18n-is             80.0.1-1               81.0-1
                     firefox-i18n-it             80.0.1-1               81.0-1
                     firefox-i18n-ja             80.0.1-1               81.0-1
                     firefox-i18n-ka             80.0.1-1               81.0-1
                    firefox-i18n-kab             80.0.1-1               81.0-1
                     firefox-i18n-kk             80.0.1-1               81.0-1
                     firefox-i18n-km             80.0.1-1               81.0-1
                     firefox-i18n-kn             80.0.1-1               81.0-1
                     firefox-i18n-ko             80.0.1-1               81.0-1
                    firefox-i18n-lij             80.0.1-1               81.0-1
                     firefox-i18n-lt             80.0.1-1               81.0-1
                     firefox-i18n-lv             80.0.1-1               81.0-1
                     firefox-i18n-mk             80.0.1-1               81.0-1
                     firefox-i18n-mr             80.0.1-1               81.0-1
                     firefox-i18n-ms             80.0.1-1               81.0-1
                     firefox-i18n-my             80.0.1-1               81.0-1
                  firefox-i18n-nb-no             80.0.1-1               81.0-1
                  firefox-i18n-ne-np             80.0.1-1               81.0-1
                     firefox-i18n-nl             80.0.1-1               81.0-1
                  firefox-i18n-nn-no             80.0.1-1               81.0-1
                     firefox-i18n-oc             80.0.1-1               81.0-1
                  firefox-i18n-pa-in             80.0.1-1               81.0-1
                     firefox-i18n-pl             80.0.1-1               81.0-1
                  firefox-i18n-pt-br             80.0.1-1               81.0-1
                  firefox-i18n-pt-pt             80.0.1-1               81.0-1
                     firefox-i18n-rm             80.0.1-1               81.0-1
                     firefox-i18n-ro             80.0.1-1               81.0-1
                     firefox-i18n-ru             80.0.1-1               81.0-1
                     firefox-i18n-si             80.0.1-1               81.0-1
                     firefox-i18n-sk             80.0.1-1               81.0-1
                     firefox-i18n-sl             80.0.1-1               81.0-1
                    firefox-i18n-son             80.0.1-1               81.0-1
                     firefox-i18n-sq             80.0.1-1               81.0-1
                     firefox-i18n-sr             80.0.1-1               81.0-1
                  firefox-i18n-sv-se             80.0.1-1               81.0-1
                     firefox-i18n-ta             80.0.1-1               81.0-1
                     firefox-i18n-te             80.0.1-1               81.0-1
                     firefox-i18n-th             80.0.1-1               81.0-1
                     firefox-i18n-tr             80.0.1-1               81.0-1
                     firefox-i18n-uk             80.0.1-1               81.0-1
                     firefox-i18n-ur             80.0.1-1               81.0-1
                     firefox-i18n-uz             80.0.1-1               81.0-1
                     firefox-i18n-vi             80.0.1-1               81.0-1
                     firefox-i18n-xh             80.0.1-1               81.0-1
                  firefox-i18n-zh-cn             80.0.1-1               81.0-1
                  firefox-i18n-zh-tw             80.0.1-1               81.0-1
                   manjaro-arm-tools              2.8.6-1              2.9.0-1
                            mesa-git20.3.0_devel.128278.20a4235c4c9-120.3.0_devel.128402.27516baa2ae-1


:: Different sync package(s) in repository extra aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-09-20         2020-09-25
-------------------------------------------------------------------------------
                              bullet               2.89-2               3.05-1
                         bullet-docs               2.89-2               3.05-1
                            cbindgen             0.14.5-1             0.14.6-1
                            chromium      85.0.4183.102-1      85.0.4183.121-1
                              clamav            0.102.4-1            0.103.0-1
                               cmake             3.18.2-1             3.18.3-1
                        cups-filters             1.28.2-1             1.28.3-1
                                 efl             1.24.3-3             1.24.3-4
                            efl-docs             1.24.3-3             1.24.3-4
                             enchant              2.2.8-3             2.2.10-1
                          fluidsynth              2.1.4-1              2.1.5-2
                             freetds              1.2.4-1              1.2.5-1
                                  gn    0.1731.5ed3c9cc-1    0.1819.e327ffdc-1
                           iptraf-ng              1.1.4-5              1.2.1-1
                              kismet         2020_04_R3-2         2020_09_R3-1
                              libbpf              0.0.9-1              0.1.1-1
                             libcbor              0.7.0-1              0.8.0-1
                            libde265              1.0.6-1              1.0.7-1
                            libfido2              1.4.0-4              1.5.0-2
                             libheif              1.8.0-1              1.9.0-1
                          libmagick6          6.9.11.29-1          6.9.11.30-1
                         libmicrodns              0.1.2-1              0.2.0-1
                             libmwaw             0.3.16-1             0.3.17-1
                        libqalculate             3.12.1-1             3.13.0-1
                          libspectre              0.2.9-1              0.2.9-2
                libtorrent-rasterbar            1:1.2.8-1           1:1.2.10-2
                        markdownpart              0.1.0-1              0.1.1-1
                           memcached              1.6.6-1              1.6.7-1
                                 mpd            0.21.25-3            0.21.26-1
                                 mtr               0.93-3               0.94-1
                             mtr-gtk               0.93-3               0.94-1
                                nasm            2.15.04-1            2.15.05-1
                               nuget              5.6.0-1              5.7.0-1
                    perl-alien-build               2.32-1               2.33-1
                         perl-libwww               6.47-1               6.49-1
                          prometheus             2.21.0-1             2.21.0-2
                         python-cffi             1.14.2-1             1.14.3-1
                 python-cryptography                3.1-1              3.1.1-1
                        python-isort              5.5.2-1              5.5.3-1
                     python-pybullet               2.89-2               3.05-1
                        python2-cffi             1.14.2-1             1.14.3-1
                python2-cryptography                3.1-1              3.1.1-1
                       qalculate-gtk             3.12.1-1             3.13.0-1
                            rinutils              0.4.1-1              0.6.0-1
                                 vlc           3.0.11.1-2           3.0.11.1-3
                               whois              5.5.6-2              5.5.6-3
                     xf86-video-vesa              2.4.0-3              2.5.0-1
                               xterm                359-1                360-1
                            liburing                    -                0.7-2


Testers needed on arm-testing branch

We are in need of testers for our arm-testing and arm-unstable branches.
So if you are adventurous and want newer software quicker, we would love for you to help us test out the new packages in arm-testing branch.

All you have to do to switch to this branch is:

  • Run this command to switch branch: sudo pacman-mirrors -aS testing && sudo pacman -Syyu. This will generate a new mirrorlist for you, sync your databases with the new mirror and update your system using the arm-testing branch.

We would then love for you to give feedback in our update posts in #arm:testing-updates. That way we can better find and fix bugs, before they hit arm-stable branch. Thank you!


  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

DP Alt Mode no longer works on Pinebook Pro
This is a known issue, the hacky patch we had to enable this has broken in recent kernels.
@tsys is looking into it.
As a workaround you can install linux-pinebookpro again.

Old Issues

Plasma Mobile Keyboard
The plasma mobile onscreen keyboard does not work with QT 5.15.0.
This is fixed by updating to kwin 5.19.3-1.1.

PinePhone uboot
This update to the PinePhone Uboot package (2020.04-2), changed how the DTS is loaded from the kernel, since the Kernel DTS for the Pinephone also changed. When doing this update on the PinePhone images from Alpha5 and back, please make this change to the /boot/extlinux/extlinux.conf before rebooting:

  • sun50i-a64-pinephone.dtb to sun50i-a64-pinephone-1.2.dtb
  • root=LABEL=ROOT to root=LABEL=ROOT_MNJRO

Manual interventions:
The nss and zn_poly packages prior to version 3.51.1-1 and version 0.9.2-2 respectively, were missing a soname link each. This has been fixed in 3.51.1-1 and 0.9.2-2 of these packages, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

nss: /usr/lib/p11-kit-trust.so exists in filesystem
zn_poly: /usr/lib/libzn_poly-0.9.so  exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/p11-kit-trust.so --overwrite /usr/lib/libzn_poly-0.9.so

to perform the upgrade.

Device stopped booting after Uboot update
The uboot update included a change to the extlinux.conf file. This change will be incompatible with the old 1 partition layout of some devices.
So if you are updating installs made with images 20.02.1 or older, you need to apply this fix before rebooting!
To fix this please edit your /boot/extlinux/extlinux.conf file and add 2 periods in front of each first slash, like so:

KERNEL ../Image
FDT ../dtbs/ #etc.
APPEND initrd=../initramfs-linux.img #etc.

Save the file and reboot.

Little bug with ssh

Welcome to Manjaro-ARM
~~Website: https://manjaro.org
~~Forum:   https://forum.manjaro.org/c/arm
~~Matrix:  #manjaro-arm-public:matrix.org
Last login: Thu Sep 24 18:59:42 2020 from Not here bro.. 
/etc/profile.d/perlbin.sh:6: command not found: append_path
/etc/profile.d/perlbin.sh:8: command not found: append_path
/etc/profile.d/perlbin.sh:10: command not found: append_path
[  8:57PM ]  [ joel@ManPi4:~ ]                                                                     $

Mainy this


/etc/profile.d/perlbin.sh:6: command not found: append_path
/etc/profile.d/perlbin.sh:8: command not found: append_path
/etc/profile.d/perlbin.sh:10: command not found: append_path

The Caidao/ungoogle-chromium issue stopped. Maybe it was the new mesa-git?

To answer @Strit’s question (which I didn’t see because I don’t see a way to enable email notifications and I only come to the forum when there’s an update or I have a problem) on my issue in the last update: I had “Use hardware acceleration when available” enabled in chromium Settings. Yet, chome://gpu shows the info below, which look like it wasn’t using any.

Either way, I went into an Xorg session, shut that chromium setting off, went back to Wayland and it worked. I wanted to test with this update, so turned the setting back on and it still works.

### Graphics Feature Status

* Canvas: Software only, hardware acceleration unavailable
* Flash: Software only. Hardware acceleration disabled
* Flash Stage3D: Software only. Hardware acceleration disabled
* Flash Stage3D Baseline profile: Software only. Hardware acceleration disabled
* Compositing: Software only. Hardware acceleration disabled
* Multiple Raster Threads: Enabled
* Out-of-process Rasterization: Disabled
* OpenGL: Disabled
* Hardware Protected Video Decode: Disabled
* Rasterization: Software only. Hardware acceleration disabled
* Skia Renderer: Enabled
* Video Decode: Software only. Hardware acceleration disabled
* Vulkan: Disabled
* WebGL: Software only, hardware acceleration unavailable
* WebGL2: Software only, hardware acceleration unavailable

### Problems Detected

* Gpu compositing has been disabled, either via blacklist, about:flags or the command line. The browser will fall back to software compositing and hardware acceleration will be unavailable.
*Disabled Features: gpu_compositing*

Seems this is a change in a rebuild Arch did yesterday, where it changes the file to use append_path instead of the regular way to set path.
I wonder where it would come from.’

Found this bug report on Arch site:
https://bugs.archlinux.org/task/67990

Sorry I forgot to add I have zsh installed with oh my zsh.

And it’s allmost 2am here.

I have the same issue.
They said it comes with the new version of filesystem 2020.09.03-1
https://bugs.archlinux.org/task/67999
And Archlinux claims that “Partial upgrades are not supported”… :wink:
So, could you please update filesystem package please ?
@Jtyle6 : the futur /etc/profile svntogit-packages/profile at master · archlinux/svntogit-packages · GitHub

Uploaded to arm-unstable branch now! :slight_smile:

1 Like

Thanks. As soon as I get the update I will keep you in touch.

1 Like

With the new package, no more append_path error ! Thanks !

1 Like

I’m going to change to unstable when I get home from the shops.

Edit:
Update. Changeed to unstable, and updated.
now it’s fixed…

Hi,

Odroid c4 up to date, it works.