[ARM Testing Update] 2020-06-22 - Pamac and kernels

Hello ARM community.

A small testing update!


Some highlights:

  • Most of our kernels got updated
  • Pamac is updated to version 9.5.6
  • Lots of python packages got updated

Upstream Notifications:

Older notifications

The nss package requires manual intervention:
https://www.archlinux.org/news/nss3511-1-and-lib32-nss3511-1-updates-require-manual-intervention/
The packages hplip and firewalld requires manual intervention:
https://www.archlinux.org/news/hplip-3203-2-update-requires-manual-intervention/
https://www.archlinux.org/news/firewalld081-2-update-requires-manual-intervention/


Package Changes (Mon Jun 22 11:37:33 CEST 2020)

  • arm-testing community aarch64: 192 new and 184 removed package(s)
  • arm-testing core aarch64: 29 new and 29 removed package(s)
  • arm-testing extra aarch64: 91 new and 88 removed package(s)
:: Different overlay package(s) in repository community aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-06-17         2020-06-22
-------------------------------------------------------------------------------
                linux-aarch64-udl-rc            5.2.rc4-2                    -
        linux-aarch64-udl-rc-headers            5.2.rc4-2                    -
             manjaro-arm-oem-install           20200521-1           20200621-1
                             tune-s2                  1-3                    -


:: Different sync package(s) in repository community aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-06-17         2020-06-22
-------------------------------------------------------------------------------
                              aeolus              0.9.8-1              0.9.9-1
                             ansible              2.9.9-2             2.9.10-1
                        avisynthplus              3.6.0-2              3.6.1-1
                           babel-cli              7.8.0-1              7.8.4-1
                            backuppc              4.3.2-2              4.4.0-1
                              bandit              1.6.0-2              1.6.2-1
                             bashtop             0.9.11-1             0.9.12-1
                               biber             1:2.13-1             1:2.14-1
                               broot             0.15.1-1             0.16.0-1
                             buildah             1.14.9-1             1.15.0-1
                            cinnamon              4.6.3-1              4.6.4-1
            cinnamon-settings-daemon              4.6.1-1              4.6.2-1
               cinnamon-translations              4.6.0-1              4.6.1-1
                            clipmenu              6.1.0-1              6.1.0-2
                             clojure             1.10.1-6             1.10.1-7
                          clusterssh               4.15-1               4.16-1
                              conmon           1:2.0.18-1           1:2.0.18-2
                            cppcheck                2.0-2                2.1-1
                           dd_rescue             1.99.8-2             1.99.8-3
                               dictd             1.12.1-6             1.13.0-1
                            dropbear            2019.78-1            2020.79-1
                        dropbear-scp            2019.78-1            2020.79-1
                               dsdcc              1.8.6-1              1.8.7-1
                             dua-cli              2.6.0-1              2.6.1-1
                              erlang             22.3.4-1               23.0-1
                         erlang-docs               22.3-1               23.0-1
                          erlang-nox             22.3.4-1               23.0-1
                     erlang-unixodbc             22.3.4-1               23.0-1
                              eslint              7.2.0-1              7.3.0-1
                              fcitx5     0.0.0.20200615-1     0.0.0.20200617-1
                                fltk              1.3.5-1              1.3.5-2
                           fltk-docs              1.3.5-1              1.3.5-2
                             foliate              2.1.1-1              2.3.0-2
                      fuse-overlayfs              1.0.0-2              1.1.0-1
                               fwupd              1.4.2-1              1.4.4-1
                               giada           0.16.2.2-1             0.16.3-1
                golang-golang-x-text              0.3.2-1              0.3.3-1
                              httpie              2.1.0-1              2.2.0-1
                           ibus-m17n              1.4.2-1              1.4.3-1
                                 iwd                1.7-1                1.8-1
                             jenkins              2.239-1              2.241-1
                               kitty             0.17.4-1             0.18.0-1
                      kitty-terminfo             0.17.4-1             0.18.0-1
                           kustomize              3.5.4-1              3.6.1-1
                    libcontentaction             0.3.14-1             0.3.15-1
                              libiio               0.20-1               0.21-2
                           libsigrok              0.5.2-3              0.5.2-4
                         lxqt-runner             0.15.0-2             0.15.0-3
                              marisa            0.2.5-8.1              0.2.6-1
                          maxima-ecl             5.44.0-1             5.44.0-2
                         meilisearch             0.10.1-1             0.11.0-1
                               mruby              2.1.0-2              2.1.1-1
                                mypy              0.780-1              0.781-1
                             neomutt           20200501-1           20200619-1
                 netsurf-buildsystem                1.8-1                1.9-1
                            newsboat               2.19-2               2.20-1
                  nextcloud-app-deck            1:1.0.2-1            1:1.0.3-1
                  nextcloud-app-mail              1.3.4-1              1.4.0-1
                       nlohmann-json              3.8.0-1              3.8.0-2
                           nsgenbind                0.7-1                0.8-1
                             oidentd              2.4.0-1              2.5.0-1
                            openblas              0.3.9-1             0.3.10-1
                    otf-font-awesome             5.13.0-1             5.13.1-1
                            pcsclite             1.8.26-1              1.9.0-1
                     perl-image-sane               0.14-4                  5-1
                         perl-marisa            0.2.5-8.1              0.2.6-1
                       perl-www-curl              4.17-10                    -
                        phpldapadmin              1.2.5-2              1.2.5-3
                                po4a             0.59.1-1             0.59.1-2
                              podman              1.9.3-2              2.0.0-1
                       podman-docker              1.9.3-2              2.0.0-1
                              puppet             6.14.0-1             6.16.0-1
                             pychess              1.0.0-4              1.0.2-1
                               pyenv             1.2.18-1             1.2.19-1
                        python-arrow             0.15.5-1             0.15.7-1
           python-aws-sam-translator             1.24.0-1             1.25.0-1
                     python-cfn-lint             0.33.0-1             0.33.1-1
                    python-chameleon              3.7.2-1              3.7.4-1
                 python-cinderclient              7.0.0-1              7.1.0-1
                python-elasticsearch              7.7.1-1              7.8.0-1
                    python-fonttools             4.12.0-1             4.12.1-1
                 python-glanceclient              3.1.1-1              3.2.0-1
                  python-google-auth             1.17.2-1             1.18.0-1
                   python-hypothesis             5.16.1-1             5.16.3-1
           python-importlib-metadata              1.6.0-1              1.6.1-1
              python-language-server             0.33.1-1             0.33.2-1
                         python-ldap              3.2.0-4              3.3.0-1
               python-logilab-common              1.6.4-1              1.7.1-1
                        python-magic               5.38-1               5.39-1
                       python-marisa            0.2.5-8.1              0.2.6-1
                   python-matplotlib              3.2.1-1              3.2.2-1
                   python-matrix-nio             0.13.0-1             0.14.0-1
              python-openstackclient              5.2.0-1              5.2.1-1
                 python-openstacksdk             0.46.0-1             0.47.0-1
             python-oslo-concurrency              4.1.0-1              4.1.1-1
                  python-oslo-config              8.1.0-1              8.2.0-1
           python-oslo-serialization              3.2.0-1              4.0.0-1
                     python-oslotest              4.3.0-1              4.4.0-1
                       python-pandas              1.0.4-1              1.0.5-1
                    python-periphery              2.0.1-1              2.1.0-1
                       python-pg8000             1.15.2-1             1.15.3-1
                 python-phonenumbers             8.12.5-1             8.12.6-1
                      python-pikepdf             1.14.0-1             1.15.1-1
                         python-pint               0.12-1               0.13-1
                           python-py              1.8.1-1              1.8.2-1
                   python-py-cpuinfo              5.0.0-5              6.0.0-1
                    python-pyqtgraph             0.10.0-8             0.11.0-1
                   python-pytest-cov              2.9.0-1             2.10.0-1
              python-pytest-services              2.0.1-1              2.1.0-1
               python-pytest-timeout              1.3.4-1              1.4.1-1
                      python-pytools             2020.2-1             2020.3-1
                        python-qt.py              1.2.5-1              1.2.5-3
                         python-rpy2              3.3.3-1              3.3.4-1
                 python-scikit-build             0.10.0-4             0.11.1-1
             python-sphinx_rtd_theme              0.4.3-4              0.5.0-1
               python-zita-jacktools              1.0.0-4              1.2.0-1
          python2-importlib-metadata              1.6.0-1              1.6.1-1
                          python2-py              1.8.1-1              1.8.2-1
                   python2-pyqtgraph             0.10.0-8                    -
                  python2-pytest-cov              2.9.0-1             2.10.0-1
              python2-pytest-timeout              1.3.4-1              1.4.1-1
                            qastools             0.22.0-1             0.23.0-1
                            qmidiarp              0.6.5-3              0.6.5-4
                            qtractor             0.9.14-1             0.9.14-2
                         ruby-marisa            0.2.5-8.1              0.2.6-1
                       ruby-net-ping              2.0.7-1              2.0.8-1
                  ruby-sys-proctable              1.2.3-1              1.2.5-1
                              skopeo              1.0.0-1              1.1.0-1
                              smtube             20.1.0-1             20.6.0-1
                              sn0int             0.18.2-1             0.19.0-1
                             snapper              0.8.9-1             0.8.10-1
                            spectrwm              3.3.0-1              3.4.0-1
                            sshuttle              1.0.1-1              1.0.2-1
                           stylelint             13.6.0-1             13.6.1-1
                          subsurface              4.9.5-1              4.9.6-1
                    subsurface-libdc              4.9.5-1              4.9.6-1
                          swi-prolog              8.0.3-2              8.2.0-1
                           syncthing              1.5.0-1              1.6.1-1
                  syncthing-relaysrv              1.5.0-1              1.6.1-1
                        systemd-swap              4.2.1-1              4.2.2-1
                    telegram-desktop             2.1.11-1             2.1.12-1
                               tiled              1.3.5-1              1.4.0-1
                    ttf-font-awesome             5.13.0-1             5.13.1-1
                                 tup              0.7.8-2              0.7.9-1
                             txt2man              1.6.0-2              1.7.0-1
                      ubuntu-keyring       2020.02.11.2-1       2020.06.17.1-1
                               udpxy          1.0.23.12-2           1.0.24.1-1
                           uglify-js              3.9.4-1             3.10.0-1
                    ukui-screensaver              2.1.1-2              2.1.1-3
                               uwsgi             2.0.18-7           2.0.19.1-1
                    uwsgi-plugin-cgi             2.0.18-7           2.0.19.1-1
                    uwsgi-plugin-jvm             2.0.18-7           2.0.19.1-1
                  uwsgi-plugin-lua51             2.0.18-7           2.0.19.1-1
               uwsgi-plugin-notfound             2.0.18-7           2.0.19.1-1
                    uwsgi-plugin-php             2.0.18-7           2.0.19.1-1
                   uwsgi-plugin-psgi             2.0.18-7           2.0.19.1-1
                 uwsgi-plugin-python             2.0.18-7           2.0.19.1-1
                uwsgi-plugin-python2             2.0.18-7           2.0.19.1-1
                   uwsgi-plugin-rack             2.0.18-7           2.0.19.1-1
                 uwsgi-plugin-webdav             2.0.18-7           2.0.19.1-1
                 uwsgi-plugin-zabbix             2.0.18-7           2.0.19.1-1
                               v2ray             4.24.2-1             4.25.0-1
         v2ray-domain-list-community       202006141101-1       202006211221-1
                         v2ray-geoip       202006100003-1       202006170003-1
                           verilator              4.034-1              4.036-1
                        vim-nerdtree             6.7.12-1             6.7.14-1
                                wabt             1.0.15-1             1.0.17-1
                           watchexec             1.12.0-1             1.13.1-1
                              websvn              2.3.3-8                2.5-1
                                when             1.1.39-1             1.1.40-2
                                 wtf           20200217-1           20200613-1
                                  xa             2.3.10-1             2.3.11-1
                                xaos                3.7-1                4.0-1
                       xcursor-comix              0.9.0-3              0.9.2-1
                              xdebug              2.9.4-1              2.9.6-1
                          xdiskusage               1.51-3               1.52-1
                            xkeycaps               2.46-8               2.47-1
                               yaegi              0.8.4-1              0.8.8-1
                             you-get           0.4.1432-1           0.4.1432-2
                           zeroc-ice              3.7.3-2              3.7.4-1
                            birdfont                    -             2.29.0-2
                             ddcutil                    -              0.9.8-1
                       fltk-examples                    -              1.3.5-2
             indicator-china-weather                    -              3.0.4-1
                      libretro-mesen                    -               2898-1
                    libretro-mesen-s                    -                870-1
                    libretro-sameboy                    -               1277-1
                          libxmlbird                    -             1.2.11-2
                 new-session-manager                    -              1.3.2-1
                   openapi-generator                    -              4.3.1-1
                  python-commentjson                    -              0.8.3-1
                            tupitube                    -             0.2.15-1
                         wf-recorder                    -              0.2.1-1


:: Different overlay package(s) in repository core aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-06-17         2020-06-22
-------------------------------------------------------------------------------
                       linux-aarch64              5.7.2-1              5.7.4-1
               linux-aarch64-headers              5.7.2-1              5.7.4-1
                     linux-pinephone              5.5.0-7              5.7.0-1
             linux-pinephone-headers              5.5.0-7              5.7.0-1
                            linux-rc            5.8.rc1-1            5.8.rc1-2
                    linux-rc-headers            5.8.rc1-1            5.8.rc1-2
                 linux-rpi4-mainline             5.6.17-1              5.7.3-1
         linux-rpi4-mainline-headers             5.6.17-1              5.7.3-1
              raspberrypi-bootloader           20200610-1           20200617-1
            raspberrypi-bootloader-x           20200610-1           20200617-1
                     uboot-pinephone            2020.04-1            2020.04-2


:: Different sync package(s) in repository core aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-06-17         2020-06-22
-------------------------------------------------------------------------------
                               bison              3.6.3-1              3.6.4-1
             ca-certificates-mozilla               3.53-1             3.53.1-1
                                dash           0.5.10.2-2             0.5.11-1
                              dhcpcd              9.1.1-1              9.1.2-1
                            elfutils              0.179-1              0.180-1
                                file               5.38-3               5.39-1
                              libcap               2.35-1               2.36-1
                              libelf              0.179-1              0.180-1
                                 nss               3.53-1             3.53.1-1
                              sqlite             3.32.2-1             3.32.3-1
                     sqlite-analyzer             3.32.2-1             3.32.3-1
                          sqlite-doc             3.32.2-1             3.32.3-1
                          sqlite-tcl             3.32.2-1             3.32.3-1
                                sudo              1.9.0-1              1.9.1-1
                             systemd              245.6-6              245.6-7
                        systemd-libs              245.6-6              245.6-7
                  systemd-resolvconf              245.6-6              245.6-7
                  systemd-sysvcompat              245.6-6              245.6-7


:: Different overlay package(s) in repository extra aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-06-17         2020-06-22
-------------------------------------------------------------------------------
            archlinux-appstream-data         20200516-1.1         20200612-1.1
                            mesa-git20.2.0_devel.124965.356be07ce27-120.2.0_devel.125242.82815bc9803-1
                           pamac-cli              9.5.5-1              9.5.6-1
                        pamac-common              9.5.5-1              9.5.6-1
                pamac-flatpak-plugin              9.5.5-1              9.5.6-1
                           pamac-gtk              9.5.5-1              9.5.6-1
                   pamac-snap-plugin              9.5.5-1              9.5.6-1
             pamac-tray-appindicator              9.5.5-1              9.5.6-1
                              libnma                    -             1.8.28-2
              network-manager-applet                    -             1.16.0-2
                nm-connection-editor                    -             1.16.0-2


:: Different sync package(s) in repository extra aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-06-17         2020-06-22
-------------------------------------------------------------------------------
                        alertmanager             0.20.0-3             0.21.0-1
                            alsa-lib              1.2.3-1            1.2.3.1-1
                       alsa-ucm-conf              1.2.3-1              1.2.3-2
            archlinux-appstream-data           20200612-1                    -
                                bind             9.16.3-1             9.16.4-1
                          bind-tools             9.16.3-1             9.16.4-1
                            chromium      83.0.4103.106-1      83.0.4103.106-3
                  desktop-file-utils               0.24-2               0.26-1
                                 ecl             16.1.3-4            20.4.24-1
                              evince             3.36.5-1             3.36.6-1
                                 exo            0.12.11-2            0.12.11-4
                          fontconfig2:2.13.91+24+g75eadca-22:2.13.91+48+gfcb0420-1
                             freetds             1.1.40-1             1.1.42-1
                         fuse-common              3.9.1-1              3.9.2-1
                               fuse3              3.9.1-1              3.9.2-1
                      gnome-calendar             3.36.1-1             3.36.2-1
                      gnome-contacts             3.36.1-1             3.36.2-1
                             haveged             1.9.11-1             1.9.12-1
                            intltool             0.51.0-5             0.51.0-6
                         kinfocenter             5.19.1-1                    -
                               krita              4.2.9-6              4.3.0-1
                            lablgtk2            2.18.10-1            2.18.11-1
                               lcms2               2.11-1               2.11-2
                         libgweather             3.36.0-1             3.36.1-1
                            libinput             1.15.5-1             1.15.6-1
                          libmagick6          6.9.11.18-1          6.9.11.20-1
                              libnma             1.8.28-1                    -
                          libsynctex        2019.51075-10         2020.54586-3
                               meson             0.54.2-1             0.54.3-1
                             metalog           20181125-2           20200113-1
                              mpg123            1.25.13-2             1.26.1-1
                            muparser              2.3.1-1              2.3.2-1
                                mutt             1.14.3-1             1.14.4-1
                                neon             0.31.1-1             0.31.2-1
              network-manager-applet             1.16.0-1                    -
                nm-connection-editor             1.16.0-1                    -
                             openmpi              4.0.3-1              4.0.4-1
                 perl-image-exiftool              11.85-2              12.00-1
                  perl-io-socket-ssl              2.066-2              2.067-1
                          prometheus             2.19.0-1             2.19.1-1
                             pyside2             5.15.0-1             5.15.0-2
                          python-pip             20.0.2-1               20.1-1
                        python-pyqt5             5.15.0-2             5.15.0-3
                     python-requests             2.23.0-1             2.24.0-1
                   python-setuptools           1:47.3.0-1           1:47.3.1-1
                       python2-isort             4.3.15-1             4.3.17-1
                         python2-pip             20.0.2-1               20.1-1
                       python2-pyqt5             5.15.0-2             5.15.0-3
                    python2-requests             2.23.0-1             2.24.0-1
                       qt5-webengine             5.15.0-1             5.15.0-2
                           qtcreator             4.12.2-1             4.12.3-1
                                rust           1:1.44.0-2           1:1.44.1-1
                           rust-docs           1:1.44.0-2           1:1.44.1-1
                                sbcl              2.0.3-1              2.0.5-1
                            seahorse             1:3.36-1           1:3.36.2-1
                 texlive-bibtexextra         2019.52577-1         2020.55376-1
                         texlive-bin        2019.51075-10         2020.54586-3
                        texlive-core         2019.52579-1         2020.55416-1
                  texlive-fontsextra         2019.52580-1         2020.55407-1
                texlive-formatsextra         2019.51280-1         2020.54498-1
                       texlive-games         2019.52525-1         2020.55271-1
                  texlive-humanities         2019.52574-1         2020.55389-1
                 texlive-langchinese         2019.52237-1         2020.55162-1
                texlive-langcyrillic         2019.52494-1         2020.54594-1
                   texlive-langextra         2019.52581-1         2020.55417-1
                   texlive-langgreek         2019.51628-1         2020.54512-1
                texlive-langjapanese         2019.52531-1         2020.55320-1
                  texlive-langkorean         2019.51035-1         2020.54519-1
                  texlive-latexextra         2019.52575-1         2020.55418-1
                       texlive-music         2019.52275-1         2020.54758-2
                    texlive-pictures         2019.52499-1         2020.55342-1
                    texlive-pstricks         2019.52550-1         2020.55289-1
                  texlive-publishers         2019.52538-1         2020.55415-1
                     texlive-science         2019.52582-1         2020.55390-1
                          ttf-dejavu               2.37-3  2.37+18+g9b5d1b2f-1
                                vino 3.22.0+60+gd29a4f2-2 3.22.0+72+g3fe1f12-1
                                 vlc             3.0.10-4             3.0.11-1
                      wpebackend-fdo              1.6.0-1              1.6.1-1
                          x2goserver            4.1.0.3-6            4.1.0.3-7
                   xfce4-eyes-plugin              4.5.0-2              4.5.1-1
                    xkeyboard-config               2.30-1               2.30-2
                        python-csv23                    -              0.3.2-1
                   python-resolvelib                    -              0.4.0-1
                       python2-csv23                    -              0.3.2-1
                  python2-resolvelib                    -              0.4.0-1

Testers needed on arm-testing branch
We are in need of testers for our arm-testing and arm-unstable branches.
So if you are adventurous and want newer software quicker, we would love for you to help us test out the new packages in arm-testing branch.

All you have to do to switch to this branch is:

  • Edit /etc/pacman-mirrors.conf and change Branch = arm-stable to Branch = arm-testing.
  • Run this command: sudo pacman-mirrors -f5 && sudo pacman -Syyu. This will generate a new mirrorlist for you, sync your databases with the new mirror and update your system using the arm-testing branch.

We would then love for you to give feedback in our update posts in #manjaro-arm:arm-testing-updates. That way we can better find and fix bugs, before they hit arm-stable branch. Thank you!


  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

PinePhone uboot
This update to the PinePhone Uboot package (2020.04-2), changed how the DTS is loaded from the kernel, since the Kernel DTS for the Pinephone also changed. When doing this update on the PinePhone images from Alpha5 and back, please make this change to the /boot/extlinux/extlinux.conf before rebooting:

  • sun50i-a64-pinephone.dtb to sun50i-a64-pinephone-1.2.dtb
  • root=LABEL=ROOT to root=LABEL=ROOT_MNJRO
Old Issues

Manual interventions:
The nss and zn_poly packages prior to version 3.51.1-1 and version 0.9.2-2 respectively, were missing a soname link each. This has been fixed in 3.51.1-1 and 0.9.2-2 of these packages, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

nss: /usr/lib/p11-kit-trust.so exists in filesystem
zn_poly: /usr/lib/libzn_poly-0.9.so  exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/p11-kit-trust.so --overwrite /usr/lib/libzn_poly-0.9.so

to perform the upgrade.

Device stopped booting after Uboot update
The uboot update included a change to the extlinux.conf file. This change will be incompatible with the old 1 partition layout of some devices.
So if you are updating installs made with images 20.02.1 or older, you need to apply this fix before rebooting!
To fix this please edit your /boot/extlinux/extlinux.conf file and add 2 periods in front of each first slash, like so:

KERNEL ../Image
FDT ../dtbs/ #etc.
APPEND initrd=../initramfs-linux.img #etc.

Save the file and reboot.

Odroid C2 & N2 fine (xfce) .. update & reboot via terminal
Thanks

**Update @Strit
update PinePhone from Alpha5 to Testing 2020-06-22

sudo pacman -Syyu
(208/449) upgrading gstreamer                                                        [################################################] 100%
Failed to set capabilities on file `usr/lib/gstreamer-1.0/gst-ptp-helper' (Operation not supported)
usage: setcap [-q] [-v] [-n <rootid>] (-r|-|<caps>) <filename> [ ... (-r|-|<capsN>) <filenameN> ]

 Note <filename> must be a regular (non-symlink) file.
error: command failed to execute correctly

(331/449) upgrading kwin                                                             [################################################] 100%
Failed to set capabilities on file `/usr/bin/kwin_wayland' (Operation not supported)
usage: setcap [-q] [-v] [-n <rootid>] (-r|-|<caps>) <filename> [ ... (-r|-|<capsN>) <filenameN> ]

 Note <filename> must be a regular (non-symlink) file.
error: command failed to execute correctly

(431/449) upgrading sudo                                                             [################################################] 100%
warning: directory permissions differ on /etc/sudoers.d/
filesystem: 755  package: 750

(433/449) upgrading uboot-pinephone                                                  [################################################] 100%
warning: /boot/extlinux/extlinux.conf installed as /boot/extlinux/extlinux.conf.pacnew
Install new bootloader by running:
# dd if=/boot/u-boot-sunxi-with-spl-pinephone.bin of=/dev/mmcblkX bs=8k seek=1 for PinePhone SD/eMMC

problem after reboot with new /boot/extlinux/extlinux.conf.pacnew btw with old /boot/extlinux/extlinux.conf(*update warning 433 befor)

  • no start
  • no display
    = nothing

diff extlinux.conf vs extlinux.conf.pacnew

extlinux.conf

LABEL Manjaro ARM
KERNEL /Image
FDT /dtbs/allwinner/sun50i-a64-pinephone.dtb
APPEND initrd=/initramfs-linux.img console=tty1 console=ttyS0,115200 root=LABEL=ROOT_MNJRO rw rootwait bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash

extlinux.conf.pacnew

LABEL Manjaro ARM
KERNEL /Image
FDT /dtbs/allwinner/sun50i-a64-pinephone.dtb
APPEND initrd=/initramfs-linux.img console=tty1 console=ttyS0,115200 root=LABEL=ROOT rw rootwait bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash

after change

  • sun50i-a64-pinephone.dtb to sun50i-a64-pinephone-1.2.dtb
  • root=LABEL=ROOT to root=LABEL=ROOT_MNJRO

booting pinephone with
Linux manjaro-arm 5.7.0-1-MANJARO-ARM #1 SMP Sat Jun 20 22:28:25 UTC 2020 aarch64 GNU/Linux
:innocent:

ls -al /boot/dtbs/allwinner/
total 1388
drwxr-xr-x 2 root root  8192 Jun 24 15:54 .
drwxr-xr-x 3 root root  4096 Apr 17 20:17 ..
-rwxr-xr-x 1 root root 40813 Jun 20 22:25 sun50i-a64-amarula-relic.dtb
-rwxr-xr-x 1 root root 41170 Jun 20 22:25 sun50i-a64-bananapi-m64.dtb
-rwxr-xr-x 1 root root 43891 Jun 20 22:25 sun50i-a64-dontbeevil.dtb
-rwxr-xr-x 1 root root 40042 Jun 20 22:25 sun50i-a64-nanopi-a64.dtb
-rwxr-xr-x 1 root root 39495 Jun 20 22:25 sun50i-a64-oceanic-5205-5inmfd.dtb
-rwxr-xr-x 1 root root 40923 Jun 20 22:25 sun50i-a64-olinuxino-emmc.dtb
-rwxr-xr-x 1 root root 40794 Jun 20 22:25 sun50i-a64-olinuxino.dtb
-rwxr-xr-x 1 root root 41821 Jun 20 22:25 sun50i-a64-orangepi-win.dtb
-rwxr-xr-x 1 root root 41230 Jun 20 22:25 sun50i-a64-pine64-lts.dtb
-rwxr-xr-x 1 root root 40290 Jun 20 22:25 sun50i-a64-pine64-plus.dtb
-rwxr-xr-x 1 root root 40128 Jun 20 22:25 sun50i-a64-pine64.dtb
-rwxr-xr-x 1 root root 42791 Jun 20 22:25 sun50i-a64-pinebook.dtb
-rwxr-xr-x 1 root root 47317 Jun 20 22:25 sun50i-a64-pinephone-1.0.dtb
-rwxr-xr-x 1 root root 47532 Jun 20 22:25 sun50i-a64-pinephone-1.1.dtb
-rwxr-xr-x 1 root root 47759 Jun 20 22:25 sun50i-a64-pinephone-1.2.dtb
-rwxr-xr-x 1 root root 42744 Jun 20 22:25 sun50i-a64-pinetab.dtb
-rwxr-xr-x 1 root root 40590 Jun 20 22:25 sun50i-a64-sopine-baseboard.dtb
-rwxr-xr-x 1 root root 42056 Jun 20 22:25 sun50i-a64-teres-i.dtb
-rwxr-xr-x 1 root root 31512 Jun 20 22:25 sun50i-h5-bananapi-m2-plus-v1.2.dtb
-rwxr-xr-x 1 root root 31119 Jun 20 22:25 sun50i-h5-bananapi-m2-plus.dtb
-rwxr-xr-x 1 root root 30832 Jun 20 22:25 sun50i-h5-emlid-neutis-n5-devboard.dtb
-rwxr-xr-x 1 root root 29973 Jun 20 22:25 sun50i-h5-libretech-all-h3-cc.dtb
-rwxr-xr-x 1 root root 29711 Jun 20 22:25 sun50i-h5-libretech-all-h3-it.dtb
-rwxr-xr-x 1 root root 30564 Jun 20 22:25 sun50i-h5-libretech-all-h5-cc.dtb
-rwxr-xr-x 1 root root 29491 Jun 20 22:25 sun50i-h5-nanopi-neo-plus2.dtb
-rwxr-xr-x 1 root root 29019 Jun 20 22:25 sun50i-h5-nanopi-neo2.dtb
-rwxr-xr-x 1 root root 29852 Jun 20 22:25 sun50i-h5-orangepi-pc2.dtb
-rwxr-xr-x 1 root root 29896 Jun 20 22:25 sun50i-h5-orangepi-prime.dtb
-rwxr-xr-x 1 root root 29314 Jun 20 22:25 sun50i-h5-orangepi-zero-plus.dtb
-rwxr-xr-x 1 root root 29042 Jun 20 22:25 sun50i-h5-orangepi-zero-plus2.dtb
-rwxr-xr-x 1 root root 31403 Jun 20 22:25 sun50i-h6-beelink-gs1.dtb
-rwxr-xr-x 1 root root 32545 Jun 20 22:25 sun50i-h6-orangepi-3.dtb
-rwxr-xr-x 1 root root 30086 Jun 20 22:25 sun50i-h6-orangepi-lite2.dtb
-rwxr-xr-x 1 root root 29865 Jun 20 22:25 sun50i-h6-orangepi-one-plus.dtb
-rwxr-xr-x 1 root root 32086 Jun 20 22:25 sun50i-h6-pine-h64-model-b.dtb
-rwxr-xr-x 1 root root 32119 Jun 20 22:25 sun50i-h6-pine-h64.dtb
-rwxr-xr-x 1 root root 27630 Jun 20 22:25 sun50i-h6-tanix-tx6.dtb

I don't know if it's relevant but since pamac 9.5.6 I have issues when upgrading from it.

** (pamac:244212): WARNING **: 03:35:07.879: transaction_interface_daemon.vala:47: failed to connect to dbus daemon: Timeout was reached
Preparing...
Error: Daemon Error: get_authorization: Timeout was reached
Error: Daemon Error: remove_authorization: Timeout was reached

I saw an old post about that error but not very helpful. https://forum.manjaro.org/t/pamac-4493-critical-1333-496-transaction-interface-daemon-vala-failed-to-connect-to-dbus-daemon-timeout-was-reached/119244

Even after rebooting?

Hi,

Lila-Kuh is running odroid c2 and n2 with the testing branch, thanks to her (I'm right?)
I'll continue to use the testing branch for the odroid c4 for the moment, I think it's a good chose, eventually helpful for the manjaro arm devs.

before the update

[nlc4@c4 ~]$ date -u
mar. 23 juin 2020 15:20:26 UTC
[nlc4@c4 ~]$ uname -a
Linux c4.test.2020.05.14 5.7.2-1-MANJARO-ARM #1 SMP Wed Jun 10 21:56:16 CEST 2020 aarch64 GNU/Linux
[nlc4@c4 ~]$ sudo pacman -Syyuu
[sudo] password for nlc4: 
:: Synchronising package databases...
 core                                                  218,3 KiB  1679 KiB/s 00:00 [###############################################] 100%
 extra                                                   2,3 MiB  1483 KiB/s 00:02 [###############################################] 100%
 community                                               5,1 MiB  1333 KiB/s 00:04 [###############################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (36) alsa-lib-1.2.3.1-1  alsa-ucm-conf-1.2.3-2  archlinux-appstream-data-20200612-1.1  bison-3.6.4-1
              ca-certificates-mozilla-3.53.1-1  desktop-file-utils-0.26-1  dhcpcd-9.1.2-1  elfutils-0.180-1  exo-0.12.11-4  file-5.39-1
              fontconfig-2:2.13.91+48+gfcb0420-1  fuse-common-3.9.2-1  haveged-1.9.12-1  lcms2-2.11-2  libcap-2.36-1  libelf-0.180-1
              libinput-1.15.6-1  linux-aarch64-5.7.4-1  neon-0.31.2-1  nss-3.53.1-1  openmpi-4.0.4-1  pamac-cli-9.5.6-1
              pamac-common-9.5.6-1  pamac-gtk-9.5.6-1  pamac-tray-appindicator-9.5.6-1  pcsclite-1.9.0-1  python-requests-2.24.0-1
              python-setuptools-1:47.3.1-1  qt5-webengine-5.15.0-2  sqlite-3.32.3-1  sudo-1.9.1-1  systemd-245.6-7  systemd-libs-245.6-7
              systemd-sysvcompat-245.6-7  vlc-3.0.11-1  xkeyboard-config-2.30-2

Total Download Size:   155,60 MiB
Total Installed Size:  429,99 MiB
Net Upgrade Size:        1,05 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 bison-3.6.4-1-aarch64                                 653,5 KiB  2,13 MiB/s 00:00 [###############################################] 100%
 libcap-2.36-1-aarch64                                  56,5 KiB  5,52 MiB/s 00:00 [###############################################] 100%
 systemd-libs-245.6-7-aarch64                          459,7 KiB  2,14 MiB/s 00:00 [###############################################] 100%
 ca-certificates-mozilla-3.53.1-1-aarch64              327,4 KiB  2,13 MiB/s 00:00 [###############################################] 100%
 libelf-0.180-1-aarch64                                412,7 KiB  2,12 MiB/s 00:00 [###############################################] 100%
 systemd-245.6-7-aarch64                                 5,0 MiB  2,07 MiB/s 00:02 [###############################################] 100%
 dhcpcd-9.1.2-1-aarch64                                182,5 KiB  2,23 MiB/s 00:00 [###############################################] 100%
 sqlite-3.32.3-1-aarch64                              1409,8 KiB  2,09 MiB/s 00:01 [###############################################] 100%
 elfutils-0.180-1-aarch64                              527,4 KiB  2,15 MiB/s 00:00 [###############################################] 100%
 file-5.39-1-aarch64                                   311,7 KiB  2,03 MiB/s 00:00 [###############################################] 100%
 linux-aarch64-5.7.4-1-aarch64                          69,1 MiB  2,06 MiB/s 00:33 [###############################################] 100%
 nss-3.53.1-1-aarch64                                 1326,5 KiB  2,09 MiB/s 00:01 [###############################################] 100%
 sudo-1.9.1-1-aarch64                                  940,1 KiB  2,09 MiB/s 00:00 [###############################################] 100%
 systemd-sysvcompat-245.6-7-aarch64                      8,0 KiB  0,00   B/s 00:00 [###############################################] 100%
 alsa-ucm-conf-1.2.3-2-any                              33,6 KiB  3,28 MiB/s 00:00 [###############################################] 100%
 alsa-lib-1.2.3.1-1-aarch64                            405,1 KiB  2,08 MiB/s 00:00 [###############################################] 100%
 archlinux-appstream-data-20200612-1.1-any              19,1 MiB  2,06 MiB/s 00:09 [###############################################] 100%
 desktop-file-utils-0.26-1-aarch64                      42,1 KiB  0,00   B/s 00:00 [###############################################] 100%
 fontconfig-2:2.13.91+48+gfcb0420-1-aarch64            888,1 KiB  2,06 MiB/s 00:00 [###############################################] 100%
 lcms2-2.11-2-aarch64                                  187,4 KiB  2,29 MiB/s 00:00 [###############################################] 100%
 xkeyboard-config-2.30-2-any                           626,4 KiB  2,11 MiB/s 00:00 [###############################################] 100%
 exo-0.12.11-4-aarch64                                 618,1 KiB  2,16 MiB/s 00:00 [###############################################] 100%
 fuse-common-3.9.2-1-aarch64                             2,6 KiB  0,00   B/s 00:00 [###############################################] 100%
 haveged-1.9.12-1-aarch64                               43,9 KiB  4,29 MiB/s 00:00 [###############################################] 100%
 libinput-1.15.6-1-aarch64                             233,4 KiB  2,28 MiB/s 00:00 [###############################################] 100%
 neon-0.31.2-1-aarch64                                 190,7 KiB  2,33 MiB/s 00:00 [###############################################] 100%
 openmpi-4.0.4-1-aarch64                                 3,0 MiB  2,07 MiB/s 00:01 [###############################################] 100%
 python-setuptools-1:47.3.1-1-any                      296,5 KiB  2,07 MiB/s 00:00 [###############################################] 100%
 python-requests-2.24.0-1-any                           86,3 KiB  2,11 MiB/s 00:00 [###############################################] 100%
 pamac-common-9.5.6-1-aarch64                          434,0 KiB  2,12 MiB/s 00:00 [###############################################] 100%
 pamac-cli-9.5.6-1-aarch64                              47,1 KiB  1569 KiB/s 00:00 [###############################################] 100%
 pamac-gtk-9.5.6-1-aarch64                             125,1 KiB  2,44 MiB/s 00:00 [###############################################] 100%
 pamac-tray-appindicator-9.5.6-1-aarch64                17,2 KiB  0,00   B/s 00:00 [###############################################] 100%
 qt5-webengine-5.15.0-2-aarch64                         37,9 MiB  2,06 MiB/s 00:18 [###############################################] 100%
 vlc-3.0.11-1-aarch64                                   10,9 MiB  2,06 MiB/s 00:05 [###############################################] 100%
 pcsclite-1.9.0-1-aarch64                               91,2 KiB  2,23 MiB/s 00:00 [###############################################] 100%
(36/36) checking keys in keyring                                                   [###############################################] 100%
(36/36) checking package integrity                                                 [###############################################] 100%
(36/36) loading package files                                                      [###############################################] 100%
(36/36) checking for file conflicts                                                [###############################################] 100%
(36/36) checking available disk space                                              [###############################################] 100%
:: Processing package changes...
( 1/36) upgrading alsa-ucm-conf                                                    [###############################################] 100%
( 2/36) upgrading alsa-lib                                                         [###############################################] 100%
( 3/36) upgrading archlinux-appstream-data                                         [###############################################] 100%
( 4/36) upgrading bison                                                            [###############################################] 100%
( 5/36) upgrading libcap                                                           [###############################################] 100%
( 6/36) upgrading systemd-libs                                                     [###############################################] 100%
( 7/36) upgrading ca-certificates-mozilla                                          [###############################################] 100%
( 8/36) upgrading desktop-file-utils                                               [###############################################] 100%
( 9/36) upgrading libelf                                                           [###############################################] 100%
(10/36) upgrading systemd                                                          [###############################################] 100%
(11/36) upgrading dhcpcd                                                           [###############################################] 100%
(12/36) upgrading sqlite                                                           [###############################################] 100%
(13/36) upgrading elfutils                                                         [###############################################] 100%
(14/36) upgrading fontconfig                                                       [###############################################] 100%
Rebuilding fontconfig cache... done.
(15/36) upgrading lcms2                                                            [###############################################] 100%
(16/36) upgrading xkeyboard-config                                                 [###############################################] 100%
(17/36) upgrading exo                                                              [###############################################] 100%
(18/36) upgrading file                                                             [###############################################] 100%
(19/36) upgrading fuse-common                                                      [###############################################] 100%
(20/36) upgrading haveged                                                          [###############################################] 100%
(21/36) upgrading libinput                                                         [###############################################] 100%
(22/36) upgrading linux-aarch64                                                    [###############################################] 100%
(23/36) upgrading neon                                                             [###############################################] 100%
(24/36) upgrading nss                                                              [###############################################] 100%
(25/36) upgrading openmpi                                                          [###############################################] 100%
(26/36) upgrading python-setuptools                                                [###############################################] 100%
(27/36) upgrading python-requests                                                  [###############################################] 100%
(28/36) upgrading pamac-common                                                     [###############################################] 100%
(29/36) upgrading pamac-cli                                                        [###############################################] 100%
(30/36) upgrading pamac-gtk                                                        [###############################################] 100%
(31/36) upgrading pamac-tray-appindicator                                          [###############################################] 100%
(32/36) upgrading pcsclite                                                         [###############################################] 100%
(33/36) upgrading qt5-webengine                                                    [###############################################] 100%
(34/36) upgrading sudo                                                             [###############################################] 100%
warning: directory permissions differ on /etc/sudoers.d/
filesystem: 755  package: 750
(35/36) upgrading systemd-sysvcompat                                               [###############################################] 100%
(36/36) upgrading vlc                                                              [###############################################] 100%
:: Running post-transaction hooks...
( 1/21) Creating system user accounts...
( 2/21) Updating journal message catalog...
( 3/21) Reloading system manager configuration...
( 4/21) Updating udev hardware database...
( 5/21) Applying kernel sysctl settings...
( 6/21) Creating temporary files...
( 7/21) Reloading device manager configuration...
( 8/21) Arming ConditionNeedsUpdate...
( 9/21) Updating module dependencies...
(10/21) Updating linux-aarch64 module dependencies...
(11/21) Updating linux-aarch64 initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux-aarch64.preset: 'default'
  -> -k 5.7.4-1-MANJARO-ARM -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 5.7.4-1-MANJARO-ARM
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
(12/21) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux-aarch64.preset: 'default'
  -> -k 5.7.4-1-MANJARO-ARM -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 5.7.4-1-MANJARO-ARM
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
(13/21) Updating uimg initcpios...
Image Name:   Ramdisk Image
Created:      Tue Jun 23 17:25:04 2020
Image Type:   AArch64 Linux RAMDisk Image (uncompressed)
Data Size:    7855854 Bytes = 7671.73 KiB = 7.49 MiB
Load Address: 00000000
Entry Point:  00000000
(14/21) Reloading system bus configuration...
(15/21) Updating icon theme caches...
(16/21) Updating the info directory file...
(17/21) Updating the appstream cache...
AppStream cache update completed successfully.
(18/21) Rebuilding certificate stores...
(19/21) Updating the desktop file MIME type cache...
(20/21) Updating the MIME type database...
(21/21) Updating the vlc plugin cache...
[nlc4@c4 ~]$ reboot

after the update

[nlc4@c4 ~]$ uname -a
Linux c4.test.2020.05.14 5.7.4-1-MANJARO-ARM #1 SMP Thu Jun 18 17:08:35 CEST 2020 aarch64 GNU/Linux
[nlc4@c4 ~]$ date -u
mar. 23 juin 2020 15:28:16 UTC
[nlc4@c4 ~]$ 

The only problem I found are the preview images, if you look here it don't appears
Should I report this bug to kde ?

Can you try using a different application style, like Breeze to see if it works there?

If you look here it's the same, the bug is old for me, since a long time, stable branch included

It's odd indeed. I haven't seen it on any of my devices. :frowning:

Maybe something to do with kde oxygen I install on the devices ?

The answer is no, look at my n2 19.08 without kde oxygen
same issue

I've rebooted now and it's weird because when I type "pamac update -a" it asks for sudo credentials but when it's on a script it doesn't ask for it and I guess that the issue waiting for authorization.
You can consider it's fixed.

1 Like

Hi

Have two things but just started on the testing branch for Pinebook Pro, so I am not sure if it comes from the latest update as both points are a bit special.

In Settings -> Global Theme -> Get new global themes (sort by stars)
The frame of the demo screenshots is a bit flimmering, something is not quite right with the graphics.


You can see the points splattered around the screenshot. In live this is actually flimmering when the screen is scrolled and not static.

In this screenshot it is easier to see (but also slightly different):
Screenshot_20200624_144446

Not sure if it's the driver or KDE.

When you start a programme from the app task bar - Task manager you get for 1-2 seconds a ring to indicate the system is working. However, if I open the same programme from the terminal it seems to appear much faster. Basically without the 1-3 sec penalty at the beginning.

I am reporting this as this was the same in stable for a while and I feel that from one of the recent releases that got much better.
My gut feeling is that the task manager waits for something to happen, some timeout or so which extends the startup time (could be completely wrong)

I am aware that these are fringe cases, but maybe others can check if they have a similar experience ?

I have noticed this as well. It might be related to panfrost.
Can you try switching to XRender backend in Settings -> Display -> Compositor. Is it also present there?

I haven't noticed this difference myself, but it could be a change in how Plasma Frameworks does its app launch thing.

For the second point I have found a setting that helps.
Settings -> Applications -> Launch feedback

  • set to static
  • disable animation

With that my test programme (Termite) starts instantly, no delay at all.

Okay, so the animation actually adds a delay too.
That sounds like a KDE Plasma bug.

I have tried with Xrender (and reboot). That does not make any difference.
I have also checked my Manjaro KDE 'stable'. No flimmer there.

The delay is maybe a regression error, I had the feeling that it was solved on stable in one of the last releases.
However, the work around with different setting sworks fine for me.

Thanks. Added to issues post.

On my VIM2 clone HDMI seems now much more stable, allows uptimes of days while TV off/on different HDMI. Else no difference to the version before (and after)

1 Like

Forum kindly sponsored by