[ARM Testing Update] 2020-008-01 - Thunderbird, KDE Plasma, Plasma Framworks Git and kernels

Hello ARM community.

Another testing update for you all...

thunderbird-email


Some highlights:

  • A couple of our kernels got updated
  • Thunderbird is now updated to 68.11.0
  • Version 5.19.4 of KDE Plasma is now here
  • Added git versions of the Plasma Frameworks packages
  • Some python packages got updated

Upstream Notifications:

Older notifications

The nss package requires manual intervention:
https://www.archlinux.org/news/nss3511-1-and-lib32-nss3511-1-updates-require-manual-intervention/
The packages hplip and firewalld requires manual intervention:
https://www.archlinux.org/news/hplip-3203-2-update-requires-manual-intervention/
https://www.archlinux.org/news/firewalld081-2-update-requires-manual-intervention/


Package Changes (Sat Aug 1 20:37:10 CEST 2020)

  • arm-testing community aarch64: 263 new and 231 removed package(s)
  • arm-testing core aarch64: 19 new and 19 removed package(s)
  • arm-testing extra aarch64: 211 new and 168 removed package(s)
:: Different overlay package(s) in repository community aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-07-27         2020-08-01
-------------------------------------------------------------------------------
                            electron              9.1.1-1              9.1.2-1
                     element-desktop              1.7.1-1              1.7.2-1
                         element-web              1.7.1-1              1.7.2-1
                           feedbackd  0.0.0+git20200707-2  0.0.0+git20200726-1
                           libhandy1             0.83.0-1             0.84.0-1
                               phosh   0.4.1+9+g835f4bb-1              0.4.2-1
            pinephone-manjaro-tweaks           20200725-1           20200731-1
                    plasma-mobile-nm             5.19.3-1             5.19.4-1
                         plasma-nano             5.19.3-1             5.19.4-1
             plasma-phone-components             5.19.3-1             5.19.4-1
                         wayfire-git      r1341.5f32ef6-10.4.0.r244.g9e971208-1
                             wcm-gitv0.3.1.r29.g2a0a70f-1v0.4.0.r14.g1595d35-1
                       wf-config-git       r124.94c7ecb-2  0.4.0.r6.ge3b78da-1
                        wf-shell-git       r134.923104d-2 0.4.0.r10.g12435d0-1
                wf-sound-control-git        r14.5770403-1                    -
             extra-cmake-modules-git                    -5.73.0.r3175.g6a278df-2
                         kapidox-git                    -5.73.0.r481.gb3dff93-2
                           kauth-git                    -5.73.0.r368.g4960beb-2
                         kcodecs-git                    -5.73.0.r317.g3c83f81-2
                     kcompletion-git                    -5.73.0.r374.g46377c4-2
                         kconfig-git                    -5.73.0.r709.g7c96cf2-2
                  kconfigwidgets-git                    -5.73.0.r481.ge3bdcc2-2
                     kcoreaddons-git                    -5.73.0.r1006.g614d986-2
                       kdoctools-git                    -5.73.0.r548.g8265a67-2
                      kguiaddons-git                    -5.73.0.r295.g51a6566-2
                           ki18n-git                    -5.73.0.r404.g1bc742e-2
                  kwidgetsaddons-git                    -5.73.0.r699.gc5d6ea9-2
                   kwindowsystem-git                    -5.73.0.r523.g97468c9-2
                       libmm-pp-glib                    -             1.14.0-1
                     modemmanager-pp                    -             1.14.0-1


:: Different sync package(s) in repository community aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-07-27         2020-08-01
-------------------------------------------------------------------------------
                           alacritty              0.4.3-1              0.5.0-1
                  appmenu-gtk-module            0.7.3.1-1            0.7.3.2-1
                          argocd-cli              1.6.1-1              1.6.2-1
                            asciidoc             8.6.10-2              9.0.2-1
                auto-multiple-choice              1.4.0-7              1.4.0-8
                               botan             2.14.0-1             2.15.0-1
                               broot             0.19.2-1             0.19.4-1
                             buildah             1.15.0-1             1.15.1-1
                             cargo-c              0.6.9-1             0.6.10-1
                                ccls       0.20190823.6-1       0.20190823.6-2
                                cgdb              0.7.1-2              0.7.1-3
               cldr-emoji-annotation      37.0.13.0.0.1-1      37.0.13.0.0.2-1
                              cobalt             0.16.0-1             0.16.1-1
                              conmon           1:2.0.19-1           1:2.0.20-1
                               copyq             3.11.1-1             3.12.0-1
                          cozy-stack           1:1.4.14-1           1:1.4.14-2
                               csfml                2.5-3                2.5-4
                          curseofwar              1.2.0-4              1.3.0-1
                             diffpdf            2.1.3.1-2            2.1.3.1-3
                 digikam-plugin-gmic              2.9.1-2              2.9.1-3
                         dns-lexicon             3.3.27-1             3.3.28-1
                            dokuwiki         20200609rc-1           20200729-1
                                dune              2.6.1-1              2.6.2-1
                               dunst              1.4.1-1              1.5.0-1
                             e-antic              0.1.7-1              0.1.8-1
                            ejabberd              20.04-1              20.07-1
                          emscripten            1.39.20-2            1.39.20-4
                              eslint              7.5.0-1              7.6.0-1
                               fcitx            4.2.9.7-3            4.2.9.8-1
                           fcitx-qt5              1.2.4-5              1.2.5-1
                              fcitx5     0.0.0.20200726-1   0.0.0.20200801.1-1
                        fcitx5-anthy     0.0.0.20200527-1     0.0.0.20200728-1
                      fcitx5-chewing     0.0.0.20200509-1     0.0.0.20200728-1
               fcitx5-chinese-addons     0.0.0.20200722-1     0.0.0.20200728-1
                       fcitx5-hangul     0.0.0.20200610-1     0.0.0.20200728-1
               fcitx5-material-color     0.0.0.20200410-1     0.0.0.20200729-1
                           fcitx5-qt     0.0.0.20200723-1     0.0.0.20200801-1
                 firefox-dark-reader             4.9.15-1             4.9.16-1
              firefox-tree-style-tab             3.5.13-1             3.5.15-1
                               flint              2.6.1-1              2.6.2-1
                           freeimage             3.18.0-6             3.18.0-7
                               fwupd              1.4.4-2              1.4.5-1
                    gimp-plugin-gmic              2.9.1-2              2.9.1-3
                              girara              0.3.4-2              0.3.5-1
                               gitea             1.11.6-2             1.12.3-1
                          github-cli             0.11.0-2             0.11.1-1
                               gloox             1.0.23-1             1.0.24-1
                                gmic              2.9.1-2              2.9.1-3
                              gnunet             0.13.0-1             0.13.1-1
                  go-bindata-assetfs              1.0.0-5              1.0.1-1
                         go-ethereum             1.9.17-1             1.9.18-1
             golang-github-kr-pretty              0.2.0-2              0.2.1-1
                         grammalecte              1.9.0-1             1.11.0-1
                           gscan2pdf              2.8.1-1              2.8.2-1
                               gsoap            2.8.104-1            2.8.105-1
                                gulp              4.0.2-2              4.0.2-3
                                haxe              4.0.5-1              4.1.3-1
                                hugo             0.73.0-2             0.74.0-1
                               i3-wm             4.18.1-1             4.18.2-1
                        i3lock-color           2.12.c.4-1           2.12.c.5-1
                             jenkins              2.248-1              2.250-1
                          jupyterlab              2.2.0-1              2.2.2-1
                          kcm-fcitx5     0.0.0.20200722-1     0.0.0.20200730-1
                                 kea             1.5.0-13             1.5.0-14
                           keepassxc              2.6.0-1              2.6.0-2
                                khal             0.10.1-3             0.10.2-1
                               kitty             0.18.1-2             0.18.2-2
                      kitty-terminfo             0.18.1-2             0.18.2-2
                   krita-plugin-gmic              2.9.1-2              2.9.1-3
                           kustomize              3.6.1-1              3.8.1-1
                        kyotocabinet             1.2.77-2             1.2.78-1
                             labplot              2.7.0-4              2.7.0-5
                              libasr              1.0.4-1                    -
                    libqtshadowsocks              2.1.0-9             2.1.0-10
                       libretro-play               5750-1               5758-1
              libretro-shaders-slang                760-1                764-1
                           lostfiles               4.04-1               4.05-1
                               lxcfs              4.0.4-1              4.0.4-2
                                 lxd                4.3-1                4.4-1
                             mbedtls             2.16.6-1             2.16.7-1
                           mitmproxy              5.1.1-1                5.2-1
                      mongo-c-driver             1.16.2-2             1.17.0-1
                           mtd-utils              2.1.1-2              2.1.2-1
             nextcloud-app-bookmarks            1:3.2.5-1            1:3.3.2-1
                              nodejs             14.6.0-1             14.7.0-1
                  nodejs-lts-dubnium            10.20.1-2            10.22.0-1
                   nodejs-lts-erbium            12.17.0-1            12.18.3-1
                              nomacs         1:3.16.224-2         1:3.16.224-3
                            normaliz              3.8.5-2              3.8.7-1
                             notmuch             0.29.3-2               0.30-1
                        notmuch-mutt             0.29.3-2               0.30-1
                     notmuch-runtime             0.29.3-2               0.30-1
                         notmuch-vim             0.29.3-2               0.30-1
                              nsjail                2.9-5                3.0-1
                         opencascade              7.4.0-2            7.4.0.1-1
                 openshadinglanguage            1.10.11-1            1.10.13-1
                           opensmtpd            6.7.1p1-4            6.7.1p1-5
                            pageedit              1.2.0-2              1.3.0-1
                          pcsc-tools              1.5.6-1              1.5.7-1
                         pdfarranger              1.6.0-2              1.6.2-1
                               pdfpc              4.4.0-1              4.4.0-2
                             perl-gd               2.71-3               2.72-1
                 perl-ppix-quotelike              0.011-2              0.012-1
                    perl-ppix-regexp              0.072-2              0.073-1
                      perl-type-tiny           1.004002-3           1.010002-1
                         php-mongodb              1.7.5-1              1.8.0-1
                               pinfo             0.6.10-9             0.6.13-1
                              podman              2.0.3-1              2.0.4-1
                       podman-docker              2.0.3-1              2.0.4-1
                             postfwd               2.02-2               2.03-1
                                ptex              2.3.2-1              2.3.2-2
                         python-amqp              2.6.0-1              2.6.1-1
                     python-atpublic                1.0-1                2.0-1
                      python-awkward            0.12.22-1             0.13.0-1
                    python-braintree              4.2.0-1              4.3.0-1
                       python-celery              4.4.6-1              4.4.7-1
                         python-cfgv              3.1.0-2              3.2.0-1
                       python-cftime              1.1.3-1              1.2.1-1
                   python-cloudflare              2.8.6-1              2.8.8-1
                         python-cmd2              1.1.0-1              1.2.1-1
                     python-curtsies              0.3.1-2              0.3.4-1
                python-debtcollector              2.1.0-1              2.2.0-1
                python-dogpile.cache              0.9.2-1              1.0.1-1
                      python-dropbox             10.2.0-1             10.3.0-1
                python-elasticsearch              7.8.0-1              7.8.1-1
                     python-eventlet             0.25.2-1             0.26.0-1
             python-flask-sqlalchemy              2.4.3-1              2.4.4-1
                   python-flufl.i18n                3.0-1              3.0.1-1
                        python-gammu                3.0-1                3.1-1
                       python-geoip2              3.0.0-1              4.0.2-1
                        python-gmpy2            2.1.0b4-1            2.1.0b5-1
                  python-google-auth             1.19.2-1             1.20.0-1
                      python-helpdev             0.6.10-1              0.7.1-1
                   python-hypothesis             5.22.0-1             5.23.8-1
                         python-jose              3.1.0-1              3.2.0-1
                 python-magnumclient              3.1.0-1              3.2.0-1
                        python-mamba             0.11.0-1             0.11.1-1
                    python-maxminddb              1.5.4-1              2.0.2-1
                      python-mutagen             1.45.0-1             1.45.1-1
                      python-netcdf4              1.5.3-3              1.5.4-1
              python-netcdf4-openmpi              1.4.2-1              1.5.4-1
       python-openapi-spec-validator              0.2.8-3              0.2.9-1
                     python-openmdao              3.1.1-1              3.2.0-1
                  python-oslo-config              8.3.0-1              8.3.1-1
                   python-oslo-utils              4.3.0-1              4.4.0-1
                     python-pdfminer           20200517-1           20200720-1
                python-process-tests              2.0.2-3              2.1.1-1
                       python-psutil              5.7.0-1              5.7.1-1
                   python-py-cpuinfo              6.0.0-1              7.0.0-1
                      python-pymongo             3.10.1-2             3.11.0-1
                   python-pynormaliz               2.11-1               2.12-1
                python-pytest-forked              1.2.0-1              1.3.0-1
                 python-pytest-xdist             1.33.0-1             1.34.0-1
                  python-pytest-xvfb              1.2.0-1              2.0.0-1
             python-pyvirtualdisplay              0.2.5-1              1.3.2-1
                    python-soupsieve              1.9.6-1              2.0.1-1
               python-spyder-kernels              1.9.1-1              1.9.3-1
                        python-sybil              1.3.0-1              1.3.1-1
                        python-tblib              1.6.0-1              1.7.0-1
                      python-testflo              1.4.2-1              1.4.2-2
                      python-tomlkit              0.6.0-1              0.7.0-1
                          python-tox             3.18.0-1             3.18.1-1
                    python-typeguard              2.7.1-1              2.8.0-1
                        python-vcrpy              4.0.2-1              4.1.0-1
                       python-xarray             0.15.1-1             0.16.0-2
                         python-yarl              1.4.2-1              1.5.0-1
             python2-netcdf4-openmpi              1.4.2-1                    -
               python2-process-tests              2.0.2-3              2.1.1-1
                      python2-psutil              5.7.0-1              5.7.1-1
               python2-pytest-forked              1.2.0-1              1.3.0-1
                python2-pytest-xdist             1.33.0-1             1.34.0-1
                   python2-soupsieve              1.9.6-1              1.9.6-2
                         python2-tox             3.18.0-1             3.18.1-1
                                qcad           3.24.3.4-1          3.24.3.10-2
                            qjackctl              0.6.2-1              0.6.3-1
                            qmidictl              0.6.2-1              0.6.3-1
                            qmidinet              0.6.2-1              0.6.3-1
                                qmmp              1.4.0-1              1.4.1-1
                         qpid-proton             0.30.0-3             0.31.0-1
                              qsynth              0.6.2-1              0.6.3-1
                             qxgedit              0.6.2-1              0.6.3-1
                            range-v3             0.10.0-1             0.10.0-2
                            restinio              0.6.8-1            0.6.8.1-1
                       rust-analyzer           20200720-1           20200727-1
                        rust-bindgen             0.54.0-2             0.54.1-1
                           shorewall            5.2.6.1-1              5.2.7-1
                      shorewall-core            5.2.6.1-1              5.2.7-1
                          shorewall6            5.2.6.1-1              5.2.7-1
                               sigil              1.2.1-2              1.3.0-1
                              skopeo              1.1.0-1              1.1.1-1
                               sopel              7.0.4-1              7.0.5-1
                              spyder              4.1.3-2              4.1.4-1
                         staticcheck           2020.1.4-1           2020.1.5-1
                    telegram-desktop              2.2.0-1              2.2.0-2
                           terraform            0.12.28-1            0.12.29-1
         terraform-provider-keycloak             1.19.0-1             1.20.0-1
                            three.js               r118-1               r119-1
                               tmuxp              1.5.4-1              1.5.5-1
              ubuntukylin-wallpapers            20.04.1-1                    -
                 ukui-control-center              2.0.5-1              3.0.0-1
                        ukui-greeter              1.2.6-1              3.0.0-1
                          ukui-media              2.0.4-1              3.0.0-1
                          ukui-panel              2.0.7-1              3.0.1-1
                        ukui-sidebar              1.1.2-1              3.0.0-1
                             unbound             1.10.1-2             1.11.0-1
                            urlwatch               2.19-1               2.21-1
         v2ray-domain-list-community     20200725163800-1     20200731003854-1
                         v2ray-geoip       202007220003-1       202007290004-1
                        vim-nerdtree              6.9.0-1              6.9.1-1
                                wofi              1.1.2-2              1.2.1-1
                              xxhash              0.7.4-1              0.8.0-1
                          youtube-dl       2020.06.16.1-2         2020.07.28-1
                      youtube-viewer            1:3.7.6-1            1:3.7.7-1
              yubikey-touch-detector              1.7.1-1              1.8.1-1
                                zart              2.9.1-2              2.9.1-3
                                 zig              0.6.0-1              0.6.0-2
                   fcitx5-configtool                    -     0.0.0.20200801-2
                        feathernotes                    -              0.7.0-3
                                kmon                    -              1.3.4-2
                               libbf                    -         2020.01.19-1
                          manuskript                    -             0.11.0-1
                      podman-compose                    -              0.1.5-1
                         python-dask                    -             2.21.0-2
                  python-distributed                    -             2.21.0-1
                       python-fsspec                    -              0.7.4-2
                     python-heapdict                    -              1.0.1-1
                         python-lmdb                    -               0.98-1
                       python-locket                    -              0.2.0-1
                       python-mocket                    -              3.8.7-1
                        python-partd                    -              1.1.0-1
       python-pipenv-to-requirements                    -              0.9.0-1
                         python-pook                    -              1.0.1-1
                         python-spur                    -             0.3.21-1
                         python-zict                    -              2.0.0-1
                           scenarist                    -         0.7.2.rc9i-1
                           symphytum                    -                2.6-2
                               yices                    -              2.6.2-1


:: Different overlay package(s) in repository core aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-07-27         2020-08-01
-------------------------------------------------------------------------------
                       linux-aarch64             5.7.10-2             5.7.12-1
               linux-aarch64-headers             5.7.10-2             5.7.12-1
                     linux-pinephone             5.7.0-10             5.7.0-11
             linux-pinephone-headers             5.7.0-10             5.7.0-11
                            linux-rc            5.8.rc7-1            5.8.rc7-3
                    linux-rc-headers            5.8.rc7-1            5.8.rc7-3
                   uboot-pinebookpro         2020.07rc5-1            2020.07-1


:: Different sync package(s) in repository core aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-07-27         2020-08-01
-------------------------------------------------------------------------------
                     ca-certificates           20181109-3           20181109-4
             ca-certificates-mozilla               3.54-1               3.55-2
               ca-certificates-utils           20181109-3           20181109-4
                                grub             2:2.04-7             2:2.04-8
                              json-c               0.14-4               0.15-1
                                nano              4.9.3-1                5.0-1
                                nspr               4.26-1               4.27-1
                                 nss               3.54-1               3.55-2
                             systemd              245.6-8              245.7-1
                        systemd-libs              245.6-8              245.7-1
                  systemd-resolvconf              245.6-8              245.7-1
                  systemd-sysvcompat              245.6-8              245.7-1


:: Different overlay package(s) in repository extra aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-07-27         2020-08-01
-------------------------------------------------------------------------------
                         kinfocenter             5.19.3-1             5.19.4-1
                   kscreenlocker-git       r776.115a5c2-15.19.80.r795.gf53b9b3-1
                 kwayland-server-git5.19.80.r1071.g7172fa7-15.19.80.r1098.gcccc77f-1
                                kwin           5.19.3-1.1                    -
                            mesa-git20.2.0_devel.126488.14a12b771d0-120.2.0_devel.126539.e2e89fb137c-1
                          attica-git                    -5.73.0.r758.gef33d1e-1
                          breeze-git                    -5.19.80.r2015.ge575c42d-1
                    breeze-icons-git                    -5.73.0.r1610.g9776efc2-1
             extra-cmake-modules-git                    -5.73.0.r3175.g6a278df-1
            frameworkintegration-git                    -5.73.0.r528.gfe2f686-1
                     kactivities-git                    -5.73.0.r1296.g5b8af490-1
                        karchive-git                    -5.73.0.r428.gcbd0b17-1
                           kauth-git                    -5.73.0.r368.g4960beb-1
                      kbookmarks-git                    -5.73.0.r345.g2c6cb26-1
                        kcmutils-git                    -5.73.0.r415.g57c7822-1
                         kcodecs-git                    -5.73.0.r317.g3c83f81-1
                     kcompletion-git                    -5.73.0.r374.g46377c4-1
                         kconfig-git                    -5.73.0.r709.g7c96cf2-1
                  kconfigwidgets-git                    -5.73.0.r481.ge3bdcc2-1
                     kcoreaddons-git                    -5.73.0.r1006.g614d986-1
                          kcrash-git                    -5.73.0.r323.g45e8369-1
                     kdbusaddons-git                    -5.73.0.r315.gde2efca-1
                    kdeclarative-git                    -5.73.0.r790.g909be01-1
                     kdecoration-git                    -5.19.80.r232.g0539093-1
                       kdoctools-git                    -5.73.0.r548.g8265a67-1
                    kglobalaccel-git                    -5.73.0.r373.gcfdbf5e-1
                      kguiaddons-git                    -5.73.0.r295.g51a6566-1
                           ki18n-git                    -5.73.0.r404.g1bc742e-1
                     kiconthemes-git                    -5.73.0.r434.ga4f1533-1
                       kidletime-git                    -5.73.0.r254.g8debece-1
                           kinit-git                    -5.73.0.r352.g91174aa-1
                             kio-git                    -5.73.0.r4116.gd8fa6aaa-1
                       kirigami2-git                    -5.73.0.r2281.g80ce6971-1
                      kitemviews-git                    -5.73.0.r276.g99ec8d4-1
                     kjobwidgets-git                    -5.73.0.r307.g4518dce-1
                       knewstuff-git                    -5.73.0.r882.g19cd11a2-1
                  knotifications-git                    -5.73.0.r553.gb2f1e84-1
                        kpackage-git                    -5.73.0.r589.g705ad04-1
                        kservice-git                    -5.73.0.r786.g04af66b-1
                    ktextwidgets-git                    -5.73.0.r331.gb5c1a48-1
                         kwallet-git                    -5.73.0.r984.gc8905cf-1
                        kwayland-git                    -5.73.0.r1019.gc8d44d3-1
                  kwidgetsaddons-git                    -5.73.0.r699.gc5d6ea9-1
                   kwindowsystem-git                    -5.73.0.r523.g97468c9-1
                         kxmlgui-git                    -5.73.0.r638.g2bbb468-1
                plasma-framework-git                    -5.73.0.r15507.ge0a721c10-1
        plasma-wayland-protocols-git                    -1.1.1.r1018.g61b389b-1
                           solid-git                    -5.73.0.r580.g0ac1bf3-1
                          sonnet-git                    -5.73.0.r541.g8e4b252-1


:: Different sync package(s) in repository extra aarch64

-------------------------------------------------------------------------------
                             PACKAGE          2020-07-27         2020-08-01
-------------------------------------------------------------------------------
                                 ark            20.04.3-1            20.04.3-2
                           bluedevil           1:5.19.3-1           1:5.19.4-1
                              breeze             5.19.3-1             5.19.4-1
                         breeze-grub             5.19.3-1             5.19.4-1
                          breeze-gtk             5.19.3-1             5.19.4-1
                              breezy            3.1.0.4-1            3.1.0.5-1
                            chromium       84.0.4147.89-1      84.0.4147.105-1
                               cmake             3.18.0-3             3.18.1-1
                             digikam              7.0.0-1              7.0.0-2
                            discover             5.19.3-1             5.19.4-1
                             drkonqi             5.19.3-1             5.19.4-1
                                 git             2.27.0-1             2.28.0-1
                             gnuplot              5.4.0-1              5.4.0-3
                            graphviz             2.44.0-5             2.44.1-2
                         imagemagick          7.0.10.24-2          7.0.10.25-1
                     imagemagick-doc          7.0.10.24-2          7.0.10.25-1
                   kactivitymanagerd             5.19.3-1             5.19.4-1
                       kde-cli-tools             5.19.3-1             5.19.4-1
                      kde-gtk-config             5.19.3-1             5.19.4-1
                         kdecoration             5.19.3-1             5.19.4-1
                    kdeplasma-addons             5.19.3-1             5.19.4-1
                             kgamma5             5.19.3-1             5.19.4-1
                            khotkeys             5.19.3-1             5.19.4-1
                          kitinerary            20.04.3-1            20.04.3-2
                           kmenuedit             5.19.3-1             5.19.4-1
                          knetattach             5.19.3-1             5.19.4-1
                             kscreen             5.19.3-1             5.19.4-1
                       kscreenlocker             5.19.3-1             5.19.4-1
                         ksshaskpass             5.19.3-1             5.19.4-1
                           ksysguard             5.19.3-1             5.19.4-1
                         kwallet-pam             5.19.3-1             5.19.4-1
                kwayland-integration             5.19.3-1             5.19.4-1
                     kwayland-server             5.19.3-1             5.19.4-2
                                kwin             5.19.3-1             5.19.4-1
                             kwrited             5.19.3-1             5.19.4-1
                             libcerf               1.13-2                2.0-1
                          libkscreen             5.19.3-1             5.19.4-1
                        libksysguard             5.19.3-1             5.19.4-1
                        libqalculate             3.11.0-1             3.12.0-1
                             libteam               1.30-1               1.31-1
                   libva-mesa-driver             20.1.4-1             20.1.4-3
                              libx11              1.6.9-7             1.6.10-1
                                mesa             20.1.4-1             20.1.4-3
                          mesa-vdpau             20.1.4-1             20.1.4-3
                               milou             5.19.3-1             5.19.4-1
                                 mlt             6.20.0-4             6.22.0-2
                         ocaml-topkg              1.0.1-4              1.0.2-1
                              okteta           1:0.26.3-1           1:0.26.4-1
                         opencl-mesa             20.1.4-1             20.1.4-3
                              opencv              4.3.0-7              4.4.0-1
                      opencv-samples              4.3.0-7              4.4.0-1
                              oxygen             5.19.3-1             5.19.4-1
                 perl-compress-bzip2               2.27-2               2.28-1
          plasma-browser-integration             5.19.3-1             5.19.4-1
                      plasma-desktop             5.19.3-1             5.19.4-1
                  plasma-integration             5.19.3-1             5.19.4-1
                           plasma-nm             5.19.3-1             5.19.4-1
                           plasma-pa             5.19.3-1             5.19.4-1
                          plasma-sdk             5.19.3-1             5.19.4-1
                  plasma-thunderbolt             5.19.3-1             5.19.4-1
                        plasma-vault             5.19.3-1             5.19.4-1
            plasma-wayland-protocols              1.1.0-1              1.1.1-1
              plasma-wayland-session             5.19.3-2             5.19.4-1
                    plasma-workspace             5.19.3-2             5.19.4-1
         plasma-workspace-wallpapers             5.19.3-1             5.19.4-1
                    polkit-kde-agent             5.19.3-1             5.19.4-1
                             postfix              3.5.5-1              3.5.6-1
                          powerdevil             5.19.3-1             5.19.4-1
                              python              3.8.3-1              3.8.5-1
                   python-asn1crypto              1.3.0-1              1.4.0-1
                         python-cffi             1.14.0-3             1.14.1-1
                 python-cryptography              2.9.2-1                3.0-1
                  python-ordered-set              3.1.1-2              4.0.2-1
                        python-tests              3.8.3-1              3.8.5-1
                  python2-asn1crypto              1.3.0-1              1.4.0-1
                        python2-cffi             1.14.0-3             1.14.1-1
                python2-cryptography              2.9.2-1                3.0-1
                       qalculate-gtk             3.11.0-1             3.12.0-1
                                 qca              2.3.1-1              2.3.1-2
                        quadrapassel            3.36.02-1            3.36.04-1
                                 re2         1:20200706-1         1:20200801-1
                              recode              3.7.6-2              3.7.7-1
                        rpcsvc-proto              1.4.1-1              1.4.2-1
                                rust           1:1.45.0-2           1:1.45.1-1
                           rust-docs           1:1.45.0-2           1:1.45.1-1
                            sddm-kcm             5.19.3-1             5.19.4-1
                              spglib             1.15.1-1             1.16.0-1
                      systemsettings             5.19.3-1             5.19.4-1
                                 tbb             2020.2-1             2020.3-1
                         thunderbird            68.10.0-1            68.11.0-1
                 thunderbird-i18n-ar            68.10.0-1            68.11.0-1
                thunderbird-i18n-ast            68.10.0-1            68.11.0-1
                 thunderbird-i18n-be            68.10.0-1            68.11.0-1
                 thunderbird-i18n-bg            68.10.0-1            68.11.0-1
                 thunderbird-i18n-br            68.10.0-1            68.11.0-1
                 thunderbird-i18n-ca            68.10.0-1            68.11.0-1
                 thunderbird-i18n-cs            68.10.0-1            68.11.0-1
                 thunderbird-i18n-cy            68.10.0-1            68.11.0-1
                 thunderbird-i18n-da            68.10.0-1            68.11.0-1
                 thunderbird-i18n-de            68.10.0-1            68.11.0-1
                thunderbird-i18n-dsb            68.10.0-1            68.11.0-1
                 thunderbird-i18n-el            68.10.0-1            68.11.0-1
              thunderbird-i18n-en-gb            68.10.0-1            68.11.0-1
              thunderbird-i18n-en-us            68.10.0-1            68.11.0-1
              thunderbird-i18n-es-ar            68.10.0-1            68.11.0-1
              thunderbird-i18n-es-es            68.10.0-1            68.11.0-1
                 thunderbird-i18n-et            68.10.0-1            68.11.0-1
                 thunderbird-i18n-eu            68.10.0-1            68.11.0-1
                 thunderbird-i18n-fi            68.10.0-1            68.11.0-1
                 thunderbird-i18n-fr            68.10.0-1            68.11.0-1
              thunderbird-i18n-fy-nl            68.10.0-1            68.11.0-1
              thunderbird-i18n-ga-ie            68.10.0-1            68.11.0-1
                 thunderbird-i18n-gd            68.10.0-1            68.11.0-1
                 thunderbird-i18n-gl            68.10.0-1            68.11.0-1
                 thunderbird-i18n-he            68.10.0-1            68.11.0-1
                 thunderbird-i18n-hr            68.10.0-1            68.11.0-1
                thunderbird-i18n-hsb            68.10.0-1            68.11.0-1
                 thunderbird-i18n-hu            68.10.0-1            68.11.0-1
              thunderbird-i18n-hy-am            68.10.0-1            68.11.0-1
                 thunderbird-i18n-id            68.10.0-1            68.11.0-1
                 thunderbird-i18n-is            68.10.0-1            68.11.0-1
                 thunderbird-i18n-it            68.10.0-1            68.11.0-1
                 thunderbird-i18n-ja            68.10.0-1            68.11.0-1
                 thunderbird-i18n-ko            68.10.0-1            68.11.0-1
                 thunderbird-i18n-lt            68.10.0-1            68.11.0-1
              thunderbird-i18n-nb-no            68.10.0-1            68.11.0-1
                 thunderbird-i18n-nl            68.10.0-1            68.11.0-1
              thunderbird-i18n-nn-no            68.10.0-1            68.11.0-1
                 thunderbird-i18n-pl            68.10.0-1            68.11.0-1
              thunderbird-i18n-pt-br            68.10.0-1            68.11.0-1
              thunderbird-i18n-pt-pt            68.10.0-1            68.11.0-1
                 thunderbird-i18n-rm            68.10.0-1            68.11.0-1
                 thunderbird-i18n-ro            68.10.0-1            68.11.0-1
                 thunderbird-i18n-ru            68.10.0-1            68.11.0-1
                 thunderbird-i18n-si            68.10.0-1            68.11.0-1
                 thunderbird-i18n-sk            68.10.0-1            68.11.0-1
                 thunderbird-i18n-sl            68.10.0-1            68.11.0-1
                 thunderbird-i18n-sq            68.10.0-1            68.11.0-1
                 thunderbird-i18n-sr            68.10.0-1            68.11.0-1
              thunderbird-i18n-sv-se            68.10.0-1            68.11.0-1
                 thunderbird-i18n-tr            68.10.0-1            68.11.0-1
                 thunderbird-i18n-uk            68.10.0-1            68.11.0-1
                 thunderbird-i18n-vi            68.10.0-1            68.11.0-1
              thunderbird-i18n-zh-cn            68.10.0-1            68.11.0-1
              thunderbird-i18n-zh-tw            68.10.0-1            68.11.0-1
                        user-manager             5.19.3-1             5.19.4-1
                                vala             0.48.7-1             0.48.8-1
                  vulkan-mesa-layers             20.1.4-1             20.1.4-3
                       vulkan-radeon             20.1.4-1             20.1.4-3
            vulkan-validation-layers            1.2.146-1            1.2.146-2
                          webkit2gtk             2.28.3-1             2.28.4-1
                      wireguard-dkms       1.0.20200712-1       1.0.20200729-1
              xdg-desktop-portal-kde             5.19.3-1             5.19.4-1
                               xfwm4             4.14.3-1             4.14.4-1
                         xorg-server             1.20.8-2             1.20.8-3
                  xorg-server-common             1.20.8-2             1.20.8-3
                   xorg-server-devel             1.20.8-2             1.20.8-3
                  xorg-server-xephyr             1.20.8-2             1.20.8-3
                   xorg-server-xnest             1.20.8-2             1.20.8-3
                    xorg-server-xvfb             1.20.8-2             1.20.8-3
                xorg-server-xwayland             1.20.8-2             1.20.8-3
                              zenity 3.32.0+17+gfb0938f-3 3.32.0+50+gc229637-1
                           zxing-cpp              1.0.8-1              1.1.0-1

Testers needed on arm-testing branch
We are in need of testers for our arm-testing and arm-unstable branches.
So if you are adventurous and want newer software quicker, we would love for you to help us test out the new packages in arm-testing branch.

All you have to do to switch to this branch is:

  • Edit /etc/pacman-mirrors.conf and change Branch = arm-stable to Branch = arm-testing.
  • Run this command: sudo pacman-mirrors -f5 && sudo pacman -Syyu. This will generate a new mirrorlist for you, sync your databases with the new mirror and update your system using the arm-testing branch.

We would then love for you to give feedback in our update posts in #manjaro-arm:arm-testing-updates. That way we can better find and fix bugs, before they hit arm-stable branch. Thank you!


  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

1 Like

Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

Old Issues

Plasma Mobile Keyboard
The plasma mobile onscreen keyboard does not work with QT 5.15.0.
This is fixed by updating to kwin 5.19.3-1.1.

PinePhone uboot
This update to the PinePhone Uboot package (2020.04-2), changed how the DTS is loaded from the kernel, since the Kernel DTS for the Pinephone also changed. When doing this update on the PinePhone images from Alpha5 and back, please make this change to the /boot/extlinux/extlinux.conf before rebooting:

  • sun50i-a64-pinephone.dtb to sun50i-a64-pinephone-1.2.dtb
  • root=LABEL=ROOT to root=LABEL=ROOT_MNJRO

Manual interventions:
The nss and zn_poly packages prior to version 3.51.1-1 and version 0.9.2-2 respectively, were missing a soname link each. This has been fixed in 3.51.1-1 and 0.9.2-2 of these packages, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

nss: /usr/lib/p11-kit-trust.so exists in filesystem
zn_poly: /usr/lib/libzn_poly-0.9.so  exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/p11-kit-trust.so --overwrite /usr/lib/libzn_poly-0.9.so

to perform the upgrade.

Device stopped booting after Uboot update
The uboot update included a change to the extlinux.conf file. This change will be incompatible with the old 1 partition layout of some devices.
So if you are updating installs made with images 20.02.1 or older, you need to apply this fix before rebooting!
To fix this please edit your /boot/extlinux/extlinux.conf file and add 2 periods in front of each first slash, like so:

KERNEL ../Image
FDT ../dtbs/ #etc.
APPEND initrd=../initramfs-linux.img #etc.

Save the file and reboot.

Hi,

/*
Congratulations


*/

Odroid c4 up to date

before the update

[nlc4@c4 ~]$ screenfetch
                             nlc4@c4.test.2020.05.14
                             OS: Manjaro-ARM 20.07
                             Kernel: aarch64 Linux 5.7.10-2-MANJARO-ARM
         #####               Uptime: 23h 11m
        #######              Packages: Unknown
        ##O#O##              Shell: bash 5.0.17
        #######              Resolution: 1920x1080
      ###########            DE: KDE 5.72.0 / Plasma 5.19.3
     #############           WM: KWin
    ###############          GTK Theme: Breeze [GTK2/3]
    ################         Icon Theme: oxygen
   #################         Disk: 258G / 991G (27%)
 #####################       CPU: Unknown @ 4x 1.908GHz
 #####################       GPU: 
   #################         RAM: 781MiB / 3628MiB
                            
                            
                            
[nlc4@c4 ~]$ date -u
dim. 02 août 2020 03:57:57 UTC
[nlc4@c4 ~]$ uname -a
Linux c4.test.2020.05.14 5.7.10-2-MANJARO-ARM #1 SMP Sun Jul 26 19:23:54 CEST 2020 aarch64 GNU/Linux
[nlc4@c4 ~]$ sudo pacman -Syyuu
[sudo] password for nlc4: 
:: Synchronising package databases...
 core                                    218,1 KiB  2,13 MiB/s 00:00 [######################################] 100%
 extra                                     2,4 MiB  2,06 MiB/s 00:01 [######################################] 100%
 community                                 5,2 MiB  2,05 MiB/s 00:03 [######################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (57) ark-20.04.3-2  bluedevil-1:5.19.4-1  breeze-5.19.4-1  breeze-gtk-5.19.4-1
              ca-certificates-20181109-4  ca-certificates-mozilla-3.55-2  ca-certificates-utils-20181109-4
              drkonqi-5.19.4-1  git-2.28.0-1  json-c-0.15-1  kactivitymanagerd-5.19.4-1  kde-cli-tools-5.19.4-1
              kde-gtk-config-5.19.4-1  kdecoration-5.19.4-1  kinfocenter-5.19.4-1  kmenuedit-5.19.4-1
              knetattach-5.19.4-1  kscreen-5.19.4-1  kscreenlocker-5.19.4-1  ksysguard-5.19.4-1
              kwallet-pam-5.19.4-1  kwayland-integration-5.19.4-1  kwayland-server-5.19.4-2  kwin-5.19.4-1
              libkscreen-5.19.4-1  libksysguard-5.19.4-1  libqalculate-3.12.0-1  libteam-1.31-1  libx11-1.6.10-1
              linux-aarch64-5.7.12-1  mesa-20.1.4-3  milou-5.19.4-1  nano-5.0-1  nspr-4.27-1  nss-3.55-2
              oxygen-5.19.4-1  plasma-desktop-5.19.4-1  plasma-integration-5.19.4-1  plasma-nm-5.19.4-1
              plasma-pa-5.19.4-1  plasma-vault-5.19.4-1  plasma-workspace-5.19.4-1  polkit-kde-agent-5.19.4-1
              powerdevil-5.19.4-1  python-3.8.5-1  python-ordered-set-4.0.2-1  qca-2.3.1-2  re2-1:20200801-1
              sddm-kcm-5.19.4-1  systemd-245.7-1  systemd-libs-245.7-1  systemd-sysvcompat-245.7-1
              systemsettings-5.19.4-1  tbb-2020.3-1  user-manager-5.19.4-1  xorg-server-1.20.8-3
              xorg-server-common-1.20.8-3

Total Download Size:   183,53 MiB
Total Installed Size:  551,44 MiB
Net Upgrade Size:        1,23 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 systemd-libs-245.7-1-aarch64            459,1 KiB  2,13 MiB/s 00:00 [######################################] 100%
 ca-certificates-utils-20181109-4-any      7,9 KiB  0,00   B/s 00:00 [######################################] 100%
 ca-certificates-mozilla-3.55-2-aarch64  322,5 KiB  2,10 MiB/s 00:00 [######################################] 100%
 ca-certificates-20181109-4-any            2,1 KiB  0,00   B/s 00:00 [######################################] 100%
 json-c-0.15-1-aarch64                    50,6 KiB  2,47 MiB/s 00:00 [######################################] 100%
 systemd-245.7-1-aarch64                   5,0 MiB  2,05 MiB/s 00:02 [######################################] 100%
 nspr-4.27-1-aarch64                     184,2 KiB  2047 KiB/s 00:00 [######################################] 100%
 nss-3.55-2-aarch64                     1409,8 KiB  2,05 MiB/s 00:01 [######################################] 100%
 linux-aarch64-5.7.12-1-aarch64           69,1 MiB  2,01 MiB/s 00:34 [######################################] 100%
 nano-5.0-1-aarch64                      492,2 KiB  2,09 MiB/s 00:00 [######################################] 100%
 systemd-sysvcompat-245.7-1-aarch64        8,0 KiB  0,00   B/s 00:00 [######################################] 100%
 libx11-1.6.10-1-aarch64                2018,6 KiB  2,05 MiB/s 00:01 [######################################] 100%
 mesa-20.1.4-3-aarch64                    13,6 MiB  2,04 MiB/s 00:07 [######################################] 100%
 python-3.8.5-1-aarch64                   10,5 MiB  2,04 MiB/s 00:05 [######################################] 100%
 ark-20.04.3-2-aarch64                  1208,6 KiB  2,07 MiB/s 00:01 [######################################] 100%
 bluedevil-1:5.19.4-1-aarch64            328,1 KiB  2,14 MiB/s 00:00 [######################################] 100%
 kdecoration-5.19.4-1-aarch64             64,4 KiB  3,15 MiB/s 00:00 [######################################] 100%
 breeze-5.19.4-1-aarch64                  19,9 MiB  2,04 MiB/s 00:10 [######################################] 100%
 breeze-gtk-5.19.4-1-any                 254,6 KiB  2,07 MiB/s 00:00 [######################################] 100%
 drkonqi-5.19.4-1-aarch64                693,5 KiB  1926 KiB/s 00:00 [######################################] 100%
 git-2.28.0-1-aarch64                      6,1 MiB  2,05 MiB/s 00:03 [######################################] 100%
 kactivitymanagerd-5.19.4-1-aarch64      169,4 KiB  2,36 MiB/s 00:00 [######################################] 100%
 kde-cli-tools-5.19.4-1-aarch64          861,2 KiB  2,10 MiB/s 00:00 [######################################] 100%
 kde-gtk-config-5.19.4-1-aarch64          50,7 KiB  4,95 MiB/s 00:00 [######################################] 100%
 kinfocenter-5.19.4-1-aarch64           1483,7 KiB  2,07 MiB/s 00:01 [######################################] 100%
 kmenuedit-5.19.4-1-aarch64             1016,5 KiB  2,07 MiB/s 00:00 [######################################] 100%
 knetattach-5.19.4-1-aarch64              24,0 KiB  2,34 MiB/s 00:00 [######################################] 100%
 libkscreen-5.19.4-1-aarch64             378,2 KiB  2,05 MiB/s 00:00 [######################################] 100%
 kscreen-5.19.4-1-aarch64                220,4 KiB  2,39 MiB/s 00:00 [######################################] 100%
 kscreenlocker-5.19.4-1-aarch64          183,6 KiB  2,56 MiB/s 00:00 [######################################] 100%
 re2-1:20200801-1-aarch64                152,2 KiB  2,12 MiB/s 00:00 [######################################] 100%
 libksysguard-5.19.4-1-aarch64           796,2 KiB  2,05 MiB/s 00:00 [######################################] 100%
 ksysguard-5.19.4-1-aarch64              757,1 KiB  2,11 MiB/s 00:00 [######################################] 100%
 kwallet-pam-5.19.4-1-aarch64             11,4 KiB  0,00   B/s 00:00 [######################################] 100%
 kwayland-integration-5.19.4-1-aarch64    27,1 KiB  2,65 MiB/s 00:00 [######################################] 100%
 kwayland-server-5.19.4-2-aarch64       1108,0 KiB  2,08 MiB/s 00:01 [######################################] 100%
 kwin-5.19.4-1-aarch64                     6,1 MiB  2,01 MiB/s 00:03 [######################################] 100%
 libqalculate-3.12.0-1-aarch64          1600,1 KiB  2,06 MiB/s 00:01 [######################################] 100%
 libteam-1.31-1-aarch64                  226,3 KiB  2,21 MiB/s 00:00 [######################################] 100%
 milou-5.19.4-1-aarch64                   89,6 KiB  2,19 MiB/s 00:00 [######################################] 100%
 oxygen-5.19.4-1-aarch64                   4,4 MiB  2,05 MiB/s 00:02 [######################################] 100%
 polkit-kde-agent-5.19.4-1-aarch64        55,5 KiB  2,71 MiB/s 00:00 [######################################] 100%
 plasma-integration-5.19.4-1-aarch64     124,1 KiB  2,42 MiB/s 00:00 [######################################] 100%
 plasma-workspace-5.19.4-1-aarch64         7,0 MiB  2,03 MiB/s 00:03 [######################################] 100%
 systemsettings-5.19.4-1-aarch64         311,1 KiB  2,17 MiB/s 00:00 [######################################] 100%
 plasma-desktop-5.19.4-1-aarch64          10,9 MiB  2,04 MiB/s 00:05 [######################################] 100%
 qca-2.3.1-2-aarch64                     679,3 KiB  2,07 MiB/s 00:00 [######################################] 100%
 plasma-nm-5.19.4-1-aarch64             1270,0 KiB  2,07 MiB/s 00:01 [######################################] 100%
 plasma-pa-5.19.4-1-aarch64              204,5 KiB  2,22 MiB/s 00:00 [######################################] 100%
 plasma-vault-5.19.4-1-aarch64           279,3 KiB  2,10 MiB/s 00:00 [######################################] 100%
 powerdevil-5.19.4-1-aarch64             792,7 KiB  2,09 MiB/s 00:00 [######################################] 100%
 python-ordered-set-4.0.2-1-any           13,0 KiB  0,00   B/s 00:00 [######################################] 100%
 xorg-server-common-1.20.8-3-aarch64      26,7 KiB  0,00   B/s 00:00 [######################################] 100%
 xorg-server-1.20.8-3-aarch64           1183,2 KiB  2,10 MiB/s 00:01 [######################################] 100%
 sddm-kcm-5.19.4-1-aarch64               100,5 KiB  2010 KiB/s 00:00 [######################################] 100%
 tbb-2020.3-1-aarch64                    354,0 KiB  2,16 MiB/s 00:00 [######################################] 100%
 user-manager-5.19.4-1-aarch64             9,4 MiB  2,05 MiB/s 00:05 [######################################] 100%
(57/57) checking keys in keyring                                     [######################################] 100%
(57/57) checking package integrity                                   [######################################] 100%
(57/57) loading package files                                        [######################################] 100%
(57/57) checking for file conflicts                                  [######################################] 100%
(57/57) checking available disk space                                [######################################] 100%
:: Processing package changes...
( 1/57) upgrading systemd-libs                                       [######################################] 100%
( 2/57) upgrading ca-certificates-utils                              [######################################] 100%
( 3/57) upgrading ca-certificates-mozilla                            [######################################] 100%
( 4/57) upgrading ca-certificates                                    [######################################] 100%
( 5/57) upgrading libx11                                             [######################################] 100%
( 6/57) upgrading mesa                                               [######################################] 100%
( 7/57) upgrading json-c                                             [######################################] 100%
( 8/57) upgrading systemd                                            [######################################] 100%
( 9/57) upgrading python                                             [######################################] 100%
(10/57) upgrading nspr                                               [######################################] 100%
(11/57) upgrading nss                                                [######################################] 100%
(12/57) upgrading ark                                                [######################################] 100%
(13/57) upgrading bluedevil                                          [######################################] 100%
(14/57) upgrading kdecoration                                        [######################################] 100%
(15/57) upgrading breeze                                             [######################################] 100%
(16/57) upgrading breeze-gtk                                         [######################################] 100%
(17/57) upgrading drkonqi                                            [######################################] 100%
(18/57) upgrading git                                                [######################################] 100%
(19/57) upgrading kactivitymanagerd                                  [######################################] 100%
(20/57) upgrading kde-cli-tools                                      [######################################] 100%
(21/57) upgrading kde-gtk-config                                     [######################################] 100%
(22/57) upgrading kinfocenter                                        [######################################] 100%
(23/57) upgrading kmenuedit                                          [######################################] 100%
(24/57) upgrading knetattach                                         [######################################] 100%
(25/57) upgrading libkscreen                                         [######################################] 100%
(26/57) upgrading kscreen                                            [######################################] 100%
(27/57) upgrading kscreenlocker                                      [######################################] 100%
(28/57) upgrading re2                                                [######################################] 100%
(29/57) upgrading libksysguard                                       [######################################] 100%
(30/57) upgrading ksysguard                                          [######################################] 100%
(31/57) upgrading kwallet-pam                                        [######################################] 100%
(32/57) upgrading kwayland-integration                               [######################################] 100%
(33/57) upgrading kwayland-server                                    [######################################] 100%
(34/57) upgrading kwin                                               [######################################] 100%
(35/57) upgrading libqalculate                                       [######################################] 100%
(36/57) upgrading libteam                                            [######################################] 100%
(37/57) upgrading linux-aarch64                                      [######################################] 100%
(38/57) upgrading milou                                              [######################################] 100%
(39/57) upgrading nano                                               [######################################] 100%
(40/57) upgrading oxygen                                             [######################################] 100%
(41/57) upgrading polkit-kde-agent                                   [######################################] 100%
(42/57) upgrading plasma-integration                                 [######################################] 100%
(43/57) upgrading plasma-workspace                                   [######################################] 100%
(44/57) upgrading systemsettings                                     [######################################] 100%
(45/57) upgrading plasma-desktop                                     [######################################] 100%
(46/57) upgrading qca                                                [######################################] 100%
(47/57) upgrading plasma-nm                                          [######################################] 100%
(48/57) upgrading plasma-pa                                          [######################################] 100%
(49/57) upgrading plasma-vault                                       [######################################] 100%
(50/57) upgrading powerdevil                                         [######################################] 100%
(51/57) upgrading python-ordered-set                                 [######################################] 100%
(52/57) upgrading xorg-server-common                                 [######################################] 100%
(53/57) upgrading xorg-server                                        [######################################] 100%
(54/57) upgrading sddm-kcm                                           [######################################] 100%
(55/57) upgrading systemd-sysvcompat                                 [######################################] 100%
(56/57) upgrading tbb                                                [######################################] 100%
(57/57) upgrading user-manager                                       [######################################] 100%
:: Running post-transaction hooks...
( 1/19) Creating system user accounts...
( 2/19) Updating journal message catalog...
( 3/19) Reloading system manager configuration...
( 4/19) Updating udev hardware database...
( 5/19) Applying kernel sysctl settings...
( 6/19) Creating temporary files...
( 7/19) Reloading device manager configuration...
( 8/19) Arming ConditionNeedsUpdate...
( 9/19) Rebuilding certificate stores...
(10/19) Updating module dependencies...
(11/19) Updating linux-aarch64 module dependencies...
(12/19) Updating linux-aarch64 initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux-aarch64.preset: 'default'
  -> -k 5.7.12-1-MANJARO-ARM -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 5.7.12-1-MANJARO-ARM
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
(13/19) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux-aarch64.preset: 'default'
  -> -k 5.7.12-1-MANJARO-ARM -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 5.7.12-1-MANJARO-ARM
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
(14/19) Updating uimg initcpios...
Image Name:   Ramdisk Image
Created:      Sun Aug  2 06:02:46 2020
Image Type:   AArch64 Linux RAMDisk Image (uncompressed)
Data Size:    7865105 Bytes = 7680.77 KiB = 7.50 MiB
Load Address: 00000000
Entry Point:  00000000
(15/19) Reloading system bus configuration...
(16/19) Updating icon theme caches...
(17/19) Updating the info directory file...
(18/19) Updating the desktop file MIME type cache...
(19/19) Updating the MIME type database...
[nlc4@c4 ~]$

after the update

[nlc4@c4 ~]$ screenfetch
                             nlc4@c4.test.2020.05.14
                             OS: Manjaro-ARM 20.07
                             Kernel: aarch64 Linux 5.7.12-1-MANJARO-ARM
         #####               Uptime: 2m
        #######              Packages: Unknown
        ##O#O##              Shell: bash 5.0.17
        #######              Resolution: 1920x1080
      ###########            DE: KDE 5.72.0 / Plasma 5.19.4
     #############           WM: KWin
    ###############          GTK Theme: Breeze [GTK2/3]
    ################         Icon Theme: oxygen
   #################         Disk: 258G / 991G (27%)
 #####################       CPU: Unknown @ 4x 1.908GHz
 #####################       GPU: 
   #################         RAM: 703MiB / 3628MiB
                            
                            
                            
[nlc4@c4 ~]$ date -u
dim. 02 août 2020 04:08:42 UTC
[nlc4@c4 ~]$ uname -a
Linux c4.test.2020.05.14 5.7.12-1-MANJARO-ARM #1 SMP Fri Jul 31 19:38:24 CEST 2020 aarch64 GNU/Linux
[nlc4@c4 ~]$

Enjoy!

1 Like

Upgrade ok.
I have to problems since Plasma installation on Rpi4
first I set up samba and since then kdewallet asks for password after login. Edit not samba it is wifi connection
second why firefox has two bars?
Screenshot_20200802_084715

You can remove the gtk3-nocsd package and reboot to get rid of one of them.

1 Like

Password pop up solved. I forgot that plasma needs to be setup on at least two places for one function. :slight_smile:
When one wants to connect to WiFi just password is not enough, full setting is needed to be done unlike other DE.

Updating Uboot caused Pinebook Pro to not boot (black screen). Fixed by reverting the extlinux.conf file. Looking at it, I'm not sure why this update created the .pacnew version.

$ sudo diff /boot/extlinux/extlinux.conf /boot/extlinux/extlinux.conf.pacnew                                                                                                                                         
[sudo] password for yosuke: 
4c4
< APPEND initrd=/initramfs-linux.img console=tty1 console=ttyS2,1500000 root=LABEL=ROOT_MNJRO rw rootwait video=eDP-1:1920x1080@60 video=HDMI-A-1:1920x1080@60 bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash
---
> APPEND initrd=/initramfs-linux.img console=tty1 console=ttyS2,1500000 root=LABEL=ROOT rw rootwait bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash

Hm. I'm not sure why it did that though.
When a file mentioned in the backup() array, gets changed from the default package, it should not get overwritten, but be created as a .pacnew file. It's then up to you (the user) to make it correct. Are you saying, that is not what happened?

everything fine on my pbp!

The installer did everything correctly. It did not overwrite anything. This was user error on my part. I was the one who manually overwrote it.

What do you mean by this exactly? How does one “make it correct”? Or is it safe to just ignore pacnew files?

Ah okay. Good to know. :wink:

I mean, it's up to the user to "merge" the two files into one. :slight_smile:
Pacnew files can often be ignored, if the system boots and works, but if it doesn't, because the software now expects a new syntax or something, then they need to be merged.

1 Like

Thanks again for updating wayfire-git :smiley:

1 Like

Forum kindly sponsored by