[ARM Stable Update] 2022-05-06 - Firefox 100, Plasma 5.24.5, Gnome 42 and Kernels

Hello ARM community.

Pretty big update this time. Plasma and Firefox 100!

A big milestone for the leading open source browser!

Some highlights:

  • Most of our kernels got updated
  • Firefox updated to 100.0
  • Plasma got a new point release with 5.24.5
  • Gnome updated 42.1
  • Plasma Mobile Gear updated to 22.04
  • Lots of updated packages for our Mobile offerings
  • The regular Python updates
  • And regular updates from upstream

How to get Waydroid working

If you follow these steps, you should have Waydroid working fine.

Remember, Waydroid only works on wayland!

  • Install waydroid-image and all it’s dependencies.
  • Run pkexec setup-waydroid.
  • You should now be able to launch Waydroid. The first launch takes a while.
How to use Kodi RPI on Manjaro ARM

If anyone wants to test kodi on the rpi, install these packages:

sudo pacman -S kodi-rpi kodi-rpi-dev kodi-rpi-eventclients kodi-rpi-tools-texturepacker libcec-rpi linux-rpi4 xf86-video-fbdev

Have it set up is to boot straight in to kodi

This means the kodi.service file need to replace whatever login manager you have installed. In my case I would:

sudo systemctl disable lightdm.service
sudo systemctl enable kodi.service

They recommend removing custom configs in config.txt. We ran into an issue if a value was set with gpu_mem=.

My config.txt with a bit of overclocking:

#gpu_mem=64     #disable this
initramfs initramfs-linux.img followkernel

#enable sound

#enable vc4
#max_framebuffers=2    #disable cause kodi uses more

Some notes:

The default user will be kodi
kodi home directory will be /var/lib/kodi
So put test video in /var/lib/kodi/Videos so you can get to it
after setting up the video directory in kodi.

Upstream Notifications:

Older notifications

If you used the Manjaro ARM Installer or is using PinePhone or PineTab, you need to redo your passwords, because of an update to libxcrypt:
Arch Linux - News: Sorting out old password hashes

Chromium will loose sync support in early March:
Arch Linux - News: Chromium losing Sync support in early March

ghostpcl>=9.53.2-2 and ghostxps>=9.53.2-2 updates require manual intervention:
Arch Linux - News: ghostpcl>=9.53.2-2 and ghostxps>=9.53.2-2 updates require manual intervention

The nss and zn_poly packages requires manual intervention:
Arch Linux - News: nss>=3.51.1-1 and lib32-nss>=3.51.1-1 updates require manual intervention
Arch Linux - News: zn_poly 0.9.2-2 update requires manual intervention

The packages hplip and firewalld requires manual intervention:
Arch Linux - News: hplip 3.20.3-2 update requires manual intervention
Arch Linux - News: firewalld>=0.8.1-2 update requires manual intervention

Package changes:

(Fri May 6 22:01:14 CEST 2022)

  • arm-stable community aarch64: 1494 new and 1406 removed package(s)
  • arm-stable core aarch64: 115 new and 113 removed package(s)
  • arm-stable extra aarch64: 1099 new and 1092 removed package(s)
  • arm-stable kde-unstable aarch64: 423 new and 422 removed package(s)

See the full package list here

Testers needed on arm-testing branch

We are in need of testers for our arm-testing and arm-unstable branches.
So if you are adventurous and want newer software quicker, we would love for you to help us test out the new packages in arm-testing branch.

All you have to do to switch to this branch is:

  • Run this command to switch branch: sudo pacman-mirrors -aS testing && sudo pacman -Syyu. This will generate a new mirrorlist for you, sync your databases with the new mirror and update your system using the arm-testing branch.

We would then love for you to give feedback in our update posts in #manjaro-arm:arm-testing-updates. That way we can better find and fix bugs, before they hit arm-stable branch. Thank you!


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

Waydroid container cannot access internet

Cause: new default waydroid configuration issue, tracked here.

Short-term Solution:

  1. create /etc/nftables.d/waydroid.nft with the following contents:
#!/usr/sbin/nft -f
table inet filter {
    chain input {
        iifname "waydroid0" accept comment "Allow incoming network traffic from WayDroid"
    chain forward {
        iifname "waydroid0" accept comment "Allow outgoing network traffic from WayDroid"
        ct state {established, related} counter accept comment "accept established connections"
  1. any time you launch waydroid, run the following after it has started:
echo "ip route add default via" |sudo waydroid shell
Old Issues
Plasma Dialer cannot answer calls

Sadly Plasma Dialer 22.02 has a serious regression with no known workaround. It’s not possible to accept incoming calls. Very sorry about this. Follow the upstream bug report. We will patch the package as soon as a solution is found.

Plasma Mobile - Black screen after update

We are seeing some reports about Plasma Mobile on the PinePhone only showing a black screen after entering the PIN after this update.
Workaround: Downgrade qt5-es2-wayland to 5.15.2+kde+r41 which is now back in Stable and Testing branch repositories.

New Breath theme not applying correctly

With the update to the new Breath theme, a migration package tries to apply the new theme correctly.
However this is not getting done for Plasma’s Lockscreen and the SDDM theme.
So please go through your settings after updating to make sure the themes are correctly applied.
Fix: manjaro-system should take care of this for you.

Plasma Mobile switch to ModemManager

With the PlaMo Gear 21.12 release, Plasma Mobile is now using ModemManager as the telephony stack. So in order to use SIM capabilities, you need to switch from using oFono to ModemManager.
Fix: Run sudo systemctl disable --now ofono ofonoctl && sudo systemctl enable --now ModemManager. You might have to reboot your phone for Plasma Mobile to pick up this change.

Plasma Mobile has does not launch after update
This was caused by an error in kwin 5.23.2 which only affects installs based on openGLES (qt5-es2).
Fix: Update to kwin 5.23.2-1.2 or above.

No ethernet on rk3399 boards
A recent kernel regression has resulted in built in ethernet on rk3399 based boards, such as RockPro64 and Rock Pi 4’s, no longer works on kernel 5.14. This is an upstream issue that has not been fixed yet.
Fix: Update to linux-5.14.1-2 or newer.

Vivaldi no longer working
The issue is present in all chrome based browser (except Chromium that got a patch for it).
It’s an issue with systemd-resolved and has been reported in the Arch Linux Bug Tracker.
Needs to be fixed by Vivaldi updates in the future.
Fix: Vivaldi 4.1.2369.21 fixed this issue.

Modemmanager-pp dependency issue
modemmanager-pp 1.16.10 depends on libqmi-pp and libmbim-pp, but they are no longer found in the repo.
Fixed by updated to modemmanager-pp 1.18rc1+2+ga20f2c05-2.

systemd-hook unsuccesful after pacman 6 update
After the pacman 6 update, updates will create this message in the post-transation hooks part:

Running the command manually works and there has been no issues reported as the result of this. This will either get fixed at some point in Pacman or SystemD.
Should be fixed with pacman-6.0.0-4

Keyring issues
If you have some gpg keyring issues, you can run sudo systemctl start pacman-init.service which will regenerate your keyring. Will take a few minutes to complete.
Should be fixed with manjaro-system-20210716-1

Plasma Mobile no longer boots
The current update to qt5-es2-base results in Plasma Mobile no longer booting, showing a screen that says to run a loginctl command to login.
Fixed by updating to qt5-es2-base-5.15.2+kde+r199-3.1 and qt5-es2-declarative-5.15.2+kde+r28-3.1.

Kwin crashes on startup on Pinebook Pro
This seems to be related to Mesa 20.3 and the Pinebook Pro support in kernel 5.10, as this does not seem to happen on other devices.
It does not impact 3d performance as far as I can tell. Just the OpenGL compositing in Kwin.
Fixed with mesa 20.3.2-2.

My VPN no longer connects
OpenVPN 2.5.0 changed how VPN routes work.
Workaround is to downgrade to previous version (2.4.9):

sudo pacman -U /var/cache/pacman/pkg/openvpn-2.4.9*

DP Alt Mode no longer works on Pinebook Pro
This is a known issue, the hacky patch we had to enable this has broken in recent kernels.
@tsys and Ayufan are looking into it.
As a workaround you can install linux-pinebookpro again.
FIXED with linux-5.9.12-4 and linux-rc-5.10-rc7-2 and above.

brcm-patchram-plus and pi-blueooth are in conflict
See this post for workaround:
[ARM Testing Update] 2020-11-16 - Bitwarden, Mesa-Git, Pacman and kernels - #10 by Darksky

Plasma Mobile Keyboard
The plasma mobile onscreen keyboard does not work with QT 5.15.0.
This is fixed by updating to kwin 5.19.3-1.1.

PinePhone uboot
This update to the PinePhone Uboot package (2020.04-2), changed how the DTS is loaded from the kernel, since the Kernel DTS for the Pinephone also changed. When doing this update on the PinePhone images from Alpha5 and back, please make this change to the /boot/extlinux/extlinux.conf before rebooting:

  • sun50i-a64-pinephone.dtb to sun50i-a64-pinephone-1.2.dtb

Manual interventions:
The nss and zn_poly packages prior to version 3.51.1-1 and version 0.9.2-2 respectively, were missing a soname link each. This has been fixed in 3.51.1-1 and 0.9.2-2 of these packages, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

nss: /usr/lib/p11-kit-trust.so exists in filesystem
zn_poly: /usr/lib/libzn_poly-0.9.so  exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/p11-kit-trust.so --overwrite /usr/lib/libzn_poly-0.9.so

to perform the upgrade.

Device stopped booting after Uboot update
The uboot update included a change to the extlinux.conf file. This change will be incompatible with the old 1 partition layout of some devices.
So if you are updating installs made with images 20.02.1 or older, you need to apply this fix before rebooting!
To fix this please edit your /boot/extlinux/extlinux.conf file and add 2 periods in front of each first slash, like so:

KERNEL ../Image
FDT ../dtbs/ #etc.
APPEND initrd=../initramfs-linux.img #etc.

Save the file and reboot.

Is it OK to remove libkipi? Somehow libkipi became AUR package and I tried to update libkipi but it keep asking GPG keys.

If nothing you have installed, depends on it, then yes.

1 Like

Every time I update the system on rpi4, /boot/initramfs-linux.img is built twice:

(12/33) Updating linux-rpi4 module dependencies...
(13/33) Updating linux-rpi4 initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux-rpi4.preset: 'default'
  -> -k 5.15.36-1-MANJARO-ARM-RPI -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 5.15.36-1-MANJARO-ARM-RPI
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [plymouth]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
  -> Running build hook: [lvm2]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
(14/33) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux-rpi4.preset: 'default'
  -> -k 5.15.36-1-MANJARO-ARM-RPI -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 5.15.36-1-MANJARO-ARM-RPI
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [plymouth]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
  -> Running build hook: [lvm2]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful

Is there a way to avoid it?

RPi4 using WiFi. Failure because default eth0 interface is not connected after default 120 second timeout:

$ journalctl -p 3 -b | grep systemd
May 07 10:23:09 pi002.adbuco.com systemd-networkd-wait-online[247]: Timeout occurred while waiting for network connectivity.
May 07 10:23:09 pi002.adbuco.com systemd[1]: Failed to start Wait for Network to be Configured.

See what the invocation line is:

$ grep ExecStart=/usr/lib/systemd/systemd-networkd-wait-online /etc/systemd/system/network-online.target.wants/systemd-networkd-wait-online.service

Specify wait only until any interface to becomes online:

$ sudo sed -i 's\ExecStart=/usr/lib/systemd/systemd-networkd-wait-online\ExecStart=/usr/lib/systemd/systemd-networkd-wait-online --any\' /etc/systemd/system/network-online.target.wants/systemd-networkd-wait-online.service

Check edit results:

$ grep ExecStart=/usr/lib/systemd/systemd-networkd-wait-online /etc/systemd/system/network-online.target.wants/systemd-networkd-wait-online.service
ExecStart=/usr/lib/systemd/systemd-networkd-wait-online --any

Reboot and verify fixed.


GT King Pro updated successfully.


Rpi4 running KDE/Wayland. This update bricked my system. I get the Manjaro splash screen with the spinning icon thing, but it never gets past that. Doesn’t look like it manages to start the display manager.

Restored from a backup, which is something I seem to have to do after every other Manjaro update.

Updating libkipip tells me it is not available for AARCH64?

Building libkipi…
==> ERROR: libkipi is not available for the ‘aarch64’ architecture.

Add’aarch64’ to the PKGBUILD:

arch=('x86_64' 'aarch64')
1 Like

I tried again.

This time, instead of using the GUI client (pamac, is it called?) I ran ‘sudo pacman -Syu’. This time the update finished, and now my system boots.

This is the third time in 5 updates that the GUI client has left me with a system that doesn’t boot. I guess that’s a lesson, but I’m not sure who for.

That is interesting. I wondered why you were having so much trouble but I thought it might be KDE related as I run XFCE. I live on the “unstable” branch and never had that issue. I never use the GUI but use pacman -Syu also.

I usually update my Plasma systems via the GUI for these tests and I have had about zero issues like you describe. :frowning:

Thanks. I found the file PKGBUILD in: /var/tmp/pamac-build-rock/libkipi/
I guess where I have rock (in pamac-build-rock), is the user name.

Pamac is prone to freezing or crashing. Now on i always use pacman -Syu for upgrades because it’s reliable.

Well, which GUI client have you used? Are you sure it is Pamac (from Manjaro) and not Discover (from Plasma)? Discover is known to be very broken for system updates on Manjaro at the moment. I have summarized the issues here: Discover system updates still very unreliable.

The update breaks the Timeshift program. New images are no longer reflected after we have created it in the program. After rolling back from updates, everything works fine. There are a lot of conflicts during the upgrade with other packages related to manjaro settings.

Running Manjaro minimal install for RPi4 on RPi3 created on SD card using Manjaro ARM Flasher. Not sure if this update created the problem: Failed to find module ‘pkcs8_key_parser’. Description and fix of removing iwd are in this post:


I wonder if enabling CONFIG_PKCS8_PRIVATE_KEY_PARSER in the kernel would make it work again?