[ARM Stable Update] 2022-02-27 - Plasma 5.24, GCC Toolchain, Firefox 97, Gnome 41.4, PlaMo Gear 22.02 and Kernels

kodi will not boot again.

error while loading shared libraries: libnfs.so.13: cannot open shared object file: No such file or directory

Need a rebuild. Hopefully tomorrow.

Thanks for reporting.

I updated my Rpi few minutes ago, i have a minimal installation without DE, just Kodi on it, the update appears to be fine, Kodi starts as it should.


Would the rebuild of kodi appear on test branch first?

Since the update I have a problem with Gnome Keyring and GOA.
In the logs I see that gnome-keyring-d is interrupted at startup.
I guess GOA doesn’t remember passwords anymore because of this.
In Seahorse the keys appear but the passwords only appear on a few startups.

An extract from the logs

mars 01 11:23:46 pbpro systemd-coredump[2707]: [🡕] Process 607 (gnome-keyring-d) of user 1000 dumped core.
                                               Module linux-vdso.so.1 with build-id 4f9136b827d0b2e9137b7cfb2fb0353898353baa
                                               Module librt.so.1 with build-id c929d8361c460ba82fa61ea1e0b4614df91744d7
                                               Module libblkid.so.1 with build-id 3d4c42385032a4286bad0a93bcc95c0dbae5ce6d
                                               Module libdl.so.2 with build-id 3d5771318379b07f0a5dda7613f76422aa7f6022
                                               Module libgpg-error.so.0 with build-id c21af18f2e32320cae7e1cc42a9e7dfa0f0ca02a
                                               Module libpcre.so.1 with build-id 75dc63d269e8b1acbd020273e4ada841b6217666
                                               Module libffi.so.8 with build-id 428dd8d9167ff2606b2f215c1450679f01c2db7a
                                               Module libresolv.so.2 with build-id 8864dfae5401109dbc3aa93749878536335a00ea
                                               Module libmount.so.1 with build-id e4ed585c555f9294d6fa83ef415b2444ea02cb60
                                               Module libz.so.1 with build-id c556c373ca4ff1466dbd5262e5436463757f8770
                                               Module libgmodule-2.0.so.0 with build-id 1fb0bd99a5ff893507680d4b0d3f1cbe5e17a83a
                                               Module libp11-kit.so.0 with build-id 5c3eefdf311483790b33a8f76dc45a87f6769ecf
                                               Module libc.so.6 with build-id 2858f54ba7c8eae476c62b8631c4feded56e9064
                                               Module libpthread.so.0 with build-id 2d7e5623023dc082483554f4447388c3a48a244b
                                               Module libgcrypt.so.20 with build-id 766e87748c92c8487a2dd42fe4cffc3c053e6036
                                               Module libglib-2.0.so.0 with build-id 9cf3e9a8f2895190b058e69a9610c1d7762c0a4f
                                               Module libgobject-2.0.so.0 with build-id 7a9b754f8a6c982140b9ac07c4813c65ddc1161e
                                               Module libgio-2.0.so.0 with build-id 448d032bfb7bcdc8b99f5204b97930a8586ba80f
                                               Module libgck-1.so.0 with build-id dce61092798b8d83dadd32f1b7a3df7ca89ff5e6
                                               Module libgcr-base-3.so.1 with build-id 56f6d65ea69788731e11dd72a1ea36c7afabef93
                                               Module gnome-keyring-daemon with build-id a7f9d2fce9e0050bfcc77f19163d65d1521ccba5
                                               Stack trace of thread 2704:
                                               #0  0x0000aaaad79153c0 n/a (gnome-keyring-daemon + 0xf53c0)
                                               #1  0x0000aaaad787c640 n/a (gnome-keyring-daemon + 0x5c640)
                                               #2  0x0000ffff7c003e10 n/a (n/a + 0x0)
                                               #3  0x0000ffff7c003e10 n/a (n/a + 0x0)
                                               ELF object binary architecture: AARCH64
mars 01 11:23:46 pbpro systemd[1]: systemd-coredump@0-2706-0.service: Deactivated successfully.

There is an issue with transmission-cli, which has been updated from 3.00-2 to 3.00-3.
It’s not possible to connect to the transmission server from a remote machine, you get “Unauthroized user”.
I downgraded to 3.00-2 version and i no longer have this issue anymore.

You can find a thread on that point on archlinuxarm forum transmission-cli 3.00-3 unauthroized user

1 Like

Thanks for the reminder. Completely forgot.

Will update it now.

thank you so much! It is working with the update now.

Display Settings (Ustawienia Wyświetlania) widget has wrong dimensions:

This is on the Pinebook Pro.


It’s is not display-mode-switcher from AUR:

because it isn’t installed on my system.
The only package with KDE Plasma addons installed in my system is kdeplasma-addons from the official repository extra:

But I don’t remember its English name, so if you know the package name, so I can remove the package, it would be helpful.
But if you just assumed it’s from AUR without knowing the package name, then thank you very much for your time, sir.

This is it:

$ pacman -F /usr/share/plasma/plasmoids/org.kde.kscreen/metadata.json
usr/share/plasma/plasmoids/org.kde.kscreen/metadata.json należy do extra/kscreen 5.24.2-1

It looks the same on the rpi4:

wireplumber 0.4.8 is broken on RPi4.
It is somehow fixed on upstream since compiling it from master branch it works.

1 Like

Unfortunately, when trying to upgrade my PinePhone from the ancient 2021-11-30 stable to this current one, Discover decided to not upgrade glibc! Needless to say, that leads to a very broken system (no Plasma Mobile, no NetworkManager, it’s a miracle I get to a shell with a working pacman at all). Thankfully, I have the USB dock and know how to fix things (plug in a USB keyboard and a USB stick with the missing glibc-2.35-2-aarch64.pkg.tar.xz), but I do not understand why Discover created such a broken state to begin with.

And it is not just glibc: the subsequent pacman -Su that I ran (after fixing glibc with pacman -U /mnt/glibc-2.35-2-aarch64.pkg.tar.xz from USB, which brought NetworkManager back) updates 97 more packages, bringing Plasma Mobile back to life (after reboot).

Autorotate stopped working after the update (and the quick toggle had no effect) because, for some reason, in the display configuration, “Only when in tablet mode” (under “Orientation” / “Automatic”) got checked. Unchecking that option fixed the issue, now autorotate works again (and can be toggled on/off through the quick toggle).

Another issue is that GTK applications (Megapixels, Geary) are not showing most icons anymore. (Some icons do show up for some reason.) I have still not managed to find out why that is. I tried regenerating GTK icon caches in several directories, checking the gdk-pixbuf loaders (the SVG one is installed and found by gdk-pixbuf-query-loaders, the PNG one is apparently supposed to be builtin, I even tried reinstalling gdk-pixbuf2), even setting the GTK icon theme in ~/.gtk-3.0/settings.ini to Adwaita (normally, it is set to breeze with Adwaita as fallback), nothing helped.

UPDATE: Reinstalling adwaita-icon-theme (with sudo pacman -S adwaita-icon-theme) fixed it. I can only guess that the package got corrupted by the partial update that Discover did (see above).

With the above, clearly upgrade-related, issues fixed, I am actually quite happy with this update. The showstoppers that had kept me on the ancient snapshot are fixed: mobile data can be disabled without disabling the entire modem (there is one remaining issue that the state of the toggle does not persist on a reboot, which I am trying to sort out upstream with Devin Lin: Mobile Data always gets reenabled on reboot (#182) · Issues · Plasma / Plasma Mobile · GitLab), Spacebar now properly handles messages from non-numbers such as StadtWien and OE-testet (well, I have not yet verified that receiving them works, I will be able to confirm when I take my next Covid test, but displaying the archived ones definitely does – UPDATE: confirmed, receiving new messages from non-numbers also works fine), and whatever caused the unexplained power consumption and/or charging issue in the December update seems fixed, too (power consumption and charging looks normal so far).

1 Like

Should this be moved back into known issues?

I cannot get an external monitor to work on the PbP without reverting back to linux-pinebookpro.

I have tested it to work on my end. DP Alt Mode will always be an issue on rk3399, there is no real fix. All we can do is attempt to hack something together that might work.

I tested on my PBP, with the USB-C dock for the PinePhone on my 1080p TV. Only 1 orientation seems to work.