[ARM Stable Update] 2021-02-26 - KDE Plasma 5.21, Firefox, Thunderbird, Mobile and Kernels

Update to latest Arm-Stable, all looks good. Thanks. On xfce desktop. Thank you.

Linux MNJROGTKPRO 5.11.1-1-MANJARO-ARM #1 SMP Tue Feb 23 17:43:04 UTC 2021 aarch64 GNU/Linux

After updating my Pinebook Pro (Manjaro ARM KDE) I wanted to reboot, but it didn’t show up in the menu (Application Launcher).
I used reboot on the command line.
That took a while and now I see the menu structure has changed.
Other than that, no problems so far.

Nothing wrong, but I see the the /boot/cmdline.txt settings are not reflected in /proc/cmdline

$ cat /boot/cmdline.txt
root=LABEL=ROOT_MNJRO rw rootwait console=serial0,115200 console=tty1 selinux=0 plymouth.enable=0 smsc95xx.turbo_mode=N dwc_otg.lpm_enable=0 kgdboc=serial0,115200 elevator=noop usbhid.mousepoll=8 snd-bcm2835.enable_compat_alsa=0 audit=0
$ cat /proc/cmdline
coherent_pool=1M 8250.nr_uarts=0 snd_bcm2835.enable_compat_alsa=0 snd_bcm2835.enable_hdmi=1 video=HDMI-A-1:1920x1080M@60 video=HDMI-A-2:1920x1080M@60 smsc95xx.macaddr=DC:A6:32:80:5B:D6 vc_mem.mem_base=0x3eb00000 vc_mem.mem_size=0x3ff00000 root=LABEL=ROOT_MNJRO rw rootwait console=ttyS0,115200 console=tty1 selinux=0 plymouth.enable=0 smsc95xx.turbo_mode=N dwc_otg.lpm_enable=0 kgdboc=ttyS0,115200 elevator=noop usbhid.mousepoll=8 snd-bcm2835.enable_compat_alsa=0 audit=0

Running rpi4

The new norm.

https://forum.manjaro.org/t/new-raspberry-pi-kernels-related-packages/4721/344

1 Like

GIMP is still broken on the Pinebook Pro. I’ve tried both from official repository and from the Flatpak. The Flatpak version was even worse, because it was slightly slower (or it seemed that way), black screen was longer and random parts showing, icons from the panel disappearing, etc. The Snap version can’t be installed because:

cannot perform the following tasks:
- Ensure prerequisites for "gimp" are available (cannot install prerequisite "kde-frameworks-5-core18": no snap revision available as specified)

If you excuse me, I’ve to find the rest of Flatpak packages, that probably survived the great GIMP removal :wink:

It’s perfectly fine on my end… version from the ManjaroARM repo…

2 Likes

Can you select anything in GIMP?

Yapp, no issues…

gimp

And this is like it looks on my Pinebook Pro:
https://www.dropbox.com/s/dwsn5iyfmhddquu/VID_20210228_120117.mkv?dl=0

I didn’t tried the 5.11 kernel, but I’ll in a few hours. On 5.10.17 I had the same issues.
If I’m remember right, you have also a working GPU acceleration in Firefox. What version of mesa do you use?

I’m on latest stable branch. Mesa 20.3.4 and using Wayland with Sway… maybe that’s an issue of your compositor?

I’m on the KDE Plasma desktop and not on Wayland.

I’m not a KDE guy, but noticed there have been some posts in the past mentioning the compositor option in the KDE settings… maybe you can check that?!

EDIT: e.g. here: [ARM Testing Update] 2020-12-23 - Kernels, Systemd 247.2, Pamac 10.0.2, Mesa 20.3.1 - #11 by Feakster

1 Like

Unfortunately, I don’t have to re-enable OpenGL in the Compositor settings.

Do you have certain applications that freeze or slow down?
Something is taking all the RAM since this version, especially under Firefox (Even with a clean profile).
And when all resources are taken the Pinebook Pro freezes completely and I have no choice but to force a reboot.

I have something like that a few months ago. It was my mSD (Manjaro is on) that was starting to cause problems.

I am getting same or similar behavior as wrzomar reports…but only if I have been using the system awhile (lots of browsing, running a couple work apps, etc.)…even if it is the only app currently open. GIMP works perfectly on my system if opened after a fresh reboot. …Maybe a memory issue, maybe some apps are not cleaning up their garbage as well as they should? Will test further when I get off work.

I had this also after fresh start, but today kirigami2 got updated, along with some NetworkManager packages which definitely have nothing to do with GIMP or TreeSheets, now both GIMP and TreeSheets work better. It’s not perfect, but there weren’t any blank screens or other weird stuff. But maybe it’s just a placebo effect.

I hope it’s not that because the OS is on the internal memory.
:sweat_smile: