[ARM Stable Update] 2021-01-21 - Plasma 5.20.5, Mesa 20.3.3, Mobile and Kernels

Hello ARM community.

Another Stable update is here! A big update!

logo-qt
QT 6 is now in the repositories


Some highlights:

  • Most of our kernels got updated
  • KDE Plasma updated to new point release 5.20.5
  • Introducing Mesa 20.3, which includes vulkan support for Raspberry Pi 4 and OpenGL 3.1 for Panfrost devices
  • QT 6 and GTK4 now available
  • Lots of updated packages for our Mobile offerings

Upstream Notifications:

Older notifications

ghostpcl>=9.53.2-2 and ghostxps>=9.53.2-2 updates require manual intervention:
https://www.archlinux.org/news/ghostpcl9532-2-and-ghostxps9532-2-updates-require-manual-intervention/

The nss and zn_poly packages requires manual intervention:
https://www.archlinux.org/news/nss3511-1-and-lib32-nss3511-1-updates-require-manual-intervention/
https://www.archlinux.org/news/zn_poly-092-2-update-requires-manual-intervention/

The packages hplip and firewalld requires manual intervention:
https://www.archlinux.org/news/hplip-3203-2-update-requires-manual-intervention/
https://www.archlinux.org/news/firewalld081-2-update-requires-manual-intervention/


Package changes:

(Thu Jan 21 11:33:29 CET 2021)

  • arm-stable community aarch64: 1098 new and 1020 removed package(s)
  • arm-stable core aarch64: 63 new and 59 removed package(s)
  • arm-stable extra aarch64: 918 new and 967 removed package(s)
  • arm-stable mobile aarch64: 84 new and 176 removed package(s)

To view a detailed overview of the package update, please see this snippet.


Testers needed on arm-testing branch

We are in need of testers for our arm-testing and arm-unstable branches.
So if you are adventurous and want newer software quicker, we would love for you to help us test out the new packages in arm-testing branch.

All you have to do to switch to this branch is:

  • Run this command to switch branch: sudo pacman-mirrors -aS testing && sudo pacman -Syyu. This will generate a new mirrorlist for you, sync your databases with the new mirror and update your system using the arm-testing branch.

We would then love for you to give feedback in our update posts in #manjaro-arm:arm-testing-updates. That way we can better find and fix bugs, before they hit arm-stable branch. Thank you!


Donation

Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.

Poll

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

Old Issues

Kwin crashes on startup on Pinebook Pro
This seems to be related to Mesa 20.3 and the Pinebook Pro support in kernel 5.10, as this does not seem to happen on other devices.
It does not impact 3d performance as far as I can tell. Just the OpenGL compositing in Kwin.
Fixed with mesa 20.3.2-2.

My VPN no longer connects
OpenVPN 2.5.0 changed how VPN routes work.
Workaround is to downgrade to previous version (2.4.9):

sudo pacman -U /var/cache/pacman/pkg/openvpn-2.4.9*

DP Alt Mode no longer works on Pinebook Pro
This is a known issue, the hacky patch we had to enable this has broken in recent kernels.
@tsys and Ayufan are looking into it.
As a workaround you can install linux-pinebookpro again.
FIXED with linux-5.9.12-4 and linux-rc-5.10-rc7-2 and above.

brcm-patchram-plus and pi-blueooth are in conflict
See this post for workaround:
[ARM Testing Update] 2020-11-16 - Bitwarden, Mesa-Git, Pacman and kernels - #10 by Darksky

Plasma Mobile Keyboard
The plasma mobile onscreen keyboard does not work with QT 5.15.0.
This is fixed by updating to kwin 5.19.3-1.1.

PinePhone uboot
This update to the PinePhone Uboot package (2020.04-2), changed how the DTS is loaded from the kernel, since the Kernel DTS for the Pinephone also changed. When doing this update on the PinePhone images from Alpha5 and back, please make this change to the /boot/extlinux/extlinux.conf before rebooting:

  • sun50i-a64-pinephone.dtb to sun50i-a64-pinephone-1.2.dtb
  • root=LABEL=ROOT to root=LABEL=ROOT_MNJRO

Manual interventions:
The nss and zn_poly packages prior to version 3.51.1-1 and version 0.9.2-2 respectively, were missing a soname link each. This has been fixed in 3.51.1-1 and 0.9.2-2 of these packages, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

nss: /usr/lib/p11-kit-trust.so exists in filesystem
zn_poly: /usr/lib/libzn_poly-0.9.so  exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/p11-kit-trust.so --overwrite /usr/lib/libzn_poly-0.9.so

to perform the upgrade.

Device stopped booting after Uboot update
The uboot update included a change to the extlinux.conf file. This change will be incompatible with the old 1 partition layout of some devices.
So if you are updating installs made with images 20.02.1 or older, you need to apply this fix before rebooting!
To fix this please edit your /boot/extlinux/extlinux.conf file and add 2 periods in front of each first slash, like so:

KERNEL ../Image
FDT ../dtbs/ #etc.
APPEND initrd=../initramfs-linux.img #etc.

Save the file and reboot.

Noticed that the newer kernel give some graphical glitches on the 2nd screen with my Pinebook Pro. Using the USB-C Docking Deck and an older Apple Cinema Display. Switched back to linux-pinebookpro, which still works fine…

Can paste a photo later after reboot from microSD.

On my PB pro, update went well. Rebooted. Started using PBP, and Simplenote. I was plugged into USB power (~77% charged). About 10 minutes after the update and reboot, I stopped working on the PBP and when I came back to it the screen was locked and the power indicator on the PBP was fast flashing. Powered down the PBP and booted back up. It has been running fine for the last 20+min. Not sure of the cause of the lockup and fast flash power indicator…but will keep my eye on it (first time I have experienced that behavior).

Still getting lockups when sitting not in use, but no flashing power indicator now. It responds to plugging and unplugging the USB cable (chime and screen comes un-dim) but screen is frozen with no mouse response and running cpu monitor is frozen (looks like CPU cores were spiking at around 60+% at the moment it froze). Checked power management, I only have “Dim Screen” …no suspend or energy saving… May have to do a clean reinstall since I am not seeing other reports of this issue.

No issues on my RPi 4 running 4Kp60. Might try switching to the testing branch. Only minor issue I’m seeing is no graphs in any of the system monitor widgets in KDE Plasma.

I have been using sway on Odroid N2. After update, I noticed that the display did not respond to the keyboard shortcut I use to run a alacritty. When I used the run menu to invoke alacritty directly, the program did not run. Instead, the screen started to flicker. I ssh’ed in and looked at journalctl -e and found this:

Jan 21 11:40:23 n2sw audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit>
Jan 21 11:40:23 n2sw audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=>
Jan 21 11:40:24 n2sw systemd[1]: systemd-hostnamed.service: Succeeded.
Jan 21 11:40:24 n2sw audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=>
Jan 21 11:40:24 n2sw kernel: panfrost ffe40000.gpu: AS_ACTIVE bit stuck
Jan 21 11:40:25 n2sw audit: BPF prog-id=12 op=UNLOAD
Jan 21 11:40:25 n2sw audit: BPF prog-id=11 op=UNLOAD

Could the panfrost entry have something to do with my problem?

So, after latest update, my pinephone won’t boot… I burned image to SD-card, booted from it and mounted a boot partition. But, I don’t know, what should i do now. There is no extlinux folder. I would be grateful for your help.

UPD: I installed a clean image of the system on emmc and then updated. It’s okay now. It looks like I missed one message that came up while updating:

Install new bootloader by running:

sudo dd if=/boot/u-boot-sunxi-with-spl-pinephone.bin of=/dev/mmcblkX bs=8k seek=1

Replace ‘mmcblkX’ with ‘mmcblk0’ for SD-card and ‘mmcblk2’ for eMMC.

Default RAM clock speed is 528 MHz on PC1066 DRAM. You may choose other speeds,
if you see crashes:

For slower RAM clock speed (492) use ‘u-boot-sunxi-with-spl-pinephone-492.bin’
For middle RAM clock speed (552) you may want ‘u-boot-sunxi-with-spl-pinephone-552.bin’
For faster RAM clock speed (592) you may want ‘u-boot-sunxi-with-spl-pinephone-592.bin’
For high RAM clock speed (624) you may want ‘u-boot-sunxi-with-spl-pinephone-624.bin’
Removing old extlinux folder

Updated on Beelink GTKing Pro with “Warn about old perl modules” other than that no issue.

How to keep or get “perl modules up to date”?

==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
Reloading system bus configuration...
Warn about old perl modules
Updating fontconfig cache...
Updating GIO module cache...
Compiling GSettings XML schema files...
Probing GTK3 input method modules...
Updating icon theme caches...
Reloading GVFS config...
Updating the info directory file...
Updating the desktop file MIME type cache...
Updating the MIME type database...
Transaction successfully finished.

Can not update my system. Pacman gives " GPGME error: No data. " and also reports that PGP signature of packages is damaged. So it fails to sync all databases. What can I do?

Maybe, it can help you…
https://wiki.manjaro.org/index.php/Pacman_troubleshooting#.22GPGME_error:_No_data.22_Error

I tried option 2: Comprehesive Resolution. No luck!

Hi,

My Odroid n2 is up to date, KDE, no issue, but I feel a better screen reactivity, maybe I’m wrong…

Odroid c2 is up to date, KDE, no issue.

Is it a good test ?

https://webglsamples.org/

Hmm… Maybe then changing the mirror will help (Pacman-mirrors - Manjaro):

sudo pacman-mirrors -f

After that, clean the cache:

sudo pacman -Sc (or even sudo pacman -Scc)

And update:

sudo pacman -Syyu

Thanks A2C2A!! That solved the problem.

I’ve felt quicker screen response on sway too. Youtube videos, for instance, seem rock solid as long as they are played in full screen mode. There is occasional flickering otherwise. On sway, however, I’ve seen:

  • sections of the desktop blinking or blank out. I had misstated this it my previous post. The screen did not flicker, it was actually parts of the screen.
  • alacritty bomb on start up with the message ‘There was an error initializing the shaders: Failed compiling shader: 0:1(10): error: GLSL 3.30 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES’
  • termite suddenly getting gray bands blanking out parts of the terminal. if you wait long enough parts of terminal will be blanked out, but will come back if the mouse is moved or a key pressed.
    I’m not sure what is causing all these phenomena. They might be sway specific, since you don’t have problems with kde.

The ‘panfrost ffe40000.gpu: AS_ACTIVE bit stuck’ seemed suspicious, but I could not find anything on the web, so I thought I should ask about it. Does your journalctl log have any entries like that?

I haven’t tested my most used USB-C charger yet, but so far it seems as though the USB-C charging issue is fixed with this update for those affected by it.

Thanks for your reply, reply to @Strit , he’s the dev :-)
I’m not a power user

Panfrost on the Bifrost cards are in very rapid development these days, so you might see the development better if you install mesa-git and linux-rc kernel.

But as I said. It’s in heavy development, so things change often.

Thanks for the advice! I will do that.