[ARM Stable Update] 2020-10-27 - KDE Plasma, Firefox, Uboots and Kernels

The same thing happens on reboot even when I image the card using Manjaro-ARM-kde-plasma-pbpro-20.10.img, the latest download available. So I don’t think it has to do with the image installer or this version.

I think I found a relevant thread here: Problem with the LCD screen when rebooting Pinebook Pro

For me, starting dolphin freezes entire system. Hard way.

No matter mesa or mesa-git.

I found that firefox with wayland and webrender enabled leads to massive kernel memory leaks. I wonder if it’s the same issue.

I can confirm this. PBP deep sleep will not wake up after update.

1 Like

Weirdly, this works again now. Not sure what was wrong before.

EDIT: No, it is still there. Only becomes present after opening and closing rkward.

youtube-dl doesn’t work anymore.

youtube-dl --verbose "https://www.youtube.com/watch?v=BtLZgm5k4ak"
[debug] System config: []
[debug] User config: []
[debug] Custom config: []
[debug] Command-line args: ['--verbose', 'https://www.youtube.com/watch?v=BtLZgm5k4ak']
[debug] Encodings: locale UTF-8, fs utf-8, out utf-8, pref UTF-8
[debug] youtube-dl version 2020.09.20
[debug] Python version 3.8.6 (CPython) - Linux-5.9.1-3-MANJARO-ARM-aarch64-with-glibc2.17
[debug] exe versions: ffmpeg 4.3.1, ffprobe 4.3.1, rtmpdump 2.4
[debug] Proxy map: {}
[youtube] BtLZgm5k4ak: Downloading webpage
[youtube] BtLZgm5k4ak: Downloading embed webpage
ERROR: Unable to extract JS player URL; please report this issue on https://yt-dl.org/bug . Make sure you are using the latest version; see  https://yt-dl.org/update  on how to update. Be sure to call youtube-dl with the --verbose flag and include its complete output.
Traceback (most recent call last):
  File "/usr/lib/python3.8/site-packages/youtube_dl/YoutubeDL.py", line 797, in extract_info
ie_result = ie.extract(url)
  File "/usr/lib/python3.8/site-packages/youtube_dl/extractor/common.py", line 532, in extract
ie_result = self._real_extract(url)
  File "/usr/lib/python3.8/site-packages/youtube_dl/extractor/youtube.py", line 2100, in _real_extract
jsplayer_url_json = self._search_regex(
  File "/usr/lib/python3.8/site-packages/youtube_dl/extractor/common.py", line 1010, in _search_regex
raise RegexNotFoundError('Unable to extract %s' % _name)
youtube_dl.utils.RegexNotFoundError: Unable to extract JS player URL; please report this issue on https://yt-dl.org/bug . Make sure you are using the latest version; see  https://yt-dl.org/update  on how to update. Be sure to call youtube-dl with the --verbose flag and include its complete output.

youtube-dl has problem with RIAA, who blew up the bug tracker. How to contact the developer?

I never use youtube-dl from the repo as updates are slow coming around. Mostly my purpose is because things change with youtube that prevent downloading and I get a quick fix.

Uninstall youtube-dl
sudo wget https://yt-dl.org/downloads/latest/youtube-dl -O /usr/local/bin/youtube-dl
sudo chmod a+rx /usr/local/bin/youtube-dl

About once a week I check for an update with:

sudo youtube-dl -U


I just tried and getting the same error and tried to do an update and get something weird so guess the youtube people are working on it.

[ray@ray-pc Desktop]$ sudo youtube-dl -U
ERROR: can't find the current version. Please try again later.

Not good:

Repository unavailable due to DMCA takedown.


About: youtube-dl -U: RIAA blew up the original repo!

youtube-dl works on https://www.youtube.com/watch?v=XnGVY8ZoW44

It bug on https://www.youtube.com/watch?v=BtLZgm5k4ak

It depends on the url…

1 Like

I have been getting a lot of that in the past few weeks. I guess they have stopped youtube-dl from circumventing.

Actually kernels 5.9 - 5.9.4 are unusable. The same goes to 5.10-rc1.
With 5.10-rc2 I cannot boot the machine.

Maybe switching off webrender would cure the situation but what is the point of going back.

EDIT: Just compiled 5.9.5 - it has panfrost patch and does not leak !!!

You should be able to get updates for youtube-dl using
pip install -U youtube-dl

How did you get PBP deep sleep working? It doesn’t work on mine at all…

I have the same, using qutebrowser. In my case only a reboot will free the used memory.
Is there a workaround? Because this makes my Notebook pretty much unusable, need to reboot all the time to free memory.

I’m a bit afraid of giving directions because the first time I made this the PBP wouldn’t boot and it was a while ago. I solved this by reinstalling which is not a very elegant solution…

Essentially what I did was installing “uboot-pinebookpro-bsp” and, after that, doing the necessary dd.

Found these instructions.

Thanks for pointing me to these instructions.
I did that already, but after some research I found out that sleep/suspend stopped working with this last kernel update, so now again it won’t work for me.
I think we have to wait for another update :slight_smile:

Right now my biggest troubles with this update is the severe memory leaks. Can someone tell me the best way to go back to the previous linux kernel version?

If you have the previous kernel in your cache it’s easy:

sudo pacman -U /var/cache/pacman/pkg/<package name you want to install>

I am unable to easily format and initialize my drives (wipe the emmc). There is a mechanical contact that is supposed to disconnect the memories, I want to wipe them, format them and install a partition with grub but I have been unable to do so.Neither can I rewrite the mbr. I have lost my root password which I thought was root, so unless I can re-install I cannot regain root. A circular problem. Otherwise everything works pretty well.

Thank you for the instructions.
So this would be enough?
sudo pacman -U /var/cache/pacman/pkg/linux-5.8.14-1-aarch64.pkg.tar.xz
Or do I need to downgrade another package to not break my system?