[ARM] Can't install steamlink

Hello, I have been trying to install steamlink-raspberrypi in Pamac (AUR package). There is a libcec-rpi package missing in order to install steamlink as provided here.
I have tried to build libcec as described here

#get libcec:
git clone git://github.com/Pulse-Eight/libcec.git

#force libcec to use c++11
edit the CMakeLists.txt
add following line:
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")

mkdir build
cd build
cmake -DRPI_INCLUDE_DIR=/opt/vc/include -DRPI_LIB_DIR=/opt/vc/lib -DCMAKE_INSTALL_PREFIX:PATH=/usr ..
sudo make install
sudo ldconfig

#check if installation worked
cec-client -l

When checking if the install worked I get:

libCEC version: 6.0.2, git revision: /bin/sh: line 1: /home/olividir/Sóttar: No such file or directory, compiled on 2021-03-26 12:14:37 by olividir on Linux 5.11.0-rc6-1-MANJARO-ARM (aarch64), features: P8_USB, DRM, P8_detect, randr, RPi
Found devices: 1

device:              1
com port:            RPI
vendor id:           2708
product id:          1001
firmware version:    1
type:                Raspberry Pi

But I am still unable to install steamlink and pamac still says libcec-rpi is missing (I have tried rebooting).
Does anyone know how I can install steamlink for my raspberry?

Although I have posted libcec-rpi packages in another thread here recently I have built the steamlink-raspberrypi package from AUR this mourning with libcec-rpi and it has 32bit binaries and will not run on 64bit OS as is:

Aahh, didn’t notice the 64 bit in the log…

Maybe I can build it for my raspberry???

If you have a 32 bit OS image.

Hmmm… the manjaro raspberry KDE “iso” is only 64 bit, right??

Don’t really want Raspberry OS after the Win stuff.

Maybe there will be 64 bit support for steamlink in the future?

One might find a docker or snap image to run under a 64 bit OS. I did notice when installing the package the package was designed for the pi3 and I do not know if one could get one of these images to work though as certain aspects involving the video is done differently on the pi4.

Another option is build a 32bit arch-arm image.


Thanks man, I’ll look at that 32 bit Arch, even if I was really hoping for 64 bit support. Maybe that will happen sometimes in the future.

Steamlink does not produce a aarch64 binary, so we can’t run it. :frowning:

Yup. As others have said. At the moment, the only way of using steam-link would be to run it inside a docker container or via systemd-nspawn.

I will need to read up on those two first… currently working on getting my Arch Arm working, if not, I will definitely look up Docker container and systemd-nspawn

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.