ARM builder tools, image not booting

Hello there!

I recently decided I would try building a version of Manjaro ARM for my pi 4. I setup a virtual machine and went through the process.

I'm pretty sure there were no errors, but the SD card that I flashed didn't work. I wondered whether I could get any help. There are a few things I probably should mention.

  1. I tried building the GNOME editon, completely aware that there might be after affects of it not working.

  2. I did have to use google drive to actually get onto my laptop, to the flash. I'm not that experienced in using virtual machines, before you ask...

Anything that I could do differently? Or is this impossible?

I used the ARM tools by the way.

Thanks in advance!

I don't know how virtual machines works with ARM achitectures.

But the images created with the tools, does work on the device it self.

I'm sure that on the thread I looked at, it said that the ARM tools were built to run on x86_64.

Can I build it on a Raspberry Pi using the same tools?

This is the thread: [Wiki] Contributing to Manjaro-ARM

Thanks!

Pretty sure you can't.

The tools are designed to be used on x86_64 hardware.

What you can do, is download an image from the download page and flash that to the SD card.

Right, thanks for confirming that...

I am (currently) using Manjaro XFCE on my Raspberry Pi, and that's been running quite well. However, I wanted to do something fun. A learning expeirience perhaps. And so, I went looking for a way to build an OS for my Pi from scratch. When searching the forums, I noticed the thread that I mentioned earlier. I thought I'd try to build a Gnome image for my Raspberry Pi.

It unfortunately didn't boot from my image.

Did it not boot because I was trying to build a gnome edition? Was the image broken in some way?

That's hard to know.

We would need the entire output of the sudo buildarmoem -d rpi4 -e gnome command.

Okay, I'll build the image again somepoint this week, and I'll give you the output.

Also the "SD card didn't work" report is not very helpful.

When you put it into the Raspberry Pi, how far does it get when powered on?
past the rainbow screen?
Is systemd messages scrolling by and just stops at some point?
Can you SSH to it?

It doesn't even get to the rainbow splash screen. It just starts flashing green at short intervals. This SD card has worked in the past...

Maybe It broke? I'll have to check...

There is no HDMI output either.

In that case, the image did not build successfully.

I will wait for the full output of the command. :slight_smile:

Sorry it's taken a while. For your command, it said:

==> Creating OEM image of gnome for rpi4...
  -> Extracting aarch64 rootfs...
  -> Setting up keyrings...
==> Installing packages for gnome edition on rpi4...
:: Synchronizing package databases...
error: failed retrieving file 'core.db' from manjaro-arm.moson.eu : The requested URL returned error: 404
error: failed to update core (failed to retrieve some files)
error: failed retrieving file 'extra.db' from manjaro-arm.moson.eu : The requested URL returned error: 404
error: failed to update extra (failed to retrieve some files)
error: failed retrieving file 'community.db' from manjaro-arm.moson.eu : The requested URL returned error: 404
error: failed to update community (failed to retrieve some files)
error: failed to synchronize all databases
  -> Enabling services...
  -> Applying overlay for gnome edition...
  -> Setting up system settings...
Enabling SSH login for root user for headless setup...
sed: can't read /var/lib/manjaro-arm-tools/img/rootfs_aarch64/etc/ssh/sshd_config: No such file or directory
sed: can't read /var/lib/manjaro-arm-tools/img/rootfs_aarch64/etc/ssh/sshd_config: No such file or directory
Enabling autologin for OEM setup...
Correcting permissions from overlay...
chown: cannot access '/var/lib/manjaro-arm-tools/img/rootfs_aarch64/etc/polkit-1/rules.d': No such file or directory
  -> Doing device specific setups for rpi4...
  -> Cleaning rootfs for unwanted files...
==> rpi4 gnome rootfs complete
==> Finishing image for rpi4 gnome edition...
  -> Copying files to image...
mv: cannot stat '/var/lib/manjaro-arm-tools/tmp/root/boot/*': No such file or directory
  -> Compressing Manjaro-ARM-gnome-rpi4-20.02.img...
Manjaro-ARM-gnome-rpi4-20.02.img (1/1)
xz: Manjaro-ARM-gnome-rpi4-20.02.img.xz: File exists
  -> Removing rootfs_aarch64
==> Time : 6.85 minutes...
[benaubrey@Rpi4-builder ~]$

Okay.

The mirror structure has changed significantly the last week, so the released Tools does not currently work.

I have fixed the issue in git, and I will probably tag a new release of the tools later today.

Right, thanks!

How much time does it usually take for the tag on GitLab to propagate to your repo, @Strit?

PS: Is there a PKGBUILD or it needs a bit more manual setup :slight_smile:

I usually just keep the -git package up, since the regular one is in the Manjaro repo.

1 Like

Yes, I've been thinking of the manjaro-arm-tools-git package which needs to add your repo to pacman.conf, not the one from Manjaro extra repo.

The -git version is still on 2.7.3.r4.gda4a4f8-1, while the gitlab release/tag is 2.80 :slight_smile: So, yeah, how long does it take for that update to propagate (if it's some auto tool updating it) :slight_smile: And how you make it into a package to upload :slight_smile:

I update that manually.
Will do it today. :stuck_out_tongue:

Like any other Arch/Manjaro package. :slight_smile: With makepkg.

1 Like

The update is up :slight_smile: Thanks!

Will try a few things now, maybe even play a bit with Wayfire/ Plasma-mobile defaults.

Forum kindly sponsored by