Argonone script doesn't work on manjaro arm xfce raspberryy pi 4 8gb

good morning. New to manjaro. using arm xfce on raspberry pi 4 8gb. everything good, fast as hell (even faster than the other usb ssd with raspberry pi 64 beta os…) .Just on big issue. i am not able to make argonone script work. Installed from aur, started and configured with argonone-config. Set the fan always on (that’s how i want it to be) . Nothing happens at the reboot. I also followed an advice putting
in /boot/config.txt
and removing ’ kgdboc=ttyAMA0,115200 ’ from my /boot/cmdline to avoid kernel panic at the reboot.
But i get kernel panic again. I revert to the old config and the fan is off. Please help.

i also add the following:

sudo systemctl status argononed.service
● argononed.service - Argon One Fan and Button Service
Loaded: loaded (/usr/lib/systemd/system/argononed.service; enabled; vendor>
Active: active (running) since Tue 2021-02-16 11:12:10 CET; 18s ago
Main PID: 840 (python3)
Tasks: 4 (limit: 8845)
CGroup: /system.slice/argononed.service
└─840 /opt/argonone/bin/python3 /opt/argonone/bin/

but it doesn’t work still.

Hi luca-ironman65.

Which kernel do you use (and branch) ? uname -a ?

Do you have a /dev/i2c-1 file ?

What is your temperature BTW ?

Once the kernel issue with /dev/i2c-1 is resolved, and you are still having issues, this pkgbuild may be helpful.