Are we ready for another stable update?

update

#1

Currently we have again a lot of packages in our testing branch we might want to push to stable. So what is your opinion on it?

  • Yes, I think we are ready
  • No, not yet

0 voters


There is no updates for several days
JWM updates
#2

These are the known errors so far:

Troubleshoots

GTK3

With this we updated Gnome and GTK to 3.20. This will break most of the themes, which will be fixed if and when their developers decide to update them. Some GTK 3.20-compliant themes are ready now - see further down this post.

The new default Manjaro GTK theme, which is GTK 3.20 compatible, is Vertex-Maia

You can install it with:

sudo pacman -Sy vertex-maia-themes vertex-maia-icon-theme xcursor-maia

QT apps style with GTK

With QT 5.7 you need to install qt5-styleplugins and qt5ct and configure your system to have an unified look again.

ufw

If you have issues with ufw not working anymore, you have to copy your custom rules to a different folder. Do it like this:

sudo cp -v /usr/lib/ufw/user.rules.pacsave /etc/ufw/user.rules
sudo cp -v /usr/lib/ufw/user6.rules.pacsave /etc/ufw/user6.rules

steam

Steam might not work due incompatiblity of libgpg. You my try followed command to “fix” it:

find ~/.steam/root/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete
find ~/.local/share/Steam/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete

Reference: Archlinux wiki


#3

Does this QT 5.7 issue affect all DEs? Just curious…


#4

qt5-styleplugins isn’t in the Manjaro repositories yet, but it is in the AUR.


#5

It’s in the testing repository.


#6

qt5-styleplugins and qt5ct help get consistent styles between gtk & qt applications (e.g. manjaro-settings-manager) in xfce. Also works in i3. See this thread:

https://forum.manjaro.org/t/theme-issue-with-manjaro-settings-manager/5145


#7

No hurry here! I rather wait a while for a smooth, and trouble free update. What’s the rush?


#8

There is no rush what so ever. I just ask time to time what the community thinks.


#9

I think the update script should be modified to change the theme to Vertex Maia for those who are still using Menda. It should be an easy task. :slight_smile:


#10

Because recently we had qt 5.6.1 which is lts and no apliación to ask qt5.7 as mandatory dependency. For me it is better to wait with the qt libraries and wait until 5.7.1 to not pass something similar to what happened recently with gtk and update the applications.


#11

I heard that 5.8 would be out before the end of the year. :stuck_out_tongue:


#12

I’ve added some more fixes for GTK changes in QT 5.7. With 5.8 gtk3 will be fully supported within QT. We will see what will happen next.


A couple of unpleasant local kernel vulnerabilities
#13

The only DE that have issue is lxqt. Far as I know. There is a little work around though.


The lxqt-runner part. Was more of a theme issue that I was trying to figure out. Witch got fix.


[Stable] 2016-07-19 - Snapshot ready to be moved to stable?